Camelia, the Perl 6 bug

IRC log for #darcs, 2013-01-07

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
02:26 intripoon joined #darcs
03:00 donri joined #darcs
03:10 jochu joined #darcs
03:23 carter joined #darcs
03:39 carter joined #darcs
03:50 mizu_no_oto joined #darcs
04:18 jyyou joined #darcs
04:30 favonia joined #darcs
04:34 mizu_no_oto joined #darcs
05:51 gienah joined #darcs
06:16 jochu joined #darcs
07:59 ronny joined #darcs
08:04 ronny hi
08:05 ronny whats the current state of darcs<>camp? i vaugely remember that camp was a experiment in new repo formats
09:20 jeltsch joined #darcs
10:03 raichoo joined #darcs
11:15 iago joined #darcs
11:21 owst joined #darcs
14:01 alpounet joined #darcs
16:29 mizu_no_oto joined #darcs
17:06 * sm thinks Igloo has been busy elsewhere
17:17 owst joined #darcs
17:21 jochu joined #darcs
17:43 sm__ joined #darcs
17:57 gienah joined #darcs
18:15 sm__ joined #darcs
18:40 schlaftier joined #darcs
19:18 stepcut joined #darcs
19:47 tranma joined #darcs
19:48 tranma hi, what would be the best approach for a cocoa GUI to communicate with darcs? should I be linking against darcs or munging the output of the command line?
19:59 owst tranma: darcslib
19:59 owst it'd be great to have someone working against the API
20:00 owst So I suppose the answer to your question is: probably the former
20:12 tranma left #darcs
20:12 tranma joined #darcs
20:43 mizu_no_oto joined #darcs
21:00 sm yes. The command line isn't a stable api
21:01 jochu joined #darcs
21:02 sm though, neither is libdarcs. But it's checked at compile time.
21:10 tranma so I'm using ghc 7.6.1 and the latest versions of pretty much everything, I'm having trouble building darcs because of the upper-bounds (and just general cabal hell), advice?
21:12 Heffalump unfortunately we have some actual problems supporting GHC 7.6.1 at the moment
21:12 Heffalump can you live with 7.4.2?
21:13 tranma not really, one of my other projects needs 7.6, I might have to figure out how to have multiple ghc's
21:13 Heffalump http://darcs.net/releases/branch-2.8/ does have patches that will let it build against 7.6.1, but the handling of invalid UTF8 in patch metadata is broken
21:15 favonia joined #darcs
21:15 sm multiple ghcs is really easy, just install them and if you use cabal, add -w ghc-X.Y
21:16 Heffalump it's a pain if you are just using distro packages to bgin with
21:18 gbeshers joined #darcs
21:19 sm I guess that depends whether the distro offers versioned ghc packages
21:19 Heffalump I don't think most do
21:23 nomeata joined #darcs
21:24 tranma thankfully I don't use distro packages, I'll give that multiple ghcs a try
21:24 sm anyway it's easy. tranma I doubt you are disallowed from installing haskell.org/ghc binaries
21:25 * sm excitedly waits for MacDarcs
21:30 mizu_no_oto joined #darcs
21:39 Heffalump I hope to have the 7.6.1 situation resolved withina  week or two, FWIW
22:00 sm great
22:07 owst joined #darcs
22:08 owst Heffalump: what solution have you come up with, for 7.6.1?
22:29 Heffalump the two top candidates are (1) extract the code from haskeline and put it in darcs (or a separate package) and (2) use the junk-at-the-end hack
22:32 owst My reaction was to prefer #1
22:41 Heffalump yeah, that's the way I'm heading too

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary