Perl 6 - the future is here, just unevenly distributed

IRC log for #darcs, 2015-03-13

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:00 * Heffalump suspects the solver's job would be a lot easier if we lifted the webdriver constraint, that probably needs a bit of CPP
02:31 Riastradh joined #darcs
02:40 mizu_no_oto joined #darcs
04:40 amgarching joined #darcs
05:12 c74d joined #darcs
06:26 amgarching joined #darcs
07:40 Heffalump sm: some upper bound bumps in ganesh/darcsden which may help
10:38 gal_bolle joined #darcs
11:00 mizu_no_oto joined #darcs
12:01 Igloo joined #darcs
13:02 mizu_no_oto joined #darcs
14:07 c74d joined #darcs
15:04 mizu_no_oto joined #darcs
15:41 mizu_no_oto joined #darcs
15:47 sm g'day all
15:48 sm Heffalump: thanks, would you mind rebasing that on the latest trunk some time
15:53 Heffalump what needs rebasing?
16:14 dolio joined #darcs
16:39 sm Heffalump: your upper bound bump patch, I had pushed a similar one a few days ago
16:40 sm or I can do it later, no big deal
16:42 * sm notes porting darcsden to hsp > 0.7 will probably help installability
17:23 Heffalump http://hub.darcs.net/ganesh/darcsden/compare/simon/darcsden suggests my repo is up to date, what am I missing?
17:34 sm ah! sorry, I only imagined I had pushed. Your patch wins!
17:35 * sm practices darcs rebase
17:38 sm I inserted "rebase" before the pull command, ie darcs rebase pull hub.darcs.net:ganesh/darcsden -a . It pulled and suspended your patch, so far so good
17:38 sm I'm not sure what to do next
17:38 sm darcs rebase suspend <my local conflicting patch> I guess
17:39 Heffalump that should have suspended your pathc, not mine
17:39 sm no wait.. it suspended my conflicting patch, even better
17:39 Heffalump so now unsuspend, resolve the conflicts, amend-record to edit the resolution into your patch
17:39 sm nice
17:40 sm is there a way to list the suspended patches ?
17:40 Heffalump darcs rebase log with a recent darcs
17:40 sm nice! time to update
17:40 Heffalump (or rebase changes if you're old skool like me...)
17:40 Heffalump it's not too recent, went in sometime late last year I think
17:41 Heffalump of course you can use the unsuspend interactive UI to look at them as well
17:41 sm true
17:47 sm in current darcs-screened, darcs rebase log is --interactive by default
17:52 * sm thinks it's ok to set bounds only the first time a dependency is mentioned in a cabal file
17:57 Heffalump I think rebase log follows log
17:57 Heffalump if it doesn't let me know
17:58 Heffalump sm: if it's in the library, yes, possibly not if it's only in one exe
17:58 sm here, log is non-interactive and rebase log is interactive
17:58 Heffalump ok, I'll take a look, thanks
18:08 sm currently blocked on building haskell-src-exts .. next time you can see which version you're using with ghc 7.8, that would be useful
18:20 sm hmm, maybe it's a happy versino issue
18:32 sm or not
18:36 sm yikes, Impossible case at src/Darcs/Patch/Rebase/Viewing.hs:451 compiled Mar 13 2015 11:26:17
18:37 sm after suspending your 'bump some upper bounds' patch, pulling again, and trying to unsuspend it
18:39 sm which has put my own patch, also suspended and depending on yours, slightly out of reach
18:42 sm ok, recovered via darcs diff/patch
18:44 amgarching joined #darcs
18:49 sm merged your and my bounds patches. I can build with GHC 7.6 again, and 7.8 up till haskell-src-exts and hsx
18:49 sm thanks Heffalump, see you
19:10 sm merged your darcs-1 support patch (disabled on hub.darcs.net)
19:33 mizu_no_oto joined #darcs
19:59 amgarching joined #darcs
20:16 ankitku joined #darcs
21:08 Heffalump sm: your patch ended up correupted? :-(
21:08 Heffalump you know you bumped blaze-html, did you actually manage to build with that?
21:09 Heffalump I bumped it but couldn't find an install plan, I think highlighting-kate or pandoc or something depends on < 0.8
21:10 Heffalump I think my 7.8 build used haskell-src-exts-1.13.5
21:12 Heffalump hmm, do you think you repulled the patch into your repository after it got suspended?
21:12 Heffalump looking at the code and thinking about the 'impossible' case in the light of reality makes me suspect that can go wrong
21:12 Heffalump i.e. that you had a suspended copy of your patch and an unsuspended copy
21:25 amgarching joined #darcs
22:29 sm Heffalump: yes that's right, I suspended the patch, re-pulled the same patch, and tried to unsuspend it
22:30 sm no corruption, I just couldn't unsuspend my patches because of the above
22:33 sm no indeed, it picked blaze-html 0.7.x and I can't find an install plan with 0.8
22:33 Heffalump I'd argue against bumping a dep to something we can't test
22:35 sm I've sometimes optimistically allowed the latest version of things that seem to have stable-ish apis
22:35 Heffalump fair enough, we can always drop it if necessary
22:35 sm it's so hard to find an install plan, I was trying to make that part easier and tighten up on build failures later
22:36 Heffalump I think widening the dependencies has made finding an install plan much easier
22:36 sm yeah
22:51 mizu_no_oto joined #darcs
23:16 Riastradh joined #darcs
23:27 mizu_no_oto joined #darcs

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary