Perl 6 - the future is here, just unevenly distributed

IRC log for #darcs, 2015-06-23

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:01 sm darnit, why does pulling from hub.darcs.net/darcs/darcs-2.10 give  Codec.Compression.Zlib: premature end of compressed stream
00:03 sm and the same thing from darcs.net:darcs-unstable/releases/branch-2.10 ?
00:04 sm and also from http://darcs.net/releases/branch-2.10
00:04 sm trippy
00:07 sm and also when pulling from one local dir to another. Both with the old darcs binary I've been using, and one built from today's darcs-screened.
00:07 * sm backs away from the machine
00:14 sm gh_: I've pushed a stack.yaml patch, http://hub.darcs.net/simon/darcs-screened/patch/20150623000002-3c3f9
00:25 sm more info: https://www.fpcomplete.com/blog/2015/06/announcing-first-public-beta-stack , https://github.com/commercialhaskell/stack/wiki/Lowering-the-bar-to-open-source-contributions
01:00 byorgey joined #darcs
01:27 byorgey joined #darcs
01:39 lambdabot joined #darcs
02:02 mizu_no_oto joined #darcs
02:21 mizu_no_oto joined #darcs
02:46 Riastradh joined #darcs
06:50 Heffalump sm: I've bene using darcs-screened with GHC 7.10 for a while, I'm sure..
06:51 * Heffalump is not too keen on a stack.yaml file if I'll be expected to maintain it when I change the cabal file
06:58 alexei_ joined #darcs
07:35 f-a joined #darcs
11:09 notdan Heffalump: ping
11:09 notdan Heffalump: what should happen if a user attempts to rename a repository?
11:24 f-a joined #darcs
12:31 f-a joined #darcs
13:44 mizu_no_oto joined #darcs
13:51 f-a joined #darcs
13:58 gh_ joined #darcs
13:59 sm joined #darcs
14:07 pointfree joined #darcs
14:09 pointfree sm, fyi it looks like darcsden fails to build when darcs-screened is the version of darcs installed.
14:21 gh_ I'm having this bug trying to build darcs; with both ghc 7.10 and 7.6 https://www.reddit.com/r/haskell/comments/3634x2/cabal_is_giving_a_weird_error_when_attempting_to/
14:23 gh_ some conflict between unix-2.7.1.0 and unix-2.6.0.1
14:28 byorgey joined #darcs
14:30 f-a joined #darcs
14:30 gh_ some dependency wants to install unix-2.6.0.1
14:50 gh_ ah no, unix-2.6.0.1 comes with ghc 7.6 on my system.
15:16 notdan yuck :(
15:19 gh_ it happens when you do cabal install --upgrade-dependencies
15:50 sm pointfree: thanks
15:51 sm Heffalump: you're building darcs-screened with ghc 7.10 and.. what version of dataenc ?
16:08 alexei_ joined #darcs
16:33 Heffalump sm: I'll check..
16:34 Heffalump notdan: I guess either rename the directory (and perhaps move it), or just rdon't let them
16:34 Heffalump sm: 0.12
16:36 Heffalump pointfree: I do that and it generally works, though I haven't necessarily updated everything right now
16:36 psnively joined #darcs
16:46 notdan Heffalump: what do you think about a short meeing tomorrow?
17:04 Heffalump notdan: I'm out in the evening (London haskell group) so would need to figure out a time around that
17:04 sm Heffalump: aha.. which is 6 years old, and works because it doesn't restrict base
17:05 sm cabal-install finds that old version where stack doesn't
17:07 Heffalump sm: that's pretty funny :-)
17:23 Heffalump sm: hmm, we can't easily switch to sandi for darcs 2.10, because it doesn't support base 4.5 (i.e. GHC 7.4)
17:23 Heffalump so I guess we switch screened over and hope dataenc continues working on GHC 7.10
17:33 f-a joined #darcs
17:42 alexei_ joined #darcs
17:53 Riastradh joined #darcs
18:18 Riastradh joined #darcs
18:34 mizu_no_oto joined #darcs
19:47 alexei_ joined #darcs
20:16 Riastradh joined #darcs
20:57 Riastradh joined #darcs
23:56 gh_ joined #darcs

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary