Perl 6 - the future is here, just unevenly distributed

IRC log for #darcs, 2017-08-18

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
01:24 Mysterious_Light joined #darcs
01:24 mal`` joined #darcs
01:24 pmeunier joined #darcs
01:51 ilbot3 joined #darcs
01:51 Topic for #darcs is now http://darcs.net/ | logs: http://irclog.perlgeek.de/darcs/ | darcs 2.12.5 is out http://darcs.net/Releases/2.12
02:21 Riastradh joined #darcs
03:32 dolio joined #darcs
07:21 Weltraumschaf joined #darcs
07:32 Mysterious_Light joined #darcs
07:42 Weltraumschaf joined #darcs
08:18 Weltraumschaf_ joined #darcs
08:29 Weltraumschaf joined #darcs
08:50 Weltraumschaf joined #darcs
09:00 Weltraumschaf_ joined #darcs
10:42 Mysterious_Light joined #darcs
12:08 Mysterious_Light joined #darcs
12:36 favonia joined #darcs
13:08 byorgey joined #darcs
13:08 byorgey joined #darcs
13:34 stef204 joined #darcs
15:44 favonia joined #darcs
17:23 Riastradh joined #darcs
18:13 Heffalump Cabal 2.0 doesn't like our Setup.hs, as I think someone already pointed out. Unfortunately it also has a bunch of breaking changes and it'll be hard to support all of Cabal 2.0, Cabal < 2.0, and GHC 7.10
18:14 Heffalump I'm inclined to just drop 7.10
18:14 ilovezfs_ me == $someone
18:14 Heffalump thank you :-)
18:14 ilovezfs_ :)
18:14 Heffalump it took me this long to work it out for myself, for various bad reasons
18:14 ilovezfs_ no worries
18:15 ilovezfs_ it's you and everyone else https://github.com/Homebrew/homebrew-core/pull/15934#issuecomment-317268668
18:16 Heffalump any attachment to GHC 7.10 in your case?
18:17 ilovezfs_ zero
18:17 Heffalump oh, but I guess you want to build the stable release, not HEAD? Just remembered we don't normally drop GHC support on a stable branch.
18:17 Heffalump So the result might be no GHC 8.2 in stable, and no GHC 7.10 in the next major release
18:18 ilovezfs_ right
18:18 ilovezfs_ we can't even build head since it needs darcs to fetch it
18:18 Heffalump you must bootstrap with something :-)
18:18 ilovezfs_ hehe
18:19 ilovezfs_ mercurial suffers from the same Catch-22
18:20 Heffalump so how bad would waiting for 2.14 be?
18:20 Heffalump TBH I don't know how far away that is, gh was talking about it recently
18:21 ilovezfs_ not too bad.
18:21 ilovezfs_ but we could apply a patch to stable if you have one
18:23 Heffalump ok, I'll try to produce that as well once we decide on the plan
18:23 Heffalump (remind me)
18:23 ilovezfs_ OK :)
18:29 gh__ joined #darcs
18:29 gh__ hi Heffalump
18:30 gh__ these days my plan was to review Ben's bundles and write a mail for the list about darcs 2.14
18:30 gh__ which we should try to release in the coming 1 or 2 months
18:30 gh__ and should require ghc 8
18:30 gh__ or 8.2
18:39 gh__ the reason simply being that it is predictable that we have a hard time keeping up with more than 2 versions of GHC, and that is without taking cabal into account
20:18 gh__ joined #darcs
21:01 Mysterious_Light joined #darcs
22:57 dolio joined #darcs
23:33 leg joined #darcs

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary