Perl 6 - the future is here, just unevenly distributed

IRC log for #darcs, 2017-08-19

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
01:51 ilbot3 joined #darcs
01:51 Topic for #darcs is now http://darcs.net/ | logs: http://irclog.perlgeek.de/darcs/ | darcs 2.12.5 is out http://darcs.net/Releases/2.12
07:15 Mysterious_Light joined #darcs
11:38 gh_ joined #darcs
11:56 stef204 joined #darcs
12:05 gh_ indeed cabal 2 does not accept our Setup.hs
12:07 gh_ we are currently using versionBranch which is no longer part of cabal 2 API, and it is easy to replace. Anyway, since the last 2 releases of Darcs we are not using the "alpha", "beta" and "release cantidate" version names at all, so we can just go ahead and remove this.
12:14 gh_ then the other problem is the use of FlagName :: String -> FlagName ; if Ben's unicode patches are accepted this is going to disappear. If not, the API change is minimal and we'll have to introduce conditionals in Setup.hs.
12:28 gh_ ouch, it's a little more complicated than that :)
12:46 gh_ I'm not sure how to replace externalPackageDeps
12:46 gh_ the API of cabal 2 says it's going to be removed in cabal 2.2, we should as well try to see how to do without it now
12:51 Heffalump gh_ I've got local fixes for all of this
12:51 Heffalump oh, not externalPackageDeps
12:52 gh_ this is the one I'm looking at righ now
12:52 Heffalump I didn't actually hit that, but maybe I didn't get that far. I've got as far as no instance for Package MungedPackageId with 'formatone'
12:52 Heffalump anyway, my plan was to use CPP on Setup.hs, which is apparently supported with GHC>=8.0 || cabal-install >=1.24
12:53 Heffalump so by dropping GHC 7.10 we can support both Cabal<2.0 and >=2.0
12:55 gh_ nice
12:55 gh_ what about only supporting Cabal >= 2.0 in darcs HEAD/2.14?
12:57 gh_ would this prevent some people from building darcs? or is it always possible to cabal install cabal-install and then build darcs, even with an older cabal
12:57 gh_ because if this is possible then we should not care too much, IMO
13:00 Heffalump I was going by the versions in the HP
13:01 Heffalump https://www.haskell.org/platform/contents.html
13:01 Heffalump so if we support GHC 8.0 I think we should support Cabal 1.24
13:01 Heffalump otherwise distros might have problems
13:03 gh_ hmm
13:04 gh_ I agree
13:04 gh_ it does not seem that ubuntu 17.10 is going to ship ghc 8.2
13:04 gh_ it currently ships ghc 8.0.2
13:10 gh_ in fact the package versions in debian testing are probably more relevant
13:10 Heffalump we may just need to drop externalPackageDeps
13:10 Heffalump it's not perfect anyway as it's just our direct deps
13:12 gh_ have we ever used this piece of data for bug squashing anyway?
13:13 Heffalump not that I remember
13:14 Heffalump I've just asked on #hackage, but let's assume we drop it
13:32 Mysterious_Ligh1 joined #darcs
14:49 Mysterious_Light joined #darcs
15:06 Mysterious_Light joined #darcs
16:46 Heffalump gh_: I've sent in a patch for GHC 8.2, but haven't debugged the mail problems yet, so let's see if it arrives..
19:38 Mysterious_Light joined #darcs
21:08 leg joined #darcs
21:47 Heffalump I'm thoroughly confused about the patch delivery problems. Some patches have been getting through fine. But unfortunately the last one was more than a week ago and we don't have mail logs any more
22:42 gh_ Heffalump, indeed I don't see any mail of yours on darcs-devel. Maybe you should submit it manually on bugs.darcs.net

| Channels | #darcs index | Today | | Search | Google Search | Plain-Text | summary