Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel-dev, 2014-05-14

| Channels | #fuel-dev index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:16 tzn joined #fuel-dev
03:15 warpc joined #fuel-dev
04:53 Ch00k joined #fuel-dev
05:23 mihgen alex_didenko: do we still need https://review.openstack.org/#/c/91347/ ?
05:54 sambork joined #fuel-dev
05:56 mihgen holser_: https://review.openstack.org/#/c/93535/, looks like everything is broken without this: mkfs.xfs -f -s size=512, not "mkfs.xfs -f -s 512"
06:00 Ch00k joined #fuel-dev
06:02 teran joined #fuel-dev
06:04 mihgen teran: I need your +1 here: https://review.openstack.org/#/c/93535/. Actually I think smoke passes because error is not fatal: we can still use root partition, even if we can't create /var/lib/...
06:06 teran mihgen: already done
06:06 mihgen teran: thx, merged
06:09 salmon_ joined #fuel-dev
06:29 al_ex joined #fuel-dev
06:34 teran joined #fuel-dev
06:59 EeeBotu New bug #1319269 in fuel: "Controllers failed to return to bootstrap" [Undecided, New] https://bugs.launchpad.net/bugs/1319269
06:59 izinovik joined #fuel-dev
07:00 e0ne joined #fuel-dev
07:03 mihgen xenolog_: take a look pls: https://review.openstack.org/#/c/93539/1
07:06 alex_didenko mihgen: alex_didenko: do we still need https://review.openstack.org/#/c/91347/ ? - yes
07:07 mihgen ykotko: alex_didenko folks I see https://bugs.launchpad.net/fuel/+bug/1314128 reopened without explanation why
07:07 mihgen ykotko: issues is still reproduced?
07:08 mihgen ykotko: is it related to system tests only or can be easily reproduced by master node reset ?
07:08 mihgen bogdando: need your review of https://review.openstack.org/#/c/91347/
07:09 mihgen warpc: did you see https://bugs.launchpad.net/fuel/+bug/1316720 reopened?
07:10 warpc mihgen: hi! Yes, looking it now
07:10 mihgen vkramskikh: morale: what's about https://bugs.launchpad.net/fuel/+bug/1317107 ? do we need it in 5.0? what's the status?
07:12 alex_didenko mihgen: https://bugs.launchpad.net/fuel/+bug/1314128 is fixed, the problem Egor had is related to the other bug https://bugs.launchpad.net/bugs/1319076
07:12 teran joined #fuel-dev
07:12 anotchenko joined #fuel-dev
07:12 alex_didenko mihgen: I'll work on that bug today
07:14 mihgen alex_didenko: is it related to system tests only?
07:14 alex_didenko yes
07:14 mihgen we don't keep medium bugs in 5.0 after SCF….
07:15 mihgen alex_didenko: does it affect many system tests?
07:15 alex_didenko it affects only --group=setup, not sure if we use it a lot in our system tests
07:16 mihgen alex_didenko: pls increase to high and assign to yourself. Change is going to be in docker scripts somewhere?
07:17 akislitsky left #fuel-dev
07:17 alex_didenko in bootstrap_admin_node.sh script
07:17 akislitsky joined #fuel-dev
07:18 mihgen alex_didenko: ok
07:18 mihgen bogdando: are https://bugs.launchpad.net/fuel/+bug/1319106 and https://bugs.launchpad.net/fuel/+bug/1319046 not about the same?
07:20 mihgen vkramskikh: morale: and about https://bugs.launchpad.net/fuel/+bug/1318631 ?
07:22 vkramskikh mihgen as for https://bugs.launchpad.net/fuel/+bug/1318631 it doesn't always reproduce, i'm deploying an env to test it on iso
07:23 mihgen bogdando: xenolog_ holser_ dilyin good candidate for confirming/ triaging: https://bugs.launchpad.net/fuel/+bug/1319087
07:23 mihgen vkramskikh: ok
07:24 mihgen alex_didenko: any idea why Fuel CI put -1 on your https://review.openstack.org/#/c/93317/ ?
07:24 holser_ mihgen: I have a bit different concern regarding “mkfs.xfs -f -s=512”
07:24 holser_ mihgen: but I didn’t check the syntax thus I didn’t give my +1
07:25 bogdando mihgen, no, they aren't. 1319046 has no issues with any ostf tests
07:25 mihgen holser_: I merged fix with mkfs.xfs -f -s size=512, as provided by rsokolkov
07:25 bogdando mihgen, I have an image in glance, but I cannot spawn a bootable volume from it
07:25 mihgen holser_: I tested that syntax and didn't get complains, though I didn't try to format
07:25 holser_ mihgen: thanks, but we need to revert back to 4k (bug is already opened)
07:25 bogdando mihgen, the common part is only Ceph were used both for glance and cinder
07:25 mihgen holser_: ?
07:25 mihgen what bug?
07:26 mihgen bogdando: ok
07:26 alex_didenko mihgen: https://review.openstack.org/#/c/93317/ affects fuel master node deployment only, so openstack deployment failure on ubuntu could not be caused by it, especially when centos worked fine
07:26 bogdando mihgen, watching for https://bugs.launchpad.net/fuel/+bug/1319087...
07:27 holser_ mihgen: #1318614
07:27 alex_didenko according to CI logs, ubuntu failed by timeout, which might be performance issue
07:27 mihgen alex_didenko: yep, I have to agree. wondering why still… I've retriggered build. Could be that intermittent failure aglarendil experienced with partitions
07:27 artem_panchenko joined #fuel-dev
07:28 mihgen alex_didenko: ok, anyway, I've restarted it - let's see if it passes now. If it's not, then we will get devops to fix it - we need healthy Fuel CI
07:28 alex_didenko ok
07:29 mihgen holser_: yep, it goes to 5.1, thanks
07:29 holser_ mihgen: yw
07:29 teran_ joined #fuel-dev
07:32 Ch00k_ joined #fuel-dev
07:43 akasatkin joined #fuel-dev
07:50 b-zone joined #fuel-dev
08:05 EeeBotu New bug #1319282 in fuel: "OSTF should report about PASSed tests in logs" [High, Confirmed] https://bugs.launchpad.net/bugs/1319282
08:05 EeeBotu New bug #1319276 in fuel: "Add OSTF testcase for booting instance from the volume" [Critical, Confirmed] https://bugs.launchpad.net/bugs/1319276
08:07 morale joined #fuel-dev
08:11 anotchenko joined #fuel-dev
08:26 teran[m] joined #fuel-dev
08:31 morale bookwar: please, retrigger https://fuel-jenkins.mirantis.com/job/stackforge-verify-fuel-web/3436/
08:51 tzn joined #fuel-dev
09:13 EeeBotu New bug #1319306 in fuel: "'list index out of range' error on group node disks configuration" [High, New] https://bugs.launchpad.net/bugs/1319306
09:34 ykotko joined #fuel-dev
09:35 tzn joined #fuel-dev
09:51 tzn joined #fuel-dev
09:53 vkramskikh mihgen https://review.openstack.org/#/c/93539/ should we merged?
09:54 vrovachev joined #fuel-dev
10:11 mihgen vkramskikh: done
10:15 EeeBotu New bug #1319333 in fuel: "Tests checkboxes are enabled when tests are running" [Medium, Confirmed] https://bugs.launchpad.net/bugs/1319333
10:20 ykotko joined #fuel-dev
10:21 _daks_ joined #fuel-dev
10:28 anotchenko joined #fuel-dev
10:43 teran joined #fuel-dev
10:44 teran_ joined #fuel-dev
10:45 teran_ joined #fuel-dev
10:51 tzn joined #fuel-dev
10:53 nurla_ joined #fuel-dev
11:02 teran_ joined #fuel-dev
11:09 warpc joined #fuel-dev
11:10 izinovik joined #fuel-dev
11:16 EeeBotu New bug #1319344 in fuel: "Reduce time of bootstrapping of master node" [Critical, Confirmed] https://bugs.launchpad.net/bugs/1319344
11:43 sambork I have question. I want to test changes that I made in fuel-web/bin/agent . I built new rpm with nailgun-agent and I copied built rpm to fuel-main/local_mirror/centos/os/x86_64/Packages/ . Next I built new bootstrap using: make bootstrap . In next step I copied initramfs.img to rootfs/var/lib/tftpboot/images/bootstrap/ and /rootfs/var/www/cobbler/images/bootstrap/ . I restarted containers with cobbler and nailgun .And the question is, this is correct f
11:52 anotchenko joined #fuel-dev
11:54 morale joined #fuel-dev
11:56 warpc joined #fuel-dev
12:15 teran joined #fuel-dev
12:18 EeeBotu New bug #1319363 in fuel: "DHCP in LXC container" [Undecided, New] https://bugs.launchpad.net/bugs/1319363
12:18 teran joined #fuel-dev
12:29 e0ne joined #fuel-dev
12:31 teran joined #fuel-dev
12:32 vrovachev I have started environment deployment  with KVM hypervisor, using 203 fuel iso. Deployment hangs during software installation, nodes is not even rebooted to install software.
12:36 vkramskikh mihgen as for https://bugs.launchpad.net/fuel/+bug/1318631 it seems to be a backend bug - sometimes on attempt to stop testrun hangs in running state forever
12:45 warpc joined #fuel-dev
13:09 jobewan joined #fuel-dev
13:09 akupko joined #fuel-dev
13:10 a_teem_ joined #fuel-dev
13:12 asledzinskiy joined #fuel-dev
13:13 brain461 joined #fuel-dev
13:14 meow-nofer_ joined #fuel-dev
13:14 dshulyak joined #fuel-dev
13:15 morale joined #fuel-dev
13:15 salmon_ joined #fuel-dev
13:22 EeeBotu New bug #1319392 in fuel: "Deadlocks in Nailgun" [Medium, Triaged] https://bugs.launchpad.net/bugs/1319392
13:22 EeeBotu New bug #1319385 in fuel: "MCollective isn't completely installed" [Medium, New] https://bugs.launchpad.net/bugs/1319385
13:22 EeeBotu New bug #1319383 in fuel: "rabbitmq.rb: Heartbeat read failed" [High, New] https://bugs.launchpad.net/bugs/1319383
13:22 EeeBotu New bug #1319380 in fuel: "need to update image for deploy_savanna_simple test" [Undecided, New] https://bugs.launchpad.net/bugs/1319380
13:31 tzn joined #fuel-dev
13:34 xarses joined #fuel-dev
13:35 evgeniyl holser_: hi, did you have time to check upgrades? Does it work now?
13:35 holser_ I didn’t check
13:35 holser_ I’ll start right now
13:39 holser_ evgeniyl: running now
13:46 jaranovich joined #fuel-dev
13:46 e0ne joined #fuel-dev
13:59 morale_ joined #fuel-dev
14:02 tzn joined #fuel-dev
14:07 holser_ evgeniyl: Failed to execute migraion command "manage.py syncdb" exit code 1 container id 0b7c6ed2b0f4ada005643b5cb0f508b1a60057eb32e0e6f75f09bb03809d19f <<<<
14:08 tzn joined #fuel-dev
14:22 EeeBotu New bug #1319413 in fuel: "[system_test] Support linux bonding in system_test" [High, New] https://bugs.launchpad.net/bugs/1319413
14:22 EeeBotu New bug #1319412 in fuel: "Wrong interface in dnsmasq.conf inside cobbler container" [Critical, In Progress] https://bugs.launchpad.net/bugs/1319412
14:22 EeeBotu New bug #1319400 in fuel: "Cannot delete environment after deployment is hanged" [High, New] https://bugs.launchpad.net/bugs/1319400
14:35 mihgen dilyin: xenolog_ did you guys found anything regarding https://bugs.launchpad.net/fuel/+bug/1319046 ? to add in comments at least for a bug?
14:37 mihgen holser_: bogdando folks can you help in code review https://review.openstack.org/#/c/93547/1 ?
14:37 mihgen mattymo: aglarendil if you guys are around by any chance  - help in review ^^
14:37 holser_ mihgen: sure
14:38 xenolog_ mihgen: Now I fixing keystone manifests.
14:38 holser_ mihgen: https://review.openstack.org/#/c/93547/1 it’s a brilliant fix, that’s what I was looking for :)
14:41 mihgen holser_: do we have dockerctl check implemented?)
14:42 holser_ yep
14:42 alex_didenko https://review.openstack.org/#/c/93547/1 - I've made an ISO with it, tested 2 times on --group=setup - no problemos
14:43 holser_ mihgen: +1 feel free to commit
14:43 alex_didenko right now I'm running --group=ceph_ha, it passed fuel node deployment already and setting up 3-rd controller
14:43 salmon_ joined #fuel-dev
14:44 holser_ alex_didenko: 93561 review  I would give -1
14:45 e0ne joined #fuel-dev
14:45 alex_didenko why?
14:45 holser_ the problem should be fixed in astude.yaml rather than manifest
14:45 alex_didenko no
14:45 morale joined #fuel-dev
14:45 morale_ joined #fuel-dev
14:45 holser_ it’s hardcode
14:46 alex_didenko on fuel node we run dhcprelay on fuel admin interface (eth1), but inside container we don't have eth1, only eth0
14:46 alex_didenko but REAL admin interface is eth1 (on host system)
14:46 holser_ ^^^ should be proper yaml file for docker containers :)
14:48 teran joined #fuel-dev
14:48 alex_didenko yeah, but still real admin interface is eth1, which is correct and it's reflected in astute.yaml
14:49 alex_didenko if we want to use it in some other manifests that we run on host system level, then we'll get correct admin iface (eth1)
14:50 morale joined #fuel-dev
14:50 alex_didenko so the only problem that cobbler container has "hardcoded" set of interfaces :) eth0 and lo, so we just hardcode the same in manifest for cobbler container
14:50 morale joined #fuel-dev
14:55 morale joined #fuel-dev
14:59 dshulyak bogdando, holser, vsharshov, mihgen: pls take a look https://review.openstack.org/#/c/93566/ , i think it needs to be merged today
15:01 morale joined #fuel-dev
15:05 bogdando dshulyak, LGTM. nice catch, thank you
15:05 tzn joined #fuel-dev
15:11 teran joined #fuel-dev
15:14 MorAle joined #fuel-dev
15:21 MorAle-temp joined #fuel-dev
15:23 IvanBerezovskiy1 left #fuel-dev
15:23 MorAle-temp left #fuel-dev
15:23 EeeBotu New bug #1319451 in fuel: "AMQP Channel errors in orchestrator logs" [Undecided, New] https://bugs.launchpad.net/bugs/1319451
15:25 jeremydei_ joined #fuel-dev
15:33 evgeniyl holser_: could you please try to provide more information, I described how to do it here https://bugs.launchpad.net/fuel/+bug/1319018/comments/3 also what iso did you use?
15:33 MorAle_ joined #fuel-dev
15:34 holser_ ok
15:34 evgeniyl holser_: also could you please attach logs /var/log/fuel_upgrade.log
15:34 holser_ evgeniyl: sure
15:35 holser_ let me run once again
15:36 mihgen bogdando: xenolog_ holser_ dilyin I talked over the phone with aglarendil. After we finish quick fixes with current bugs, we need to distribute tasks from https://etherpad.openstack.org/p/fuel-ha-rabbitmq between ourselves
15:36 mihgen we need to figure out how to quickly eliminate HA issues from there, and request additional info from aglarendil if needed
15:37 MorAle left #fuel-dev
15:38 evgeniyl holser_: it's really interesting bug, yesterday I checked it on the iso, and for Nastya it worked too.
15:38 holser_ k
15:50 bogdando mihgen, roger that
15:57 holser_ evgeniyl: also that would be nice to disable UI and API before upgrade script
15:58 holser_ just in case :)
15:59 evgeniyl holser_: we just shutdown all containers
15:59 holser_ evgeniyl: well I had 10 minutes until all containers are unpacked
16:11 holser_ evgeniyl: this time it passed DB upgrade
16:12 holser_ evgeniyl: I think it’s timeout issue as my hardware is slower than usual ;)
16:13 evgeniyl holser_: oh, could you please describe, what env do you use for testing?
16:13 holser_ evgeniyl: mc0n2-msk
16:15 Tatyanka_Leontov left #fuel-dev
16:16 evgeniyl holser_: I've tested on my i5 desktop in virtual box, I will install new iso and will try to reproduce it.
16:17 holser_ okey
16:24 EeeBotu New bug #1319461 in fuel: "Master node reboot problem" [Medium, New] https://bugs.launchpad.net/bugs/1319461
16:27 salmon_ joined #fuel-dev
16:45 salmon_ joined #fuel-dev
17:12 tzn joined #fuel-dev
17:18 e0ne joined #fuel-dev
17:27 tzn joined #fuel-dev
17:48 Ch00k joined #fuel-dev
17:54 tzn joined #fuel-dev
18:10 tzn joined #fuel-dev
18:15 teran joined #fuel-dev
18:28 e0ne joined #fuel-dev
18:45 xarses joined #fuel-dev
18:45 salmon_ joined #fuel-dev
18:46 salmon_ joined #fuel-dev
19:01 teran joined #fuel-dev
19:13 tzn joined #fuel-dev
19:13 teran joined #fuel-dev
19:49 teran joined #fuel-dev
20:17 xarses joined #fuel-dev
20:23 tzn joined #fuel-dev
20:46 evgeniyl holser_: I checked it again on 203 iso, I had 3 nodes, migrations worked just fine, please, try to run migrations manually, there should be some error, I'll try to take your db dump and reproduce the problem, but I don't think that I will be able to do it.
20:46 holser_ evgeniyl:
20:47 holser_ I have recreated env with 203
20:47 holser_ let me start
20:55 xarses joined #fuel-dev
21:22 holser_ evgeniyl: same thing
21:24 tzn joined #fuel-dev
21:50 teran joined #fuel-dev
21:59 holser_ left #fuel-dev
22:41 xarses joined #fuel-dev
23:34 xarses joined #fuel-dev

| Channels | #fuel-dev index | Today | | Search | Google Search | Plain-Text | summary