Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2014-03-12

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:00 richardkiene Anyone have some pointers on why Floating IP assignments might stop working?
00:01 Matt_V joined #fuel
00:10 IlyaE joined #fuel
00:29 dubmusic joined #fuel
01:03 aglarendil|home joined #fuel
01:04 jeremydei joined #fuel
01:04 bogdando joined #fuel
01:05 mattymo joined #fuel
01:07 rmoe joined #fuel
01:08 designated joined #fuel
01:10 designated has anyone successfully deployed openstack on ubuntu 12.04 using fuel 4.1?  It seems to work using centos but fails everytime with ubuntu, complaining about failed dependencies.
01:14 justif2 joined #fuel
01:19 TVR___ joined #fuel
01:19 17SAATCNX joined #fuel
02:07 vkozhukalov joined #fuel
02:09 dubmusic joined #fuel
02:18 Corleone joined #fuel
02:22 dburmistrov joined #fuel
03:16 xarses joined #fuel
03:17 ToTsiroll joined #fuel
03:18 ToTsiroll hi..any of you guys encounter problems with 4.1? i deployed in centos HA mode...i tried starting the ceph-radosgw service manually..but it keeps giving me errors
03:55 dubmusic joined #fuel
04:15 richardkiene joined #fuel
04:20 richardkiene joined #fuel
04:22 dburmistrov joined #fuel
04:58 ToTsiroll hi..any of you guys encounter problems with 4.1? i deployed in centos HA mode...i tried starting the ceph-radosgw service manually..but it keeps giving me errors
05:51 xarses ToTsiroll: just about to head off to bed, a number of the evening folks will come online soon. My guess is you should check the ceph cluster status first to see if it's healthy
05:53 vkozhukalov joined #fuel
06:06 evgeniyl` joined #fuel
06:07 miroslav_ joined #fuel
06:07 meow-nofer_ joined #fuel
06:19 xarses ToTsiroll: see https://bugs.launchpad.net/fuel/+bug/1276187
06:19 xarses specifically https://bugs.launchpad.net/fuel/+bug/1276187/comments/1 item 2
06:50 bookwar1 joined #fuel
06:52 saju_m joined #fuel
06:56 richardkiene_ joined #fuel
07:25 alex_didenko joined #fuel
08:40 e0ne joined #fuel
08:56 e0ne joined #fuel
08:57 e0ne_ joined #fuel
09:04 ToTsiroll cluster status is healthy...and im using 4.1
09:04 ToTsiroll the bug you posted was already commited to 4.1
09:05 ToTsiroll and its not a 400 error...it seems to be a permission problem
09:09 saju_m joined #fuel
09:13 topochan joined #fuel
09:26 GeertJohan joined #fuel
09:33 rvyalov joined #fuel
09:43 tatyana joined #fuel
09:55 warpig joined #fuel
09:57 DaveJ__ joined #fuel
10:28 rvyalov joined #fuel
11:23 e0ne joined #fuel
11:23 anotchenko joined #fuel
11:26 e0ne_ joined #fuel
11:29 e0ne_ joined #fuel
11:38 rvyalov joined #fuel
12:05 justif joined #fuel
12:13 e0ne joined #fuel
12:14 anotchenko joined #fuel
12:14 meow-nofer joined #fuel
12:16 meow-nofer__ joined #fuel
12:17 TVR joined #fuel
12:18 TVR morning fellow coudified folks...
12:20 MiroslavAnashkin morning
12:21 TVR I have some logs / snapshots if you would like them, as expanding my last cluster failed...was 3 controllers + ceph... tried to make it 5 controllers + ceph... failed miserably...
12:23 Dr_Drache joined #fuel
12:25 Dr_Drache blah.
12:25 Dr_Drache xarses, how come there are 2 anwsers to questiond?
12:25 Dr_Drache questions.
12:26 Dr_Drache lol
12:38 saju_m joined #fuel
12:38 MiroslavAnashkin TVR: Yes, please share the latest snapshot. I hope there is nothing related to multi-master rabbitMQ and new database connection settings
12:38 TVR ok.. where can I send it? ~ 50Mb
12:39 TVR my support might be up by now
12:40 MiroslavAnashkin Simply upload to any service like Google drive and post a link.
12:41 Dr_Drache TVR, MiroslavAnashkin, good morning
12:41 TVR oh, yea.. thx
12:48 TVR let me know if this works ... https://drive.google.com/a/techwiki.info/#folders/0B5xmhlRed6Nqb1VVTW1ENUdGU00
12:48 getup- joined #fuel
12:55 bogdando joined #fuel
13:07 MiroslavAnashkin TVR: After you uploaded something to Google drive you have to share it to make accessible by others
13:08 TVR done.. try again
13:23 warpig hi guys, quick question...
13:24 warpig any reason "fuel --env 1 deployment default" doesn't produce the default yaml files as described in the docs?
13:24 warpig (using 4.1)
13:29 dubmusic joined #fuel
13:34 Dr_Drache MiroslavAnashkin, has there been any ideas on my issue(s)? not suggesting anything be patched quite yet.
13:35 anotchenko warpig: try "fuel --env 1 deployment --default"
13:35 anotchenko Does it gives any errors?
13:36 warpig no errors, but same as before, only a directory is made
13:36 warpig "deployment_1"
13:39 evgeniyl` warpig: did you deploy your cluster? Or is it new?
13:39 warpig yes, I've already deployed a controller and two compute
13:42 evgeniyl` warpig: this command returns files for nodes which not deployed yet, anotchenko do you remember what parameter can we use to download files for any nodes?
13:43 warpig so if I destroy my environment and return all nodes to the bootstrap kernel will the yaml files be produced?
13:43 evgeniyl` warpig: I know that you can request this nodes directly via api e.g. master_node_ip:port/api/clusters/1/orchestrator/deployment/defaults?nodes=1,2,3,4
13:43 warpig OK, cool - one sec and I'll give that a try...
13:44 anotchenko you can try to run "fuel node --node-id 1 --deploy --default"
13:44 anotchenko to get deployment info for node 1
13:44 warpig it returns:  "--default", "--download" or "--upload" must appear after "--disk" or "--network" flags.
13:45 MiroslavAnashkin Dr_Drache: So far no ideas. VKozhukalov currently is in California, we'll try to reach him as they wake up.
13:45 jobewan joined #fuel
13:45 Dr_Drache MiroslavAnashkin, just checking in.
13:45 anotchenko my bad. It's not that
13:46 anotchenko you should try to access API directly
13:49 warpig anotchenko: the API call works, but it outputs JSON.  I'm looking for the yaml output so I can modify and re-import into Puppet so I can re-deploy with the required changes...
13:49 warpig (as described on page 21 of the reference architecture guide)
13:54 anotchenko warpig: please run "fuel --env 1 deployment --default --node-id 1 --debug" and paste output here
13:55 anotchenko but remove deployment_1 directory before that
13:58 warpig looking better!
13:58 warpig GET http://127.0.0.1:8000/api/v1/clusters/1/orchestrator/deployment/defaults/?nodes=1
13:58 warpig directory /root/deployment_1 was created
13:58 warpig Created /root/deployment_1/cinder_1.yaml
13:58 warpig Created /root/deployment_1/controller_1.yaml
13:58 warpig Created /root/deployment_1/ceph-osd_1.yaml
13:59 anotchenko If it will give any problems, try to remove directory
14:00 warpig I removed the directory before I ran this...
14:02 warpig so, my second question...  do I need to download the yaml and modify each and every node?
14:02 warpig or is there a default config that will apply to all nodes?
14:03 e0ne_ joined #fuel
14:06 evgeniyl` warpig: if you want to change some global parameter then you have to change it in each file.
14:07 warpig OK, cool.
14:08 warpig will that not get cumbersome on a large deployment?
14:13 evgeniyl` warpig: we already have some thoughts how to make it simpler, but we didn't have time to implement it yet. My suggestion is to use sed or to write simple script in python.
14:13 warpig haha!  OK, cool - I was already sedding away...  :o)
14:24 MiroslavAnashkin TVR: Hmm, still has no access to shared snapshot. Please select "Everyone with a link" in share options and provide this link.
14:26 TVR Please try this:
14:26 TVR https://drive.google.com/file/d/0B5xmhlRed6NqXzZwVk9qR05BNnM/edit?usp=sharing
14:26 MiroslavAnashkin TVR: Yes, this one works. Downloaded.
14:27 TVR cool.. let me know what 'jumps out' at you
14:35 e0ne joined #fuel
14:41 jobewan joined #fuel
15:02 IlyaE joined #fuel
15:03 bogdando joined #fuel
15:04 saju_m joined #fuel
15:05 brain461 left #fuel
15:08 jobewan joined #fuel
15:17 anotchenko joined #fuel
15:46 TVR anything jump out?
15:46 TVR MiroslavAnashkin .. sorry.. question was for you
15:53 aleksandr_null joined #fuel
16:03 Ch00k joined #fuel
16:13 MiroslavAnashkin TVR: Our current suggestion  - Neutron has 60 seconds timeout to start. So, if Neutron does not update DB in 60 seconds - deployment may fail.
16:14 MiroslavAnashkin TVR: still digging.
16:16 dburmistrov joined #fuel
16:17 xarses joined #fuel
16:18 vkozhukalov joined #fuel
16:29 rmoe joined #fuel
16:30 richardkiene joined #fuel
16:33 TVR so.. the storage network and the management network...both in CIDR format... what is the first IP issued, is it the .1 IP?
16:35 angdraug joined #fuel
17:07 dubmusic_ joined #fuel
17:16 xarses TVR: .2, you can manually adjust the ranges in the db if necessary
17:16 xarses Dr_Drache: 2 answers
17:16 TVR cool, but by default, does it issue out .1?
17:16 xarses ?
17:16 TVR guess I will look it up..
17:16 saju_m joined #fuel
17:17 xarses no they there is some code to prevent issuing .1
17:18 xarses s/they//
17:18 TVR cool
17:19 Dr_Drache hmmm
17:19 Dr_Drache xarses, don't worry bout it
17:21 xarses TVR: http://paste.openstack.org/show/73273/
17:22 xarses if you need to manually move the offset, you can either update the row, or create new splits
17:22 xarses Feel free to create a bug about not being able to reasonably set the ranges, it will help get it prioritized
17:23 TVR ok.. cool.. thanks man
17:25 xarses TVR: https://github.com/stackforge/fuel-web/blob/master/nailgun/nailgun/network/manager.py#L325
17:26 xarses oops, wrong line, https://github.com/stackforge/fuel-web/blob/master/nailgun/nailgun/network/manager.py#L323
17:26 Dr_Drache justif,
17:28 xarses TVR: hmm, actually it will attempt to use .1 if gateway wasn't set on the network
17:30 TVR I am talking about the storage and management networks... the public you set when installing fuel, and you specify range for public and floaters... but the storage and management are CIDR format, so if those are routable, I can see a conflict happening
17:31 TVR so, as an example... my storage is 10.7.214.0/24 on vlan 214 .... but it's routable, so .1 is taken
17:31 xarses TVR: you are correct, you should change the range in the db before you assign any nodes
17:31 xarses internal_address: 192.168.0.1
17:31 xarses storage_address: 192.168.1.1
17:40 TVR going to try to add controllers + ceph again
17:50 rmoe_ joined #fuel
18:01 IlyaE joined #fuel
18:03 dubmusic joined #fuel
18:20 aglarendil joined #fuel
18:25 xarses TVR: any love?
18:25 TVR not yet.... and not promising...
18:25 TVR so this is my process:
18:26 TVR load up 4 instances.. give floating ip to them... ssh to them and run a script in a loop continuously creating a 100M file and deleting it
18:26 TVR then... add the controllers + ceph
18:27 TVR that simulated a real world scenario
18:27 rvyalov joined #fuel
18:29 e0ne joined #fuel
18:39 tatyana joined #fuel
18:40 getup- joined #fuel
18:45 dubmusic d
18:47 TVR d?
18:56 TVR so... adding the controllers failed...
18:56 Dr_Drache heh
18:58 TVR and so my instances seemed to have survived....but their throughput seems to have tanked... even though ceph -s shows as healthy and shows the new OSD's are in
18:59 TVR I will let this all settle.. and click redeploy again
19:00 e0ne joined #fuel
19:01 tatyana joined #fuel
19:20 designate has anyone successfully deployed openstack on ubuntu 12.04 with fuel 4.1?  Every time I try I wind up getting a "failed dependencies error" during apt-get.
19:25 topochan joined #fuel
19:26 dhblaz joined #fuel
19:27 xarses designate: that is odd, you might want to re-copy the deb packages from the ISO
19:28 xarses designate: what package is comming up missing?
19:29 designate my friend has the relevant logs along with a diagnostic snapshot.  I'll try to have him jump on real quick.
19:29 mcfaddle joined #fuel
19:32 designate mcfaddle, I briefly explained the issue we're seeing when trying to deploy openstack HA with neutron/VLANS regarding the failed dependency issue.  xarses is asking about missing packages, can you give him the exact error we're seeing?
19:33 designate centos seems to work, it's only when trying to deploy on ubuntu that we're seeing this issue.
19:36 mcfaddle sure, during openstack install we are getting pretty consistently across all controllers :ERR (/Stage[main]/Nova::Utilities/Package[guestmount]/ensure) change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install guestmount' returned 100: Reading package lists..."
19:36 mcfaddle then all other subsequent packages fail.
19:45 Dr_Drache I think that's a VLAN issue.
19:46 TVR after ~ 30+ minutes.... my instances are back up > 80MB/s for the create  and destroy a file from in ceph storage....
19:47 TVR after I had added the 2 controllers, my throughput was ~= 2MB/s
19:47 TVR it was like that for > 15 min
19:48 xarses TVR: sounds like the new osd's might be getting backfilled
19:48 Dr_Drache xarses, dammit, I was just typing that
19:48 Dr_Drache :P
19:48 designate Dr_Drache, why do you think it's a VLAN issue?
19:48 TVR yea.. was thinking that myself... just reporting in here...
19:49 designate same switch configuration, same NIC assignments for network roles, centos works, ubuntu fails.
19:49 Dr_Drache designate, just resembles some issues I had with vlan/ubuntu
19:49 TVR I imagine, if I had gone from 60 to 66 OSD's rather than going from 6 to 9 it would be less impacktfull
19:49 xarses designate: thats a compute role right?
19:49 designate xarses, no, this is during controller install
19:50 dhblaz When I have a floating ip assigned to a vm network connectivity to my upstream network is sporadic
19:51 dhblaz When I do a tcpdump -i any host <floating-ip>
19:51 dhblaz I see the neutron router ip doing arp for the floating-ip
19:51 dhblaz over and over again
19:51 mcfaddle xarses: 3 controllers, 4 computes; all 3 controllers fail to install openstack and puppet errors are pretty much identical.  full error log: http://paste.openstack.org/show/73296/
19:51 dhblaz if I do tcpdump -i any on the node with the l3-agent
19:51 dhblaz it usually fixes the problem
19:52 TVR running tcpdump fixes the issue?
19:52 TVR how?
19:53 dhblaz I would say because it puts the card in promiscuous mode but I don't think that -i any does
19:55 Ch00k joined #fuel
19:57 xarses dhblaz: what is the os / nic_driver (ethtool -i) / network manager / segment type ?
19:57 xarses and still fuel 4.0?
19:57 dhblaz centos fuel 4.0 neutron vlan
19:58 Dr_Drache xarses, do you still have access to the older patches?
19:58 Dr_Drache for 4?
19:58 Dr_Drache (namly the networking backport, and the v4 patch)
19:59 dhblaz There are three types of nic drivers in this cluster
19:59 dhblaz Controllers have both of these:
19:59 dhblaz e1000e, bnx2
20:00 dhblaz and computes and storage have bnx2x
20:00 dhblaz xarses: do you want version numbers a reported by ethtool -i
20:00 xarses did you enable vlan splinters? which mode ?
20:01 dhblaz I didn't use vlan splinters using your feature
20:01 xarses no, the driver names are all i need usually
20:01 dhblaz but I later enabled vlan splinters
20:01 dhblaz let me find the command I used
20:01 MiroslavAnashkin mcfaddle: Please generate diagnostic snapshot and share it somewhere. Though, I don't think guestmount may depend on any hardware...
20:01 xarses the one liner per interface, soft mode.
20:03 xarses mcfaddle: designate, the packages are present on my install, do an apt-get update and see if you can 'apt-get install nova-api'
20:03 dhblaz I used a for loop to iterate over all of the interfaces
20:03 dhblaz I just need to find what the for loop did.
20:04 xarses dhblaz: something like: ovs-vsctl set interface eth1 other-config:enable-vlan-splinters=true
20:04 dhblaz that looks familiar
20:05 dhblaz for interface in eth0 eth1 eth2 eth3 ; do ovs-vsctl set interface $interface other-config:enable-vlan-splinters=true; done
20:06 dhblaz I have also used ovs-vlan-test and never had a failure
20:06 xarses for funzies, you could shorten the eth list to eth{0,1,2,3} and the shell will expand it to 'eth0 eth1 eth2 eth3'
20:06 xarses but ya, thats fine
20:10 dhblaz I just checked the interfaces on node-18 (l3-agent controller) and node-24 (compute node for instance) with the command
20:10 dhblaz ovs-vsctl get interface eth0 other-config:enable-vlan-splinters
20:10 dhblaz all interfaces say either true or no row
20:10 dhblaz (the PXE interface shows no row...)
20:11 mcfaddle MiroslavAnashkin: https://drive.google.com/file/d/0Bz7z6VqivHuAWlloOXpoSm1DeDQ/edit?usp%3Dsharing
20:14 designate xarses, Redeploying the environment now so we can get to the point of failure.
20:15 Dr_Drache MiroslavAnashkin, do you still have the link for the patches for 4.0?
20:17 xarses dhblaz: can you 'for iface in eth{0,1,2,3} ; do ethtool -k $iface ; done' and paste the results from the l3-agent
20:18 MiroslavAnashkin Dr_Drache: http://download.mirantis.com/fuelweb/  All 2 are there
20:18 MiroslavAnashkin Dr_Drache: Please note - these are for 4.0!
20:19 Dr_Drache MiroslavAnashkin, understandable, I need to get back to testing, and 4.1 obviouslly isn't for me yet.
20:19 dhblaz xarses: http://paste.openstack.org/show/73300/
20:20 dhblaz xarses: I don't have them problem if I am not using a floating-ip
20:20 dhblaz xarses: or rather I only have this problem when I use a floating-ip
20:21 dhblaz I would have guessed it had something to do with NAT because of that
20:21 xarses even odder. Is there a vlan tag on the public interface?
20:21 justif has anyone see the link error deploying centos? http://i.imgur.com/GPkNphb.png
20:22 dhblaz yes
20:23 justif simple fix?
20:23 MiroslavAnashkin TVR: OK, looks like your primary controller failed due to Ceph issue. And adding new controllers became more tricky with latest CRM scripts for MySQL. Need to think out what we may do with both issues.
20:24 TVR OK.. well when this finishes, I will give you these logs as well, so we can see if the issue repeates itself
20:24 xarses dhblaz: eth2, eth3 have gro (generic-receive-offload) on, while 0,1 don't if your public is on them i'd try ethtool -K <iface> gso off
20:25 TVR it failed the first time once more, but this time I gave it an hour to settle
20:25 dhblaz I believe that this is my public interface:
20:25 dhblaz eth1.291  Link encap:Ethernet  HWaddr 00:1B:78:29:9E:01
20:25 dhblaz inet6 addr: fe80::21b:78ff:fe29:9e01/64 Scope:Link
20:25 dhblaz UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
20:25 dhblaz RX packets:857273606 errors:0 dropped:0 overruns:0 frame:0
20:25 dhblaz TX packets:15351198 errors:0 dropped:0 overruns:0 carrier:0
20:25 dhblaz collisions:0 txqueuelen:0
20:25 dhblaz RX bytes:677301649093 (630.7 GiB)  TX bytes:5415949196 (5.0 GiB)
20:27 MiroslavAnashkin justif: Cobbler partition manager generated incorrect settings for GRUB. It is third month we are trying to fix this issue firmly for all HP Smart Array RAID controllers.
20:27 xarses dhblaz: there was some other option I remember hearing about trying, but I can't find a link to it. I'll have to ask a co-worker. The fact that tcpdump makes it come alive makes me think one of the offload mechanisms is messing you up
20:28 dhblaz The next time it happens I could try using tcpdump on each of the vlan sub interfaces to see which one fixes it.
20:29 dhblaz I think I would just have to try the private and public
20:29 dhblaz on my network the neutron router is on .153 and this time the float was on .154
20:30 dhblaz I don't understand why I would see .153 arp for .154
20:30 dhblaz I wouldn't expect this packet to leave open vswitch
20:30 dhblaz if the NAT was configured properly
20:30 dhblaz because there would have to be ARP proxy for .154
20:31 dhblaz otherwise the local segment wouldn't be able to talk to it on the float
20:32 Dr_Drache MiroslavAnashkin, he has the same HP's as me, with the same controllers.
20:32 dhblaz I use HPs too!
20:33 dhblaz Is 4.1 having trouble with HP Smart Arrays?
20:34 dhblaz I believe I had to apply the patches I submitted to mirantis for cciss partition naming scheme to 4.0
20:36 xarses dhblaz: the cciss patches fixes should still be there (in spirit) there was a section that was refactored that shouldn't but could cause the issue to come up again
20:36 justif wonder if I have a bad iso then
20:36 e0ne joined #fuel
20:38 Dr_Drache justif, check the md5
20:40 justif 7049520bc641df15de1fe0e572c70001
20:40 xarses dhblaz: ok, spoke with co-worker the other bnx2 driver change we have seen that fixed occasional packet loss was tcp-segmentation-offload, setting it to off helped
20:41 dhblaz okay, should I do that on all bnx2 interfaces?
20:41 Dr_Drache justif, you have a proper iso
20:41 Dr_Drache meaning, the patches arn't there, or arn't working.
20:42 MiroslavAnashkin Latest cciss partitioning patch is in 4.1.
20:42 xarses dhblaz: worth a shot
20:42 e0ne joined #fuel
20:43 dhblaz xarses: the public interface is e1000e
20:45 xarses dhblaz: hmm, and the private?
20:45 dhblaz e1000e
20:45 dhblaz The controllers are setup like this:
20:46 xarses justif: please post the kickstart for the node something like https://<fuel server>/cblr/svc/op/ks/system/<node-name>
20:46 xarses node name will be something like node-1
20:46 dhblaz eth2 - bnx2 (onboard) PXE
20:46 dhblaz eth3 - bnx2 (onboard) Management
20:47 dhblaz eth0 - e1000e (PCI) Private
20:47 justif xarses http://paste.openstack.org/show/73305/
20:47 dhblaz eth1 - e1000e (PCI) VLAN Tagged Public/Storage
20:52 xarses justif: can you switch to a pty on that anaconda run (alt + f2) and ll /dev/block ; ll /dev/cciss*
20:52 xarses justif: sorry not /dev/block /sys/block
20:56 justif sh: ll: command not found
20:56 Dr_Drache justif, i think it's ls
20:56 Dr_Drache :P
20:57 xarses justif: ls -l
20:57 justif figured something was off
20:58 justif http://i.imgur.com/7pIsfIh.png
21:02 vkozhukalov joined #fuel
21:06 xarses justif: can you cat /tmp/partition.ks on the anaconda node
21:07 justif http://i.imgur.com/xdk3B7m.png
21:10 xarses justif: can you ls -l /dev/cciss!c0d0
21:11 xarses justif: also readlink -f $( ls /dev/cciss!c0d0 )3
21:12 justif the command fails with sh: !c0d0: event not found
21:17 e0ne joined #fuel
21:22 mcfaddle xarses: per your request, ran "apt-get update" and "apt-get install nova-api" on failed ubuntu 12.04 controller, fuel 4.1 HA 3 controller/4 compute neutron vlan based install.  http://paste.openstack.org/show/73311/
21:27 xarses justif, can you paste http://<fuelnode>:8000/api/nodes/16
21:29 justif http://paste.openstack.org/show/73312/
21:32 angdraug mcfaddle: what happens when you try "service start qemu-kvm", can you get any more output from it?
21:33 mcfaddle angdraug: "start: unrecognized service"
21:37 xarses dhblaz: can you paste ls -l /dev/cciss* ; ls -l /sys/block?
21:37 dhblaz Sure from just the machines with that raid card?
21:37 dhblaz Or from my other hp equipment too?
21:38 xarses just one of the ones with the cciss controllers
21:40 dhblaz http://paste.openstack.org/show/73314/
21:40 designate it looks like the precise repo hosted on fuel might be missing packages defined as dependencies.
21:41 designate xarses, MiroslavAnashkin, any suggestions?
21:41 xarses designate: yep, should probably be copied back off the iso
21:43 designate xarses, where does fuel store those packages exactly?
21:43 designate fyi it wasn't installed from an iso, a .img was used to create a bootable USB stick
21:43 designate don't know if that is contributing to the problem
21:44 TVR as expected, the re-deploy did not succeed...
21:44 TVR MiroslavAnashkin shall I take a snapshot and post the logs for you?
21:44 TVR the instances are still up and running though.. that's good
21:46 xarses designate: http://paste.openstack.org/show/73316/ thats how they are put there in the first place
21:47 designate xarses, thanks I'll try that this evening.
21:47 xarses you will want to 'cobbler sync' afterwards
21:47 angdraug joined #fuel
21:54 dhblaz xarses: did you need anything else from me wrt cciss?
22:00 xarses nope, I see the issues
22:00 dhblaz Any other ideas about my issue?
22:01 xarses not at this time other than systematically disabeling each offload until you find a magic one
22:01 xarses or try the fedora-lt kernel
22:01 xarses 3.10
22:08 justif heading out but will be on later
22:08 getup- joined #fuel
22:11 dhblaz When we tried the other 3.10 kernel you suggested we had a number of problems with firmware
22:11 dhblaz We had to dismantle our lab but I'll look into it when we have it setup again
22:11 dhblaz Too high risk for production environment
22:12 dhblaz Any thoughts about the ARP observations?
22:25 e0ne joined #fuel
22:33 angdraug mcfaddle_afk: https://github.com/stackforge/fuel-library/blob/master/deployment/puppet/nova/manifests/compute/libvirt.pp#L12
22:33 angdraug just a shot in the dark, but maybe that symlink got lost in the manual upgrade of qemu-kvm?
22:43 bookwar1 joined #fuel
22:46 dhblaz What is expected with neutron floating IPs with regard to mac addresses.  Should hosts on the LAN segment shared with the floating IPs have the mac address shown for the port in neutron port-list or the mac-address shown for the router's port?
22:52 dhblaz Also when I do neutron port-show for the floating IP's port
22:52 dhblaz I see status DOWN
23:00 dhblaz Hmmm, show status DOWN even when it works
23:01 justif joined #fuel
23:11 tatyana joined #fuel
23:30 designate_ joined #fuel
23:37 xarses justif: still around?
23:37 justif yar
23:38 xarses We'll have a patch for you to try in a few min
23:38 justif ooohhh awesome
23:55 dhblaz Anyone know why my l3_agent.ini has this setting?
23:55 dhblaz send_arp_for_ha = 8
23:56 dhblaz As best I can tell this accepts values true,false
23:57 rmoe_ it takes an integer
23:57 rmoe_ https://github.com/openstack/neutron/blob/stable/havana/etc/l3_agent.ini#L49-L51
23:59 dhblaz Thanks

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary