Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2014-04-10

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:15 rnelan joined #fuel
00:15 rnelan sorry folks, had to move a rack.. missed the conversation.. something about windows cloud init tools?
00:18 justif joined #fuel
00:19 justif joined #fuel
00:20 xarses rnelan: mutex recommended installing cloud-init-tools for windows. I noted that cloud-init is a requirement in my book
00:20 xarses logs are http://irclog.perlgeek.de/fuel/, its in the topic =)
00:21 rnelan you are teaching a man to fish xarses.. ;) thanks!
00:30 isAAAc joined #fuel
01:07 sunxin3 joined #fuel
01:17 Arminder- joined #fuel
01:17 IlyaE joined #fuel
01:21 aedocw_ joined #fuel
01:37 rmoe joined #fuel
01:50 ilbot3 joined #fuel
01:50 Topic for #fuel is now Fuel 4.1 for Openstack: http://fuel.mirantis.com/ | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
02:05 dhblaz joined #fuel
02:11 dhblaz joined #fuel
02:37 justif joined #fuel
02:38 racingferret joined #fuel
02:49 sunxin3 joined #fuel
02:51 dhblaz joined #fuel
03:24 fandi joined #fuel
04:02 Akshik joined #fuel
04:32 aleksandr_null joined #fuel
04:44 fandi joined #fuel
05:02 Akshik are there any RBAC for fuel
05:11 neophy joined #fuel
05:15 sunxin3 joined #fuel
05:20 IlyaE joined #fuel
05:56 dburmistrov_ joined #fuel
06:10 piersdd joined #fuel
06:11 piersdd Have somewhat successfully installed a HA Neutron cloud using 4.1, however Horizon fails.. leavinga 504 Gateway Time-out error.  Any ideas?
06:13 piersdd also, looking at /var/log/user.log on a controller node, I see a zfs-fuse message.  Where to look to learn about the use of ZFS within Fuel?  TIA, Piers
06:35 vk joined #fuel
06:38 al_ex joined #fuel
06:49 mihgen joined #fuel
07:10 holser joined #fuel
07:40 e0ne joined #fuel
07:53 e0ne_ joined #fuel
08:02 e0ne joined #fuel
08:02 topochan joined #fuel
08:05 m_ joined #fuel
08:09 holser joined #fuel
08:18 monester joined #fuel
08:21 Akshik joined #fuel
08:22 Akshik Hi Team
08:23 Akshik can we enable authentication for the fuel interface
08:25 rvyalov joined #fuel
08:30 bogdando joined #fuel
08:53 mihgen joined #fuel
08:55 vk joined #fuel
08:57 tatyana joined #fuel
09:00 holser joined #fuel
09:15 jkirnosova joined #fuel
09:20 evg joined #fuel
09:29 IlyaE joined #fuel
09:40 neophy joined #fuel
09:43 topochan joined #fuel
09:56 anotchenko joined #fuel
10:02 evg Akshik: hi, something like: location / {auth_basic "blabla"; auth_file .htpass;} in nginx's config
10:13 mattymo but you'll break Health Check from being able to make API calls back to Fuel Web if you add a password
10:13 mattymo you have to whitelist localhost requests and allow them to make calls unauthenticated
10:14 aglarendil|nb joined #fuel
10:23 anotchenko joined #fuel
10:33 rvyalov joined #fuel
10:47 rvyalov joined #fuel
10:53 e0ne joined #fuel
10:58 Akshik joined #fuel
11:07 al_ex joined #fuel
11:16 nikalgiv joined #fuel
11:21 holser joined #fuel
11:26 neophy I am getting this warning : http://derp.co.uk/eb8bf while configuring.
11:30 racingferret neophy: you have another DHCP server on the network that eth0 is attached to
11:31 racingferret Fuel configures it's own DHCP server in order to provision the other hosts.
11:34 neophy racingferret: How to avoid this? It requires completely different network?
11:35 racingferret neophy: yes.  you can't have two DHCP servers on the same network or they'll clash
11:44 aglarendil|nb joined #fuel
11:46 e0ne joined #fuel
11:47 topochan joined #fuel
11:48 TomekG joined #fuel
11:49 e0ne joined #fuel
11:55 neophy racingferret: Ok. I tried fuel with automatic installation in VM environment. It woks fine without any issue. I am trying to install Fuel in physical environment to give demo of Fuel Web UI. I am always struggling in network configuration part. Even after reading Fuel installation doc multiple times I am not able to configure it properly. I am trying in a physical machine where there are three network interface card.
11:56 neophy do you have any link with fuelmenu network configuration with step by step screen short?
12:00 e0ne joined #fuel
12:05 Akshik joined #fuel
12:20 evg neophy: network configuration is well documented in installation guide. Do you have some complicated network?
12:24 neophy evg: It is managed by other team. It seems in my network there is one DHCP server 10.0.0.12. I have asked ip address from isolated network.
12:24 justif joined #fuel
12:27 neophy evg: It requires at least two interface right? my confusion is how to configure two interface and make it up in fuelmenu after first reboot
12:47 anotchenko joined #fuel
12:51 piersdd joined #fuel
13:04 nikalgiv neophy - do you have IPMI
13:05 nikalgiv that is requird if you would like to change IPs
13:05 nikalgiv or attach monitor to that fuel machine and keyboard - then change IPs as required
13:06 nikalgiv I did not try to change showmenu=yes in first boot screen - that should give you fuelmenu before first reboot as I understood
13:07 xdeller joined #fuel
13:11 Nanoflex joined #fuel
13:16 ogelbukh joined #fuel
13:50 saju_m joined #fuel
13:59 topochan joined #fuel
14:08 e0ne joined #fuel
14:08 jobewan joined #fuel
14:11 e0ne_ joined #fuel
14:17 topochan joined #fuel
14:22 justif2 joined #fuel
14:30 xarses joined #fuel
14:40 anotchenko joined #fuel
15:02 IlyaE joined #fuel
15:03 xarses joined #fuel
15:57 e0ne joined #fuel
16:02 rmoe joined #fuel
16:08 bookwar joined #fuel
16:10 crandquist joined #fuel
16:15 aglarendil joined #fuel
16:27 e0ne joined #fuel
16:27 xarses joined #fuel
16:36 xarses joined #fuel
16:37 holser joined #fuel
16:48 saju_m joined #fuel
16:52 IlyaE joined #fuel
16:59 dburmistrov_ joined #fuel
17:02 rvyalov joined #fuel
17:23 Nanoflex joined #fuel
17:35 IlyaE joined #fuel
17:43 gleam joined #fuel
17:59 rnelan joined #fuel
18:01 rnelan you know, I always try to solve my own problems before seeking help... but since last night, I just cant solve this one.. I need to build a windows server image to upload into glance.. I have at my disposal a Win2012R2 server running hyper-v, an apple macbook pro and an old sony laptop with a centrino processor in which to create this image.. every instruction I have read assumes that you start with a linux machine running kvm..
18:01 rnelan is there another instruction that will tell me how to build an image in hyper-v or virtualbox?
18:03 MiroslavAnashkin http://docs.openstack.org/image-guide/content/
18:04 rnelan reading that now..
18:05 rnelan but, again, the very first step assumes you have libvirt running
18:06 MiroslavAnashkin Yes, the best way is to install Windows right to OpenStack VM, and then run sysprep against this installation.
18:08 rnelan so, I do that from the compute node, right? well those nodes dont have cd drives.. so, I would have to scp them over..
18:08 rnelan I have virtualbox on my mac.. I can build out the image there, and save it as a qcow and then import it from horizon.. but there are these drivers that need to be installed also? libvirt?
18:08 MiroslavAnashkin No, you should upload Windows DVD image to OpenStack as CD image, mount it as CD image to VM and boot from it
18:10 rnelan is the virtualbox route a good route?
18:11 MiroslavAnashkin Yes, you may create VirtualBox VM with Virtio bus and devices and install Windows to this VM for future sysprep run.
18:11 rnelan exactly what i needed to know.. thanks miroslav.. now, I am going to kick of the install..
18:18 xarses joined #fuel
18:19 MiroslavAnashkin And when you come to run sysprep -  Remove the 'generalize' section from unattend.xml.
18:20 MiroslavAnashkin You need Virtio drivers remained installed in your image
18:29 BillTheKat joined #fuel
18:34 Gil_McGrath I have standard fuel openstack environment up and I neutron over VLAN (not GRE).  I want to create a second external network - everything seems to created fine and the tenants can see the external network, create routers, floating IPs etc. Except when using this external network - I can not ssh-keys from from meta data server, it says 169.254.169.253 unreachable - the command I used to create the second extern network is
18:34 Gil_McGrath : neutron net-create  --provider:physical_network=physnet2 --provider:network_type=vlan --provider:segmentation_id=906 --router:external=true  net906_ext
18:35 mjeanson joined #fuel
18:49 xarses joined #fuel
19:05 MiroslavAnashkin Gil_McGrath: Have you added  'metadata_port = <port>' to the second L3 agent? Please check https://answers.launchpad.net/neutron/+question/237835 for details.
19:08 Gil_McGrath thanks - let me look at this in more detail - thanks for the pointer
19:13 Gil_McGrath MiroslavAnashkin: metadata_port = 8775 already in l3_agent.ini and nova_metadata_port = 8775 in metadata_agent.ini
19:15 Gil_McGrath MiroslavAnashkin: I also tried to add in a host route 169.254.169.254/32,135.25.92.4 the DHCP server - that also did not work
19:17 MiroslavAnashkin Please check if  'handle_internal_only_routers = False' is set for both L3 agents.
19:19 holser joined #fuel
19:23 Gil_McGrath MiroslavAnashkin: it is not set at all in ls_agent.ini - what do you mean both l3 agents?
19:31 MiroslavAnashkin I mean http://docs.openstack.org/havana/config-reference/content/adv_cfg_l3_agent_multi_extnet.html.
19:32 Gil_McGrath thanks - let me do some more research thenm
19:32 Gil_McGrath thanks for the pointer
19:57 thehybridtech joined #fuel
20:15 e0ne joined #fuel
20:24 xarses joined #fuel
20:29 saju_m joined #fuel
20:32 e0ne joined #fuel
20:43 owentl joined #fuel
20:43 e0ne joined #fuel
21:10 xarses joined #fuel
21:11 e0ne joined #fuel
21:22 akasatkin joined #fuel
21:46 tatyana joined #fuel
22:03 rnelan joined #fuel
22:04 rnelan ok, another q... is there a limit to the size of an image that can be uploaded to glance off the command line? or out of the web page?
22:08 tsduncan_ joined #fuel
22:42 xarses rnelan: not that I'm aware of. I've seen images over 50gb uploaded. Although depending on your env this may take for ever to provision if you do
22:44 the_hybrid_tech joined #fuel
22:49 tatyana joined #fuel
22:54 rnelan maybe it is a file type problem then.. when I try vdi or qcow, the page just sits there.. raw or .qcow2 and it goes fine..
23:21 rnelan joined #fuel
23:21 justif joined #fuel
23:36 thehybridtech joined #fuel
23:42 tsduncan__ joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary