Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2014-04-11

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:27 rmoe joined #fuel
00:32 rnelan joined #fuel
00:32 rnelan ok, Xarses.. I give up..
00:33 rnelan I tried and tried.. nothing I could do will get my windows image into horizon..
00:34 rnelan I even tried importing cloudbase.it Server 2012.... the web page just sat there..
01:33 crandquist joined #fuel
01:39 thehybridtech joined #fuel
01:56 piersdd joined #fuel
01:58 crandquist joined #fuel
02:00 chinalujw joined #fuel
02:46 chinalujw left #fuel
03:04 dburmistrov_ joined #fuel
03:05 evgeniyl joined #fuel
04:16 xarses joined #fuel
05:16 saju_m joined #fuel
05:20 mihgen joined #fuel
05:32 IlyaE joined #fuel
06:26 mihgen joined #fuel
06:42 al_ex joined #fuel
07:02 pbrooko joined #fuel
07:10 IlyaE joined #fuel
07:26 e0ne joined #fuel
07:36 sbartel joined #fuel
07:37 sbartel hello
07:37 e0ne joined #fuel
07:37 sbartel I have a problem on boostrap of iblm server x3550
07:37 sbartel the centos installed during bootstrap doesn't seems to be able to see the server disk
07:37 sbartel it is shown as ?Bytes
07:38 sbartel so adding one of these server to an environment leading to an error
07:41 holser joined #fuel
08:04 mihgen joined #fuel
08:18 e0ne joined #fuel
08:36 sbartel is there a way to delete discovered node from inventory?
08:54 holser joined #fuel
09:20 monester joined #fuel
09:27 e0ne joined #fuel
09:29 aglarendil|nb joined #fuel
09:39 e0ne joined #fuel
09:45 racingferret sbartel: do you have a raid controller in the host?
09:46 sbartel no
09:46 sbartel excuse me
09:46 sbartel yes there is a raid
09:47 e0ne joined #fuel
09:47 racingferret have you defined a logical drive within the controller itself?
09:52 evg joined #fuel
10:02 saju_m joined #fuel
10:50 anotchenko joined #fuel
10:59 fandi joined #fuel
11:02 holser joined #fuel
11:15 al_ex joined #fuel
11:15 TomekG Hell, I am evaluating Fuel, and during new environment setup process I am restricted to use the same network for public and floating IPs purposes. In addition, all nodes has IP from this subnet assigned. I would like to avoid wasting of public IPv4 adressess. An ideal solution would be to assign private subnet for nodes and API, and add additional addresses to particular instances as a floating IP, but I don't see such option in FuelWEB.
11:16 TomekG s/Hell/Hello/ :)
11:16 aglarendil|nb joined #fuel
11:27 nikalgiv joined #fuel
11:35 racingferret TomekG: when creating a new environment within Fuel, you have the option to set any subnet you like for the Public/Floating range
11:50 saibarspeis joined #fuel
11:53 mihgen TomekG: hi, yes, unfortunately it's current limitation
11:53 mihgen we are working on fixing this
11:54 mihgen you might see email in openstack-dev with subject [Fuel][Neutron] Networking Discussions last week
11:55 mihgen TomekG: please follow up there if you have any additional suggestions / use cases. For now, you can still use CLI to remove unneeded IPs
11:56 anotchenko joined #fuel
11:59 nikalgiv joined #fuel
12:10 TomekG OK, thanks for info, I'll monitor that thread
12:11 TomekG So how really big deployments looks like? Are all floating IP in one huge subnet?
12:23 mutex_ joined #fuel
12:25 MiroslavAnashkin It is possible to add several subnets and even multiple external networks to OpenStack installation. So, one huge subnet is not the only solution.
12:31 dburmistrov_ joined #fuel
12:57 holser joined #fuel
12:57 al_ex joined #fuel
13:03 nikalgiv joined #fuel
13:11 DaveJ__ joined #fuel
13:12 TomekG @Miroslav, is it possible to add that subnets via FuelWeb? I can add multiple ranges in Networks->Public->Ip ranges, but all the must be in one subnet. And this is not configurable after deployment. Should I edit some YAMLs to do this?
13:14 TomekG Or directly in openstack's horizon.
13:29 aglarendil|nb joined #fuel
13:42 MiroslavAnashkin TomekG: With current Fuel version you may configure only single external network. We have plans to allow to configure multiple custom networks with future Fuel versions.
13:43 MiroslavAnashkin With Horizon you may add new Network. To add subnet to existing network you have to use OpenStack CLI.
13:45 MiroslavAnashkin And you may have to do some manual changes in configuration after adding new network with Horizon. Horizon functionality is a bit limited and added network may not work out of the box.
13:46 MiroslavAnashkin Small correction - You may add subnet with Horizon in scope of new network creation.
14:00 IlyaE joined #fuel
14:02 thehybridtech joined #fuel
14:24 e0ne_ joined #fuel
14:28 bogdando joined #fuel
14:30 jobewan joined #fuel
14:35 vk joined #fuel
14:40 anotchenko joined #fuel
14:46 TomekG Miroslav, thanks. I'll try to do it in this way.
14:47 e0ne joined #fuel
14:52 bookwar joined #fuel
14:54 e0ne joined #fuel
14:55 Akshik joined #fuel
14:58 xarses joined #fuel
15:06 fandi joined #fuel
15:08 Akshik Hi im not able to reach my fuel master ip
15:09 Akshik and from fuel master im not able to ping gateway ip
15:09 Akshik do i need to fix something
15:10 lromagnoli joined #fuel
15:11 lromagnoli hi did Mirantis OpenStack support deploing on vmware for testing purpose?
15:12 MiroslavAnashkin Akshik: Where did you installed your Mirantis OpenStack master node? Is it virtual machine or hardware node?
15:12 Akshik in a physical environment
15:13 Akshik seperate hardware node only
15:14 lromagnoli all can be done in virtual eviroment and maybe compute can be two phisical node
15:14 lromagnoli The Master Node is virtual now
15:15 lromagnoli is a lab not production, to have a look as it sounds
15:15 MiroslavAnashkin lromagnoli: Yes. You have to allow promiscuous mode on all virtual NICs and it should work fine. For better results please use "vlance" or "virtio" virtual network card models
15:16 lromagnoli and if i want to connect two phisical kvm the virtual switch as to have vlan id 4095
15:17 lromagnoli it's quite strange configuration i'm sorry
15:18 MiroslavAnashkin Akshik: First, run ip a or ipconfig on your local machine to check your current network IP and mask. Then, please recall, if you changed default network parameters during the Fuel master node installation.
15:19 lromagnoli U mean that after deplying a Correct Master node configuration U can support my "quite strange" lab?
15:19 lromagnoli sorry for my english i'm italian
15:19 lromagnoli ;-)
15:19 Akshik MiroslavAnashkin:actually i did changed the netwoek configuration during my installation process
15:19 MiroslavAnashkin lromagnoli: Mirantis OpenStack admin network must be untagged. If possible - you may set your switch port to Access Port mode and assign necessary VLAN number as default VLAN for your access port
15:21 MiroslavAnashkin Akshik: So, if your machine and master node reside in different network segments - you have to add route to master node on your local machine
15:22 Akshik MiroslavAnashkin:why am i not able to ping the gateway from my master node
15:22 Akshik are there any configuration which im missing
15:25 lromagnoli MiroslavAnashkin: I can completely destroy my lab i've got 3 old computer to use as ceph node, two compute node with virtualization possible, and 1 server with 64GB and virtualization ready one cisco 3750, in your mind wich is the best config to test Openstack HA and ceph
15:26 racingferret Akshik: it's likely a network mis-configuration.  What is the IP of the gateway you want to ping?
15:28 MiroslavAnashkin lromagnoli: This config is OK. Please do not forget to set Ceph replication factor to 3 on Settings tab in Fuel UI.
15:29 rvyalov joined #fuel
15:29 MiroslavAnashkin lromagnoli: To make this config a HA - combine Controller and Ceph OSD roles to the same 3 servers.
15:34 Akshik http://picpaste.com/Untitled-G9uNH4rc.png
15:34 Akshik MiroslavAnashkin: ive pasted my network configuration
15:35 Akshik sorry racingferret: thats my network configuration
15:41 lromagnoli MiroslavAnashkin:all server have to be 64 bit or something can be 32?
15:43 MiroslavAnashkin All
15:44 racingferret Akshik: can you paste the output of "route -n" as well
15:46 Akshik http://picpaste.com/1-YdsSizKH.png
15:46 racingferret thanks
15:48 racingferret Akshik: just to confirm 10.209.224.1 is definitely your gateway?
15:48 racingferret could it be 10.209.225.254?
15:51 Akshik racingferret: 10.209.224.1 is correct, i have few other server in the network with that being configured as gw and they work
15:51 the_hybrid_tech joined #fuel
15:51 racingferret can you ping something else in that network that you know is up?
15:52 racingferret does "arp -an" show anything?
15:53 Akshik arp -an returns incomplete on eth0
15:53 racingferret can you ping 10.209.224.63?
15:54 Akshik im able to ping that
15:54 Akshik thats the other ip i configured for eth1
15:55 Akshik sorry eth0
15:58 lromagnoli Ok thank u very much
15:58 the_hybrid_tech joined #fuel
16:00 MiroslavAnashkin Akshik: So,  10.209.224.63 looks like your Master node actual IP address.
16:00 Akshik yes
16:00 lromagnoli on the user guide Mirantis OpenStack v4.1 Pre-Installation Guide pag 43 I read: G0/3 Compute Node 1 eth0 untagged 103 is really untagged? all other Compute Node are tagged
16:03 MiroslavAnashkin lromagnoli: Yes, eth0 is used for Admin network (network between master node and OpenStack installations) and it must be untagged or set to access port with necessary default VLAN
16:04 racingferret Akshik: were you able to ping anything else on that network?
16:04 Akshik no im not able to ping anything
16:05 racingferret hmmm, odd.
16:05 lromagnoli MiroslavAnashkin:  G0/5 Compute Node n eth0 tagged 103, G0/7 Controller Node 1 eth0 tagged 103 - is it right?
16:06 Akshik racingferret: is it because of me changing the ip during installation
16:06 Akshik should i go with default installation
16:06 racingferret Akshik: well, if you were given that range, then no, changing the IP isn't a problem
16:07 Akshik racingferret: fine
16:07 racingferret are you on a VLAN tagged network?
16:07 racingferret seems like you might have the correct network details, but possibly on the wrong VLAN...
16:08 Akshik racingferret: is it something to be bothered
16:08 Akshik racingferret: where or how do we configure vlan
16:08 racingferret if your port isn't tagged with the vlan
16:09 racingferret for the network you've configured, you won't be able to ping anything
16:09 racingferret do you have a network administrator?
16:09 racingferret I'd start with them...
16:10 xarses joined #fuel
16:10 racingferret everything in your config looks good otherwise
16:11 Akshik racingferret: not sure if the network administrator is available
16:12 Akshik racingferret: is there something with which we can test and confirm that it would be a problem with vlan
16:12 MiroslavAnashkin lromagnoli: Default network settings are following (for Neutron+VLAN) http://picpaste.com/News_page1-Os5xdyVN.jpg
16:12 racingferret Akshik: not much you can do in that case unfortunately.  Get them to check the port configuration when they can
16:13 MiroslavAnashkin lromagnoli: So, admin network on eth0 is untagged, other 3 nets on eth0 are VLAN tagged
16:13 racingferret Akshik: not really, not unless you have access to the switch
16:13 Akshik racingferret: i dont have access to switch
16:13 racingferret :o(
16:15 Akshik racingferret: what shold i ask my network administrator to look for
16:15 lromagnoli ok now I understand what i'm missing
16:16 racingferret Akshik: you'll have to speak to your network admin
16:17 lromagnoli MiroslavAnashkin:  i use these rules http://picpaste.com/Screen_Shot_2014-04-11_at_6.14.27_PM-hvPrzmAO.png
16:20 e0ne joined #fuel
16:22 MiroslavAnashkin lromagnoli: This config should work, if there is no surprises on router side.
16:24 lromagnoli MiroslavAnashkin  that one the U upload is much more simplier I've got some proble if on the private network I use GRE?
16:24 MiroslavAnashkin lromagnoli: Simply move all tagged network to eth1 for every node, leave Public on eth1 untagged and leave Admin on eth0 untagged
16:25 lromagnoli MiroslavAnashkin: I will give a try
16:28 MiroslavAnashkin lromagnoli: GRE may have issues with some interfaces/drivers. Most of issues related to GRO/GSO. You may have do disable these manually https://bugs.launchpad.net/fuel/+bug/1275650
16:29 lromagnoli MiroslavAnashkin: the simpliest config to have multitenant with overlapping ip is vlan?
16:30 rmoe joined #fuel
16:31 MiroslavAnashkin lromagnoli: GRE is simplier, but slower and has more hardware related issues. VLAN depends on available VLANs on your hardware.
16:35 lromagnoli MiroslavAnashkin: MirantisOpenstack with ceph is able to do live migration?
16:35 MiroslavAnashkin Akshik: If there is no even arp info on you interface - you have to check your switch first and IPMI (iLO, iDRAC or whatever your server use) settings. Active management session to IPMI on your fuel node may break all traffic if management interface shares same network interface with eth0.
16:37 MiroslavAnashkin lromagnoli: With Ceph and Ephemeral Volumes ON. Please enable Ceph RBD for ethemeral volumes on settings tab in Fuel UI
16:37 Akshik MiroslavAnashkin: I have a different iDRAC ip for that server
16:38 Akshik MiroslavAnashkin: Im installing Fuel using the iDRAC only
16:41 MiroslavAnashkin Akshik: I mean not the IP but physical network interface.
16:43 Akshik MiroslavAnashkin: how do we check that
16:43 MiroslavAnashkin lromagnoli: Please change all your eth0 on nodes to untagged - to match with eth0 on master node.
16:44 e0ne joined #fuel
16:46 MiroslavAnashkin Akshik: You or your network administrator have to check BIOS settings for iDRAC.
16:47 e0ne joined #fuel
16:47 Akshik MiroslavAnashkin: what should i ask my network admin to check for
16:48 MiroslavAnashkin Akshik: Simply complain that there is no response from switch on your arp requests.
16:49 Akshik MiroslavAnashkin: Thanks,
16:52 lromagnoli MiroslavAnashkin: I will
17:06 dburmistrov_ joined #fuel
17:23 akasatkin left #fuel
17:23 lromagnoli MiroslavAnashkin: thanls of all, see u
17:27 IlyaE joined #fuel
17:30 lromagnoli joined #fuel
17:39 e0ne joined #fuel
17:51 BillTheKat joined #fuel
17:56 e0ne joined #fuel
18:01 e0ne_ joined #fuel
18:16 e0ne joined #fuel
18:47 IlyaE joined #fuel
19:18 e0ne joined #fuel
19:52 holser joined #fuel
20:04 thehybridtech joined #fuel
20:56 e0ne joined #fuel
21:27 e0ne joined #fuel
21:29 e0ne joined #fuel
21:47 the_hybrid_tech joined #fuel
23:33 justif joined #fuel
23:48 TVR_ how do I get the dashboard to answer https instead of http?

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary