Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2014-04-14

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:17 e0ne joined #fuel
01:06 IlyaE joined #fuel
01:54 sunxin3 joined #fuel
02:26 e0ne joined #fuel
02:30 e0ne_ joined #fuel
03:35 sunxin3 joined #fuel
03:47 thehybridtech joined #fuel
05:20 sunxin3 joined #fuel
05:50 IlyaE joined #fuel
06:05 dburmistrov_ joined #fuel
06:19 sunxin3_ joined #fuel
06:27 alex_didenko joined #fuel
06:42 e0ne joined #fuel
06:42 al_ex joined #fuel
07:10 mirrorbox joined #fuel
07:10 mirrorbox joined #fuel
07:11 e0ne_ joined #fuel
07:29 the_hybrid_tech joined #fuel
07:30 sunxin3_ joined #fuel
07:33 e0ne joined #fuel
07:43 e0ne joined #fuel
07:46 racingferret joined #fuel
07:50 al_ex joined #fuel
07:50 strictlyb joined #fuel
08:02 topochan joined #fuel
08:39 asledzinskiy joined #fuel
09:11 aglarendil|nb joined #fuel
09:30 lromagnoli joined #fuel
09:30 DaveJ__ joined #fuel
09:32 rvyalov joined #fuel
09:32 topochan joined #fuel
09:51 vk joined #fuel
10:23 topochan joined #fuel
11:12 vk joined #fuel
11:37 e0ne joined #fuel
11:41 evg joined #fuel
11:44 anotchenko joined #fuel
11:55 topochan joined #fuel
12:07 e0ne joined #fuel
12:09 e0ne_ joined #fuel
12:11 TomekG left #fuel
12:20 bookwar1 joined #fuel
12:21 TomekG joined #fuel
12:22 TomekG Hi, I've noticed puppet manifests on slaves are deployed from fuelmaster using "cp puppet-slave.tgz" in kickstart. Is this method used for whole environment lifetime? What is the best way if I'd like to inject own puppet modules? Should I rebuild this .tgz file?
12:24 racingferret joined #fuel
12:27 e0ne joined #fuel
12:29 boris-42 mihgen  ^
12:34 dilyin joined #fuel
12:37 mihgen TomekG: hi
12:37 aglarendil|nb TomekG: nope, puppet manifests are copied from the master node using rsync
12:38 holser joined #fuel
12:38 aglarendil|nb you can easily rsync your own puppet modules to the master node and then they will be redistributed to the slave nodes before puppet is fired
12:39 anotchenko joined #fuel
12:40 aglarendil|nb you can also alter puppet manifests locally and rerun deployment by firing puppet apply /etc/puppet/manifests/site.pp on the slave node
12:40 aglarendil|nb also you can modify /etc/astute.yaml and retrigger particular node deployment
12:42 TomekG OK, thx, I'll check this out
12:43 TomekG What is the first place in the chain where I can safely alter manifest to avoid overwriting?
12:43 TomekG (when I do "fuel ..... node deploy")
12:46 TomekG Are /etc/puppet/modules on master node and slave the same?
12:47 TomekG I've found rsyncd.conf, so I assume "yes" :)
12:49 dilyin when master node is deployed you can got into /etc/puppet/modules on the master ndoe and add/adit modules and manifests there
12:49 dilyin these modules and manifests will be synced to the managed nodes when they are deployed
12:50 dilyin you can also alter astute.yaml on managed nodes but don't alter modules and manifests there because they will be overwritten. make all changes on the master node
12:53 TomekG I understand, what mechanism generates astute.yaml on slaves? For example, I'd like to add additional section in astute.yaml for my new module.
12:55 dilyin astute.yaml is generated based on node's setting during it's deployment. if your node is already deployed and you want to change something you can just modify it and then sync modules and run puppet (use puppet-pull command)
12:55 holser You’ve got the point
12:56 dilyin but if you want this changes to be persistent and evironment-wide you should use fuel cli tool to download setting, modify them and upload, the nyoul be able to beploy new nodes with modified settings
12:57 mihgen TomekG: there is some explanation at the end of the page here: http://docs.mirantis.com/fuel-dev/develop/sequence.html
12:57 mihgen basically initially data is calculated in nailgun
12:57 mihgen then it's pushed via AMQP to Astute
12:57 mihgen and Astute places the data onto every server into /etc/astute.yaml
12:58 mihgen if you want to dirty-hack it, you can use Fuel CLI for it
12:58 dilyin yes data is sent from nailgun to astute and astute creates these files on nodes before puppet is run
12:58 dilyin http://docs.mirantis.com/fuel/fuel-4.1/user-guide.html#cli-commands-reference
12:59 dilyin Passing Custom Attributes From Fuel To Puppet
12:59 monester joined #fuel
13:00 mihgen TomekG: dilyin: there is one more doc for passing custom stuff: http://docs.mirantis.com/fuel/fuel-4.1/user-guide.html#passing-custom-attributes-from-fuel-to-puppet
13:00 TomekG I'd like to avoid dirty-hacks at start, but some may be needed some day :)
13:00 mihgen TomekG: what are the changes you actually want to make?
13:00 dilyin using fuel cli tools to add custom data for custom modules is not that dirty
13:01 mihgen we try to keep data logic in Nailgun, and keep Astute as simple async worker
13:01 TomekG @mighen: this doc seems to be exactly what I'm looking for
13:01 mihgen good. Hard to find one though I bet… we need to move this into fuel-dev docs I believe...
13:02 TomekG I don't have any particular example yet, I'm still doing research :)
13:02 mihgen oh ok ) cool. share your findings on the way ;)
13:02 TomekG I think I'll try to add custom packages to Ubuntu at first.
13:03 justif joined #fuel
13:03 TomekG And I'll try to install Ironic for experimental and self-teaching purposes.
13:05 TomekG Great, example in the docs you've pasted here describes adding custom packages :)
13:13 holser joined #fuel
13:15 xdeller joined #fuel
13:20 holser joined #fuel
13:52 anotchenko joined #fuel
14:08 jobewan joined #fuel
14:12 holser joined #fuel
14:17 anotchenko joined #fuel
14:33 racingferret joined #fuel
14:38 bbfoto joined #fuel
14:44 xdeller_ joined #fuel
14:45 bbfoto running 4.1 release, during my initial HA deployment the 3rd controller fails at keystone-db-manage db_sync attempting to connect o mysql on the wrong IP(I don't see xxx.xxx.xxx.2 ever assigned to any of the nodes.) xxx.xxx.xxx.3 would make sense though. I suspect a network range config option I have is wrong or something like that. any ideas?
14:47 Ts joined #fuel
14:47 Ts guys
14:47 Ts hello
14:47 TVR_ morning sir
14:47 syudin i need to modify one section of env network
14:48 lromagnoli joined #fuel
14:48 syudin floating_range to be more precise
14:48 syudin and i want to just upload new range without merging it onto full network json
14:48 syudin is it possible using cli or api?
14:50 jobewan joined #fuel
14:51 IlyaE joined #fuel
14:51 akasatkin joined #fuel
14:52 evgeniyl akasatkin: ^
14:53 lromagnoli To test fuel i tried to install on vmware but i don't understand how to configure the virtual switch, here there is the configuration interfaces of my machines http://picpaste.com/Screen_Shot_2014-04-14_at_4.50.13_PM-EylUDucQ.png
14:54 syudin akasatkin: hello
14:54 akasatkin hello
14:54 syudin akasatkin: is it possible to update single network config attribute, without parsing whole network json/yaml?
14:55 syudin using cli or api
14:55 syudin i want to update floating range but not want to merge it onto network config
14:56 racingferret joined #fuel
14:56 lromagnoli and here the failure http://picpaste.com/Screen_Shot_2014-04-14_at_4.55.37_PM-x5umnezG.png
15:02 holser joined #fuel
15:06 asledzinskiy joined #fuel
15:17 albionandrew joined #fuel
15:19 BillTheKat joined #fuel
15:22 albionandrew Good morning - I’m deploying a new cluster I added three controllers. One of the controllers disappeared
15:22 albionandrew http://pastebin.com/3QNGmLEN
15:22 albionandrew I can ping from the controller to the master etc
15:22 albionandrew Any ideas?
15:23 BillTheKat I have a fuel node that was replaced becuase of a hardware issue - the old node still shows up when doing a "fuel node" command. When I do a "fuel node remove --node 56" I get the following error:  HTTP Error 404: Not Found (not found).
15:23 thehybridtech joined #fuel
15:24 xarses joined #fuel
15:27 albionandrew xarses - Good morning - I’m deploying a new cluster I added three controllers. One of the controllers disappeared. http://pastebin.com/3QNGmLEN I can ping from the controller to the master etc.
15:27 evg lromagnoli: your the first screen looks OK. What's about your Network Setings?
15:27 lromagnoli two node with vlan
15:29 lromagnoli evg: two node with vlan, everithing default except i changed the vlanid http://picpaste.com/Screen_Shot_2014-04-14_at_5.28.55_PM-hVB5LFat.png
15:34 lromagnoli evg: http://picpaste.com/Screen_Shot_2014-04-14_at_5.33.58_PM-6UwHhbZP.png
15:35 evg lromagnoli: looks well. Am I right you're using nova-network?
15:36 lromagnoli evg:neutron
15:41 evg BillTheKat: the were tolks about deleting nodes here several day ago. http://irclog.perlgeek.de/fuel/2014-04-07. It's not a solution, but mb it help
15:43 anotchenko joined #fuel
15:46 evg lromagnoli: i've missed something, shouldn't it be written "Network verification on Neutron is not implemented yet"?
15:48 lromagnoli evg: sorry maybe i've missed something where should?
15:50 pm__ joined #fuel
15:54 evg lromagnoli: your configuration looks well, I'll try the same tomorrow and will see. Sorry I have no posibility just now.
15:55 lromagnoli ok thank you very much
15:55 lromagnoli so i hope to see u again tomorow
15:58 holser joined #fuel
15:58 lromagnoli evg: is there any way to have your result back?
15:59 e0ne joined #fuel
16:05 evg lromagnoli: excuse me, what do you mean? We'll met here tomorrow.
16:05 lromagnoli ok good
16:05 lromagnoli evg: thanks for all
16:14 rmoe joined #fuel
16:18 xarses albionandrew: did the node deploy?
16:31 albionandrew_ joined #fuel
16:35 rvyalov joined #fuel
16:37 albionandrew_ xarses -sorry my machine locked up. I think you asked about a deployment. I added the controllers, there were 3 in the gui. Then I looked again and the one b5 disapeared.
16:37 rmoe joined #fuel
16:41 topochan joined #fuel
16:55 angdraug joined #fuel
17:02 mutex joined #fuel
17:03 xarses albionandrew_: ok, can you give me about 400 lines from /var/log/nailgun/app.log from before that message occurred?
17:04 albionandrew_ xarses - dhblaz is here now. I’ll let you know what we find.
17:05 albionandrew_ xarses we had some issues witht the mac addresses last week and it might be realated? 2014-04-14 16:57:02.768 DEBUG [722277fff700] (logger) Response code '409 Conflict' for POST /api/nodes/ from 10.1.4.225:58708
17:07 albionandrew_ xarses - it was the mac address issue.
17:07 albionandrew_ xarses is there a quick way to delete a previous node that is no longer online?
17:07 albionandrew_ xarses - The primary mac changes and conflicts with the old one.
17:08 albionandrew_ xarses - should we change the mac address int eh datebase or something else?
17:08 rnelan joined #fuel
17:08 rnelan Hi folks, hope everyone is doing well, just have a couple short questions!
17:09 dhblaz joined #fuel
17:09 rnelan I am installing cloudbase for server 2012. I am being asked where services are located and what my Rabbit password is. Having completed a FUEL installation, could someone please tell me how to find out those answers? Thanks!
17:09 xarses albionandrew_: the mac should only change if the interface with the PXE network changes or the default route
17:09 dhblaz joined #fuel
17:10 dhblaz Right, the mac address changed on the PXE nic
17:10 xarses rnelan: /etc/astute.yaml on a deployed node
17:10 dhblaz I’m inclined to remove it from the database but if the fuel cli allows me to remove it from there that seems like it would be easier
17:11 xarses dhblaz: so you have more than one interface on the PXE network
17:11 rnelan thaks xarses.. does that give me both pieces?
17:11 dhblaz xarses: the nic changed mac addresses
17:12 dhblaz a firmware upgrade changed the nic
17:12 xarses dhblaz: ahh, thats odd that it did
17:13 xarses rnelan: you should just be able to point it to keystone and it should find the services it needs from there
17:14 rnelan ok, thanks, now, with 17 servers running, I just need to know where fuel put keystone and what the rabbit password is..
17:14 xarses rnelan: the keystone data is in there aswell but its easier to find in /root/openrc on the controller its something like keystone_auth_url
17:14 albionandrew_ xarses - It deleted them. It was an HP firmware updated - http://tinyurl.com/oo2qzak
17:15 albionandrew_ xarses - It has caused a mess to say the least
17:18 xarses dhblaz: I don't think the 'fuel node --delete <id>' will work for the one that "disappeared" because it's api model isn't valid (hence why it disappeared) for the other nodes, that should work
17:19 albionandrew_ xarses could we just change them to some random mac address? in the db?
17:20 dhblaz We want to delete the old node
17:20 xarses you could also send a curl -x DELETE http://localhost:8000/api/node/<id>
17:20 dhblaz but that syntax doesn’t appear to work with the fuel 4.0 cli
17:22 rnelan what am i missing? I dont see what you refer to xarses.. I am looking for a rabbit password and cant seem to locate it.
17:23 xarses rnelan, look for rabbit in /etc/astute.yaml and then scroll down just a bit there should be a line like ' - password: "A#)8fo3"' a couple of lines from it (and indented under it)
17:25 dhblaz xarses: will you confirm the url, it doesn’t seem to work
17:26 xarses sorry its nodes not node
17:29 dhblaz xarses: I had to change -x to -X but that worked after I removed both “offending” nodes and reran the nailgun agent
17:33 xarses dhblaz: yep sorry, commands from memory
17:46 dhblaz xarses: sorry, not complaining just trying to reinforce the memory circuits
17:52 xarses yep
17:56 evg joined #fuel
17:58 IlyaE joined #fuel
18:20 e0ne joined #fuel
18:34 albionandrew joined #fuel
18:39 albionandrew joined #fuel
18:40 IlyaE joined #fuel
18:42 e0ne joined #fuel
18:42 albionandrew joined #fuel
18:46 holser joined #fuel
18:51 albionandrew joined #fuel
19:04 bookwar1 joined #fuel
19:48 e0ne joined #fuel
20:00 tatyana joined #fuel
20:00 e0ne joined #fuel
20:10 e0ne joined #fuel
20:11 e0ne joined #fuel
20:17 e0ne joined #fuel
20:19 holser joined #fuel
20:19 BillTheKat joined #fuel
20:20 e0ne_ joined #fuel
20:30 e0ne joined #fuel
21:20 warpig_ joined #fuel
22:10 rnelan joined #fuel
22:52 rnelan Have you ever seen where Horizon stops logging in user accounts.. No error message, but spins until eventually a 500 error pops? If i use a bad account and password, immediate error.. good username and password just hangs at login screen
22:55 rnelan sorry 504
23:11 rnelan I deleted one of my compute nodes and it all went to hell.. I can get to the FUEL server via ssh and web ui, but when I try to login to horizon with good creds, it just hangs.. bad creds and immediate error..
23:17 xarses you didn't wack a controller?
23:17 rnelan no, just a compute...
23:28 rnelan no idea? I may have to destroy the environment and start over.. grrrrrr
23:37 rnelan looks like neutron lost conection to the mysql server.. all three controller nodes are throwing errors in the neutron-server logs..
23:40 rnelan I had to destroy the environment anyway.. i have another problem with nics.. but that sucked.. it was working well for a while..
23:41 IlyaE joined #fuel
23:42 rnelan https://bugs.launchpad.net/fuel/+bug/1297355
23:45 rnelan another problem. FUEL wont forget about a node that I deleted.. hours after still shows in the total nodes and unallocated nodes count.. Is there a way to rescan or fix this?
23:46 rnelan shows up as "offline" in another screen within fuel
23:55 justif joined #fuel
23:58 warpig_ rnelan: has the fuel node you deleted been rebooted and come back up with the bootstrap kernel?

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary