Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2014-08-14

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
01:08 potato_farmer Hi, when I go to configure interfaces, I don't see an option for "floating", should I?
01:17 Krast joined #fuel
01:20 rmoe joined #fuel
01:30 kupo24z potato_farmer: when spawning an instance you will not see any floating ip options, only the private and public networks
01:30 kupo24z to assign a floating ip you will need to use more -> associate floating ip
01:38 lordd_ joined #fuel
01:39 potato_farmer Thanks kupo24z, but I am just starting out.. This is in the node configuration pages where you can decide which networks go into which interfaces before deploying openstack.
01:39 potato_farmer I see Public, Management, Admin, Storage, and Fixed. But no floating.
01:41 xarses joined #fuel
01:46 kupo24z potato_farmer: are you using Neutron VLAN/GRE?
01:46 kupo24z Should be on the bottom of the network config page
01:46 kupo24z 'Floating IP ranges' above DNS servers
01:48 kupo24z If you are using nova-network I'd refer to the fuel docs, ive not personally used it in fuel
01:49 kupo24z http://docs.mirantis.com/openstack/fuel/fuel-5.0/user-guide.html#nova-network-settings
02:03 potato_farmer Yes, I am using nova-network.
02:03 potato_farmer Thanks for the link, reading now...
02:59 gleam
02:59 gleam whoops.
03:30 Samos123 mihgen: btw after I setup my vagrant vm to use a http_proxy I was able to succesfully build an ISO yeah! So guess most of the issues I encountered really were network / firewall related. Thanks for the help
03:39 lordd_ joined #fuel
03:46 teknomega joined #fuel
03:56 ilbot3 joined #fuel
03:56 Topic for #fuel is now Fuel 5.0 for Openstack: https://wiki.openstack.org/wiki/Fuel | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
04:11 ilbot3 joined #fuel
04:11 Topic for #fuel is now Fuel 5.0 for Openstack: https://wiki.openstack.org/wiki/Fuel | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
04:20 ArminderS joined #fuel
04:48 xarses joined #fuel
04:52 HeOS joined #fuel
05:04 lordd_ joined #fuel
05:10 Bomfunk_ joined #fuel
05:10 Bomfunk_ joined #fuel
05:10 scroiset_ joined #fuel
06:33 adanin joined #fuel
07:03 Baboune How does Fuel 5 handles upgrades of the OpenStack libraries/services?  Basically, if there are patches to ice house, how does one get those to a deployed environment?
07:08 pasquier-s joined #fuel
07:13 Longgeek joined #fuel
07:19 HeOS joined #fuel
07:46 Longgeek joined #fuel
07:57 pasquier-s_ joined #fuel
07:59 HeOS joined #fuel
08:00 Longgeek joined #fuel
08:05 Longgeek joined #fuel
08:08 pasquier-s joined #fuel
08:25 e0ne joined #fuel
08:53 isviridov joined #fuel
08:54 adanin joined #fuel
09:02 DaveJ__ joined #fuel
09:31 geekinutah joined #fuel
09:42 Baboune installing FUEL nightly build on a server.  After successful install there is no "fuel" cli available.  Any ideas?
09:43 Baboune installing is from a DVD
09:43 Baboune the fuelmenu is available though
09:47 Baboune yum install python-fuelclient lets me install it though.. is that expected?
09:52 Baboune also "[root@kds-cmc-fuel-01 init.d]# docker ps CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES"
09:52 Baboune so no containers were launched/created
09:53 Baboune docker images are also missing
09:53 Baboune What did I do wrong?
09:53 ArminderS- joined #fuel
09:54 Baboune or rather what is the pb/fix?
10:09 Baboune also on a HP DL320 G3, set with an RAID array, the installer issues an error about the second disk /dev/sdb and a long numbger string. Then decides to ignore it.
10:11 Longgeek joined #fuel
10:30 lordd_ joined #fuel
10:34 HeOS joined #fuel
10:37 Longgeek joined #fuel
10:43 lordd_ joined #fuel
11:02 Baboune using  fuel-community-master-69-2014-08-14_05-27-34.iso, during installation, I get: Please insert disk 1.  While I only have 1 ISO.  Nightly build is broken?
11:19 Baboune https://dl.dropboxusercontent.com/u/18136096/2014-08-14%2013.11.18.jpg
11:20 e0ne joined #fuel
11:32 saibarspeis joined #fuel
11:33 ArminderS joined #fuel
11:39 pasquier-s joined #fuel
11:50 xdeller joined #fuel
12:10 e0ne joined #fuel
12:18 BillTheKat joined #fuel
12:19 BillTheKat Is there a way to determine number of free addresses in fuel 5.0 server - I am having issues with PXE
12:30 BillTheKat I am trying to PXE boot KVM VMs with a fuel server (running my openstack on KVM VMs - I see the DHCP request but I do not see fuel sending a reply - help?  Is there a way to reset fuel or determine available PXE resoures?
12:38 kaliya BillTheKat: has the master booted properly? Are all the docker services running?
12:40 BillTheKat The fuel is fine as far as I can tell - It is on a bare metal machine and I have been using it for a while.  The issue is that when I try to run a KVM  VM and have it PXE to my fuel server when I "tcpdump -i eth0" on the fuel server I do not see the DHCP requests but not a reply
12:41 BillTheKat Mean I see the DHCP req but not the reply
12:48 Baboune on a HP DL320 G3, the docker images are not loaded into docker.  I can see the loaded images in a VM with the exact same ISO.  So on the HP, the docker images are not installed, nor loaded.  What can possibly cause this problem and, after a successful install, on the reboot, not generate/deploy the images into docker?
12:50 kaliya BillTheKat: if you run dockerctl list -l on the master, are all those containers running?
12:53 BillTheKat kaliya: dockerctl list -l is not a valid command from what I can see?
12:55 kaliya BillTheKat: command not found?
12:56 BillTheKat kaliya: invalid selection
12:56 BillTheKat kaliya: so yes command not found
12:57 kaliya BillTheKat: seems that the fuel master did not deploy itself correctly, so it's no service ready to release DHCP
12:58 BillTheKat hmm - I have used for a long time with no problems...... is there a way to reset it
13:01 evg BillTheKat: please run "docker ps"
13:01 Baboune How does Fuel 5 handles upgrades of the OpenStack libraries/services?  Basically, if there are patches to ice house, how does one get those to a deployed environment?
13:02 evg BillTheKat: then try restarting cobbler conteiner
13:05 BillTheKat evg: and how do I do that?
13:05 evg BillTheKat: dockerctl restart cobbler
13:05 BillTheKat evg: will do
13:06 evg BillTheKat: but before play with https://10.20.0.2/cobbler_web
13:06 BillTheKat evg: is there a way to see free IPs in fuel dhcp?
13:07 evg BillTheKat: is cobbler url answers?
13:07 BillTheKat evg: or does cobbler handle all that - obvious I am a PXE/cobbler novice
13:07 evg BillTheKat: yes, it cobbler
13:07 evg BillTheKat: try the url
13:07 evg BillTheKat: cobbler/cobbler
13:08 BillTheKat evg: ok - rebooting fuel server now - it has been a while
13:12 evg BillTheKat: you can set pxe network with fuelmenu berofe fuel install. I'm not sure you can change it after
13:13 pasquier-s_ joined #fuel
13:14 BillTheKat evg: I do not have direct access to fuel server - it is on a private net so I ssh port map the fuel gui - so url cobbler/cobbler is difficult - is there a curl comamnd I can run to see cobbler fee resources like IPs etc?
13:17 evg BillTheKat: "cobbler" command
13:19 evg BillTheKat: I don't think the problem is in resources shortage.
13:20 BillTheKat evg: ok after reboot - I now see dhcp reply's  - there was a bunch on stale nodes in cobbler I removed...
13:21 BillTheKat evg: Hmm so now I need to figure out why kvm linux bridge is not seeing DHCP response
13:24 evg BillTheKat: The was a bug in 5.0 https://bugs.launchpad.net/fuel/+bug/1333362 when cobbler container got a wrong ip
13:24 evg BillTheKat: may be it's your case
13:25 BillTheKat evg: let me look at bug report - thanks
13:25 twforeman joined #fuel
13:32 evg Baboune: Fuel 5 doesn't upgrade openstack services. The _master_ node only  is upgradable.
13:55 adanin joined #fuel
14:01 getup- joined #fuel
14:09 jaypipes joined #fuel
14:10 HeOS [15:02:02]  <Baboune> using  fuel-community-master-69-2014-08-14_05-27-34.iso, during installation, I get: Please insert disk 1.  While I only have 1 ISO.  Nightly build is broken? <--- not reproduced.
14:10 HeOS [15:02:02]  <Baboune> using  fuel-community-master-69-2014-08-14_05-27-34.iso, during installation, I get: Please insert disk 1.  While I only have 1 ISO.  Nightly build is broken?
14:14 Baboune @HeOS I have not tried again but that is the behavior observed on our HP DL320. As per the picture
14:18 Baboune I have a new one... After a successful install, the docker containers are available, but in the UI no release are available to select. https://www.dropbox.com/s/yhicy450mw6uatm/no-release-fuel-5.0-169-2014-08-11_12-45-06-iso.png
14:18 Baboune that is from the RC
14:23 rmoe joined #fuel
14:49 Baboune but "fuel env create --name test --release ubuntu" worked somehow the UI does not see the releases.
14:50 mattgriffin joined #fuel
14:50 Baboune and creating another env from the UI then works...
14:51 mattgriffin joined #fuel
14:52 getup- joined #fuel
15:31 getup- joined #fuel
15:40 dpyzhov joined #fuel
15:46 rmoe joined #fuel
15:52 angdraug joined #fuel
15:54 BillTheKat joined #fuel
15:55 ArminderS joined #fuel
16:17 MiroslavAnashkin Baboune: Please always do Shift+Reload on Fuel UI after every new Fuel master node installation
17:02 jaypipes joined #fuel
17:18 ArminderS- joined #fuel
17:23 ppradhan joined #fuel
17:31 BillTheKat joined #fuel
17:40 angdraug joined #fuel
17:46 e0ne joined #fuel
17:56 xarses joined #fuel
18:02 BillTheKat joined #fuel
18:13 adanin joined #fuel
18:35 getup- joined #fuel
18:36 e0ne joined #fuel
19:01 adanin joined #fuel
19:03 BillTheKat joined #fuel
19:14 Eucke joined #fuel
19:25 ppradhan joined #fuel
20:01 geekinutah left #fuel
20:55 HeOS joined #fuel
21:20 tatyana joined #fuel
21:23 lordd_ joined #fuel
21:27 lordd_ joined #fuel
21:32 lordd_ joined #fuel
21:40 gregory_green_PM joined #fuel
21:42 gregory_green_PM anyone home?
22:07 potato_farmer joined #fuel
22:08 potato_farmer Hi I have a question about Fuel. After setting up the network and clicking Verify, does Fuel go in and configure the network on each node? Or do we need to do that ahead of time? I am using Nova-Network with FlatDHCP Manager.
22:29 xarses the verify networks will ensure that the configured networks pass traffic on the interfaces configured.
22:29 xarses potato_farmer: ^^
22:29 xarses gregory_green_PM: yes
22:30 gregory_green_PM when is 5.1 going to be available?
22:30 gregory_green_PM we ran into the issue with Broadcom 10gig nics and had to drop back to 2.6 for the bootloader.
22:30 gregory_green_PM a la: https://bugs.launchpad.net/fuel/+bug/1323354
22:51 jobewan joined #fuel
22:53 potato_farmer Hi @xarses, Do I need to configure it myself first? Or does Fuel handle that?
22:55 xarses potato_farmer: in the switch, yes. On the nodes no
22:55 potato_farmer ok, thank you
22:55 xarses potato_farmer: you will end up with defaults if you dont configure anything which will end up with testing most of the networks on the first nic. You can change which nic has roles from the nodes page, and the networks settings from the network page
22:56 xarses gregory_green_PM: we are probably a two to three weeks out
22:56 potato_farmer Hi @xarses, Do I do a deploy before a verify network?
22:56 xarses but that might move around if we find any more critical issues before testing
22:57 xarses potato_farmer: no, you can test networks before deploying and in most cases after aswell, but thats usually a little redundant
22:57 xarses in pre-deployment it will temporarily configure the nodes to perform the testing
22:58 potato_farmer @xarses: It keeps failing in pre-deployment and tells me to look at orchestrator logs. Note: this is my first ever deployment
22:59 xarses go to logs and then server and astute.log
23:03 potato_farmer @xarses: I have several different errors at the moment. I'll run Verify networks and see what the latest shows. As far as networking, I have the default VLAN on the switch (no tagging), and I added 3 VLANS (101, 102, 103) for Management, Storage, and Nova respectively. I thought that's all I needed to do.
23:04 potato_farmer Also, for Public, I am using an existing network and have a block that I can use. I wonder if that might cause issues or not (in case fuel wants to create dhcp on the network).
23:04 xarses potato_farmer: there won't be dhcp on that network, only the Admin (PXE) network
23:05 kupo24z xarses: im a little confused on the last meeting notes, 5.0.2 = 5.1?
23:05 xarses kupo24z: as far as openstack version
23:05 xarses and by the looks of it, os
23:06 kupo24z are their heavy fuel changes in 5.1 vs 5.0.2?
23:07 xarses for fuel its self, probably
23:08 kupo24z Will lbaas packages be delayed for 5.0.2 as well then? I don't see a 5.0.1 milestone on the bug https://bugs.launchpad.net/fuel/+bug/1330610
23:10 xarses lbaas packages should be available via the mirror for 5.0.x and 4.1.1
23:10 xarses they will be on the 5.1 iso
23:11 xarses but not installed
23:11 kupo24z http://fuel-repository.mirantis.com/fwm/5.0.1/ubuntu/pool/main/ ?
23:12 xarses yep, and I see they aren't there. I'll poke some one about it
23:12 kupo24z ty
23:15 kupo24z xarses: is the current implementation of fuel-upgrade to upgrade 5.0 -> 5.0.1 -> 5.1 -> 6.0 then have the ability to bring the env from 5.0 to 6.0? or is it not decided yet
23:22 xarses fuel should be able to upgrade its self after 5.0 to newer versions, and continue to manage existing clouds. starting with 5.1 clouds we can patch openstack within minor versions. starting with a version in 6.x we will be able to upgrade from icehouse to havana
23:23 xarses erm
23:23 xarses icehouse to juno
23:42 potato_farmer Hi @xarses, I ran the verification and it failed again.
23:43 potato_farmer This time it says "Expected VLAN (not received)" and shows untagged for all nodes.
23:43 potato_farmer This is for the Public, and I unchecked "Use Vlan", so I am not sure why it expects it.

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary