Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2014-09-09

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:16 rmoe joined #fuel
00:24 eshumkher joined #fuel
00:27 harybahh joined #fuel
00:46 xarses joined #fuel
01:13 eshumkher joined #fuel
01:49 alex_didenko joined #fuel
01:54 eshumkher joined #fuel
02:09 dshulyak joined #fuel
02:11 eshumkher joined #fuel
02:11 bogdando joined #fuel
03:01 adanin joined #fuel
03:08 Samos123 What is the suggested way to have different IP subnet and vlan for floating and public using neutron in Fuel 5.1?
03:33 evgeniyl__ joined #fuel
03:42 MorAle joined #fuel
03:42 meow-nofer_ joined #fuel
03:42 kat_pimenova joined #fuel
03:42 brain461 joined #fuel
03:42 bookwar joined #fuel
03:42 jkirnosova joined #fuel
03:42 rsFF joined #fuel
03:45 sbog joined #fuel
03:58 eshumkher joined #fuel
04:26 ArminderS joined #fuel
04:27 harybahh joined #fuel
04:35 alex_didenko joined #fuel
04:52 eshumkher joined #fuel
05:05 eshumkher joined #fuel
05:10 taj joined #fuel
05:21 eshumkher joined #fuel
05:24 AKirilochkin joined #fuel
05:24 AKirilochkin привет
05:25 AKirilochkin Народ у меня траблы на проекте, щас постараюсь объяснить
05:25 AKirilochkin У клиента есть 3 стойки, в каждой стойке серваки и свой свитч, каждая стойка имеет собственный диапазон сетей для mgmt, admin, prv, stor. Таким образом, это низя задеплоить при помощи FUEL UI. Вопрос, возможно ли такое сконфигурить из cli? Будет ли такая конфа
05:25 AKirilochkin работать, если учесть, что все 3 контроллера в одной стойке и той же подсети, floating в той же подсети.
05:25 AKirilochkin я подумал, что если контроллеры в разных стойках - это не будет работать совсем, поэтому как вариант решения можно поместить их в одну стойку
05:26 AKirilochkin например для mgmt 172.30.64.0/21 и этот диапазон поделен между стойками по /25 эти адреса рутятся роутером и так со всеми диапазонами, тобишь из UI такое точно не заработает
05:37 AKirilochkin joined #fuel
05:38 AKirilochkin_ joined #fuel
05:58 ilbot3 joined #fuel
05:58 Topic for #fuel is now Fuel 5.0.1 for Openstack: https://wiki.openstack.org/wiki/Fuel | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
06:06 eshumkher joined #fuel
06:28 harybahh joined #fuel
06:33 Obi-Wan joined #fuel
06:33 Obi-Wan joined #fuel
06:43 tuvenen joined #fuel
06:57 e0ne joined #fuel
07:13 mrasskazov left #fuel
07:23 harybahh joined #fuel
07:24 hyperbaba joined #fuel
07:30 adanin joined #fuel
07:37 adanin joined #fuel
07:50 tuvenen_ joined #fuel
07:53 pasquier-s joined #fuel
08:10 [HeOS] joined #fuel
08:17 ddmitriev joined #fuel
08:19 Picachu Hi, I got an issue when trying to deploy  a computer in my fuel environment, maybe someone can help
08:20 Picachu in fuel logs there is only one error : "Error running provisioning: <class 'cobbler.cexceptions.CX'>:'MAC address duplicated: 00:26:55:D1:C1:83'............."
08:20 Picachu full log here : http://paste.openstack.org/show/108759/
08:20 Picachu but i don't know where to delete the MAC address duplicated
08:25 kaliya Picachu: did you detect a duplicate MAC with arp -a?
08:29 Picachu nop no ducplicate with this command
08:33 kaliya Picachu: before deploying, did you run Verify Network and all was fine?
08:39 Picachu nop, i can try to do that, but just before i delpoyed my controllers without any problem, i can reach dashboard etc
08:42 noisette joined #fuel
08:43 kaliya please try to, after adding the node and before starting the deployment
08:43 e0ne joined #fuel
08:48 kupo24z joined #fuel
08:51 vtzan joined #fuel
09:03 e0ne joined #fuel
09:07 tuvenen joined #fuel
09:07 Picachu it seems that i can't run network verification, i got this message : "Network verification on Neutron is not implemented yet"
09:08 Picachu I'm using Fuel 3.2.1
09:09 kaliya Picachu: ah I understand
09:13 harybahh joined #fuel
09:16 evg Picachu: am I right you're using real HW? It hardly probable to have mac dublicate in this case.
09:18 Picachu yes i'm using real hardware
09:19 evg Picachu: do you see this mac in "fuel node"?
09:19 Picachu yes that's very strange but it is the only clue i've found in log
09:20 Picachu nop, this mac belong to the compute node i try to deploy, but it is not its fuel network interface
09:23 kaliya Picachu: is the Admin-binded interface? Or the public one
09:27 Picachu I mean that mac / interface i found in logs do not belong to a configured interface. My machine got 8 nics and this mac belong to the 8th, not used for a network in interface configuration
09:28 mrasskazov joined #fuel
09:28 evg Picachu: is it connected?
09:29 Picachu nop
09:30 evg Picachu: is it possible that this node is exist somehow in fuel db? I mean not deleted properly.
09:31 geekinutah joined #fuel
09:33 Picachu maybe, how can i check that?
09:34 Picachu I've used the curl command you gave me a few days ago to delete nodes when they are stucked in a state. And this one always get stucked when i try to deploy
09:35 kaliya Picachu: please provide `fuel --env <YOURENVID> node | grep <YOUR MAC>` ?
09:39 Picachu no output, this mac is not associated to an admin interface
09:44 e0ne joined #fuel
09:57 evg Picachu: so this node you've deleted stuck in db
10:33 Longgeek joined #fuel
10:33 kupo24z joined #fuel
10:35 evg Picachu: please look into your db if the node is stuck there somehow
10:35 evg Picachu: su - postgres
10:35 evg Picachu: psql nailgun
10:35 evg Picachu: select * from nodes;
10:36 evg Picachu: btw, do you remember the id of the node you've deleted?
10:49 pal_bth joined #fuel
10:50 kupo24z joined #fuel
10:52 pal_bth manashkin_: After reinstalling Fuel from the CD; I managed to deploy an OS environment, but the Compute nodes failed to fire up. This add  (rootdelay=90) is this to be done where, on the PXE image used to boot the nodes?
11:07 e0ne joined #fuel
11:20 kupo24z1 joined #fuel
11:22 DaveJ__ joined #fuel
11:23 DaveJ__ Hi folks
11:23 DaveJ__ I'm having trouble removing a node
11:23 DaveJ__ it's offline, but still listed
11:23 DaveJ__ is there a way to forceably remove it from the fuel db?
11:23 DaveJ__ I've tried fuel node remove ,but I get a json error
11:31 DaveJ__ hmm seems to have finally disappeared on its own
11:54 brain461 joined #fuel
11:54 taj_ joined #fuel
12:02 rsFF joined #fuel
12:05 kat_pimenova joined #fuel
12:05 jkirnosova joined #fuel
12:09 harybahh joined #fuel
12:26 AKirilochkin joined #fuel
12:26 kupo24z joined #fuel
12:32 pasquier-s joined #fuel
12:37 kaliya DaveJ__: what happened?
12:38 DaveJ__ kaliya: The node just disappeared - previously when I did 'fuel node list' the offline node was still listed
12:39 DaveJ__ eventually it seemed to get removed.
12:43 Picachu @evg : I checked database and i don't see any stucked node in it, there is just only single entry for the nodes I'm using
13:09 manashkin_ joined #fuel
13:12 AKirilochkin joined #fuel
13:14 evg Picachu: is the node in bootstrap mode now?
13:15 evg Picachu: please try 1) run "cobbler sync", 2) restart nailgun service, 3) reboot the node
13:17 pal_bth manashkin_: would this edit be done in /var/lib/tftpboot/grub, in the file corresponding to the DELL device...
13:22 brain461 joined #fuel
13:23 manashkin_ pal_bth, The best place to fix it is in pmanager.py file.
13:23 pal_bth manaskin_: where would I find that?
13:24 pal_bth manskin_: /etc/puppet or /usr/lib...
13:25 manashkin_ Please check your /usr/bin/pmanager.py first
13:25 AKirilochkin joined #fuel
13:25 manashkin_ Sorry, /usr/lib/python2.6/site-packages/cobbler/pmanager.py
13:25 pal_bth :)
13:29 Picachu @ evg : Ok i did your 3 steps, node is rebooting, I guess i should try anew to deploy it now ?
13:31 pal_bth manashkin_ : Any hints on where in that file? Any location where to add generic kernel parameters?
13:32 manashkin_ There is "def bootloader(self):" - please add all the necessary GRUB parameters as it done in https://github.com/stackforge/fuel-library/blob/stable/4.1/deployment/puppet/cobbler/templates/scripts/pmanager.py
13:33 evg Picachu: yes, try please
13:33 manashkin_ In your case I recommend 2 parameters - rootdelay=90 and nomodeset , last is for buggy Matrox and nVidia drivers
13:37 mattgriffin joined #fuel
13:39 AKirilochkin joined #fuel
13:40 jaypipes joined #fuel
13:41 Longgeek joined #fuel
13:42 emagana joined #fuel
13:43 manashkin_ Additionally, you may do this: http://paste.openstack.org/show/108909/
13:44 AKirilochkin joined #fuel
13:44 manashkin_ You may not change the whole eval(self) but only add the part with "self.late("sed -i "..."
13:48 Picachu @evg : interresting, now the node don't boot, it get stucked when get its pxe conf, it loads its pxelinux.cfg /<Mac_address> file, then print the following message on console : "Boot sector signature not found (Unbootable disk/partition)"
13:48 tatyana joined #fuel
13:55 pasquier-s_ joined #fuel
13:56 evg Picachu: please go to https://10.20.0.2/cobbler_web and find this node there
13:58 evg Picachu: but I still suspect you haven't appropriately search in database
14:03 adanin joined #fuel
14:08 pal_bth manashkin: my fuel is old, I only found once instance of the apt-get... grub-pc..
14:22 pal_bth joined #fuel
14:23 pal_bth manshkin
14:23 pal_bth manshkin_; changed and now doing a test deployment.
14:24 manashkin_ Correct, there is only one such place.
14:25 manashkin_ pal_bth, did you removed old *pyc/**pyo files?
14:25 pal_bth no..
14:26 manashkin_ Please remove. And, you have to restart nailgun with `supervisorctl restart nailgun; service nginx restart; cobbler sync`
14:27 pal_bth not used to python, should I remove pmanager.pyc ? no .pyo version found.
14:27 manashkin_ And please re-add the nodes to environment after pmanager change.
14:28 pal_bth Ok, its sufficient to delete nodes and re-add them? No need to remove the environment completely?
14:28 manashkin_ Yes, you even may do `rm -rf `/usr/lib/python2.6/site-packages/cobbler/*.pyc; /usr/lib/python2.6/site-packages/cobbler/*.pyo`
14:29 pal_bth and the nailgun will re-initiate those files, from the template?
14:34 e0ne joined #fuel
14:35 pasquier-s joined #fuel
14:46 mpetason joined #fuel
14:51 jobewan joined #fuel
14:53 Miroslav_ joined #fuel
14:56 Picachu @evg : I rechecked database but i promise i am not seeing any unused node id
14:57 Picachu but in cobbler i found a node id that is no more used and seems to match the problematic node
14:57 Picachu I'm on the way to re-test deploy
14:59 angdraug joined #fuel
15:02 Picachu @evg : Compute deployment started correctly, I really thank you man !!!
15:02 Picachu you made my day :)
15:10 evg Picachu: you're welcome
15:11 getup- joined #fuel
15:12 geekinutah joined #fuel
15:17 ArminderS joined #fuel
15:24 pasquier-s_ joined #fuel
15:25 e0ne joined #fuel
15:31 ArminderS- joined #fuel
15:33 tatyana joined #fuel
15:38 ArminderS joined #fuel
15:39 pal_bth manshkin_; thanks for the help, fuel reports that the nodes deployed (marked Ready in the web). But the controller does not report them, only internal.
15:40 eshumkher joined #fuel
15:41 taj joined #fuel
15:45 Longgeek joined #fuel
15:48 taj_ joined #fuel
15:48 artem_panchenko joined #fuel
15:57 Longgeek joined #fuel
15:58 getup- joined #fuel
16:08 ArminderS- joined #fuel
16:14 Longgeek joined #fuel
16:16 hoban joined #fuel
16:16 geekinutah joined #fuel
16:17 hoban geekinutah: Tim here
16:18 geekinutah xarses: This is Mike, I'm at adobe with hoban, can you answer some networking questions for us
16:18 xarses ?
16:18 xarses geekinutah: ?
16:20 geekinutah so we have some blades with 2 NICs, one is a fuel node the rest are compute
16:20 geekinutah compute/controller
16:20 geekinutah we also have 4 VLANs, 1811-1814
16:20 geekinutah which VLANs need to be tagged and which are native?
16:21 rmoe joined #fuel
16:22 xarses Only the Admin PXE network must remain un-tagged (native) the remaining roles can be tagged.
16:22 xarses Addtionally, the Admin PXE interface can not be moved, or placed into a bond
16:22 geekinutah should/can?
16:23 geekinutah okay, so with just 2 nics we can't bond then
16:23 geekinutah correct?
16:23 xarses correct
16:23 xarses its possible to force it outside of the UI, but its a bit of a pita
16:24 hoban is there anything on the roadmap to allow for the PXE NIC to be bonded? This was a recent feature added to VMWare to allow for this IIRC.
16:24 xarses Its problematic with lag bundles
16:25 xarses both parts of the lag have to support having non lag traffic (to allow the PXE) to run, untill the network part of puppet is complete
16:26 xarses usually, we see that the switch config wont allow the node to PXE boot
16:27 AKirilochkin joined #fuel
16:27 hoban thank you
16:27 geekinutah so with two nics, can I use one for PXE untagged and the other for all the tagged traffic?
16:28 xarses or mix
16:28 xarses dealers choice
16:30 geekinutah ty much xarses
16:31 xarses yw
16:31 taj joined #fuel
16:32 pasquier-s joined #fuel
16:34 AKirilochkin joined #fuel
16:37 AKirilochkin joined #fuel
16:47 AKirilochkin joined #fuel
16:54 Picachu joined #fuel
17:02 ArminderS joined #fuel
17:02 tdubyk joined #fuel
17:08 Longgeek joined #fuel
17:10 mattgriffin joined #fuel
17:24 ArminderS- joined #fuel
17:35 e0ne joined #fuel
17:38 emagana joined #fuel
17:47 xarses joined #fuel
17:52 ArminderS joined #fuel
17:54 geekinutah joined #fuel
18:00 emagana joined #fuel
18:01 emagana_ joined #fuel
18:19 xarses joined #fuel
18:22 e0ne joined #fuel
18:38 ArminderS- joined #fuel
18:41 ArminderS joined #fuel
18:43 eshumkher joined #fuel
18:43 Longgeek joined #fuel
18:50 eshumkher joined #fuel
19:06 emagana_ joined #fuel
19:15 emagana_ joined #fuel
19:20 geekinutah hoban: how's it going over there?
19:26 hoban geekinutah: thanks for checking in
19:27 hoban geekinutah: the deployment was hung again when I checked in on it awhile ago. One of the nodes was stuck on Installing CentOS...I checked the mcollective log and noticed that the node had stopped responding
19:27 hoban geekinutah: I rebooted that node, and things picked up again
19:27 hoban geekinutah: at this point, my controller nodes are Ready and the initial compute node is installing OpenStack
19:35 geekinutah okay good
19:35 geekinutah was there any other information in logs on the node that stopped responding to indicate what went wrong?
19:37 hoban not sure which logs to check
19:37 hoban in /var/log/docker-logs/mcollective.log, I found a bunch of these:
19:37 hoban W, [2014-09-09T18:27:26.713859 #467]  WARN -- : client.rb:218:in `rescue in start_receiver' Could not receive all responses. Expected : 4. Received : 3
19:52 e0ne joined #fuel
19:56 angdraug joined #fuel
20:01 HeOS joined #fuel
20:21 geekinutah xarses: ^
20:21 geekinutah xarses: any suggestions?
20:22 xarses take two Tynol prior to banging your head against ...
20:23 xarses is it ubuntu / centos?
20:25 xarses ya, centos
20:26 xarses geekinutah: hoban, I was speaking with rmoe, mcollective isn't running on the nodes during os-install, so that message is just pointing to one of the nodes not operating as expected
20:26 xarses as to what was going on in anaconda, I'd need a copy of the failed log, but since it was restarted there isn't much to look at
20:27 emagana joined #fuel
20:30 emagana_ joined #fuel
20:34 geekinutah agotcha
20:34 geekinutah gotcha even
20:35 xarses bless you?
20:35 geekinutah something like that...
20:40 hoban xarses: the OS install was completed successfully
20:40 hoban xarses: the node that was "stuck" on the Installing CentOS state was actually fully installed & booted up to CentOS, sitting at the login prompt. I rebooted it, and then Fuel proceeded with the remaining setup (state: Installing OpenStack)
20:42 xarses hmm, seems like it had some problem with its network or starting mcollective
20:42 adanin joined #fuel
20:43 emagana joined #fuel
20:43 ArminderS- joined #fuel
20:44 hoban xarses: at any rate, I have a workaround (reboot the stuck node). :-)
20:52 AKirilochkin hi guys
20:52 AKirilochkin what is the new password for cobbler web?
20:54 xarses AKirilochkin: 5.1?
20:54 AKirilochkin yes
20:54 AKirilochkin how i can get it?
20:57 xarses check /etc/fuel/astute.yaml
20:58 xarses it is generated randomly for each fuel master install now
20:58 xarses AKirilochkin: ^
21:09 AKirilochkin ok thx
21:18 AKirilochkin Guys, how i can change the mask of the pxe network after the installation?
21:19 AKirilochkin instellation of fuel
21:19 AKirilochkin can it be changed
21:19 AKirilochkin ?
21:19 AKirilochkin where>
21:19 AKirilochkin ?
21:22 AKirilochkin Guys, i need help now
21:27 e0ne joined #fuel
21:28 adanin joined #fuel
21:30 AKirilochkin Народ
21:30 AKirilochkin помогите
21:31 AKirilochkin Где в nailgun db содержится данная информация?
21:31 christopheraedo AKirilochkin: From the docs, looks like it's possible but could require rebuilding the docker containers. http://docs.mirantis.com/openstack/fuel/fuel-5.0/user-guide.html#changing-pxe-network-parameters-during-installation
21:31 mihgen AKirilochkin: dude, it's 1.30pm in MSK, not sure if we still have ppl who speak russian
21:32 mihgen AKirilochkin: you better reinstall
21:32 mihgen but if you really want to play, remember there are a few places
21:32 mihgen nailgun settings.yaml is one of them I believe
21:32 mihgen then it's going to be dnsmasq config
21:32 AKirilochkin the network is fine, but the hetwork mask is not got
21:33 mihgen might be some related service like tftp, but not sure here
21:33 AKirilochkin in this file I already changed
21:33 AKirilochkin seems that it is in postgres
21:35 mihgen AKirilochkin: there is also /etc/cobbler/dnsmasq.template, which is used by cobbler I believe as template, might be related
21:35 mihgen if you change this template, you would need to run "cobbler sync"
21:35 AKirilochkin i understand
21:37 eshumkher joined #fuel
21:37 e0ne joined #fuel
21:39 AKirilochkin Problem is that when i trya to save network configuration i have network intersection
21:39 AKirilochkin i just fill another value inside
21:41 hoban left #fuel
21:42 emagana joined #fuel
21:42 angdraug joined #fuel
21:43 bookwar joined #fuel
21:57 eshumkher joined #fuel
22:06 AKirilochkin joined #fuel
22:21 emagana joined #fuel
22:37 emagana joined #fuel
23:01 emagana joined #fuel
23:02 emagana joined #fuel
23:09 eshumkher joined #fuel
23:19 AKirilochkin_ joined #fuel
23:40 AKirilochkin_ Fuel ui everytime gives me a message
23:40 AKirilochkin_ Unable to log in
23:41 AKirilochkin_ How to resolve this?
23:57 eshumkher joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary