Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-03-12

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:03 Longgeek joined #fuel
00:19 Longgeek joined #fuel
00:27 rmoe joined #fuel
00:38 monester_laptop joined #fuel
01:26 LiJiansheng joined #fuel
01:37 xarses joined #fuel
01:52 Longgeek joined #fuel
02:09 CheKoLyN joined #fuel
03:37 Longgeek joined #fuel
03:48 mattgriffin joined #fuel
05:02 teran_ joined #fuel
05:03 loth1 joined #fuel
05:04 aleksandr_null_ joined #fuel
05:05 kevinbenton_ joined #fuel
05:07 kiwnix- joined #fuel
05:09 dpyzhov joined #fuel
05:09 zimboboy- joined #fuel
05:10 aarefiev joined #fuel
05:17 mattgriffin joined #fuel
05:45 Longgeek joined #fuel
05:45 mattgriffin joined #fuel
05:50 tzn joined #fuel
06:54 dklepikov joined #fuel
07:05 gongysh joined #fuel
07:49 ChrisNBlum joined #fuel
07:56 kozhukalov joined #fuel
08:03 Longgeek joined #fuel
08:42 dkusidlo joined #fuel
08:47 hyperbaba joined #fuel
09:04 dkusidlo joined #fuel
09:07 HeOS joined #fuel
09:13 gongysh joined #fuel
09:15 omolchanov joined #fuel
09:30 subscope joined #fuel
09:39 tonyha joined #fuel
09:45 ddmitriev joined #fuel
09:54 teran joined #fuel
09:54 Longgeek joined #fuel
09:55 e0ne joined #fuel
10:09 e0ne joined #fuel
10:10 e0ne joined #fuel
10:12 andriikolesnikov joined #fuel
10:15 alecv joined #fuel
10:24 sc-rm joined #fuel
10:31 monester_laptop joined #fuel
10:42 teran joined #fuel
10:44 teran_ joined #fuel
11:00 subscope joined #fuel
11:45 dkusidlo joined #fuel
11:59 Longgeek joined #fuel
12:08 dkusidlo_ joined #fuel
12:13 dkusidlo_ joined #fuel
12:39 Longgeek joined #fuel
13:32 julien_ZTE joined #fuel
13:37 Longgeek joined #fuel
13:44 e0ne joined #fuel
14:13 claflico joined #fuel
14:26 julien_ZTE joined #fuel
14:49 akupko joined #fuel
14:51 daniel3_ joined #fuel
15:04 dkusidlo joined #fuel
15:16 blahRus joined #fuel
15:21 e0ne joined #fuel
15:26 thumpba joined #fuel
15:27 KenV joined #fuel
15:29 dkusidlo joined #fuel
15:31 [HeOS] joined #fuel
15:32 thumpba_ joined #fuel
15:41 jgriffith joined #fuel
15:42 jgriffith Hello Fuel peoples....
15:42 jgriffith Wondering if there's an output file for the Health Checks in Fuel?
15:43 jgriffith So after running everything, is there an EZ bundle of logs or such that I can grab and submit for the runbook qual?
15:46 xarses joined #fuel
15:51 adanin joined #fuel
15:55 aliemieshko_ joined #fuel
15:56 Longgeek joined #fuel
16:00 angdraug joined #fuel
16:11 alex_didenko joined #fuel
16:12 thumpba joined #fuel
16:12 evkonst joined #fuel
16:13 evkonst_ joined #fuel
16:15 kaliya jgriffith: mmh no
16:15 dpyzhov_ joined #fuel
16:17 mrasskazov left #fuel
16:21 thumpba_ joined #fuel
16:26 alex_didenko joined #fuel
16:28 rmoe joined #fuel
16:32 evg jgriffith: /g 11
16:32 jgriffith evg: ?
16:32 evg jgriffith: sorry
16:33 jgriffith evg: darn, thought you had a great solution like "everythin in this hidden dir" :)
16:33 jgriffith kaliya: bummer, ok, thanks!
16:33 evg jgriffith: :)
16:33 evg jgriffith: Health Checks logs are in docker-ostf.log on master node
16:34 jgriffith evg: oh.. awesome!
16:34 jgriffith evg: thanks!
16:38 tzn joined #fuel
16:49 Miouge joined #fuel
16:55 adanin joined #fuel
17:11 championofcyrodi left #fuel
17:48 ddmitriev1 joined #fuel
17:51 adanin joined #fuel
17:52 championofcyrodi joined #fuel
17:58 andriikolesnikov joined #fuel
18:05 dpyzhov_ joined #fuel
18:11 Longgeek joined #fuel
18:18 glavni_ninja hello, i'm trying to install fuel and never bumped to this kind of problem... when i get to menu "Which of the detected hard drives do you want to be used as the installation target?"
18:18 glavni_ninja i type "sda" which is listed
18:18 glavni_ninja it hangs
18:19 glavni_ninja if i type Enter twice
18:19 glavni_ninja it goes back to same menu
18:20 glavni_ninja any idea?
18:21 championofcyrodi glavni_ninja: maybe a silly question, but is the drive healthy?
18:21 glavni_ninja i tried to choose sdb
18:21 championofcyrodi e.g.  can you create a partition, filesystem and read/write ?
18:21 glavni_ninja both are new disks in new server
18:21 glavni_ninja fresh
18:21 glavni_ninja less then 24hours
18:21 glavni_ninja yes i tried
18:22 glavni_ninja i created partition
18:22 glavni_ninja it works
18:22 championofcyrodi it sounds like there is an issue with your configuration and the fuel installer.  what version are you using?
18:22 glavni_ninja 6.0
18:23 glavni_ninja i used 6.0 earlier
18:23 championofcyrodi hmm.. well I don't know what to tell you.  Maybe double check the information you're providing in each step...
18:23 glavni_ninja well... no other interaction prior to that
18:23 championofcyrodi your disk are /dev/sdX so the 1st disk in your BIOS will be /dev/sda, 2nd disk will be /dev/sdb
18:23 championofcyrodi and so on
18:23 glavni_ninja ofcourse
18:24 glavni_ninja it gives me possible choices
18:24 glavni_ninja sda and sdb
18:24 glavni_ninja and asks to choose one
18:24 glavni_ninja whetever i choose it hangs
18:24 glavni_ninja after i hit Enter 2 times
18:24 glavni_ninja it's back on same menu
18:25 glavni_ninja nothing happens
18:25 glavni_ninja i installed fuel like XX times
18:25 glavni_ninja this never happened
18:26 championofcyrodi maybe check the disk mode in your bios or something...
18:26 glavni_ninja i tried all options in bios
18:26 championofcyrodi something is causing the issue, and if your just booting from ISO...
18:26 xdeller joined #fuel
18:26 glavni_ninja from ahci to enhanced mode
18:26 championofcyrodi tried resetting to defaults?
18:26 championofcyrodi (the whole bios)
18:27 championofcyrodi or updating firmware?
18:27 glavni_ninja i can try that
18:27 championofcyrodi also, if you could drop to a console, maybe the fuel installer has logs with errors?
18:27 glavni_ninja didn't get yet to that part
18:27 championofcyrodi i've never encountered an issue w/ the installer like that, so I'm not sure how you would even do that.
18:28 glavni_ninja as i am saying installation never starts
18:28 glavni_ninja because it hangs when you choose where to install
18:28 championofcyrodi right i understand, somtimes installers boot to an initramfs...
18:28 championofcyrodi which you can sometimes 'drop' out of the installer to the bash prompt there...and look over configs and logs..
18:29 championofcyrodi but i'm not familiar with the fuel installer itself enough to know how to do that, or if you can even
18:29 championofcyrodi e.g: http://docs.mirantis.com/openstack/fuel/fuel-6.0/_images/fuel_welcome_customized_settings.jpg
18:30 championofcyrodi that is grub...
18:30 championofcyrodi initrd.img is the image that is booting which has the filesystem with all of the modules to support the install
18:30 glavni_ninja well i'm passing that
18:30 glavni_ninja ...
18:31 championofcyrodi there may be a custom boot flag you can pass to run the installer in debug mode, which may help identify what the problem is
18:31 championofcyrodi but it's late on a Friday (EST) and i think most of the fuel developers in this room are gone...
18:32 glavni_ninja i see
18:32 championofcyrodi perhaps try the #fuel-dev and ask about running the installer with debugging/logging.  if resetting bios and updating firmware doesnt help
18:33 glavni_ninja championofcyrodi: thanks anyways
18:33 championofcyrodi sorry i couldn't be of more help.
18:33 glavni_ninja championofcyrodi: no worries
18:44 championofcyrodi So it looks like my DHCP issue might be related to a redhat bug: https://github.com/mseknibilel/OpenStack-Folsom-Install-guide/issues/14#issuecomment-10277135
18:46 championofcyrodi or, not so much a bug... but by design for udp performance
18:54 championofcyrodi The simplest workaround is to change the virtual NIC type from virtio to Intel e1000 in KVM. Apparently this driver calculates checksums. But virtio is the default driver type.
18:55 monester_laptop joined #fuel
18:56 mattgriffin joined #fuel
19:00 championofcyrodi also, even though dhcp is disabled in my subnet, new instances are still getting IP addresses on the UI
19:01 championofcyrodi I would prefer them to just be "-" since dhcp is disabled
19:06 MiroslavAnashkin glavni_ninja: Is your /dev/sda an ordinary hard drive? Is it partitioned? What is the disk size?
19:07 glavni_ninja MiroslavAnashkin: ordinary SATA disk
19:07 glavni_ninja not partitioned
19:07 glavni_ninja also tried to make one partition
19:07 glavni_ninja its 2TB size
19:21 glavni_ninja MiroslavAnashkin: any ideas? i'm out of any...
19:23 stamak joined #fuel
19:27 championofcyrodi glavni_ninja: what's the server?
19:28 championofcyrodi the model
19:28 championofcyrodi or motherboard model if it's a custom build
19:30 glavni_ninja championofcyrodi: Intel Server Board S1200V3RPL
19:32 championofcyrodi https://downloadcenter.intel.com/download/24647/S1200V3RPL-S1200V3RPO-S1200V3RPM-Firmware-Update-Package-for-IDA-OFU-WinPE-EFI
19:32 championofcyrodi bios update released 1/23/2015
19:33 championofcyrodi since that's a Q2 '13 mobo, so if you havent updated the firmware you probably should...
19:34 championofcyrodi recently i had an intel machine that wasnt PXE booting... in that the DHCP server was not getting requests... and the pxe boot just kept saying it couldnt find the server... firmware update fixed it.
19:34 glavni_ninja championofcyrodi: already latest firmware
19:38 championofcyrodi hmm..
19:39 e0ne joined #fuel
19:41 stamak joined #fuel
19:43 MiroslavAnashkin Well. There were cases when disks had some strange partitioning. Please try to erase at least first and last 10 MB on the problematic disk with dd. Or even the whole disk overnight.
19:44 glavni_ninja MiroslavAnashkin: yeah... i thought about that... just in case i tried to install fresh centos and it worked
19:44 glavni_ninja MiroslavAnashkin: i'll try to nullify whole disk overnight
19:44 glavni_ninja MiroslavAnashkin: but i'm afraid it's not gonna help
19:44 MiroslavAnashkin BTW, please try to wait ~30 minutes before considering the installation stalled.
19:45 glavni_ninja MiroslavAnashkin: i waited for about 20 minutes
19:45 glavni_ninja MiroslavAnashkin: strange thing is that if i hit Enter 2 times
19:45 glavni_ninja MiroslavAnashkin: it gives same menu again
19:46 MiroslavAnashkin Ah, one more point - Fuel does not support EFI (shame on us). Please switch your server to old BIOS compatibility mode.
19:48 angdraug joined #fuel
19:50 MiroslavAnashkin And about hitting Enter twice - I do not see anything, what may lead back to disk selection here: https://github.com/stackforge/fuel-main/blob/stable/6.0/iso/ks.template#L107-L127
19:52 MiroslavAnashkin Please install isomd5sum and run `checkisomd5 <isofilename>` to verify the image is not corrupted. There is md5 checksum, implanted to the ISO image.
19:53 [HeOS] joined #fuel
19:54 glavni_ninja MiroslavAnashkin: checksum is right
19:54 glavni_ninja MiroslavAnashkin: already did that
19:55 glavni_ninja MiroslavAnashkin: I run SATA controller in compatibility mode
19:55 glavni_ninja MiroslavAnashkin: tried Enhanced and AHCI mode already
19:56 MiroslavAnashkin AHCI should work...
19:56 glavni_ninja MiroslavAnashkin: well it
19:57 glavni_ninja MiroslavAnashkin: well it's not
19:57 glavni_ninja MiroslavAnashkin: about the code / link you sent
19:57 glavni_ninja MiroslavAnashkin: that's the menu where it hangs
19:58 glavni_ninja MiroslavAnashkin: and yes it asks again to select disk after hitting Enter twice
20:05 MiroslavAnashkin Oh, looks like I see... https://github.com/stackforge/fuel-main/blob/stable/6.0/iso/ks.template#L112-L114  This condition should never work.
20:07 glavni_ninja MiroslavAnashkin: I nullified first 10 mb of disk
20:07 glavni_ninja MiroslavAnashkin: and it worked!
20:07 glavni_ninja MiroslavAnashkin: thanks for your help!
20:07 glavni_ninja championofcyrodi: thank u 2!
20:08 MiroslavAnashkin Yes, and you even found a bug  - Fuel will never ask to confirm to erase the already available partitions...
20:10 glavni_ninja MiroslavAnashkin: i'm giving my part...
20:10 glavni_ninja MiroslavAnashkin: :D
20:16 Longgeek joined #fuel
20:31 teran joined #fuel
20:34 e0ne joined #fuel
20:35 mattgrif_ joined #fuel
20:50 thumpba joined #fuel
20:53 thumpba_ joined #fuel
20:54 mattgriffin joined #fuel
21:02 loth1 Hey all, I'm trying to setup a provider flat external network on fuel 5.1, i have enabled DHCP on net04_ext however i cant seem to get a dhcp response from the server. I show the interface has ACTIVE and UP in the neutron port listing
21:04 loth1 could iptables be blocking it?
21:16 thumpba joined #fuel
21:51 thumpba joined #fuel
22:08 Longgeek joined #fuel
22:12 designated joined #fuel
22:13 designated According to http://docs.mirantis.com/openstack/fuel/fuel-6.0/user-guide.html#setting-nic-bonding-nic-aggregation I should be able to bond multiple NICs.  I am running fuel 6.0 but do not have the option to select(check) NICs.  Can someone please tell me why?
22:19 mattgriffin joined #fuel
22:51 thumpba joined #fuel
23:02 dpyzhov_ joined #fuel
23:11 loth1 xarses: you around?
23:13 xarses nope
23:14 xarses loth1: are you booting the instance not receiving the address from openstack?
23:19 kupo24z I think the problem stems from trying to bind net04_ext to an interface in a VM, i dont see br-ex on the compute node so i dont think this will work
23:23 xarses that could be the case
23:23 kupo24z are provider networks a possiblity in 6.x?
23:23 xarses is there are reason you don't want to assign floating addresses from the external network and instead want to put them directly on the external net?
23:23 kupo24z left #fuel
23:23 kupo24z joined #fuel
23:24 xarses fuel won't configure them for you, you'd have to alter the configs yourself
23:24 kupo24z Yeah,thats fine. we have users that need to have the external ip address in their VM
23:28 julien_ZTE joined #fuel
23:32 xarses as the primary interface?
23:32 xarses oh, you mean @provider networks
23:34 kupo24z yea
23:34 kupo24z preferred to have eth0 be a provider external network, and eth1 be gre/vxlan tenant network
23:52 thumpba joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary