Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-05-26

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:13 LiJiansheng joined #fuel
01:09 LiJiansheng joined #fuel
01:48 ilbot3 joined #fuel
01:48 Topic for #fuel is now Fuel 5.1.1 (Icehouse) - Fuel 6.0 (Juno) https://software.mirantis.com | https://wiki.openstack.org/wiki/Fuel | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
04:21 gongysh joined #fuel
05:42 saibarspeis joined #fuel
05:46 e0ne joined #fuel
06:04 youellet__ joined #fuel
06:09 saibarspeis joined #fuel
06:16 ub joined #fuel
06:21 Hulda joined #fuel
06:45 fedexo joined #fuel
06:52 alecv joined #fuel
06:57 ub joined #fuel
07:18 pbeskow joined #fuel
07:22 hyperbaba joined #fuel
07:23 gongysh joined #fuel
07:39 e0ne joined #fuel
07:42 dklepikov joined #fuel
07:59 samuelBartel joined #fuel
08:40 fedexo joined #fuel
09:00 HeOS joined #fuel
09:03 subscope joined #fuel
09:17 Hulda aliemieshko_: turned out to be corrupted docker containers. followed this: https://bugs.launchpad.net/fuel/+bug/1383741 and got it to work
09:18 gongysh joined #fuel
09:56 ub joined #fuel
10:01 LiJiansheng joined #fuel
10:17 TiDjY35 joined #fuel
10:17 TiDjY35 hello everybody
10:17 TiDjY35 i've changed the ips adresses of fuel server. How to rebuild all Docker containers ?
10:28 e0ne joined #fuel
10:37 TiDjY35_ joined #fuel
10:45 teran joined #fuel
10:50 evg glavni_ninja_: You don't need to add modprobe 8021q. It will be loaded by kernel/udev when you create vlan
10:54 gongysh joined #fuel
11:04 teran joined #fuel
11:45 kutija_ joined #fuel
11:51 TiDjY35 joined #fuel
11:58 ub joined #fuel
12:00 e0ne joined #fuel
12:12 ub joined #fuel
12:20 ub joined #fuel
12:25 kutija__ joined #fuel
12:38 kutija_ joined #fuel
12:48 alxy joined #fuel
12:48 alxy left #fuel
12:53 kaliya joined #fuel
13:11 pbrooko joined #fuel
13:23 pbrooko joined #fuel
13:26 e0ne joined #fuel
13:30 rmoe joined #fuel
13:31 evg TiDjY35: hello, it's not recommended, you should run menu during install. Now you can check /etc/astute.yaml and try "dockerctl destroy/build" your containers. May be some more manual work will be required.
13:31 evg TiDjY35: I hope it's not poduction/working environment.
13:39 championofcyrodi joined #fuel
14:07 julien_ZTE joined #fuel
14:14 julien_ZTE joined #fuel
14:29 matthieucan joined #fuel
14:29 matthieucan hi
14:29 matthieucan quick question
14:30 matthieucan all torrents for the nightly builds in IMG format return 404s
14:30 matthieucan where can I get them?
14:34 evg hi, I see them work. What urls do you use?
14:39 rmoe joined #fuel
14:40 daniel3_ joined #fuel
14:41 emagana joined #fuel
14:44 matthieucan evg: this one https://ci.fuel-infra.org/view/ISO/
14:44 championofcyrodi left #fuel
14:44 matthieucan the IMG links on the right
14:50 evg hm, really
14:51 evg we just don't separate img and iso now, please use iso link
14:52 pasquier-s joined #fuel
14:55 matthieucan evg: oh good news, didn't see that
14:55 matthieucan thank you
14:58 e0ne joined #fuel
15:02 evg matthieucan: np
15:10 angdraug joined #fuel
15:58 blahRus joined #fuel
16:01 monester_laptop joined #fuel
16:08 teran joined #fuel
16:11 championofcyrodi joined #fuel
17:10 julien_ZTE joined #fuel
17:23 daniel3_ joined #fuel
17:46 igorbelikov joined #fuel
18:03 xek joined #fuel
18:13 julien_ZTE joined #fuel
18:19 ub joined #fuel
18:27 monester_laptop joined #fuel
18:46 HeOS joined #fuel
18:48 glavni_ninja_ evg: well that's not happening... our deploy failed because of missing 8021q module... we had to add it by hand
18:53 e0ne joined #fuel
19:14 julien_ZTE joined #fuel
19:50 gongysh joined #fuel
20:00 e0ne joined #fuel
20:11 daniel3 joined #fuel
20:18 julien_ZTE joined #fuel
20:25 teran joined #fuel
20:27 kutija I have a strange issue with HA Juno deploy (6.1 #250) - only one node (2nd controller) is able to ping and gain access  through Virtual IP
20:27 kutija because of this aI have strange issues - every fifth login to Horizon works, volumes are attaching from 3rd try....
20:27 kutija what could be a cause for this?
20:27 kutija I have no idea  where to look
20:28 kutija I can launch instances, use volumes (when I manage to attach them)
20:28 kutija but If i have two computers in front of me on the same network - one will be able to login, other dont
20:28 kutija I'm getting something like
20:28 kutija <140>May 26 11:30:15 node-2 dashboard-horizon.exceptions: WARNING Recoverable error: HTTPConnectionPool(host='5.189.188.5', port=8774): Max retries exceeded with url: /v2/5d6ccc07e0ed41afbedc44282d72d54d/extensions (Caused by <class 'socket.error'>: [Errno 113] No route to host)
20:29 kutija in dashboard.lo
20:29 kutija and I have no idea why
20:29 mwhahaha may want to check the status of the HA cluster for your controllers
20:30 kutija I did
20:30 mwhahaha and everything is up?
20:30 kutija http://paste.openstack.org/show/238469/
20:30 kutija if I read this correctly
20:30 kutija yes it is
20:30 kutija everything is there
20:30 kutija all services are rtunning
20:30 mwhahaha it sounds like the haproxy stuff isn't working correclty
20:30 kutija also sometimes rabbitmq just falls down for no reason, every 5 to 6 hours
20:31 mwhahaha did you add/remove controllers?
20:31 kutija nope
20:31 kutija 6 nodes deployed in ne turn
20:31 kutija 18 hours ago
20:31 kutija *one
20:32 kutija HAProxy crossed my mind
20:32 kutija but I did not see any kind of log available on Controllers
20:33 kutija btw "keystone client is missing" bug is not fixed in #250 when trying to do health check
20:33 mwhahaha missing or unavailable?
20:33 kutija sorry, not available :)
20:34 mwhahaha i think that's the catchall error ;)
20:34 glavni_ninja_ mwhahaha: catchall error?
20:34 mwhahaha it seems to show up if anyting goes wrong
20:34 mwhahaha that isn't already caught
20:35 glavni_ninja_ mwhahaha: it's a feature then :D
20:35 mwhahaha like it's the error that shows up but that's not actually a problem
20:35 kutija mwhahaha: how can I check if HA Proxy is working properly?
20:35 mwhahaha was just trying to look into that for you
20:35 mwhahaha give me a few minutes
20:36 kutija thanks
20:36 glavni_ninja_ mwhahaha: thanks... also interested!
20:37 mwhahaha you could try restarting it via pacemaker
20:37 mwhahaha pcs resource restart clone_p_haproxy
20:39 mwhahaha https://github.com/stackforge/fuel-library/blob/master/files/fuel-misc/haproxy-status.sh
20:39 mwhahaha might also be distributed so you could look for that command
20:40 kutija it looks like that command is not complete since it gives a list of all possible commands
20:41 kutija script works though
20:41 kutija gives a status
20:41 kutija http://paste.openstack.org/show/238470/
20:41 kutija looks like everything is up and running
20:43 mwhahaha so haproxy runs in a network namespace, you could try seeing if that namespace is having issues connecting to the backend services
20:43 mwhahaha like it might only be working when it talks to the local instance
20:43 mwhahaha would seem odd that this would just start happening though
20:47 matthieucan left #fuel
20:48 mwhahaha by the way restart was wrong, it would be pcs resource disbale clone_p_haproxy and pcs resource enable clone_p_haproxy
20:50 mwhahaha also haproxy log should be logging to the  remote logs on the admin node https://bugs.launchpad.net/fuel/+bug/1330948
20:51 kutija yeah, it's there
20:51 kutija haproxy reboot did not do the trick
20:51 kutija nodes cannot access VIP
20:52 kutija (only one can though, I have no idea how)
20:55 mwhahaha is this ubuntu or centos?
20:55 kutija Ubuntu
20:55 kutija actually my nodes can't ping each other via public IP
20:55 kutija but they can ping default router04 and instances
20:56 kutija weird
20:56 mwhahaha indeed
20:56 kutija also instances are available via public network
20:56 kutija it's a GRE segmentation
20:57 mwhahaha there is this, https://bugs.launchpad.net/fuel/+bug/1451756
21:01 kutija yeah looks similar
21:01 kutija but this is for Centos if i'm correct
21:03 kutija there is one more issue that I saw just after finished deploy
21:03 kutija networks switched places
21:03 kutija net04_ext is Local type
21:03 kutija and net04 is GRE
21:03 kutija and when u launch the instance, it's not accessible via public IP
21:04 kutija only if you add floating IP to net04 interface
21:05 mwhahaha might want to create a bug around it and upload the logs. someone with more familiarity with the gre stuff might be able to take look
21:06 mwhahaha i'll poke around some more but i don't have an answer for you right now
21:06 kutija allright, I will
21:06 kutija what is needed for a bug report, Diagnostic snapshot?
21:06 mwhahaha yea
21:06 mwhahaha that and the version you're running
21:07 kutija ok, will do
21:07 mwhahaha https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Test_and_report_bugs
21:25 TiDjY35 thank evg
21:40 julien_ZTE joined #fuel
22:09 julien_ZTE joined #fuel
22:29 julien_ZTE joined #fuel
22:46 goukos sup guys, are there any plugins for fuel except for those mentioned on the website? even something unstable or on alpha versions :P
22:55 julien_ZTE joined #fuel
23:09 angdraug goukos: https://github.com/stackforge/?query=fuel-plugin
23:10 goukos angdraug: nice, thanks
23:13 julien_ZTE joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary