Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-06-12

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:30 sbfox joined #fuel
01:07 danwest joined #fuel
01:54 sbfox joined #fuel
02:29 Samos123 kaliya: Tried using fuelmenu and then buildall, but because all containers are running nothing happens. So i first tried: `dockerctl list | xargs dockerctl stop` and then `dockerctl build` but it still says: http://paste.openstack.org/show/284858/
02:31 Samos123 I am trying to change the pxe interface for reference. So any tips greatly appreciated
02:35 Samos123 planning to file a bug and update the documentation for this. This is probably quite a common use case
03:05 Samos123 the docker containers get automatically started even if i stop them... seems there is some process auto-restarting those, pacemaker/corosync?
03:25 sbfox joined #fuel
03:27 sbfox1 joined #fuel
03:52 dmitryme joined #fuel
04:03 fedexo joined #fuel
04:06 sbfox joined #fuel
04:24 sbfox joined #fuel
06:11 HeOS joined #fuel
06:39 saibarspeis joined #fuel
06:44 HeOS joined #fuel
07:03 xarses joined #fuel
07:07 dancn joined #fuel
07:16 fedexo joined #fuel
07:39 samuelBartel joined #fuel
08:00 teran joined #fuel
08:19 hyperbaba joined #fuel
08:19 HeOS joined #fuel
08:20 subscope joined #fuel
08:38 e0ne joined #fuel
08:50 stephenking joined #fuel
08:51 stephenking hi there
08:51 daniel2 joined #fuel
08:52 stephenking I've some issues with deploying an environment. I downloaded the nightly build yesterday and the ubuntu installation of the nodes fails with "Failed to execute hook 'shell' Failed to run command cd / && fa_build_image ..." (details see https://gist.github.com/StephenKing/d2ead4351a6cb066c5e1)
08:52 stephenking I'm not sure, how I can debug this
08:52 stephenking I already moved to 6.1, as 6.0 gave me some "cannot connect to mcollective" errors during deployment
08:52 stephenking any ideas?
09:04 wayneeseguin joined #fuel
09:28 eliqiao joined #fuel
10:04 e0ne joined #fuel
10:20 Miouge joined #fuel
10:21 eliqiao left #fuel
10:26 bookwar stephenking: which build it was?
10:30 bookwar if you check https://ci.fuel-infra.org/, 6.1 panel, then the 6.1-272 failed test but today's 273 looks ok
10:41 stephenking ah, fuel releases  broken build. didn't expect that :)
10:42 stephenking will give it a try with today's
10:44 stephenking preferably 6.1 or 7.0?
10:50 subscope joined #fuel
12:19 bookwar stephenking: depending on what you are looking for
12:19 stephenking a working environment ^^
12:20 stephenking I've set up v7 now and am deploying right now
12:20 stephenking in what log should I see some progress?
12:21 bookwar stephenking: you should have used 6.1 as it is built from stable/6.1 branch, and 7.0 is our development branch currently
12:21 bookwar but they didn't diverged much yet
12:21 bookwar so should be ok for now
12:21 stephenking I think it will end up like with the 6.0, when the ubuntu installation progress then timed out
12:21 stephenking I remember from the 5.x installations that I saw some progress of puppet in some logs
12:21 stephenking where should that be?
12:22 stephenking is it true that this message is "normal"? >>Could not get url from configuration file: No such file or directory - /etc/nailgun-agent/config.yaml, trying other ways.. <<
12:38 subscope joined #fuel
13:00 stephenking bookwar: again the same issue as before :( that fa_build_image timed out after 1h :(
13:00 stephenking not sure, what I'm doing wrong with mantis
13:01 e0ne joined #fuel
13:42 bookwar stephenking: how do you start deployment?
13:42 stephenking through the web ui?
13:43 stephenking it worked better now with a different ubuntu mirror, not sure if the german one was a bit flaky
13:43 stephenking now it has been refusing to deploy to 3 of the nodes because of some disk layout issues.
13:47 bookwar we use 'deb http://archive.ubuntu.com/ubuntu/ trusty main universe multiverse' in our ci test https://ci.fuel-infra.org/job/fuel_community.ubuntu.bvt_2/153/console but if you are unsure about upstream you can use the fixed snapshot we have to track changes: http://mirror.fuel-infra.org/pkgs/ubuntu-2015-06-11-170128/ for example
13:48 bookwar but if it is disk layput - there is smth else going on, and i guess we need bug with more logs and diagnostic snapshot
13:50 mwhahaha are there already partitions on the machines?
13:52 stephenking from the previous deployment, yes
13:52 stephenking (I gues..)
13:52 stephenking I try it once more, if that doesn't work, I will empty the disk first on monday
13:52 mwhahaha i don't think we are clearing partitions before attempting deployment so you may need to wipe the disks
13:52 stephenking ah, good to know
13:53 mwhahaha normally during our environment deletion we run an erase function
13:53 mwhahaha but if you are using existing hardware with partitions you may need to remove them
13:53 mwhahaha (this should be a bug)
13:55 stephenking I only did reset of the environment
13:56 stephenking btw what's the meaning of installing the operating system when selecting the roles. what happens, when I don't select "Operating System", but only compute etc? :)
13:56 mwhahaha It'll put the os
13:57 mwhahaha er it'll put the os on the box when you select a role
13:57 mwhahaha the os-only really should be greyed out if you select a role like compute
13:57 mwhahaha i'm not sure what happens if you select both
13:57 stephenking k
13:57 stephenking error is > fuel_agent.cmd.agent [-] /boot partition has not been created for some reasons
13:59 stephenking https://gist.github.com/StephenKing/fe3428348fa816470efb
14:00 stephenking where does it install the boot record?
14:00 stephenking maybe the problem is that the system disk is the last one in the disks listing?
14:01 magicrobotmonkey joined #fuel
14:01 stephenking ah.. nope.. this is the case only for my storage nodes (and they seem to work well). those that fail are those which have the system on the raid-1 array
14:01 magicrobotmonkey hey anyone had any luck with EFI support?
14:02 magicrobotmonkey I've patched up the old version of cobbler and I can get it to install with EFI, but it won't boot off the disks post install
14:02 mwhahaha yea i don't think we install grub-efi
14:02 mwhahaha there was a bug about that somewhere, we're using grub-pc which may not work with efi if i recall correctly
14:04 magicrobotmonkey yea thats pretty much the conclusion I came to
14:04 magicrobotmonkey the kickstarts are hard to read, eh?
14:06 mwhahaha https://bugs.launchpad.net/fuel/+bug/1463708 i think was the bug i previously have seen but it's marked as invalid
14:06 mwhahaha not sure why
14:07 mwhahaha if that's what you're running into please add a note on that bug so we can reopen it
14:09 magicrobotmonkey ooh you're on launchpad, no wonder i couldn't find anything
14:28 monester_laptop joined #fuel
14:41 claflico joined #fuel
15:13 xarses joined #fuel
15:20 blahRus joined #fuel
15:26 rmoe joined #fuel
15:51 kutija joined #fuel
16:00 championofcyrodi joined #fuel
17:06 Samos123 fuel reports my node has 0 disks, I'm guessing it's missing a raid controller driver? Anybody tips on how to proceed?
17:07 mwhahaha what raid card?
17:08 Samos123 07:00.0 RAID bus controller: Hewlett-Packard Company Device 3239 (rev 01)
17:09 mwhahaha what system is it?
17:09 Samos123 bootstrap image of Fuel
17:09 mwhahaha no what's the model of the server
17:10 mwhahaha https://bugs.launchpad.net/fuel/+bug/1445029 was for hp raid in Gl gen9 servers
17:10 mwhahaha it's in 6.1 but not 6.0
17:10 Samos123 oh sorry: HP ProLiant BL460c Gen9
17:10 mwhahaha You'd need to use 6.1
17:10 Samos123 no work around?
17:11 mwhahaha i'm sure there's a complicated work around involving including the driver in the bootstrap images
17:12 mwhahaha Are you trying to add it to an existing 6.0 installation or something?
17:12 Samos123 yea
17:12 mwhahaha You could post a question to that bug
17:12 mwhahaha and see if someone can reply with a workaround
17:13 mwhahaha basically the driver needs to up dated and i'm not sure what that all involves
17:13 mwhahaha oh it looks like it'll be in 6.0.1
17:13 mwhahaha not sure when that officially comes out
17:13 Samos123 ok i will give it a try and if i dont succeed i will just install 6.1
17:15 Samos123 thanks mwhahaha
17:15 mwhahaha no problem
17:19 magicrobotmonkey is 6.1 out?
17:19 Samos123 no it's not released yet
17:20 magicrobotmonkey ah
17:21 magicrobotmonkey is it possible to do a setup with ceph where 1 ssd is the journal for a bunch of platters?
17:22 jaypipes joined #fuel
17:32 daniel2 left #fuel
17:35 Samos123 mwhahaha: do you think that I can just switch bootstrap image from current 6.1 nightly with my current installation?
17:35 Samos123 i wanna try it out :P any easy way to get the 6.1 bootstrap image?
17:44 rmoe magicrobotmonkey: that's how it actually works even though the UI doesn't make it clear. If you allocate one disk as a journal and say 5 disks as OSD when the node is provisioned it will create 5 partitions on the journal device and each OSD will use one
17:47 magicrobotmonkey oh rad
17:47 magicrobotmonkey I'd like to try a 6.1 as well
17:47 magicrobotmonkey i had to do a bunch of hacking on cobbler to get UEFI installing going, and it stil wasn't quite all the way there
17:47 magicrobotmonkey my vendor gave me a magic ipmi string to switch everything to legacy I might try though
17:49 Samos123 wait 6.1 supports UEFI?
17:49 magicrobotmonkey lol i dunno
17:49 magicrobotmonkey i doubt it
17:49 Samos123 i dont think so, there is a blueprint for it: https://blueprints.launchpad.net/fuel/+spec/uefi-support
17:50 magicrobotmonkey I have a couple patches in newer cobbler that help support it
17:50 magicrobotmonkey i manually backported them and got them to bootstrap and install ubuntu
17:50 magicrobotmonkey but they wont boot off the disk
17:51 magicrobotmonkey i actually almost got it working by hard coding the kernel into the localboot template in cobbler
17:51 magicrobotmonkey but that seemed too sketchy
17:54 DrSlump have people used the nightly community builds to any success?
17:54 magicrobotmonkey I don't know where they are
17:54 magicrobotmonkey I'd love to though
17:55 DrSlump i'm referring to https://ci.fuel-infra.org/
17:55 magicrobotmonkey oooh look at that
17:55 magicrobotmonkey I'll give one a try
17:56 DrSlump i've had raid controller driver issues too. someone from mirantis had posted old semi-compatible drivers but it's been removed. now i'm considering using a nightly build since it prolly has it merged in there
17:56 magicrobotmonkey ugh im so glad we went all HBA in our latest build
18:00 e0ne joined #fuel
18:06 jaycee joined #fuel
18:19 e0ne joined #fuel
18:43 jaypipes joined #fuel
18:46 nurla joined #fuel
19:09 e0ne joined #fuel
20:07 dmellado joined #fuel
20:07 teran joined #fuel
20:08 bookwar joined #fuel
20:11 aleksandr_null joined #fuel
20:11 aignatov joined #fuel
20:35 samuelBartel joined #fuel
21:10 darkhuy joined #fuel
21:13 HeOS joined #fuel
21:44 HeOS joined #fuel
22:01 rmoe joined #fuel
22:12 nurla joined #fuel
22:17 LiJiansheng joined #fuel
23:55 xarses joined #fuel
23:56 xarses joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary