Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-07-17

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:00 mattymo joined #fuel
00:02 mattymo joined #fuel
00:04 mattymo joined #fuel
00:06 mattymo joined #fuel
00:09 mattymo joined #fuel
00:11 mattymo joined #fuel
00:13 mattymo joined #fuel
00:15 mattymo joined #fuel
00:17 mattymo joined #fuel
00:19 mattymo joined #fuel
00:19 Rodrigo_BR joined #fuel
00:21 mattymo joined #fuel
00:22 Rodrigo_BR Hi
00:22 Rodrigo_BR How to control Bandwith of the instances ?
00:22 Rodrigo_BR I try nova flavor-key silver_1 set quota:vif_inbound_average=1024
00:23 mattymo joined #fuel
00:25 mattymo joined #fuel
00:27 mattymo joined #fuel
00:29 mattymo joined #fuel
00:31 mattymo joined #fuel
00:33 mattymo joined #fuel
00:35 mattymo joined #fuel
00:37 mattymo joined #fuel
00:39 mattymo joined #fuel
00:39 tzn joined #fuel
00:41 mattymo joined #fuel
00:43 mattymo joined #fuel
00:45 mattymo joined #fuel
00:47 mattymo joined #fuel
00:49 mattymo joined #fuel
00:51 mattymo joined #fuel
00:53 mattymo joined #fuel
00:55 mattymo joined #fuel
00:57 mattymo joined #fuel
00:59 mattymo joined #fuel
01:01 mattymo joined #fuel
01:03 mattymo joined #fuel
01:05 mattymo joined #fuel
01:07 mattymo joined #fuel
01:09 mattymo joined #fuel
01:12 mattymo joined #fuel
01:14 mattymo joined #fuel
01:16 mattymo joined #fuel
01:18 mattymo joined #fuel
01:20 mattymo joined #fuel
01:22 mattymo joined #fuel
01:24 mattymo joined #fuel
01:26 mattymo joined #fuel
01:28 mattymo joined #fuel
01:30 mattymo joined #fuel
01:32 mattymo joined #fuel
01:34 mattymo joined #fuel
01:36 mattymo joined #fuel
01:38 mattymo joined #fuel
01:40 mattymo joined #fuel
01:41 tzn joined #fuel
01:45 mattymo joined #fuel
01:45 mattymo joined #fuel
01:48 ilbot3 joined #fuel
01:48 Topic for #fuel is now Fuel 6.1 (Juno) https://software.mirantis.com | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
01:48 mattymo joined #fuel
02:04 youellet_ joined #fuel
02:22 rbrooker anyone have an idea what the size of the full ubuntu local mirror is?
02:39 Rodrigo_BR left #fuel
02:53 hakimo joined #fuel
03:10 hakimo_ joined #fuel
03:27 hakimo joined #fuel
03:42 tzn joined #fuel
03:44 hakimo_ joined #fuel
04:01 hakimo joined #fuel
04:18 hakimo_ joined #fuel
04:24 saibarspeis joined #fuel
04:26 neophy joined #fuel
04:31 rbrooker I have attempted to deploy several times, I updated fuel and rebooted --> 2 nodes [ one controller] [one compute/cinder]  -- http://paste.openstack.org/show/382722/
04:32 rbrooker I have already built a partial mirror -- I am now running a full mirror (currently) -- Ubuntu   using 6.1  kvm hypervisor
04:33 rbrooker os installs but fails on installing openstack on controller node.
04:34 rbrooker I had one successful deployment, prior to update. is this a possible bug, or just PEBKAC
04:35 rbrooker and ideas would be awesome. -- although I am heading to bed now, I figure I would check back later.  -- thank you
05:29 ilbot3 joined #fuel
05:29 Topic for #fuel is now Fuel 6.1 (Juno) https://software.mirantis.com | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
05:31 darkhuy_ joined #fuel
05:43 tzn joined #fuel
06:03 darkhuy_ joined #fuel
06:19 stamak joined #fuel
06:31 pab10 joined #fuel
06:37 mkwiek joined #fuel
06:54 ub joined #fuel
06:57 NERvOus joined #fuel
07:10 dkusidlo joined #fuel
07:15 devvesa joined #fuel
07:25 aliemieshko_ joined #fuel
07:25 dancn joined #fuel
07:26 kutija joined #fuel
07:46 dklepikov joined #fuel
07:47 tzn joined #fuel
07:48 kutija_ joined #fuel
07:49 _tzn joined #fuel
08:27 stamak joined #fuel
08:30 evgeniyl___ joined #fuel
08:40 monester joined #fuel
08:49 dkusidlo joined #fuel
08:49 ashtokolov joined #fuel
08:53 alex_didenko left #fuel
08:59 HeOS joined #fuel
09:01 e0ne joined #fuel
09:02 dkusidlo joined #fuel
09:11 DaveJ__ joined #fuel
09:11 barthalion joined #fuel
09:20 dkusidlo joined #fuel
09:24 azemlyanov joined #fuel
09:25 barthalion joined #fuel
09:26 azemlyanov_ joined #fuel
10:01 ashtokolov joined #fuel
10:11 teran joined #fuel
10:17 teran joined #fuel
10:21 barthalion joined #fuel
10:27 barthalion joined #fuel
10:43 teran joined #fuel
11:13 teran joined #fuel
11:14 teran joined #fuel
11:21 teran joined #fuel
11:23 teran joined #fuel
11:26 ashtokolov joined #fuel
12:24 NERvOus1 joined #fuel
12:27 NERvOus joined #fuel
12:28 NERvOus2 joined #fuel
12:35 dkusidlo joined #fuel
12:36 teran_ joined #fuel
12:36 ashtokolov joined #fuel
12:38 tzn joined #fuel
13:22 mwhahaha rbrooker: if you manually run the fuel_pkgs task on the node it's failing on, what's the error message?
13:43 hakimo joined #fuel
13:48 ashtokolov joined #fuel
13:50 alex_didenko joined #fuel
13:56 jdandrea joined #fuel
13:57 rbrooker mwhahaha: I haven't tried that yet, I will test that out now.
13:57 mwhahaha or check the puppet logs
13:57 mwhahaha for the error message
13:57 mwhahaha that task is pretty simple i think it just pulls in two packages
13:58 teran joined #fuel
14:02 rbrooker the other part that was odd and I'm now just noticing it. -- there was no puppet logs in the fuel web interface
14:02 ashtokolov joined #fuel
14:05 mwhahaha they don't show up until the logging task which is after that one
14:11 hakimo_ joined #fuel
14:17 rbrooker when I run -> puppet module list on the controller  ---   Warning: Missing dependency 'nanliu-staging':   plus a list of others
14:18 darkhuy joined #fuel
14:20 rbrooker when attempting apt-get upgrade on the controller node, it fails to upgrade nailgun from mos6.1-update I get 403 errors
14:21 mwhahaha what repo are you using? ours or your own local?
14:22 rbrooker local
14:23 mwhahaha that would probably be an apache config issue on the fuel master
14:23 mwhahaha or the repo doesn't exist
14:24 rbrooker I've checked and rerun the fuel-createmirror script
14:24 rbrooker I also have a full ubuntu mirror local
14:24 mwhahaha i'm not sure if that takes the update repos into account
14:25 rbrooker http://paste.openstack.org/show/383813/
14:26 rbrooker it shows that it sees the update repos, It just doesn't like the keys
14:26 claflico joined #fuel
14:34 mwhahaha a 403 would be a pathing issue, if you try and wget those files does it work?
14:35 ashtokolov joined #fuel
14:42 ashtokolov joined #fuel
14:42 rmoe joined #fuel
15:01 jaypipes joined #fuel
15:03 ashtokolov joined #fuel
15:17 sergmelikyan joined #fuel
15:26 blahRus joined #fuel
15:45 ggolin hi all
15:45 ggolin why is the admin(pxe) iface locked to eth0 in 6.1?
15:46 ggolin in the fuel web
15:48 xarses_ ggolin: the nic selected is whichever it's discovered to route on
15:48 ggolin is it a naming thing perhaps, as per the reference doc..
15:48 ggolin eth2 is where the dhcp runs
15:49 xarses_ on your network?
15:49 ggolin eth3, sorry. and thats where the nodes receive the ip addresses, eth3.
15:50 ggolin thats the iface from which nodes boot, too.
15:50 ggolin but in webui i cannot drag the pxe iface from eth0 to eth3
15:51 pab10 joined #fuel
15:51 xarses_ its likely that the kernel in discovery re-ordered the nics then. the admin is selected by 1)the nic that after dhcp is the same nic as which matches the network of the fuel pxe 2) the nic with the default route
15:51 ggolin im wondering if thats why my deployment does not complete.
15:52 CheKoLyN joined #fuel
15:52 ggolin ubuntu never gets installed, the nodes time out.
15:52 xarses_ did you run the network check?
15:52 ggolin tried. it runs and times out.
15:53 xarses alot of vlan id's in the private range?
15:54 ggolin default. thirty.
15:54 ggolin let me limit it to one.
15:54 xarses should not be from that, but ya moving it to 1 reduces the work
15:55 ggolin im seeing in the logs that its trying to connect to ethX.XXX - what is that? it expects virtual interfaces to be present?
15:56 xarses so, in 6.1 you fuel master, the dhcp-pool's route, and the public network need access to the repositories for ubuntu (they are listed on the settings page)
15:56 ggolin indeed
15:57 xarses if the discovered nodes never rebooted into ubunto from centos, then something probably building the disk image on the master
15:58 ggolin gah the dhcp does not route out? my dhcp pool is in 10.0.0.0/24
15:58 ggolin nodes resolve google.com but cant actually hit it
16:01 ggolin -A POSTROUTING -s 10.53.108.0/24 -o eth+ -m comment --comment "004 forward_admin_net" -j MASQUERADE
16:05 ggolin sorry
16:08 ggolin :err=>"Command ['ip', 'link', 'show', 'eth2.822'] executed. RC 1, stdout , stderr Device \"eth2.822\" does not exist. - 822 is the vlan id assigned to that iface - what am i missing here?
16:08 ggolin feel like a total pebcak
16:10 ashtokolov joined #fuel
16:20 angdraug joined #fuel
16:21 neophy joined #fuel
16:26 ashtokolov joined #fuel
16:30 mwhahaha is that part of the network verification process?
16:30 mwhahaha that error
16:31 ggolin that shows up in the logs.
16:32 ggolin i had to add a firewall rule for the nodes to be able to access the repos, so that works now. at least on the console. net verify is still running. and i get the feeling there will be a timeout error again.
16:33 ggolin heh. repo availability problem again. i am on the node, running nc mirror.fuel-infra.org 80 - and it returns the html
16:33 mwhahaha what network setup are you using? neutron vlan?
16:33 ggolin yes.
16:33 ggolin as well as this Method verify_networks. 75dd9d69-8f30-48c6-8c5e-72dfe340007a: MCollective call failed in agent 'net_probe', method 'get_probing_info', failed nodes: ID: 42 - Reason: execution expired ID: 43 - Reason: execution expired ID: 44 - Reason: execution expired .
16:35 mwhahaha https://bugs.launchpad.net/fuel/+bug/1466020
16:37 ggolin mwhahaha: you're saying a reboot will fix this? :)
16:37 mwhahaha it might :D
16:39 mwhahaha also check switch config
16:41 * ggolin reboots all nodes
16:41 ggolin dont own the switch, unfortunately
16:42 ggolin part of the reason i didnt want to eval this amazing thing is the fact that i do not own the network
16:43 mwhahaha use gre then
16:43 * ggolin hmms
16:54 jobewan joined #fuel
17:10 ggolin my public net intersects with admin/pxe for some reason
17:11 ggolin admin/pxe is 10.0.0.0/24, pub is 10.53.109.0/24. 10.53.109.254 is also an address assigned to the fuel master.
17:13 tzn joined #fuel
17:32 ggolin mwhahaha: so when the net verify tells me nodes cannot hit the repos it means "im assinging ip addresses from the pub pool you specified and i cant hit the repos with that net setup"?
17:36 mwhahaha yea
17:36 mwhahaha so whatever your network config is going to be, it won't be able to hit the repos
17:45 ggolin just to be clear, admin/pxe is the network onto which the nodes boot up
17:46 ggolin ?
17:47 ggolin i mean, obviously, but just to be clear because when i add a physical private network which is not 10.0.0.0/24 fuel tells me it intersects with admin/pxe
17:48 mwhahaha sounds like a netmask is getting missed somewhere
17:51 ggolin 10.0.0.0/24 vs 10.53.108.0/24?
17:51 mwhahaha yea like it's not honoring the /25
17:52 mwhahaha er /24
17:52 ashtokolov joined #fuel
17:53 ggolin grr
17:54 ggolin heh. if i set up 10.0.0.0/24 as the private network - it takes.
17:54 ggolin i mean the form validation.
17:54 ggolin do i just blow away this entire installation and start over
17:55 stamak joined #fuel
17:56 teran joined #fuel
18:10 ashtokolov joined #fuel
18:16 stamak joined #fuel
18:21 xarses joined #fuel
18:26 neophy joined #fuel
18:29 e0ne joined #fuel
18:42 xarses ggolin: any luck?
18:44 stamak joined #fuel
18:44 sergmelikyan joined #fuel
18:55 sergmelikyan joined #fuel
18:59 monester joined #fuel
19:24 osryan_ joined #fuel
19:25 tzn joined #fuel
19:26 osryan_ Hello all, I'm having a tough time deploying the Fuel master node. The web UI doesn't work. I've attempted to rebuild multiple times and verified settings. I think there's an internal service failure somewhere but I'm not familiar with Docker. Anyone else run into this?
19:27 mwhahaha osryan_: what errors are you getting?
19:28 osryan_ The web page doesnt come up, just says connection refused. Netstat doesn't show any service running on port 8000
19:28 osryan_ i'll see if i can find an error in the log file
19:29 mwhahaha how are you deploying this fuel master node?
19:29 osryan_ on a kvm virtual machine
19:29 mwhahaha have you connected to the console and run through the fuelmenu setup?
19:31 osryan_ yes i have. i can get through all of it and back to prompt where it says to login at the ip:8000, but it doesnt work and nothing is there
19:31 mwhahaha so it takes like 10 minutes once the machine boots for everything to come up live
19:31 mwhahaha you can use 'dockerctl check' to make sure all the services are up and running
19:32 osryan_ ahh i did not know that. i dont think i waited 10 minutes
19:32 sergmelikyan joined #fuel
19:33 osryan_ ok, i will try waiting first. thank you
19:34 osryan_ heres an error i get: checking container postgres
19:34 osryan_ checking with command "shell_container postgres PGPASSWORD=6kFrDoBQ /usr/bin/psql -h 10.20.0.2 -U "nailgun" "nailgun" -c '\copyright' 2>&1 1>/dev/null"
19:34 osryan_ Error: No such image or container: postgres
19:34 osryan_ Could not get docker ID for container postgres. Is it running?
19:34 mwhahaha what does 'dockerctl list' show
19:36 osryan_ ill check, i was messing with it and so i am rebuilding the vm. will take about 10 minutes
19:36 mwhahaha also what version are you installing?
19:38 osryan_ 6.1
19:45 tzn joined #fuel
19:48 izinovik joined #fuel
19:48 meow-nofer joined #fuel
19:49 kat_pimenova joined #fuel
19:49 vkramskikh joined #fuel
19:50 xenolog joined #fuel
19:50 nurla joined #fuel
19:51 aglarendil joined #fuel
19:51 mrasskazov joined #fuel
19:52 mihgen joined #fuel
19:52 bdudko joined #fuel
19:52 MorAle joined #fuel
19:53 sbog joined #fuel
19:54 apalkina joined #fuel
19:55 evg joined #fuel
19:56 MiroslavAnashkin joined #fuel
19:57 akislitsky joined #fuel
19:58 rvyalov joined #fuel
20:00 thansen joined #fuel
20:00 thansen must all nodes be connected to all logical networks?  for example why is public necessary on a storage/compute/whatever node when I've disabled the public on all nodes option?
20:07 osryan_ mwhahaha: thanks for the help. that was it. i wasn't ending the install correctly because i wasn't waiting long enough. didn't realize the install process isnt finished at the fuelmenu screen
20:10 teran joined #fuel
20:24 HeOS joined #fuel
20:29 angdraug joined #fuel
20:35 sergmelikyan joined #fuel
20:41 thansen mwhahaha, do you know if it's possible to use external nfs/iscsi that isn't managed as a fuel node?
20:42 mwhahaha for what
20:42 thansen cinder and nova at least I guess
20:43 mwhahaha i'm sure you can
20:43 mwhahaha i don't know how, but i would be shocked if you couldn't
20:43 mwhahaha might require some post-deployment configuration updates
20:43 thansen I see
20:44 thansen yeah, I've got a freenas box I'd like to leverage for this purpose
20:45 mwhahaha https://community.mellanox.com/docs/DOC-1462
20:45 mwhahaha that doc reference's an older version of fuel
20:45 mwhahaha but what you want would just be more cinder stuff which would be after fuel
20:46 thansen yeah, that's pretty much the kind of hardware I've got
20:48 thansen looks like the path of least resistance is the best way to go here
20:49 thansen ceph appears to be the preferred way to do nova
20:49 thansen nova over nfs/iscsi is really the critical one for me
20:58 ggolin xarses: just reinstalled master, going through the iface config. not gonna touch the default pxe set up for now.
21:00 ggolin so i have 4 networks configured for me on the switch, two smalls ones with outside access and two large ones, one with outside access, the other without
21:00 ashtokolov joined #fuel
21:01 alwaysatthenoc joined #fuel
21:31 sergmelikyan joined #fuel
21:52 ggolin joined #fuel
22:11 NERvOus joined #fuel
22:21 NERvOus joined #fuel
23:49 alwaysatthenoc joined #fuel
23:53 xarses joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary