Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-08-13

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:02 v1k0d3n joined #fuel
00:15 v1k0d3n joined #fuel
00:19 severion joined #fuel
00:59 izinovik joined #fuel
01:00 rvyalov joined #fuel
01:00 xenolog joined #fuel
01:02 meow-nofer joined #fuel
01:04 sbog joined #fuel
01:10 v1k0d3n joined #fuel
02:08 sergmelikyan joined #fuel
02:52 hakimo_ joined #fuel
03:36 bsilverm joined #fuel
03:44 bsilverm left #fuel
04:27 xarses_ joined #fuel
05:12 Ravindra_Dhainwa joined #fuel
05:14 Ravindra_Dhainwa Does our Mirantis deployment support LBaaS 2.0 plugin or is it limited to 1.0? If it is 1.0, is it possible to upgrade it to 2.0?
05:15 Ravindra_Dhainwa Does Mirantis deployment support LBaaS 2.0 plugin or is it limited to 1.0? If it is 1.0, is it possible to upgrade it to 2.0?
05:24 glavni_ninja joined #fuel
05:57 sergmelikyan joined #fuel
06:21 mkwiek joined #fuel
06:41 monester joined #fuel
07:17 e0ne joined #fuel
07:23 byrdnuge joined #fuel
07:26 eliqiao joined #fuel
07:27 charz joined #fuel
07:42 mkwiek joined #fuel
07:42 HeOS joined #fuel
07:42 bogdando joined #fuel
07:42 Work^Seony joined #fuel
07:42 mattymo joined #fuel
07:42 martineg_ joined #fuel
07:43 [HeOS] joined #fuel
07:45 mkwiek1 joined #fuel
07:47 martineg_ joined #fuel
07:52 ashtokolov joined #fuel
07:54 mattymo joined #fuel
07:59 Work^Seony joined #fuel
08:00 bogdando joined #fuel
08:16 Akshik joined #fuel
08:18 Akshik hi I would like to add additional bridge interface to all the nodes in the env, is there a way to do the same, is there a option to ecit the astute.yaml file on al target nodes?
08:44 lee_ joined #fuel
08:45 gongysh joined #fuel
08:52 Ravindra_Dhainwa Does Mirantis deployment support LBaaS 2.0 plugin or is it limited to 1.0? If it is 1.0, is it possible to upgrade it to 2.0?
09:01 Miouge joined #fuel
09:13 [HeOS] joined #fuel
09:13 NERvOus joined #fuel
09:20 ashtokolov joined #fuel
09:55 ashtokolov joined #fuel
09:59 ashtokolov joined #fuel
10:11 monester joined #fuel
10:13 Miouge joined #fuel
10:18 ximepa joined #fuel
10:56 pbeskow joined #fuel
11:06 osryan joined #fuel
11:12 ximepa joined #fuel
11:55 ashtokolov joined #fuel
12:00 idv joined #fuel
12:01 idv_ joined #fuel
12:01 monester joined #fuel
12:10 Miouge joined #fuel
12:11 ashtokolov joined #fuel
12:13 warpc__ joined #fuel
12:17 t_dmitry joined #fuel
12:31 Ravindra_Dhainwa left #fuel
12:46 ximepa left #fuel
12:51 sergmelikyan joined #fuel
12:58 BobBall joined #fuel
12:58 Miouge joined #fuel
13:00 BobBall Hey - where is Horizon run?  It has the IP address 10.1.10.120 however I don't see my controller, compute or storage nodes having that IP address...
13:03 ashtokolov joined #fuel
13:05 ashtokolov joined #fuel
13:15 Miouge @BobBall the horizon IP is an high availability IP, you can find where it is with: crm resource status vip__public
13:16 BobBall Ahhhh - thanks Miouge
13:16 * BobBall was hurting his head :D
13:17 julien_ZTE joined #fuel
13:19 ashtokolov joined #fuel
13:20 omolchanov joined #fuel
13:22 sergmelikyan joined #fuel
13:27 v1k0d3n joined #fuel
13:36 sergmelikyan joined #fuel
13:47 DevStok joined #fuel
13:49 DevStok fuel 6.1
13:49 DevStok HTTPConnectionPool(host='us.archive.ubuntu.com', port=80): Max retries exceeded with url: /ubuntu/ (Caused by <class 'socket.gaierror'>: [Errno -3] Temporary failure in name resolution)
13:49 DevStok the same for archive.ubuntu.com
13:49 DevStok incredible how time wated for that cazzate
13:52 julien_ZTE joined #fuel
14:03 ashtokolov joined #fuel
14:07 neophy joined #fuel
14:08 mwhahaha dns issues?
14:20 DevStok I reach that address
14:20 DevStok with curl
14:20 DevStok on shell
14:20 DevStok dunno understand
14:24 DevStok be blocked by that stupid thing is ricolous
14:29 mwhahaha hmm that's odd
14:29 e0ne joined #fuel
14:33 DevStok http://paste.openstack.org/show/412893/
14:33 DevStok from shell
14:35 mwhahaha oh
14:35 mwhahaha it's complaining because it's in a redirect loop
14:35 mwhahaha add a / on the end
14:39 claflico joined #fuel
14:41 DevStok deb http://archive.ubuntu.com/ubuntu/ trusty main universe multiverse trusty main universe multiverse
14:41 DevStok this is what is set in the fuel webinterface
14:43 mwhahaha what part of the deploy does this fail in?
14:49 rmoe joined #fuel
14:51 jeh joined #fuel
14:52 blahRus joined #fuel
14:57 DevStok deploy start and after 15 second gives that error
14:58 sergmelikyan joined #fuel
15:06 DevStok http://paste.openstack.org/show/412898/
15:07 DevStok how controller can reach that url
15:07 DevStok mpty machine
15:08 mwhahaha so that points to a network configuration issue, so we try and configure the requested network on the nodes and then perform the network check
15:08 mwhahaha so you may want to try configuring the network manually on the bootstrapped nodes and see if they can reach those urls
15:08 mwhahaha alternatively do a local mirror
15:11 DevStok mmmmm what a pain
15:12 DevStok cant understand why i need to config also bootstraped machine
15:22 mkwiek joined #fuel
15:23 angdraug joined #fuel
15:26 mwhahaha that's to troubleshoot this
15:27 mwhahaha fuel will config it, but it seems that the config you have provided results in the bootstrapped machines not being able to connect to the repos for provisioning
15:43 Akshik joined #fuel
15:44 ashtokolov joined #fuel
15:46 DevStok I set a bond
15:46 DevStok on the interfaces where the public eccc VLAN arrives
15:46 mwhahaha that might be a problem
15:47 DevStok have to unbond and divide public from others?
15:47 Akshik hi, in fuel one node is showing in error state, bu ima able to ping that node
15:47 mwhahaha DevStok: or just do a local mirror
15:48 DevStok in icehouse I put public and the other vlan on the same bond
15:48 Akshik what should i check for
15:48 Akshik Im using MOS6.1
15:48 mwhahaha Akshik: check puppet/astute logs for errors
15:49 mwhahaha DevStok: 6.1 added the requirement for internet so this is new, and it can't check repo access for bonds. Are you manually doing the network verification or is that happening as part of the deploy?
15:50 Akshik and other question i had is option to add one more bond interface to all the nodes, is there a way to automate it
15:50 mwhahaha Akshik: after a deploy? I don't think so
15:51 Akshik during deployment
15:51 mwhahaha you should be able to do it via the network interface configuration
15:54 Akshik mwhahaha, i was reading thru https://github.com/stackforge/fuel-docs/blob/master/pages/file-ref/astute-yaml-target.rst#id1
15:54 Akshik is there a option to customize this before deployment
15:54 Akshik or should i use network config as you mentioned?
15:55 mwhahaha how many nodes are you deploying to?
15:55 mwhahaha you can do it via the UI if it's not to many
16:00 ashtokolov joined #fuel
16:02 Akshik actually close to 10 nodes
16:02 geekinutah joined #fuel
16:02 Akshik and i also wanted to automate this so as to prevent manual errors
16:03 Akshik from UI?
16:03 Akshik is there a option in UI for adding additional bridge?
16:03 mwhahaha not really
16:03 mwhahaha thought you just wanted a bond
16:03 mwhahaha so yea doing it via the astute.yaml and scripting it might be best
16:04 Akshik is there a option to change the source astute.yaml
16:05 mwhahaha you can do it via the fuel cli
16:05 mwhahaha i think you can download it and adjust it and upload it
16:05 mwhahaha someone else might be able to speak about that
16:07 Akshik i tried downloading the network
16:07 Akshik and i dont see the bridge config there
16:07 Akshik thats the reason i raised this query
16:07 mwhahaha you want to add a bridge or a bond
16:08 Akshik bridge interface
16:08 Akshik not bond
16:09 Akshik the intent is i need two physnet
16:09 Akshik so for the second physnet i want it to flow thru a different interface
16:09 mwhahaha yea i'm not sure
16:12 DevStok cant configure the mirror
16:12 DevStok too tired
16:12 DevStok bah
16:14 lordd joined #fuel
16:18 aliemieshko_ joined #fuel
16:18 aliemieshko_ joined #fuel
16:23 mkwiek joined #fuel
16:40 osryan left #fuel
16:41 rawat joined #fuel
16:42 rawat hi all, i have some doubt in multi-hypervisor setup can any one help me to understand the way how it's deploying..??
16:46 Akshik joined #fuel
16:50 mkwiek joined #fuel
16:53 seens joined #fuel
16:58 sergmelikyan joined #fuel
17:00 seens is there any way to add new tab under vmware under nova compute details tab in fuel 6.1, such that compute service will install in controller?
17:02 ddmitriev joined #fuel
17:02 skylerberg joined #fuel
17:05 seens is there any way to add new tab under vmware under nova compute details tab in fuel 6.1, such that compute service will not install in controller??
17:07 ashtokolov joined #fuel
17:08 ashtokolov joined #fuel
17:12 rawat how fuel is detecting vmware compute node in multi-hypervisor setup ...????
17:14 lordd joined #fuel
17:22 ashtokolov joined #fuel
17:36 rawat hi guys, if anyone knows about muti-hypervisor work flow please explain me ..!!!
17:41 championofcyrodi i believe fuel needs to connect with vCenter
17:41 championofcyrodi and vCenter connects with ESX(i)
17:42 championofcyrodi rawat^
17:43 seens <championofcyrodi> is there any way to add new tab under vmware under nova compute details tab in fuel 6.1, such that compute service will not install in controller??
17:45 championofcyrodi i really don't know.  I'm not familiar w/ VMware.  But I think if you want to integrate VMware, it would be easier using the Fuel CLI after you have defined your openstack controller(s)
17:45 championofcyrodi sorry
17:45 championofcyrodi i use KVM
17:45 championofcyrodi but used ESX about 2 years ago.
17:46 championofcyrodi so i'm familiar w/ the proprietary API w/ vCenter
17:46 rawat <championofcyrodi> : do you know if we select for multi-hypervisor how it's detecting which is kvm compute and which is vmware compute ....
17:46 jobewan joined #fuel
17:46 championofcyrodi I don't know. But likely the metadata is kept in mysql.
17:46 championofcyrodi I believe there is a 'hypervisor type'
17:47 championofcyrodi so when the filtered scheduler needs to start an instance, the hypervisor type can be used to determine the appropriate API to use.
17:47 championofcyrodi brb
17:51 mkwiek joined #fuel
17:52 ashtokolov joined #fuel
17:57 rawat <championofcyrodi> : here my confusion is if i am taking 4  compute nodes for kvm and 1 compute node for vmware from esxi host which configured in vCenter  then how fuel will detect which node for kvm and which is for vmware...???
17:58 sergmelikyan joined #fuel
18:01 CheKoLyN joined #fuel
18:02 sc68cal joined #fuel
18:02 sc68cal joined #fuel
18:04 mwhahaha you would need to configure availability zones i think
18:04 mwhahaha to specify vcenter vs kvm
18:11 championofcyrodi joined #fuel
18:12 seens <mwhahaha> if i select multi-hypervisor (kvm and vmware), is there any way to add new tab under vmware under nova compute details tab in fuel 6.1, such that compute service will not install in controller??
18:12 mwhahaha i have no idea
18:13 rawat <mwhahaha> : ok it means which compute node from that vmware availability zone , it will take as vmware compute node. and remaining as kvm compute node..
18:14 mwhahaha rawat: if you configure it as such, yes. i don't believe it's done automatically but i've never done it so i can't say for sure what would happen.
18:15 rawat <mwhahaha> : ok
18:18 mkwiek joined #fuel
18:19 angdraug joined #fuel
18:41 jobewan joined #fuel
18:43 skylerberg I am attempting to install the fuel-master from the nightly ISO from a couple days ago. I am running into an error with the MOS mirror field in fuel-menu.
18:43 skylerberg It came with a url that did not work by default, and I can't figure out what to change it to.
18:44 skylerberg Originally it was http://mirror.fuel-infra.org/mos-repos/7.0/cluster/base/trusty, I think.
18:44 skylerberg That URL 404s.
18:44 skylerberg Anyone know what I should put there?
18:44 mwhahaha http://mirror.fuel-infra.org/mos-repos/ubuntu/7.0/
18:44 mwhahaha i think
18:46 skylerberg That looks right in my browser, but fuel-menu still says "Error: MOS repository is not accessible"
18:46 mwhahaha hmm i actually have never changed that or looked at it
18:47 mwhahaha let me check
18:47 mwhahaha might be a bug
18:48 mwhahaha i don't even know if that setting is used
18:48 skylerberg Yeah, it seems like it is set to the wrong value by default right now. It wouldn't be a problem, but fuel-menu won't let me save.
18:51 mwhahaha it let me save
18:51 mwhahaha oh no there it is
18:52 * mwhahaha sighs
18:59 mwhahaha skylerberg: https://bugs.launchpad.net/fuel/+bug/1484648 if you're following along
19:00 skylerberg mwhahaha: Do you know of a workaround? Changing the value didn't help me.
19:01 mattgriffin joined #fuel
19:03 mwhahaha let me poke at it
19:08 mwhahaha you could hack the python to just return true
19:12 sergmelikyan joined #fuel
19:14 mwhahaha skylerberg: https://bugs.launchpad.net/fuel/+bug/1484648/comments/2
19:15 skylerberg mwhahaha: Thanks. Hacking it now.
19:18 skylerberg Right now I am in the middle of installing from the ISO. Even after hacking it, it doesn't work. Most likely because it is still running the old version of the code. Can I quit without saving and then run the bootstrap script?
19:19 skylerberg Or will this lead to other problems?
19:19 mkwiek joined #fuel
19:20 mwhahaha should be ok
19:20 mwhahaha control+c and relaunch it
19:21 mwhahaha you run it by running 'fuelmenu'
19:31 lordd joined #fuel
19:34 lordd joined #fuel
19:46 mkwiek joined #fuel
20:02 ashtokolov joined #fuel
20:12 HeOS joined #fuel
20:20 ashtokolov joined #fuel
20:29 bearish joined #fuel
20:46 mattgriffin joined #fuel
20:47 mkwiek joined #fuel
20:50 mattgriffin joined #fuel
21:01 mattgriffin joined #fuel
21:11 bearish joined #fuel
21:14 mkwiek joined #fuel
21:15 ashtokolov joined #fuel
21:31 sergmelikyan joined #fuel
22:09 monester joined #fuel
22:10 sergmelikyan joined #fuel
22:15 mkwiek joined #fuel
22:24 [HeOS] joined #fuel
22:29 geekinutah joined #fuel
22:42 mkwiek joined #fuel
22:44 ashtokolov joined #fuel
22:46 skylerberg I got fuel setup by making the modification you suggested. Now I am running into some trouble deploying. Should I need to change the settings in the networking tab based on my network, or are those internal for neutron?
22:49 sergmelikyan joined #fuel
23:03 xarses joined #fuel
23:26 julien_ZTE joined #fuel
23:38 sergmelikyan joined #fuel
23:41 julien_ZTE joined #fuel
23:43 mkwiek joined #fuel
23:52 julien_ZTE joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary