Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-11-20

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:04 bapalm joined #fuel
00:04 tzn joined #fuel
00:39 tzn joined #fuel
01:05 zhangjn joined #fuel
01:31 rmoe joined #fuel
01:58 xarses joined #fuel
02:13 bearish joined #fuel
02:13 bearish joined #fuel
02:20 rmoe joined #fuel
02:24 jerrygb joined #fuel
02:33 fedexo joined #fuel
03:12 bearish joined #fuel
03:21 bearish joined #fuel
03:22 bearish joined #fuel
04:08 mwhahaha joined #fuel
04:09 jeblair joined #fuel
04:11 book` joined #fuel
04:29 zhangjn joined #fuel
04:38 bildz can someone share their /etc/ceph/ceph.conf off a working system?
04:47 poseidon1157 joined #fuel
05:11 zhangjn joined #fuel
05:18 zhangjn joined #fuel
05:57 LinusLinne joined #fuel
05:57 cartik joined #fuel
06:09 javeriak joined #fuel
06:10 javeriak_ joined #fuel
06:14 javeriak joined #fuel
06:18 elemoine joined #fuel
06:20 elemoine left #fuel
06:20 javeriak_ joined #fuel
06:30 jerrygb joined #fuel
07:17 Guest70 joined #fuel
07:38 cartik joined #fuel
07:52 mkwiek07 joined #fuel
07:56 hyperbaba joined #fuel
08:04 Wida joined #fuel
08:04 ppetit joined #fuel
08:18 zhangjn joined #fuel
08:20 LinusLinne joined #fuel
08:21 LinusLinne joined #fuel
08:23 cartik joined #fuel
08:36 zhangjn joined #fuel
09:09 f13o joined #fuel
09:19 javeriak joined #fuel
09:31 e0ne joined #fuel
09:31 zhangjn joined #fuel
09:39 cartik joined #fuel
10:03 f13o joined #fuel
10:19 tkhno joined #fuel
10:27 alex_didenko joined #fuel
10:29 javeriak joined #fuel
10:30 Wida joined #fuel
10:32 gongysh__ joined #fuel
10:35 gongysh joined #fuel
10:51 e0ne joined #fuel
10:56 tzn joined #fuel
10:58 tzn joined #fuel
11:01 az joined #fuel
11:27 Chlorum joined #fuel
12:02 zhangjn joined #fuel
12:03 magicboiz joined #fuel
12:03 zhangjn joined #fuel
12:16 javeriak joined #fuel
12:19 e0ne joined #fuel
12:20 javeriak joined #fuel
12:21 hezhiqiang joined #fuel
12:22 Miouge joined #fuel
12:24 javeriak_ joined #fuel
12:31 ddmitriev joined #fuel
12:43 LinusLinne joined #fuel
12:44 ppetit joined #fuel
12:49 poseidon1157 joined #fuel
12:55 samuelBartel joined #fuel
13:00 jaypipes joined #fuel
13:07 LinusLinne joined #fuel
13:07 f13o joined #fuel
13:13 LinusLinne joined #fuel
13:19 poseidon1157 left #fuel
13:54 hezhiqiang joined #fuel
14:00 hezhiqiang joined #fuel
14:21 jerrygb joined #fuel
14:21 ericjwolf Good morning.  Seeing a werid issue.  I need to get the public API working.  I found a thread that mentiones to modify the keystone public ip in the /etc/keystone/keystone.conf file.  I did this on all 3 controllers (HA) and restarted the keystone services on all 3 servers. I think I missed something now I am getting error when trying to connect.  I don't see any errors in Keystone logs.
14:21 ericjwolf public_bind_host=172.18.2.5 is what I cnaged
14:21 ericjwolf changed.
14:21 scheuk joined #fuel
14:24 scheuk question: Is there a channel where there is a discussion/help on the LMA toolchain?
14:26 ppetit scheuk: no specific channel for LMA. Fuel channel is fine for discussing it.
14:28 scheuk ppetit: sounds good, I'm trying to use the stable/0.8 branch in my environment, what
14:28 scheuk I'm seeing my controller nodes hekad process not forwarding metrics or logs to influx/elasticsearch
14:28 scheuk is there an easy way to troubleshoot heka to see what's going on?
14:29 scheuk nothing is showing up in the /var/log/lma_collector.log
14:30 ppetit Have you tried http://fuel-plugin-lma-collector.readthedocs.org/en/latest/user/configuration.html#troubleshooting ?
14:30 scheuk have not
14:31 ppetit Okay so please tries that and let us now if that helps solves your problem.
14:31 ppetit Each plugin of the toolchain has a troubleshooting section
14:31 ppetit ^now^know
14:32 ppetit For Influx/Grafana http://fuel-plugin-influxdb-grafana.readthedocs.org/en/latest/user.html#troubleshooting
14:37 pasquier-s scheuk, we've just pushed a 0.8.0rc1 tag for all 4 plugins, I would recommend to upgrade if it's possible for you...
14:37 scheuk ok the fist one 'pidof lma_collector' doesn't work because the process name is hekad
14:38 scheuk /usr/bin/hekad -config=/etc/lma_collector
14:39 scheuk pasquier-s: nice I'll check that our and rebuild the plugins, what's the best way of pushing that to an already running environment?
14:40 pasquier-s ah good catch regarding the doc :)
14:41 pasquier-s scheuk, there's no easy way to upgrade unfortunately hence the "if it's possible for you"
14:42 scheuk I was a bit of an early adopter with the lma plugins, and I built and deployed an environment from master about a month ago
14:42 scheuk and I saw that things have stabalized a bit and was going to upgrade
14:43 scheuk lma plugins master that is
14:43 pasquier-s understood, so you're going to upgrade with the 0.8.0rc1 tag IIUC
14:43 scheuk yes, that's my plan
14:44 scheuk what I tried doing is bumping the minor version of the plugin, (0.8.1) and perforing a fuel plugins --upgrade
14:44 pasquier-s good, back to your issue, you see the hekad process, right?
14:45 scheuk yes
14:45 scheuk it's running on th all the controllers
14:45 ericjwolf No keystone folks here today?
14:45 pasquier-s have you checked collectd too?
14:46 pasquier-s and /var/log/collectd.log?
14:46 scheuk collectd is running
14:47 scheuk aha
14:48 scheuk write_http plugin: curl_easy_perform failed with status 7: Failed to connect to 127.0.0.1 port 8325: Connection refused
14:48 pasquier-s scheuk, ok this explains your issue (or at least part of it)
14:49 scheuk ok so I just checked, nothing is listening on 8325
14:50 pasquier-s weird, we should have hekad listening
14:50 pasquier-s can you try 'killall -9 hekad && crm resource restart lma_collector'
14:50 pasquier-s ?
14:53 scheuk restarting
14:54 scheuk I wonder if the hekad config got messed up with the puppet run
14:55 scheuk still not listening to 8325
14:57 scheuk that's it i'm missing a bunch of toml files in /etc/lma_collector
14:57 scheuk n/m
14:57 scheuk there's just more on the controllers than a regular node
15:01 pasquier-s scheuk, do you mean that the lma_collector configuration has been altered somehow?
15:01 scheuk oh this is weird, I see a "Shutdown initiated" in the lma_collector.log after the "Input started: collectd_httplisten"
15:08 pasquier-s scheuk, lets try to launch hekad in the foreground
15:09 pasquier-s scheuk, so first killall -9 hekad && crm resource stop lma_collector
15:09 pasquier-s scheuk, then run: "sudo -u heka hekad -config=/etc/collector"
15:10 scheuk yup it's suck
15:11 scheuk 2015/11/20 15:10:34 Input started: mysql_logstreamer
15:11 scheuk 2015/11/20 15:10:34 Input started: openstack_dashboard_logstreamer
15:11 scheuk 2015/11/20 15:10:34 Shutdown initiated.
15:11 scheuk stuck
15:11 pasquier-s scheuk, indeed
15:12 pasquier-s scheuk, can you paste the full logs to paste.openstack.org pls?
15:13 scheuk http://paste.openstack.org/show/479598/
15:18 pasquier-s scheuk, I see strange errors starting at line 176
15:20 pasquier-s scheuk, in /etc/lma_collector/encoder-nagios_gse_node_clusters.toml you should have a service_template entry
15:23 jerrygb joined #fuel
15:27 bearish joined #fuel
15:31 scheuk let me check
15:31 poseidon1157 joined #fuel
15:32 scheuk aha: service_template = '%{cluster_name}'
15:32 thumpba joined #fuel
15:33 e0ne joined #fuel
15:34 cartik joined #fuel
15:35 pasquier-s scheuk, this is correct but doesn't match with the log message
15:39 scheuk I think I see what's wrong, I have extra config files from my iniail deploy
15:39 scheuk I have encoder-nagios_global_clusters.toml and encoder-nagios_node_clusters.toml
15:39 scheuk and those where renamed to encoder-nagios_gse_global_clusters.toml encoder-nagios_node_clusters.toml
15:50 scheuk pasquier-s: I got it now, all I did was remove everything in /etc/lma_collector and /usr/share/lma_collector and re-run the deploy
15:51 scheuk thanks for the help simon!
15:51 az joined #fuel
15:51 pasquier-s scheuk, no problem!
15:55 scheuk I'm going roll out the 0.8.0rc1 tag now
15:57 e0ne_ joined #fuel
16:00 v1k0d3n joined #fuel
16:08 DarthVigil joined #fuel
16:15 DarthVigil mwhahaha: You were right yesterday.  Thank you.  My issue was with NIC drivers.  The experiemental setup helped discover all of my boxes correctly.
16:16 mwhahaha cool
16:16 mwhahaha good to hear
16:16 bildz good morning, guys
16:22 pjm_ joined #fuel
16:22 pjm_ Hi there
16:23 pjm_ i'm trying to run an openstack environment with fuel but when I go to verify networks
16:23 pjm_ appear me this error " MCollective call failed in agent 'net_probe', method 'get_probing_info', failed nodes: ID: 1 - Reason: execution expired ID: 2 - Reason: execution expired ."
16:23 pjm_ anyone know what is? I tried check in google but didn't find any info about this error
16:25 pjm_ I check that in the "Configure interfaces" the public interface (eth1) appears me gray
16:25 pjm_ but i have connectivity
16:25 pjm_ in the 2 nodes that appear in gray, I logged in pxe SO loaded
16:25 pjm_ and do a dhcp for that interface I have connectivity
16:25 pjm_ thanks in advance :)
16:26 mwhahaha pjm_: what version? we used to have a bug with the execution expired thing
16:26 pjm_ It's the last version i think
16:26 pjm_ fuel community 7.0
16:26 pjm_ I downloaded from here: https://www.fuel-infra.org/
16:31 mwhahaha so that usually happens when connective is lost
16:31 mwhahaha nodes go grey when they can't connect back to the fuel master and the same would explain the execution expired
16:32 mwhahaha when we a network validation, we configured the interfaces. so if you've configured it in such a way that it is no logner able to get back to the fuel master on the admin network it might do that
16:33 pjm_ sorry i think I explain bad
16:33 pjm_ in the configure interface of the nodes
16:33 pjm_ the eth0 green with 1Gbps
16:34 pjm_ (admin (pxe), private, management and storage)
16:34 pjm_ the eth1 public aooear state down
16:34 pjm_ but it has connectivity
16:34 pjm_ and if i make "dhclient eth1" in that machine i will receive IP and connectivity to the Internet
16:34 pjm_ but for some reason the fuel web admin says that the state of the NIC is down
16:35 pjm_ https://cloudbase.it/wp-content/uploads/2015/10/fuel_net_list.png something like this, but the public NIC is gray
16:36 mwhahaha odd, i'm not sure perhaps someone else might know
16:36 mwhahaha usually it'll report the speed correctly. I wonder if it's a driver/hardware thing
16:37 pjm_ in my case it reports the speed
16:37 pjm_ eth0: Speed: 1.0 Gbps Admin (PXE) Storage VLAN ID:102 Management VLAN ID:101 Private VLAN IDs:1000-1030
16:37 pjm_ eth1: Speed: 0.0 Gbps Public
16:37 mwhahaha ah
16:37 pjm_ and gray
16:39 pjm_ but it should be green, right?
16:40 mwhahaha yea if it's up and got a link
16:40 mwhahaha I'm not sure the inner workings of that
16:40 * mwhahaha will have to defer to others
16:41 pjm_ so to that problem have any advise what i can do?
16:42 mwhahaha I've got to run, but you could try a the ubuntu bootstrap image
16:42 mwhahaha let me get the docs
16:43 pjm_ hmm, i was seeing, it's mandatory to have gigabit network interface ?
16:43 mwhahaha https://docs.mirantis.com/openstack/fuel/fuel-7.0/operations.html#enable-ubuntu-bootstrap-experimental
16:43 mwhahaha it's a good idea for your cloud
16:43 mwhahaha but if you're just testing, no it's not
16:43 pjm_ yes, but i'm in development
16:43 pjm_ thanks :) i will try that
16:43 pjm_ but that error is strange :\ it sends the network probe but not find it
16:44 bildz what is the best way to apply updates to each node?  for instance, Im using ubuntu, do I just ssh to all nodes and apt-get update/upgrade ?
16:45 blahRus joined #fuel
17:00 Guest70_ joined #fuel
17:16 javeriak_ hey everyone is there a way to create a plugin UI input field that can be edited after the deployment is up as well?
17:18 severion joined #fuel
17:22 xarses joined #fuel
17:24 TVR joined #fuel
17:28 TVR anyone work with anti-afinity in Heat templates in kilo? my template seems to error with policies: ['anti-affinity']
17:29 TVR I am asking if this has happened to anyone else and if it's a bug or something.
17:37 HeOS joined #fuel
17:37 TVR HeOS.. like Helion?
17:51 vvalyavskiy left #fuel
17:59 gomarivera joined #fuel
18:11 e0ne joined #fuel
18:11 xarses nope, you might have better luck asking on operators
18:12 TVR cool.. I think it may be a version issue....seems this was intoduces in juno 2014.2 and that's what I am running, but the syntax doesn't support the version of heat templates that all documents use
18:13 TVR so, it might be a few months earlier than the supported syntax
18:13 TVR cool, and thanks for the reply man
18:18 srmaddox joined #fuel
18:23 w_verdugo joined #fuel
18:34 e0ne joined #fuel
18:39 f13o joined #fuel
19:06 claflico joined #fuel
19:16 javeriak_ hey how can make task ignore any failures?
19:31 tzn joined #fuel
19:34 mwhahaha i'm not sure you can set it to ignore failures
19:36 mwhahaha would be an awesome feature though
19:36 javeriak_ so it isnt possible to define that task that could possibly fail but not take down the whole deployment with it
19:37 javeriak_ the tasks.ymal is a yaml so i thought something like ignore_errors would be present, I couldnt find any documentation on this :(
19:39 javeriak_ btw i have a UI field that is supposed to be a license string, hence it could contain any valid characters, but I need it to flag any binary chars, cant figure out what regex to use
19:45 mwhahaha thought someone replied with a regex for you
19:45 mwhahaha in fuel-dev
19:46 javeriak_ i got a few links, didnt find what i was looking for
19:47 javeriak_ that was a few days ago though, surprised you remember :)
19:48 mwhahaha would probably be easier to just match the valid chars, wouldn't it just be the standard char set a-zA-Z0-9 and special chars?
19:49 mwhahaha i would assume the only super special chars you might allow are line returns or something
19:49 mwhahaha other than your standard !@#$% etc
19:51 javeriak_ yes correct standard char set and special chars, is there a regex for that?
19:54 mwhahaha not sure, can't remember if it's python or javascript regex that's used
20:22 thumpba joined #fuel
20:27 javeriak joined #fuel
20:31 thumpba_ joined #fuel
20:33 f13o joined #fuel
21:06 poseidon1157 I'm having an issue with my fuel install
21:06 poseidon1157 I'm getting task docker:PID blocked for more than 120 seconds
21:06 poseidon1157 Followed by a stack trace
21:09 poseidon1157 Is there a minimum RAM?
21:09 poseidon1157 What's the lower requirement?
21:11 poseidon1157 8GB should be sufficient, no?
21:13 mwhahaha 8g should be fine
21:13 poseidon1157 mwhahaha I rebooted the system, but it's hanging on docker
21:13 mwhahaha is this in a vm or physical gear?
21:13 srmaddox joined #fuel
21:13 poseidon1157 Physical
21:15 poseidon1157 fuel-package-updates also fails
21:16 mwhahaha would need some logs to be able to troubleshoot things, i've not run into it hanging in a vm
21:16 poseidon1157 Like I said, there's a stacktrace printed
21:17 mwhahaha screenshot?
21:17 poseidon1157 I do get "WARNING: You are running linux kernel version 2.6.32-504.16.2.el6.x86_64, which might be unstable running docker. Please upgrade your kernel to 3.8.0.""
21:17 poseidon1157 in the docker logs
21:19 poseidon1157 "statusCode=404 No such image: postgres""
21:19 poseidon1157 So that seems bad :(
21:19 mwhahaha so is this the initial install or did you get it up and reboot?
21:21 poseidon1157 mwhahaha It went through the install cycle just fine
21:21 poseidon1157 I've got fuel on another node.
21:21 poseidon1157 That node is more expensive, which is why I wanted to use this one
21:22 poseidon1157 I can try reinstalling
21:22 poseidon1157 Just weird.
21:22 poseidon1157 It's not finding the docker images
21:22 mwhahaha indeed, i'm just trying to figure out the order of operations to see where something might have broken
21:24 poseidon1157 Doing a fresh reinstall
21:24 poseidon1157 Any logs that should be interesting?
21:24 mwhahaha there's a bootstrap log in /var/log/puppet/
21:25 mwhahaha which might contain any failures during docker image building/stemp
21:25 mwhahaha s/stemp/setup
21:25 poseidon1157 I'll pastebin it if I run into this again
21:25 poseidon1157 Are you with Mirantis?
21:26 mwhahaha ya
21:27 poseidon1157 Nice.  Me too
21:27 poseidon1157 Home lab :)
21:29 mwhahaha for dev we just use 2g or 1.5g vms i think, so the stacktrace would make me thing it's a hardware driver thing
21:29 mwhahaha you could always just do it in a kvm vm :D
21:30 poseidon1157 mwhahaha That's true, but my circumstances are that I have to redeploy once every 1-2 weeks
21:30 poseidon1157 More convenient for me to have a dedicated box
21:31 mwhahaha i do it daily in vms with fuel-devops scripts
21:31 mwhahaha which use libvirt for env management
21:31 poseidon1157 That's handy
21:31 poseidon1157 I may go that route if this keeps acting up
21:31 mwhahaha https://github.com/openstack/fuel-devops
21:32 mwhahaha way better then the virtualbox stuff
21:32 poseidon1157 Looks liek
21:32 poseidon1157 *lik
21:32 poseidon1157 Wow, typing is a problem today evidently
21:33 mwhahaha it's a little awkward in the beginning but once you get used to the few of sets of commands you need it's pretty  slick
21:33 poseidon1157 I'll have to look into demoing this rather than the vbox scripts
21:34 poseidon1157 mwhahaha redeploy complete.  Let me see what I can see
21:35 mwhahaha the important commands for devops are just: http://paste.openstack.org/show/MRsu2FgdN8xyt4BciSwt/
21:35 mwhahaha once you get it all setup
21:36 mwhahaha create builds out all the vms and envs for you and admin-setup gets the fuel node booted for you
21:38 poseidon1157 tyvm
21:38 poseidon1157 I had a dumb question btw
21:39 poseidon1157 Where is the configuration dictating that control nodes cannot also be compute nodes?
21:39 poseidon1157 Is that in the database?
21:41 mwhahaha controllers?
21:41 mwhahaha no that's a thing in the tasks
21:41 mwhahaha it's not a simple flip of the switch to hack that
21:41 mwhahaha let me see if i can find it in the code
21:41 mwhahaha or rather in the role definition
21:42 mwhahaha pretty sure that'd break a whole bunch of stuff because i think we have places where things are mutually exclusive for compute and controllers
21:42 poseidon1157 Looks like docker still isn't responding
21:42 poseidon1157 showing 0% cpu util
21:43 mwhahaha sounds like a hardware bug with centos/docker, what brand of machine is it?
21:43 poseidon1157 Annnd there's the stack trace
21:43 poseidon1157 Samsung
21:44 mwhahaha laptop i assume
21:44 poseidon1157 Damn.  I was hoping to use all of my high powered machines for compute
21:44 poseidon1157 But now I gotta use one as a controller.
21:44 poseidon1157 :/
21:45 mwhahaha could always VM for it if it's just testing, take your machine that is failing and create a vm with 2g for fuel master and a vm with 3g for a controller
21:46 mwhahaha wire up the networking correctly and ta-da
21:59 neouf joined #fuel
22:02 poseidon1157 mwhahaha But I'm not testing fuel :)  I'm learning ancillary products.  Like how to set up a hadoop cluster.
22:02 mwhahaha by testing i mean that
22:02 mwhahaha evaluation
22:02 mwhahaha not actually doing perf tests
22:03 poseidon1157 mwhahaha Yeah, since it's my home lab I want to schedule some new stuff.  :)
22:04 poseidon1157 Woah.  Looks like it was just slow
22:04 poseidon1157 Now it's playing with dm-7/8 extensively
22:04 poseidon1157 The junk laptop that is
22:05 mwhahaha yea that takes a while
22:05 poseidon1157 evidently
22:05 mwhahaha so it has to download the images and build
22:06 poseidon1157 mwhahaha Yeah, it wasn't earlier
22:06 poseidon1157 Nice!
22:06 poseidon1157 Just needed time
22:06 poseidon1157 The secret ingredient, plus two packs of nordic ice.
22:06 poseidon1157 :)
22:17 tzn joined #fuel
22:51 neouf joined #fuel
22:53 mkwiek joined #fuel
22:53 idvoretskyi joined #fuel
22:57 evgenyl joined #fuel
22:58 agordeev joined #fuel
23:10 ericjwolf joined #fuel
23:12 aglarendil joined #fuel
23:12 ashtokolov joined #fuel
23:13 ericjwolf Greetings
23:15 ericjwolf I had a question.  In my lab I have a regular ubuntu Openstack install and I am now building a MOS 6.1 install and I am seeing behavior differences.  I noticed the MOS is at 2014.2.2-1~u14.04 but my ubuntu is 2014.2.3-0ubuntu1~cloud0.
23:15 ericjwolf Will there be any Juno package updates to MOS?
23:16 ericjwolf I did do a yum update on my fuel BEFORE my deployments.
23:16 ericjwolf is 2014.2.2.1 the latest MOS version?
23:19 kozhukalov joined #fuel
23:19 agordeev joined #fuel
23:19 akasatkin joined #fuel
23:19 akislitsky_ joined #fuel
23:19 evgenyl joined #fuel
23:20 jaranovich joined #fuel
23:20 tzn joined #fuel
23:22 jfluhmann joined #fuel
23:23 holser joined #fuel
23:25 teran joined #fuel
23:27 smakar joined #fuel
23:27 bpiotrowski joined #fuel
23:28 kgalanov joined #fuel
23:52 poseidon1157 Hey ericjwolf
23:52 poseidon1157 Not exactly my wheelhouse, as I don't work on the Fuel project directly.  Are you trying to do an upgrade with Fuel?
23:53 poseidon1157 Fuel 7.0 has been available for a month or two
23:53 poseidon1157 Which is on Kilo :)

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary