Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2015-12-18

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:27 krypto joined #fuel
00:28 krypto i have installed fuel6.1 with contrail plugin but instance directly connected to external network is not reachable do you guys have any idea about contrail
00:32 zhangjn joined #fuel
00:40 tzn joined #fuel
01:00 kaliya joined #fuel
01:18 zhangjn joined #fuel
01:42 rmoe joined #fuel
02:12 tzn joined #fuel
02:48 ilbot3 joined #fuel
02:48 Topic for #fuel is now Fuel 7.0 (Kilo) https://www.fuel-infra.org/ | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
02:55 zhangjn joined #fuel
03:03 kaliya joined #fuel
03:22 gongysh joined #fuel
03:45 vsedelnik joined #fuel
03:48 tzn joined #fuel
03:55 vsedelnik joined #fuel
04:04 gongysh joined #fuel
04:14 vsedelnik joined #fuel
04:28 zhangjn joined #fuel
05:01 vsedelnik joined #fuel
05:04 aleksandr_null joined #fuel
05:17 kaliya joined #fuel
05:19 tzn joined #fuel
06:08 skath_ joined #fuel
06:11 serverascode joined #fuel
06:28 javeriak joined #fuel
06:30 javeriak_ joined #fuel
06:33 javeriak joined #fuel
06:41 HeOS joined #fuel
06:49 tzn joined #fuel
07:12 gongysh joined #fuel
07:21 fzhadaev joined #fuel
07:30 gongysh joined #fuel
07:36 e0ne joined #fuel
08:00 L0chlim joined #fuel
08:09 Philipp_ joined #fuel
08:15 hyperbaba joined #fuel
08:25 penguinolog joined #fuel
08:38 L0chlim joined #fuel
08:40 Liuqing joined #fuel
08:40 tzn joined #fuel
08:45 rooltak joined #fuel
08:48 rooltak left #fuel
09:11 fzhadaev joined #fuel
09:16 e0ne joined #fuel
09:36 mattymo_ joined #fuel
09:38 HeOS joined #fuel
09:41 tzn joined #fuel
10:09 fzhadaev joined #fuel
10:12 asaprykin joined #fuel
10:40 e0ne joined #fuel
10:51 breton joined #fuel
10:51 breton hey
10:51 breton a quick question about keystone configuration in fuel
10:52 breton on controller in /etc/apache2/sites-enabled/05-keystone_wsgi_main.conf there is a line
10:52 breton ServerName node-1.test.domain.local
10:52 breton is it important? What's goint to break if I change it?
10:56 breton OK< I changed it, looks like nothing has broken
10:56 breton anyway, what could break?
11:03 Chlorum joined #fuel
11:11 L0chlim joined #fuel
11:20 asaprykin joined #fuel
11:21 magicboiz <breton>: maybe Apache....
11:25 arturdaschevici joined #fuel
11:25 zinovik joined #fuel
11:42 mattymo_ joined #fuel
12:05 breton nope
12:05 breton it didn't break
12:12 L0chlim joined #fuel
12:19 L0chlim joined #fuel
12:19 L0chlim joined #fuel
12:20 L0chlim joined #fuel
12:20 L0chlim joined #fuel
12:21 L0chlim joined #fuel
12:21 L0chlim joined #fuel
12:30 fzhadaev joined #fuel
12:31 sc-rm joined #fuel
12:31 sc-rm joined #fuel
13:32 thumpba joined #fuel
13:44 jaypipes joined #fuel
13:47 magicboiz joined #fuel
13:50 e0ne joined #fuel
14:42 krobzaur joined #fuel
14:44 anddrew joined #fuel
15:02 dnikishov joined #fuel
15:13 fzhadaev joined #fuel
15:14 L0chlim joined #fuel
15:22 evgenyl_ joined #fuel
15:29 omartsyniuk joined #fuel
15:40 zinovik joined #fuel
15:47 dancn joined #fuel
15:47 claflico joined #fuel
15:49 sb- anyone around that can help me?
15:49 sb- i am trying to add firewall rules andnothing is being sent to rabbitmq
15:49 sb- in the errors i get "topic 'notifications.info': [Errno 32] Broken pipe"
15:49 sb- any idea what i need to do to get back up?
15:50 krypto joined #fuel
15:52 sb- here is the full error, oslo.messaging._drivers.impl_rabbit error: [Errno 32] Broken pipe
15:52 dnikishov joined #fuel
15:54 mwhahaha looks like a connectivity issue?
15:54 sb- but why ?/what should i look at
15:54 mwhahaha check that rabbitmq is up and happy as well
15:54 mwhahaha check the rabbitmq logs to see if there's anything related in tehre
15:55 sb- rabbit seems up from what i can tell.
15:56 krypto joined #fuel
15:58 mwhahaha what version
16:01 krypto joined #fuel
16:02 tzn joined #fuel
16:07 Reepicheep joined #fuel
16:11 vsedelnik joined #fuel
16:13 javeriak joined #fuel
16:23 javeriak_ joined #fuel
16:26 tzn joined #fuel
16:29 javeriak joined #fuel
16:30 HeOS joined #fuel
16:38 javeriak_ joined #fuel
16:49 krypto joined #fuel
16:54 krypto joined #fuel
17:09 Zer0Byte__ joined #fuel
17:22 tzn joined #fuel
17:32 xarses joined #fuel
17:41 Zer0Byte__ joined #fuel
17:45 zinovik joined #fuel
18:00 e0ne joined #fuel
18:03 magicboiz joined #fuel
18:12 Zer0Byte__ joined #fuel
18:15 Yofti joined #fuel
18:15 [HeOS] joined #fuel
18:27 krypto joined #fuel
18:31 e0ne joined #fuel
18:37 dancn joined #fuel
18:38 Zer0Byte__ joined #fuel
18:46 krypto joined #fuel
18:59 kaliya joined #fuel
19:00 fzhadaev joined #fuel
19:03 mattymo_ joined #fuel
19:13 L0chlim joined #fuel
19:22 sb- @mwhahaha sorry
19:22 sb- http://pastebin.com/iFjfSRVw
19:23 sb- rabbitmq_server-3.3.5
19:23 sb- fuel 6.0.0
19:25 mwhahaha have you applied all the updates?
19:25 mwhahaha i found a bug from 6 that corresponded with your issue
19:26 mwhahaha of course i closed the tab so i'll have to refind it
19:27 sb- i havent ever done a patch any chance you can help me in right direction?
19:27 mwhahaha it seemed to be related to rabbitmq heartbeats but let me see if i can pull up the bug
19:27 mwhahaha i forgot updates were 6.1+ :D
19:28 sb- thanks, i just wanna make sure i dont break anything
19:28 mwhahaha https://bugs.launchpad.net/mos/+bug/1371723
19:28 mwhahaha not sure if that's the exact bug but it might b e
19:29 sb- how do i update this ?
19:29 mwhahaha would have to update the messaging package
19:29 mwhahaha i'm not sure the update proces for 6.0
19:30 sb- how does this happen out of no where>
19:30 mwhahaha from the comments of that bug, perhaps it's load related?
19:30 mwhahaha The Oslo messaging service had a bug that affected MOS HA environments. The bug could make OpenStack unstable; the problem got worse as the load increased. A large number of broken AMQP connections caused Oslo-related errors appear in different logs. See LP1371723.
19:30 sb- im not in HA
19:30 sb- is also not very high load .
19:30 elo joined #fuel
19:31 sb- on the node this runs on " 19:30:47 up 207 days, 20:35,  2 users,  load average: 1.02, 1.06, 1.08"
19:31 mwhahaha yea i can't say for sure. most of my experience has been 6.1+
19:38 krypto any way to execute "deploy changes" from cli
19:39 e0ne joined #fuel
19:40 mwhahaha fuel deploy-changes ?
19:47 Yofti joined #fuel
19:53 krypto thanks
19:54 mwhahaha no problem
20:02 jmjava joined #fuel
20:26 gomarivera joined #fuel
20:40 e0ne joined #fuel
20:47 claflico joined #fuel
21:07 Chlorum joined #fuel
21:10 kaliya joined #fuel
21:16 Zer0Byte__ hey
21:16 Zer0Byte__ someone know where i can change the switch where KVM is loaded
21:17 Zer0Byte__ i mean change the system manufacter and system product
21:17 Zer0Byte__ ?
21:18 mwhahaha you mean the detected manufacter/product that's listed on the node in the ui?
21:18 Zer0Byte__ no
21:19 Zer0Byte__ i mean when a virtual its launched
21:19 Zer0Byte__ the system manufacter on the guest is openstack foundation
21:19 Zer0Byte__ i dont see in nova any setup for that
21:20 mwhahaha oh that seems more like an openstack question than a fuel question :D
21:20 mwhahaha wonder if it's hardcoded in nova or something
21:21 Zer0Byte__ looks like
21:21 Zer0Byte__ cuz when KVM its launched go with these switch
21:21 Zer0Byte__ as a parameter
21:22 mwhahaha there's this thing, https://github.com/openstack/nova/blob/1635086529c43edcb69966c48c41b5fca2d1b26c/etc/nova/release.sample
21:23 Zer0Byte__ got it
21:23 mwhahaha https://review.openstack.org/#/c/18082/
21:27 Zer0Byte__ thanks
21:27 Zer0Byte__ im testing right now
21:27 Zer0Byte__ that should be put on each compute node right.
21:27 Zer0Byte__ ?
21:28 mwhahaha i'd assume so
21:39 Zer0Byte__ Worked :)
21:52 Zer0Byte__ joined #fuel
21:52 Zer0Byte__ thanls
21:52 Zer0Byte__ thanks
22:23 xarses joined #fuel
22:28 rmoe joined #fuel
22:28 krypto joined #fuel
22:39 neouf joined #fuel
22:59 jmjava how can you debug public network connectivity from compute node?
23:00 mwhahaha hey
23:00 mwhahaha so is this during a deploy or the verification step?
23:00 mwhahaha jmjava: -^
23:01 jmjava verification step... hang on up until a few moments ago i was able to ping the default gateway from the compute node
23:02 mwhahaha so the verification steps configure your network ranges on the interfaces then attempts to request the repo via HTTP
23:02 mwhahaha so you could manually configure your interfaces and perform the curl
23:02 mwhahaha the boostrapped node will proxy through the fuel master until the network is configured
23:03 jmjava its not doing that now...
23:03 jmjava let me check if i can still see from the fuel master
23:04 mwhahaha my assumption is that your public network once configured no longer has access to the internet
23:05 jmjava yes i can't ping the gateway even from fuel now..
23:05 mwhahaha that'd be a problem :D
23:06 jmjava lol
23:13 _tzn joined #fuel
23:23 jmjava ok bounced fuel and reset name server on switch and now i just get Verfication Failed and a list of expected vlans it's not hitting
23:24 jmjava Expected VLAN (not received) and then a list of 1000+ numbers for each node
23:24 mwhahaha what network config did you use?
23:25 mwhahaha tunneling or just straight vlans?
23:26 jmjava these are not vlans i set up
23:26 jmjava its just coming up on network verification
23:27 mwhahaha right that's why i'm asking what network configuration you selected for your environment in fuel
23:27 mwhahaha vlan or tunnel
23:29 jmjava let me check i think i selected default my router setup is based on this:  https://github.com/openstack/fuel-docs/blob/master/pages/planning-guide/0090-appendix/0095-neutron-switch-cisco-2960g.rst
23:29 jmjava Neutron with VLAN segmentation
23:30 mwhahaha ok
23:31 jmjava reading fine print gre is the option i should choose i guess
23:31 jmjava making a new environment
23:32 mwhahaha https://ask.openstack.org/en/question/83262/fuel-70-neutron-l2l3-networking-configuration/
23:32 mwhahaha not necessarily, but you can use the tunneling option instead. it depends on what you're trying to do
23:36 jmjava i am so new i really don't know the difference yet... just the config i based my setup on says gre
23:37 dnikishov joined #fuel
23:37 mwhahaha sure
23:39 jmjava no i am just getting vlan 103 in the expected vlans not recieved
23:39 jmjava let me check the allowed vlans on each interface
23:40 mwhahaha so you aren't allowing that on eth1 and make sure the interface settings have the tagged check box unchecked
23:40 mwhahaha for eth0
23:41 mwhahaha (at least from your config from the mailing list)
23:51 jmjava ok let me try that thanks
23:52 jmjava just for 103?
23:53 mwhahaha well 103 is your public network right?
23:53 jmjava 100
23:54 mwhahaha then what's 103?
23:54 jmjava private
23:55 mwhahaha http://imgur.com/qAGo4sq
23:55 mwhahaha that's what i've got for vlan config
23:55 mwhahaha which would correspond with that ask.openstack.org thing previously
23:55 mwhahaha so you'd need to allow private on the trunk and it should work
23:55 mwhahaha but that limits you to a single neutron network i think
23:57 jmjava it seems like i am close its just not seeing 103 ...at least compared to what i have been fixing all week that is :(
23:57 mwhahaha add 103 to the allowed vlan list for eth1 (if that's what you have the private network on)
23:57 mwhahaha and it might work
23:58 jmjava ok will check brb

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary