Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2016-03-11

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:02 skamithi14 joined #fuel
00:16 whoanow joined #fuel
00:17 whoanow hey all. installed fuel8.0 just now and on a fresh install the webui is not working. it says nailgun is not available. im trying to rebuild the nailgun container, its taking forever. any other suggestions?
00:29 whoanow in fact only two containers are up, postgres and rabbitmq.
00:41 bapalm joined #fuel
00:50 whoayeah joined #fuel
00:51 whoayeah so this thing is doa, basically
00:53 whoayeah thats unfortunate.
00:56 mwhahaha It takes a while to come up
00:56 whoayeah its not doing anything
00:56 mwhahaha You can use dockerctl check to check the status of the containers.
00:57 whoayeah mq keeps dying with error 137
00:57 mwhahaha What does the admin bootstrap log say
00:57 whoayeah thats the only one there
00:57 mwhahaha You can also try dockerctl destroy all and dockerctl build all
00:58 mwhahaha But youll need to check the logs for more specific failures
00:58 whoayeah where is the bootsrap log please?
00:59 whoayeah ah puppet
01:00 whoayeah it was trying to build mq forever
01:01 whoayeah im running that script manually.
01:03 skamithi13 joined #fuel
01:05 skamithi13 joined #fuel
01:24 whoayeah destroying all containers and running bootstrap manually revived the master.
01:40 neophy joined #fuel
01:48 vsedelnik joined #fuel
01:52 xarses joined #fuel
01:59 whoayeah smh
02:16 tzn joined #fuel
02:16 bapalm joined #fuel
02:41 dslevin joined #fuel
02:49 vsedelnik joined #fuel
03:30 koma joined #fuel
03:30 koma joined #fuel
03:49 vsedelnik joined #fuel
03:56 koma joined #fuel
04:17 fedexo joined #fuel
04:35 treaki_ joined #fuel
04:50 vsedelnik joined #fuel
04:53 javeriak joined #fuel
05:04 rmoe joined #fuel
05:43 javeriak joined #fuel
05:47 javeriak_ joined #fuel
05:55 tzn joined #fuel
06:02 ashtokolov joined #fuel
06:02 evgenyl joined #fuel
06:02 mwhahaha joined #fuel
06:02 mescanef joined #fuel
06:02 aglarendil_ joined #fuel
06:17 rongze joined #fuel
06:24 fzhadaev joined #fuel
06:35 cartilk joined #fuel
06:36 cartilk 400 Client Error: Bad Request (Node '43': '53' network(s) are left unassigned), while trying to upload fuel node --node-id 43 --network upload
06:37 cartilk http://paste.openstack.org/show/490098/
06:37 cartilk is the yams file
06:37 cartilk yaml file
06:38 cartik joined #fuel
06:42 kozhukalov akasatkin: could you please help with network advanced configuration? ^
06:45 javeriak joined #fuel
07:21 ashtokolov joined #fuel
07:21 evgenyl joined #fuel
07:21 mwhahaha joined #fuel
07:21 mescanef joined #fuel
07:21 aglarendil_ joined #fuel
07:26 gongysh joined #fuel
07:32 javeriak_ joined #fuel
07:44 pbelamge joined #fuel
07:54 ashtokolov joined #fuel
07:54 evgenyl joined #fuel
07:54 mwhahaha joined #fuel
07:54 mescanef joined #fuel
07:54 aglarendil_ joined #fuel
07:55 Miouge joined #fuel
07:59 Miouge_ joined #fuel
08:08 vsedelnik joined #fuel
08:09 vsedelni_ joined #fuel
08:09 criss2016 joined #fuel
08:10 akaszuba joined #fuel
08:20 e0ne joined #fuel
08:32 zubchick joined #fuel
08:32 magicboiz joined #fuel
08:48 HeOS joined #fuel
08:52 gongysh joined #fuel
09:07 Miouge joined #fuel
09:13 neilus joined #fuel
09:28 tzn joined #fuel
09:37 permalac joined #fuel
09:38 permalac_ joined #fuel
09:41 pbelamge joined #fuel
09:44 neilus joined #fuel
09:54 zubchick joined #fuel
10:29 neilus1 joined #fuel
10:29 Bomfunk joined #fuel
10:36 samuelBartel joined #fuel
11:26 e0ne joined #fuel
11:27 javeriak joined #fuel
11:33 zubchick joined #fuel
11:36 HeOS joined #fuel
11:37 asilenkov joined #fuel
11:45 HeOS joined #fuel
12:23 magicboiz joined #fuel
12:42 rongze joined #fuel
12:54 e0ne joined #fuel
12:59 slo_ joined #fuel
13:01 slo_ can one help me, where within fuel MOS configuration files, i can change attributes values for ceph.conf - global configuration , before a deployment of an evnironment, let's say i want to change pg_num, pgp_num, which is now default set to 64...?
13:04 e0ne joined #fuel
13:37 zubchick joined #fuel
14:02 HeOS joined #fuel
14:21 dslevin left #fuel
14:49 zubchick joined #fuel
14:52 dslevin joined #fuel
15:14 blahRus joined #fuel
15:20 claflico joined #fuel
15:35 xarses joined #fuel
15:40 fedexo joined #fuel
15:40 HeOS joined #fuel
15:45 rongze joined #fuel
15:59 Miouge joined #fuel
16:01 permalac joined #fuel
16:08 gardlt joined #fuel
16:10 gariveradlt joined #fuel
16:17 gariveradlt joined #fuel
16:17 gariveradlt joined #fuel
16:21 zubchick joined #fuel
16:32 claflico1 joined #fuel
16:34 krypto joined #fuel
17:07 dslevin joined #fuel
17:08 krypto one of the compute node is down,may be because of that whole environment is put into error with Failed to execute hook 'upload_file' File upload failed
17:08 HeOS joined #fuel
17:09 palexster joined #fuel
17:09 krypto when ever i add new compute nodes in the last stage this error is coming
17:09 mwhahaha error state in fuel-master doesn't necessarily affect the status of openstack itself
17:09 krypto openstack is fine
17:10 mwhahaha which task is the upload_file one that is failing?
17:10 krypto "Deployment has failed. Method granular_deploy. Failed to execute hook 'upload_file' File upload failed"
17:10 krypto mwhahaha how do i check that
17:11 mwhahaha which version? 7?
17:12 krypto astutue log with details http://paste.ubuntu.com/15348911/
17:12 krypto 6.1
17:14 mwhahaha check the mcollective logs
17:15 xarses krypto: the debug output might have slightly more information, normally we should see a response message that shows which nodes didn't pass
17:15 mwhahaha so upload file should copy a file to the nodes i believe and it uses mcollective and calls a specific mcollective agent to transfer a file
17:17 krypto xarses: the log is debug log
17:18 krypto actually whole environment is in error state all nodes are in error after that message
17:18 xarses then that must be all nodes failing
17:18 xarses does `mco ping` work?
17:19 xarses yes, 6.1 will mark all nodes this way
17:21 krypto yes "mco ping" is giving results but will it show details about failed nodes
17:22 mwhahaha so you have nodes that are down?
17:22 mwhahaha that would cause the failure because it'll still try to deploy to the downed nodes which will result in an error
17:24 krypto yes from fuel dasboard one of the node is marked offline there is no connectivity to that node
17:25 mwhahaha yea so that's why it's happening, there's not much to do other than either remove that node or restore connectivity
17:25 krypto any way to bring back state to ready from error.All openstack components are working only fuel status is in Error state
17:26 krypto thanks for clarifying :)
17:48 sectrgt joined #fuel
17:52 javeriak joined #fuel
17:55 xarses you can make the nodes run a task specifically, that will make those nodes in specific go back to ready
17:55 xarses but getting the cluster to go back to ready in 6.1 requires that deploy-changes runs and passes, which wont because one of the nodes is offline
17:56 e0ne joined #fuel
17:56 samuelBartel joined #fuel
17:56 xarses it is also important to force the passed nodes to execute a task before attempting deploy changes as it will re-run the whole deployment process on a node in error state
18:00 claflico joined #fuel
18:05 neilus joined #fuel
18:15 javeriak_ joined #fuel
18:17 javeriak joined #fuel
18:20 rongze joined #fuel
18:22 javeriak_ joined #fuel
18:29 pumphouse joined #fuel
19:13 e0ne_ joined #fuel
19:44 HeOS joined #fuel
19:57 zubchick joined #fuel
21:01 claflico joined #fuel
21:59 e0ne joined #fuel
22:28 test joined #fuel
22:29 Guest8259 left #fuel
22:29 ohyeahhuh joined #fuel
22:30 rsoto joined #fuel
22:55 n3m8tz joined #fuel
22:56 ohyeahhuh so,i rebooted my shiny new 8.0 fuel master and it came back up without a network configuration.
22:56 ohyeahhuh i looked in /etc/sysconfig/network-scripts and there is no config file for the first, statically configured interface.
22:57 xarses ohyeahhuh: did you use fuelmenu to set the network configuration when you installed?
22:58 ohyeahhuh yessir
23:02 xarses and if you use it again, does it save the config files or same result, just the current interface?
23:03 ohyeahhuh it wont run again, it complains that eth0 has no ip address.
23:08 * ohyeahhuh sighs
23:08 ohyeahhuh im assigning an ip address manually and giving it a go.
23:17 ohyeahhuh well, a reboot first. maybe this will go away.
23:25 ohyeahhuh alright.. its back.
23:25 ohyeahhuh where did that config file go to begin with though.
23:26 ohyeahhuh fuel2 openstack-config list -e1 The request you have made requires authentication. (HTTP 401) -- how do i go around this?
23:26 ohyeahhuh i updated the password in keystone as per documentation
23:37 smakar joined #fuel
23:38 ohyeahhuh man i managed to wedge this thing good
23:48 neouf joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary