Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2016-05-26

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:42 Julien-zte joined #fuel
00:44 xarses joined #fuel
01:05 akscram joined #fuel
01:06 aglarendil joined #fuel
01:15 Egyptian[Home] joined #fuel
01:25 warpc joined #fuel
01:28 fatdragon joined #fuel
01:46 Egyptian[Home] joined #fuel
01:46 raunak joined #fuel
01:46 fatdragon joined #fuel
01:48 ilbot3 joined #fuel
01:48 Topic for #fuel is now Fuel 8.0 (Liberty) https://www.fuel-infra.org/ | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
02:06 Egyptian[Home] joined #fuel
03:43 mescanef joined #fuel
03:47 Samos123 joined #fuel
03:49 Egyptian[Home] joined #fuel
04:27 javeriak joined #fuel
05:31 javeriak joined #fuel
06:22 fatdragon joined #fuel
06:31 parlos joined #fuel
06:38 Billias_ joined #fuel
06:38 javeriak joined #fuel
06:44 Billias joined #fuel
06:59 javeriak joined #fuel
07:01 kszukielojc joined #fuel
07:15 parlos joined #fuel
07:16 DavidRama joined #fuel
07:21 Julien-zte joined #fuel
07:22 DavidRama joined #fuel
07:33 DavidRama1 joined #fuel
07:53 fatdragon joined #fuel
08:03 DavidRama joined #fuel
08:06 nokes joined #fuel
08:08 javeriak joined #fuel
08:19 javeriak joined #fuel
08:24 HeOS joined #fuel
08:24 HeOS joined #fuel
08:42 yassine__ joined #fuel
09:39 zinovik joined #fuel
09:50 parlos joined #fuel
09:55 fatdragon joined #fuel
09:58 javeriak_ joined #fuel
10:18 Zer0Byte___ joined #fuel
10:56 fatdragon joined #fuel
11:01 Egyptian[Home] joined #fuel
11:44 DavidRama joined #fuel
11:56 fatdragon joined #fuel
12:10 javeriak joined #fuel
12:41 Gonzalocl joined #fuel
12:47 parlos joined #fuel
12:49 yassine joined #fuel
12:58 slefeuvre joined #fuel
12:58 slefeuvre Hi all
12:58 slefeuvre I'm encountering lot of problems whith Fuel 7.0 that I cannot explain
12:59 slefeuvre I tried many different configuration : (ceph deployment 2 controllers - 3 compute storage)
12:59 slefeuvre (ceph deployment 1 controllers - 3 compute storage)
13:00 slefeuvre (cinder deployment 2 controllers - 3 compute storage)
13:00 slefeuvre The only working is (ceph deployment 1 controllers - 3 compute storage)
13:00 slefeuvre *(cinder deployment 1 controllers - 3 compute storage)
13:01 slefeuvre But it failed when I add a controller after deployment success
13:01 slefeuvre The error I get now is : rsync -q -a -r rsync://192.168.11.3/swift_server/backups/ /etc/swift/backups/ returned 12 instead of one of [0]
13:02 slefeuvre in the syslog of the controller I have this error : object-updater: ERROR: Unable to access /srv/node: [Errno 2] No such file or directory: '/srv/node'
13:02 slefeuvre someone already have encountered this issue ?
13:07 degorenko joined #fuel
13:08 Julien-zte joined #fuel
13:13 degorenko slefeuvre, hey, for swift backups problem, check please this bug https://bugs.launchpad.net/fuel/+bug/1518305 , may this fix can help https://review.openstack.org/#/c/276853/
13:28 javeriak joined #fuel
13:29 slefeuvre degorenko: This bug is for FUEL 8.0 but we are using Fuel 7.0, does it mean that we have to apply it even if we are using FUEL 7.0 ?
13:30 degorenko slefeuvre, you can try it, i'm not sure. I don't know, how i can help else. That's only one my idea :)
13:34 DavidRama Hello, is there a way to add murano (or equivalent) on a installed MOS9.0 ?
13:35 kur1j joined #fuel
13:38 kur1j What would cause an Ethernet device to be "down" in Fuel? The Ethernet cable is plugged into the server. does it need to see a gateway? or what?
13:42 javeriak joined #fuel
13:53 LGee does it have an assigned IP address?
13:54 MikeG451 joined #fuel
13:55 kur1j how would it have an assigned IP?
13:56 kur1j so I have two network cards.
13:57 kur1j PXE/storage vlan112 on eth0. private/management/public - vlan 111, 110, 100 on eth1
13:58 kur1j PXE has no vlan
13:58 fatdragon joined #fuel
13:58 kur1j eth0 is green (bc I guess it is getting ip) but the others aren't going to get dhcp or anything on their network
14:27 xarses joined #fuel
14:27 xarses joined #fuel
14:58 fatdragon joined #fuel
15:15 javeriak joined #fuel
15:16 kszukielojc joined #fuel
15:22 javeriak_ joined #fuel
15:35 krypto joined #fuel
15:36 omolchanov joined #fuel
15:59 gomarivera joined #fuel
16:01 MikeG451 /join #openstack-meeting-alt
16:01 akostrikov joined #fuel
16:05 BobBall left #fuel
16:14 sraju joined #fuel
16:15 sraju Bootstrap node not creating parition
16:17 hyperscsi joined #fuel
16:18 sraju Error
16:18 sraju Node 'Untitled (26:98)' has insufficient disk space
16:21 hyperscsi Hi all, I'm trying to install Fuel on a UCS C220-M4 and the installation is stopping at the same point every time. Towards the end of the console I see  "Kickstart loaded. Please re-insert installation media." and "Warning: could not bring interface eth0 up!" Is the eth0 interface being down preventing installation? I took a screenshot of the console: http://i.imgur.com/JWYpN80.png
16:24 raunak joined #fuel
16:33 elopez joined #fuel
16:45 javeriak joined #fuel
16:48 mwhahaha @hyperscsi. looks like the fuel iso doesn't support the ethernet driver.  don't see it on the hardware compability list. https://www.mirantis.com/validated-solution-integrations/hardware-compatibility/
16:50 hyperscsi @mwhahaha wow, i should have checked that. Sorry to waste your time. So it looks like I need to go with 7.0?
16:50 mwhahaha at least 7.0
16:51 mwhahaha it'll probably also work in 8.0
16:52 hyperscsi Thank you. I'll try 8.0
16:53 gomarivera joined #fuel
16:59 jerryz joined #fuel
17:08 thumpba joined #fuel
17:22 yahoooooo joined #fuel
17:40 sraju mwhahaha:http://paste.openstack.org/show/505711/
17:47 gomarivera joined #fuel
17:55 mwhahaha sraju: it looks like your disk isn't empty as it still has a dos partition table
17:56 mwhahaha i wondering if that is causing the problems
17:56 sraju mwhahaha: yes it is done by bootstrap
17:57 mwhahaha no bootstrap is ram based
17:57 mwhahaha we don't touch the disks until you deploy
17:58 sraju mwhahaha:I have cleaned up everything with dd command
17:58 thumpba joined #fuel
17:59 sraju mwhahaha: is there any other way I can clear it up completly in bootstrap
17:59 mwhahaha dd should suffice but you'll need to reboot
17:59 sraju ok will give a try again
18:00 sraju mwhahaha: is there any way we can do all-in-one deployment using fuel 8?
18:00 mwhahaha no
18:00 sraju ok
18:02 thumpba_ joined #fuel
18:10 sraju mwhahaha: here is the latest log after dd reboot http://paste.openstack.org/show/505718/
18:10 mwhahaha yea now it doesn't have any partitions
18:11 Gonzalocl joined #fuel
18:11 mwhahaha so if it's erroring, it's due to the size calculations. you may want to check the nailgun logs to so see if there are any additional details
18:14 javeriak joined #fuel
18:15 sraju mwhahaha: Sure, where can I find them in nailgun container?
18:15 mwhahaha on the master in /var/log/docker/nailgun
18:19 gomarivera joined #fuel
18:19 sraju mwhahaha: I have multiple logs in nailgin do you need oswl_volume_collectord.log?
18:19 mwhahaha no i'm not sure which log might have something
18:20 mwhahaha i'd check the app or api logs and see if there are any errors
18:23 sraju mwhahaha: I have another UCS which is working fine in the same fuel environment it is showing the paritions without any issues
18:24 mwhahaha is it also 72g?
18:25 sraju yes
18:26 sraju CPU: 2 (4)HDD: 68.0 GBRAM: 16.0 GB
18:27 sraju Fuel UI showing the HDD
18:27 mwhahaha let me go poke in the code to see where that error comes from
18:27 mwhahaha this fuel 7?
18:28 sraju Fuel 8
18:29 mwhahaha so this is an error from nailgun where it checks prior to deployment
18:30 hyperscsi looks like I was able to get past the issue I had before by using 8.0, but now its been sitting at "running post-installation scripts" for about an hour
18:30 mwhahaha I wonder since it had a partition when it first registered if it needs to be removed from nailgun and readded
18:31 mwhahaha hyperscsi: you can check /var/log/puppet/bootstrap_admin_node.log for the status of the installation
18:31 mwhahaha it may take a while depending on hardware/network speed
18:32 hyperscsi is there a way to break out of the installation to check that file
18:32 mwhahaha ssh to the box?
18:32 mwhahaha switch to a different console?
18:38 sraju mwhahaha: app log http://paste.openstack.org/show/505726/
18:39 mwhahaha i found the spot in the code that generates that error and it's during the pre-deployment disk check
18:39 mwhahaha unfortunately it doesn't look like it prints out any additional debug information to help troubleshoot it
18:39 mwhahaha all i can say is try and lower the space for the partitions and try again
18:39 mwhahaha other wise remove the node and let it reregister
18:41 sraju Done both the steps, download disk and reduced the paritions and tried no luck
18:41 sraju actually deployed fuel multiple times and added the node still same issue with this particualar model servers Sun x4100
18:42 sraju I am able to deploy openstack on same hardware a week again with fuel 8
18:42 sraju not sure what changed
18:42 mwhahaha not sure, the best bet is to file a bug
18:43 sraju Hmm
18:44 sraju Thanks for your time mwhahaha, appreciate it.
18:57 gomarivera joined #fuel
18:59 thumpba joined #fuel
19:13 DavidRama joined #fuel
19:16 gomarivera joined #fuel
19:18 thumpba joined #fuel
19:32 DavidRama joined #fuel
19:37 gomarivera joined #fuel
19:42 xarses joined #fuel
19:47 gomarivera joined #fuel
19:49 Gonzalocl joined #fuel
19:56 DavidRama1 joined #fuel
20:21 hyperscsi joined #fuel
20:27 elopez joined #fuel
21:03 gomarivera joined #fuel
21:09 meow-nofer_ joined #fuel
21:28 kur1j joined #fuel
21:28 kur1j left #fuel
21:29 kur1j joined #fuel
21:29 kur1j so for the private/management/storage networks. If they are all on their own VLANs, do they all need to have a gateway?
21:32 kur1j so for example if I have vlan 100, 110, 120, all for 192.168.100.0/24, 192.168.110.0/24, 192.168.120.0/24 being private, management and storage respectively. Is there routing that needs to be able to take place that the private network can talk with the management network?
21:34 fritchie joined #fuel
21:34 Egyptian[Home] joined #fuel
21:35 fritchie in the Fuel Web UI which network gets mapped to floating IPs, the 'Private' network or the 'Internal Network' on the Neutron L3 page?
21:36 hyperscsi does anyone have an md5 hash of a fuel 8.0 iso image that is known working
21:38 HeOS joined #fuel
21:38 hyperscsi nvm
21:38 hyperscsi found it on the website
21:52 xarses kun_huang: they don't need gateways unless you are using multiple nodegroups, the ui won't show the gateway fields until you add a second nodegroup (the first is the default networks you configure)
21:53 xarses kur1j: the networks are not expected to cross communicate in the default layout
21:55 xarses fritchie: the floating network is a subsection of the public network CIDR (default network nodegroup, or whichever all the controllers are in if you have multiple nodegroups)
21:56 fritchie ty
21:56 xarses the internal network (admin_internal_net) is a overlay network we create for you in neutron and not bound to anything external
21:57 xarses admin_internal_network will most likely transmit over whatever the 'private' nodegroup network corresponds to
21:58 xarses but they aren't functions of each others network rangers like the floating ip range is
21:58 fritchie so the floating IP is natted to the private ip, correct?
21:58 xarses as a simplification, yes
21:59 fritchie thx much
22:21 raunak left #fuel
22:27 aslaen joined #fuel
22:41 gomarivera joined #fuel
23:16 gomarivera joined #fuel
23:26 aslaen joined #fuel
23:58 Egyptian[Home] joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary