Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2016-05-27

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:22 xarses joined #fuel
00:28 User985 joined #fuel
00:40 jonmills_nasa joined #fuel
00:40 jonmills_nasa left #fuel
00:54 fatdragon joined #fuel
00:55 fatdragon joined #fuel
01:22 gomarivera joined #fuel
01:31 fatdragon joined #fuel
01:40 Egyptian[Home] joined #fuel
01:48 ilbot3 joined #fuel
01:48 Topic for #fuel is now Fuel 8.0 (Liberty) https://www.fuel-infra.org/ | Paste here http://paste.openstack.org/ | IRC logs http://irclog.perlgeek.de/fuel/
01:55 Egyptian[Home] could someone link me to the fuel plugins page pls?
02:23 raunak joined #fuel
02:52 Egyptian[Home] joined #fuel
03:02 aslaen joined #fuel
03:10 kur1j joined #fuel
03:11 kur1j xarses: thanks.
03:15 kur1j I think I have my network layout setup incorrectly. What would be the best way to debug the issue of the public network not being able to get out to the internet? If I create a new environment, add my storage and controller nodes and do a network check everything passes. But when it goes to deploy about 15% into deploying Openstack on the controller the deployment fails saying that the network
03:15 kur1j didn't come up (I see the logs showing it can't ping the public gateway 192.168.0.1).
03:29 aslaen joined #fuel
03:48 gomarivera joined #fuel
04:58 gomarivera joined #fuel
05:29 kszukielojc joined #fuel
05:35 krypto joined #fuel
05:39 krypto any idea why --provision returns "500 Server Error: Internal Server Error (http() got an unexpected keyword argument 'message')"
05:39 krypto nailgun log "ERROR [7fa6f0cb1740] (logger) Response code '500 Internal Server Error' for PUT /api/v1/clusters/1/provision/?nodes=317 from 192.68.40.34:57769"
06:27 javeriak joined #fuel
06:35 Billias joined #fuel
06:54 dancn joined #fuel
07:09 krypto i have an environment with 300+ nodes and trying to add more compute nodes,but "--deploy" is taking 39s to return result "started deploying" ,fuel is a vm with 8 Gb and 4 cpu,resource consumption is ~1 cpu and available ram is 138m+4G cached
07:11 LGee Maybe log into the nailgun container and look around in /var/log/ ?
07:14 krypto LGee there was an issue with nailgun returning 500 in the logs for provision but after rabbitmq restart that got fixed ,this i am not able to see anything in logs
07:16 DavidRama joined #fuel
07:18 DavidRama joined #fuel
07:52 noshankus joined #fuel
08:36 yassine joined #fuel
08:44 Miouge joined #fuel
09:04 HeOS joined #fuel
09:21 Miouge joined #fuel
09:39 gomarivera joined #fuel
09:44 Kdecherf what is the current state of fuel 9?
09:54 permalac joined #fuel
09:54 permalac joined #fuel
09:55 permalac joined #fuel
09:58 javeriak joined #fuel
10:10 javeriak joined #fuel
10:17 Egyptian[Home] joined #fuel
10:28 krypto joined #fuel
10:41 javeriak joined #fuel
10:58 Egyptian[Home] joined #fuel
10:59 javeriak joined #fuel
11:24 zinovik joined #fuel
11:26 LGee Kdecherf: there's a roadmap out there
11:27 LGee https://wiki.openstack.org/wiki/Fuel/9.0_Release_Schedule
11:57 Egyptian[Home] joined #fuel
12:40 parlos joined #fuel
12:50 Kdecherf LGee: Yeah I know, but i can't  see if it's an up to date schedule
12:51 Kdecherf (and if 9.0.1 is the first expected stable release, it's not clear)
13:00 MikeG451 joined #fuel
13:01 kur1j` joined #fuel
13:04 kur1j` Kdecherf: If you are asking about 9.0 in general it was released (https://www.fuel-infra.org/ download from that page). As for the 9.0.1 release, im not sure.
13:11 LGee does a channel bot create tickets from questions, or how could you see it if you just joined? :)
13:19 mwhahaha the irc channel syncs to some internal tools :)
13:30 LGee cool
13:41 gomarivera joined #fuel
13:46 Julien-zte joined #fuel
13:48 hyperscsi joined #fuel
13:59 fritchie would the be a valid network setup with Fuel 9, vxlan tunneling: [ eth0: admin net, mgmt net, private net ] [ eth1: storage net ] [ eth2: public net ]?
14:00 fritchie or does the admin net need to be alone on eth0?
14:03 dilyin joined #fuel
14:10 akaszuba joined #fuel
14:26 kur1j` joined #fuel
14:26 kur1j` has anyone else had problems with controllers on an ESXi server?
14:35 akaszuba joined #fuel
14:37 akaszuba joined #fuel
14:39 xarses joined #fuel
14:45 akaszuba joined #fuel
14:51 hyperscsi trying to install 7.0 or 8.0... never brings me to the blue setup screen to change parameters
14:52 hyperscsi gray/red/blue screen
14:52 hyperscsi as shown here http://docs.openstack.org/developer/fuel-docs/userdocs/fuel-install-guide/install/install_set_up_fuel.html#install-set-up-fuel
14:57 fritchie joined #fuel
14:59 fritchie joined #fuel
15:00 kur1j` hyperscsi: probably a networking configuration issue
15:01 kur1j` errr spoke to soon
15:01 kur1j` thought you were talking about on a deployed node
15:01 hyperscsi i think im making headway
15:02 kur1j` hyperscsi: if i remember correctly in 8 (I never used 7) there is an option to select
15:02 hyperscsi its choosing eth0 as the management interface but it needs to be eth2
15:02 hyperscsi but just confused because documentation says it'll bring me to that screen but it never does
15:02 hyperscsi so having to do it all via CLI
15:02 kur1j` if you have it run fuelsetup
15:02 hyperscsi im obviously a noob :)
15:02 hyperscsi fuelsetup
15:02 hyperscsi command not found
15:03 kur1j` errr menu
15:03 kur1j` fuelmenu
15:03 kur1j` I'm also a newb haha
15:03 hyperscsi ah yeah thats the command i was looking for. its still complaining that eth0 has no IP, going to try to point it to eth2 and set the ip manually
15:03 kur1j` you can switch it
15:03 kur1j` but make sure you have your network setup properly
15:04 kur1j` the network setup of this stuff is the biggest pain in the ass ever
15:04 hyperscsi lol
15:05 hyperscsi i guess im supposed to change it by hitting tab before installation
15:05 kur1j` you can change it in the menu for your fuel node
15:06 hyperscsi if you cd to /etc/fuel you can type in bootstrap_admin_node.sh and itll ask for the admin interface
15:06 hyperscsi trying that now
15:24 fritchie joined #fuel
15:25 fritchie has anyone else had issues with rabbitmq failing to start on fuel 9 install from iso?
15:32 gomarivera joined #fuel
15:33 mwhahaha fritchie: yea there were known issues, you can try one of the newer community builds
15:34 mwhahaha same with mysql
15:34 mwhahaha https://ci.fuel-infra.org/
15:37 fritchie ty, is there a non torrent link btw? (firewall won't allow it)
15:38 mwhahaha remove the .torrent extension
15:38 fritchie easy enough :-)
15:44 v1k0d3n joined #fuel
15:51 xarses kur1j: the public networks gateway address must respond to icmp, even if it's a rfc1819 network
15:58 kur1j` xarses: thanks. I *think* I figured it out. I've been struggling with understanding the current networks VLAN and then adding more network switches along with OS it is just a disaster
15:58 kur1j` its so confusing
15:58 xarses yes, it is. Networking is the most likely to cause failure
15:59 xarses you should be able to use the verify networks check to test before you deploy
16:03 kur1j` yeah, that is what is strange though
16:03 kur1j` it tested valid
16:03 kur1j` then failed to connect to my gateway
16:04 dnikishov joined #fuel
16:05 dnikishov joined #fuel
16:06 raunak joined #fuel
16:42 fritchie to restore a fuel master in case of a disaster can I install from the iso and simply restore the postgres db?
16:42 hyperscsi before installing fuel you can hit tab to change parameters, can I change eth0::off to eth2::off to set eth2 as the default management itnerface
16:43 hyperscsi or is that not how it works
16:54 javeriak joined #fuel
16:58 javeriak_ joined #fuel
18:06 gomarivera joined #fuel
18:13 kur1j` Will Fuel take care of adding the correct configuration if you make a deployment of 1 controller 3x storage nodes and then later down the road want to add 2 more controller nodes?
18:22 hyperscsi has anyone ever had a problem with fuel master node refusing https connectino to gui
18:30 jerryz joined #fuel
18:36 mwhahaha is it listening?
18:40 thumpba joined #fuel
18:42 hyperscsi @mwhahaha no
18:42 hyperscsi not on 443 nor 80
18:42 mwhahaha is it listening on 8000?
18:42 mwhahaha ssl is 8443
18:42 hyperscsi no
18:42 mwhahaha is nginx up? :o
18:42 hyperscsi not 8443 nor 8000
18:43 hyperscsi it says
18:43 hyperscsi one esc
18:43 hyperscsi sec
18:44 hyperscsi cant even ping the node anymore... one sec
18:45 hyperscsi the networking config keeps disappearing
18:45 hyperscsi the default gateway for my management interface keeps going away
18:45 mwhahaha that's strange
18:47 hyperscsi well i cant ssh into the box anymore
18:47 hyperscsi dont see it listening on 23
18:47 hyperscsi er
18:47 hyperscsi 22
18:55 javeriak joined #fuel
18:57 hyperscsi left #fuel
19:20 javeriak_ joined #fuel
19:27 gomarivera joined #fuel
19:33 thumpba_ joined #fuel
19:40 kur1j_ joined #fuel
19:42 kur1j_ If I create a deployment, with 5 compute nodes (along with the other support nodes) and then later on down the road I want to add 5 more compute nodes. Will Fuel destroy the contents of the current deployment and redeploy the entire thing? How would I backup the entire configuration, and deployment so I could revert back to a known good state when adding nodes?
19:44 javeriak joined #fuel
19:50 mwhahaha no it won't destroy the existing deployment, it'll just add the nodes in
19:51 mwhahaha so going from 5 compute to 10 compute, it'll just run what's required to add the additional capacity
20:18 gomarivera joined #fuel
20:27 elopez joined #fuel
20:32 MikeG451 joined #fuel
20:40 DavidRama joined #fuel
20:41 DavidRama left #fuel
21:24 thumpba joined #fuel
21:41 DavidRama joined #fuel
22:01 DavidRama1 joined #fuel
22:10 gomarivera joined #fuel
22:21 DavidRama1 left #fuel
22:46 Julien-zte joined #fuel
22:48 dnikishov joined #fuel
22:54 xarses joined #fuel
23:01 Egyptian[Home] joined #fuel
23:22 raunak joined #fuel
23:26 Egyptian[Home] joined #fuel
23:59 gomarivera joined #fuel

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary