Perl 6 - the future is here, just unevenly distributed

IRC log for #fuel, 2016-07-27

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:42 code-R joined #fuel
00:44 code-R_ joined #fuel
00:49 code-R joined #fuel
01:20 xarses joined #fuel
01:40 drmccollum what is the deal with the fwaas, lbaas and vpnaas plugins? They haven't been updated since fuel 7.0. Are they discontinued as plugins?
02:41 v1k0d3n joined #fuel
03:14 thumpba joined #fuel
03:25 Liuqing joined #fuel
04:00 thumpba joined #fuel
04:15 thumpba joined #fuel
04:24 javeriak joined #fuel
04:29 javeriak joined #fuel
04:36 thumpba joined #fuel
04:48 Sesso joined #fuel
05:21 maestropandy joined #fuel
05:47 v1k0d3n joined #fuel
05:49 Miouge joined #fuel
06:07 pradiprwt joined #fuel
06:08 pradiprwt Hi Everyone, I am trying to install fuel 9 using vertulbox but it getting timeout at "Waiting for product VM to install. Please do NOT abort the script"..
06:09 pradiprwt can anyone please help me how I can resolve this issue ..?
06:11 kaliya joined #fuel
06:12 code-R joined #fuel
06:13 Liuqing joined #fuel
06:48 maestropandy joined #fuel
06:51 igorbelikov joined #fuel
06:51 asaprykin joined #fuel
07:15 thumpba joined #fuel
07:16 mskalski drmccollum: https://www.mirantis.com/blog/whats-new-in-mirantis-openstack-8-0-webinar-qa-part-2/ " I can’t find a LBaaS Fuel Plugin for 7.0/8.0, Will this be available anytime soon?"
07:32 GMAzrael joined #fuel
07:33 mskalski pradiprwt: what version of virtualbox do you use and how much RAM do you have?
07:36 kaliya joined #fuel
07:38 code-R joined #fuel
07:41 ukinau joined #fuel
07:55 javeriak joined #fuel
07:55 DavidRama joined #fuel
07:55 chopmann joined #fuel
08:12 yassine joined #fuel
08:19 vkulanov joined #fuel
08:57 Miouge What version of ceph is in MOS 9.0?
08:59 Aurelgadjo Miouge: hammer https://docs.mirantis.com/openstack/fuel/fuel-9.0/release-notes.html
09:05 ekosareva joined #fuel
09:05 Miouge Aurelgadjo: thank you
09:06 Miouge So MOS 9.0 has “Limited Support ends: 7/12/2019” but Hammer has “Estimated retirement: November 2016”
09:19 maestropandy joined #fuel
09:32 DaveJ__ joined #fuel
10:01 ekosareva joined #fuel
10:09 dguryanov joined #fuel
10:09 dguryanov ikutukov, asvechnikov, akislitsky, gkibardin, could you, please, re-review https://review.openstack.org/#/c/340976/ ?
10:19 sbog1 joined #fuel
10:19 sbog1 left #fuel
10:27 maestropandy joined #fuel
10:37 javeriak joined #fuel
11:00 blahRus joined #fuel
11:20 kaliya joined #fuel
11:26 thiagolib joined #fuel
11:28 thiagolib Hi I am having a problem in fuel mirantis 8 after taking the cluster a machine the fuel is returning the error below.
11:28 thiagolib Verification failed.
11:28 thiagolib Method verify_networks. 4b0c3d2c-051c-4017-8e08-6f3fb9281ce7: MCollective call failed in agent 'net_probe' method 'start_frame_listeners' failed nodes:
11:28 thiagolib ID: 7 - Reason: Listener did not Reported status
11:28 thiagolib .
11:28 thiagolib Astute inspect logs for the details
11:29 Aurelgadjo try sshing the node
11:30 javeriak joined #fuel
11:31 thiagolib I managed to make the SSH normally
11:34 mskalski thiagolib: can you run `mco ping` on fuel master and check if all agents respond?
11:39 thiagolib yes, but I managed to find the error had a disconnected cable from a server
11:41 thiagolib now I will see if I can put back the server who brought the cluster
11:42 thiagolib tks mskalski
11:44 drmccollum what is the deal with the fwaas, lbaas and vpnaas plugins? They haven't been updated since fuel 7.0. Are they discontinued as plugins?
11:45 mskalski drmccollum: https://www.mirantis.com/blog/whats-new-in-mirantis-openstack-8-0-webinar-qa-part-2/ " I can’t find a LBaaS Fuel Plugin for 7.0/8.0, Will this be available anytime soon?"
11:49 drmccollum So that appears that Mirantis will no longer develop the plugins. Do you know of a link that correctly shows how to install fwaas,lbaas and VPNaas? Every example I have been able to find are mostly for Centos/RHEL and they are all slightly different.
11:58 Sketch mirantis has at least a few plugins for 9.0 on their web site
11:58 Sketch i kinda figured the rest just hadn't been ported to 9.0 yet
11:59 drmccollum Since they have not upgraded them since 7.0, I'm assuming they are no longer porting those.
11:59 Sketch hmm, now there are some listed under MOS8.0/9.0
11:59 Sketch https://www.mirantis.com/validated-solution-integrations/fuel-plugins/ ...i didn't see those before (right after 9.0 came out)
12:03 drmccollum on a different topic, do you know how to reclaim/resuse node names in fuel?
12:06 Aurelgadjo .win 8
12:07 mskalski drmccollum: Im not sure if there is other way then manually modify nailgun database
12:11 Sketch i've used fuel node --delete-from-db and it's seemed to work
12:15 maestropandy joined #fuel
12:20 javeriak joined #fuel
12:21 drmccollum Thanks Sketch
12:22 thiagolib my environment in the fuel is returning error but everything is ok but can not use the regular mirantis OpenStack. But I think because of this error can not later add more machines in the environment
12:23 mskalski what kind of error ?
12:24 Sketch btw, delete first, then --delete-from-db
12:24 Sketch and you may still have to remove /var/lib/tftp/pxelinux.cfg/<mac-address>
12:24 Sketch (i think the delete will do that, but it seems like it doesn't sometimes...)
12:27 thiagolib I do not know what the error because it is not reporting. following image. https://usercontent.irccloud-cdn.com/file/aYiPwvEC/Selection_025.png
12:28 mskalski can you click on FIt_Lab, on environment page you should have error message
12:28 vkulanov joined #fuel
12:28 thiagolib how do I access the db and delete information
12:29 thiagolib Status Error
12:32 mskalski can you please provide more details? Do you see that all nodes in your env are online?
12:42 thiagolib follow log of fuel and image of server locked in booting https://usercontent.irccloud-cdn.com/file/FztLiNNF/Selection_026.png
12:45 thiagolib https://usercontent.irccloud-cdn.com/file/m7px0eMw/fuel.log
12:46 severion joined #fuel
12:50 mskalski do you have active bootstrap image fuel-bootstrap list ?
12:51 vkulanov joined #fuel
12:57 thiagolib yes is enabled, this error started after I removed one of my server environment now want recolocalo again but I can not
12:58 ikutukov Please, review small CLI patch https://review.openstack.org/#/c/347774/, many important, much want
12:59 flerfb0rt1 joined #fuel
13:06 Liuqing joined #fuel
13:06 severion joined #fuel
13:12 jackdastripper joined #fuel
13:13 jackdastripper I have a fuel 9.0 installation that 1 of the 2 controllers keeps failing with this error. (/Stage[main]/Cluster::Mysql/Exec[wait-initial-sync]/returns) ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
13:20 mskalski thiagolib: how did you remove this server? through web ui interface? it should load bootstrap image if this server was remove correctly, can you please verify if this node is no longer assigned to cluster: fuel nodes, and is remove from cobbler: cobbler system list ?
13:21 ikutukov Please, review https://review.openstack.org/#/c/335164/
13:24 johnavp1989 joined #fuel
13:25 falavinha joined #fuel
13:27 atolochkova joined #fuel
13:28 thiagolib mskalski: I removed this server through the web interface of fuel
13:29 mskalski thiagolib: and is no longer visible in outputs from above commands ?
13:33 thiagolib no, I removed the server because it showed error status and then went offline. how do I access to cobbler system list?
13:34 mskalski jackdastripper: can you look at /var/log/mysql/error.log on failed node?
13:34 thiagolib when I give the command fuel nodelist it does not appear in my list
13:35 mskalski and what about cobbler: cobbler system list?
13:36 atolochkova akasatkin ikalnitsky ikutukov: hi. Please, merge https://review.openstack.org/#/c/339387/
13:36 thiagolib yes I would like to know how to access
13:37 code-R joined #fuel
13:41 mskalski thiagolib: what the fuel version do you use?
13:41 javeriak joined #fuel
13:41 thiagolib I'm using version 8
13:42 mskalski thiagolib: first run dockerctl shell cobbler
13:42 mskalski then cobbler system list
13:42 maestropandy left #fuel
13:45 gcmacmalloc joined #fuel
13:46 thiagolib Return command
13:46 thiagolib cobbler system list
13:46 thiagolib default
13:46 thiagolib node-6
13:46 thiagolib node-7
13:46 thiagolib node-8
13:46 thiagolib node-9
13:46 thiagolib I moved from the cluster node-9
13:48 goldenfri joined #fuel
13:48 ikalnitsky python folks, please review this patch - https://review.openstack.org/#/c/346908/
13:48 mskalski thiagolib: ok, I would try remove this node from cobbler by: cobbler system remove node-9 it should remove pxe configuration for this node, and after node reset it should boot with bootstrap image
13:49 code-R_ joined #fuel
13:52 thiagolib deleted the node-9 as you instructed me now will reboot the server to see if it picks up the bootstrap image.
13:54 GMAzrael anyone able to get a MOS 9.0 virtualbox install to work with Ubuntu?
14:05 code-R joined #fuel
14:07 code-R_ joined #fuel
14:13 thiagolib tks mskalski, the server was recognized again by the PXE boot and initialize
14:18 azemlyanov joined #fuel
14:36 garrett_ joined #fuel
14:36 garrett_ hey everyone
14:37 Guest14816 having an issue with building a fuel iso where it fails because it says it does not have libicu?
14:37 Guest14816 Error: Package: 1:v8-3.14.5.10-17.el6.x86_64 (epel)            Requires: libicuuc.so.42()(64bit)
14:43 mskalski Guest14816: which version of fuel you are trying to build? Do you have maybe full log?
14:43 Guest14816 im trying to build 7
14:43 Guest14816 and yes hang on
14:44 Guest14816 do you want just more console output?
14:44 Liuqing joined #fuel
14:45 Guest14816 ---> Package gyp.noarch 0:0.1-0.6.1010svn.el6 will be installed --> Processing Dependency: python(abi) = 2.6 for package: gyp-0.1-0.6.1010svn.el6.noarch ---> Package kernel-headers.x86_64 0:3.10.0-327.22.2.el7 will be installed ---> Package libsepol-devel.x86_64 0:2.1.9-3.el7 will be installed ---> Package pcre-devel.x86_64 0:8.32-15.el7_2.1 will be installed ---> Package python-pbr.noarch 0:0.8.0-1.el6.mira2 will be installed -->
14:45 Guest14816 hm hang on let me paste it
14:46 Guest14816 http://paste.openstack.org/show/542606/
14:47 Guest14816 there is literally all of the output my terminal captures
14:47 Guest14816 i think it fails because it does not find the libicu package or something like that so it does not meet all of the dependencies required
14:48 Guest14816 Note that i am attempting to use my own mirror of centos and ubuntu
14:50 mskalski im trying to compare your build with todays community 7.0 build https://ci.fuel-infra.org/job/7.0-community.all/531/consoleFull
14:50 mskalski which end with success
14:52 code-R joined #fuel
14:52 Guest14816 ok i will go through it as well
14:56 Guest14816 ok so i found the difference/possible error message. It appears that my build stops after this line in your build (if you search it on your paste you will find it) --> Finished Dependency Resolution
14:56 Guest14816 so is it possible that my centos mirror is incorrect?
14:56 Guest14816 or incomplete?
14:58 Guest14816 im guessing all of the error messages are just saying that my mirror has incorrect versions or is missing the files? i have only tried to mirror ubuntu and centos, im still using the default link for epel
14:59 mskalski It is something which crossed my mind, in your output I see package for el7 which not appear in community build (el6)
15:02 Guest14816 is that referring to epel 7?
15:03 Guest14816 Like i said i have not changed anything with epel which is weird
15:03 Guest14816 maybe im using centos 7 instead of 6? would that cause a similiar issue by wanting epel 7 instead of provided 6?
15:05 mskalski for fuel 7.0 we used CentOS 6.6 so pointing to centos 7 packages could generate such problems
15:06 Guest14816 do the error logs indicate that im using that centos 7?
15:06 Guest14816 also, do you have a direct link that I can rsync the correct centos repo if it is incorrect?
15:07 javeriak joined #fuel
15:07 mskalski in your log I see that package with el7 are considered which has no place in community builds
15:09 Guest14816 hmm but i have not mirrored epel7? Im using the default mirror for epel?
15:10 Guest14816 are you saying that it is looking for el7, and that indicates that they are centos 7 packages?
15:11 mskalski you can find mirror list used for standard fuel builds in https://github.com/openstack/fuel-main/blob/stable/7.0/config.mk
15:11 Sketch el7 = centos 7 (or rhel7)
15:17 Guest14816 ah i see, sorry im fairly new to this. I have gone through the config.mk file multiple times, but i am in the usa by the way so the msk mirrors do not work. is the product version 6 then?
15:17 Guest14816 6.0?
15:18 Guest14816 it would be this link: http://mirror.seed-us1.fuel-infra.org/fwm/6.0/centos/    ???
15:19 mskalski 7.0
15:19 mskalski http://mirror.seed-us1.fuel-infra.org/fwm/7.0/centos/os/
15:20 Guest14816 i belive that is the one i have mirrored though
15:20 Guest14816 i guess i can try though
15:33 mskalski Guest14816: how you use your local mirror? do you export some env variables? if yes which one?
15:34 mattymo any pythonists wanna help me with py.test and  SyntaxError: future feature print_functions is not defined error?
15:35 mattymo oh my bad.. it's print_function (without s)
15:35 Sketch fuel 8 and 9 use centos 7, btw.
15:36 mskalski Guest14816: I wonder if you are using correct version of https://github.com/openstack/fuel-main/blob/stable/7.0/config.mk#L157
15:36 Guest14816 i am sure I did clone that branch
15:36 Guest14816 I do not export any variables i have been modifying config.mk to use my mirror instead
15:36 Guest14816 is that not correct?
15:37 mskalski it is actually create upstream repo https://github.com/openstack/fuel-main/blob/stable/7.0/sandbox.mk#L12
15:37 mskalski from which we observer el7 packages comes from
15:38 Guest14816 i dont understand
15:39 mskalski look at your output you see that two version of packages are considered the one from mirror repo and another from upstream
15:41 mskalski from upstream you are getting el7 packages, and this repo is defined in sandbox.mk file which use SANDBOX_MIRROR_CENTOS_UPSTREAM variable from config.mk
15:42 Guest14816 ah i see. I do see now that my upstream was pointed to http://mirror.centos.org/centos-7/7/
15:42 Guest14816 when it should be centos-6/6
15:42 Guest14816 i think
15:43 mskalski yep, i think it should be http://vault.centos.org/6.6/
15:44 code-R joined #fuel
15:45 Guest14816 ok i changed that link and now im getting basically the same error but with different packages
15:45 Guest14816 should i try a deep clean with the different mirrors?
15:46 mskalski yes try with no cache
15:47 Guest14816 ok cool, i have to finish the download first of the fuel-infra centos 7 and then i will try that
15:48 mskalski remind me why you download centos 7? if fuel 7.0 we are using 6.6
15:49 Guest14816 sorry i mean centos 6
15:49 mskalski ok :)
15:49 Guest14816 its confusing because the centos 6 mirror is under fwm/7.0 haha :)
15:50 mskalski yeach to many product versions
15:58 Guest14816 im guessing then i need ubuntu and docker form fwm/7.0 as well? Not sure ifI have that wrong also
16:00 Guest14816 however when i mirrrored it, ubuntu was missing the universe, multiverse, etc packages?
16:15 code-R joined #fuel
16:31 xarses joined #fuel
16:34 code-R_ joined #fuel
16:39 javeriak joined #fuel
17:20 akscram joined #fuel
17:29 Guest14816 not sure if you guys are still here but my build is now failing at this step: touch /home/garrett/Tasks/fuel-main2/fuel-main/build/mirror/make-changelog.done python /home/garrett/Tasks/fuel-main2/fuel-main/packages/rpm/genpkgnames.py /home/garrett/Tasks/fuel-main2/fuel-main/build/repos/fuel-main/specs/fuel-main.spec | xargs -I{} sudo find /home/garrett/Tasks/fuel-main2/fuel-main/local_mirror/centos/os/x86_64/Packages -regex '.*/{}
17:33 fritchie joined #fuel
17:55 byrdnuge joined #fuel
18:08 byrdnuge joined #fuel
18:20 Miouge joined #fuel
18:24 flerfb0rt1 what version of Fuel Plugin Builder do I want to be using for Fuel 9.0?
18:26 mwhahaha flerfb0rt1: probably 4.1.0
18:26 flerfb0rt1 ok ty
18:38 Miouge joined #fuel
18:46 Miouge joined #fuel
19:00 javeriak_ joined #fuel
19:37 DavidRama left #fuel
20:18 flerfb0rt1 joined #fuel
20:18 flerfb0rt1 how do you restart nailgun in fuel 9.0?
20:19 flerfb0rt1 cause docker is no longer a thing
20:19 Sketch service nailgun restart
20:20 mwhahaha systemctl restart nailgun
20:20 mwhahaha but yea
20:20 mwhahaha normal way
20:21 flerfb0rt1 i just installed 9.0 and the web ui just hung
20:21 flerfb0rt1 i can log in but i cant access anything else. the deployment is fine though
20:22 mwhahaha might still be setting up
20:22 GMAzrael any luck on fuel plugin for zabbix 9.0?
20:23 flerfb0rt1 fuel-utils check_all shows the problem in naily
20:23 mwhahaha flerfb0rt1:any errors in /var/log/puppet/bootstrap_admin_node.log?
20:23 flerfb0rt1 no i was able to access my environents and set them up via the ui
20:24 mwhahaha i didn't even know fuel-utils check_all was a thing
20:24 mwhahaha does the fuel command work?
20:24 flerfb0rt1 yeah everything seems to work fine on the CLI
20:25 mwhahaha did you install any plugins?
20:25 flerfb0rt1 yeah a few
20:25 flerfb0rt1 hm
20:25 mwhahaha if the fuel-ui is just hung it might be a javascript error
20:25 mwhahaha there's a known issue where some plugins can break theui
20:25 mwhahaha or at least it was an issue
20:26 flerfb0rt1 ah and i did have mine raise warning as they were built w and earlier version of the fpb
20:29 gcmacmalloc joined #fuel
20:31 flerfb0rt1 aha! --removing all plugins plus a reboot fixed it
20:31 flerfb0rt1 thanks
21:07 johnavp1989 Hello. I just ran octane upgrade-node --isolated $SEE_ID 1 to upgrade the primary controller from 7.0 to 8.0
21:08 johnavp1989 The command complete successfully but puppet was still running after octane finished.
21:08 johnavp1989 Puppets hangs on 2016-07-27 21:03:39 +0000 Puppet (debug): Executing '/usr/bin/radosgw-admin user info --uid=ceilometer'
21:08 HeOS joined #fuel
21:09 johnavp1989 Then the nodes transitions to an error state in fuel after puppet times out. Is this an expected behavior?
21:11 johnavp1989 I wouldn't expect radosgw-admin to work since the node is not a member of a ceph cluster yet but I don't know if this could impact the rest of the upgrade
21:20 brig-man joined #fuel
21:31 brig-man Is there anyone actively online that can answer a fuel-8 question?
21:38 gcmacmalloc joined #fuel
21:39 mwhahaha depends on the question
21:41 brig-man I'm needing to add a few new compute nodes to an existing environment.  Will this kill my running vm instances?
21:41 mwhahaha so you need to expand your cloud and add new compute nodes with fuel?
21:41 brig-man Yes.
21:41 mwhahaha it should not affect the running vm instances
21:42 brig-man Would this operation be from the fuel command line or from the web interface?
21:42 mwhahaha could be either
21:42 mwhahaha it's up to you
21:54 brig-man thanks.
22:08 tobiash joined #fuel
22:35 Sesso joined #fuel
22:55 tobiash joined #fuel
23:00 johnavp1989 joined #fuel
23:20 jackdastripper For a openstack deployment meant for a public cloud connect directly to internet providers or sit behind firewalls?
23:40 eriswans joined #fuel
23:43 eriswans Can anyone point me in the direction of an answer to https://answers.launchpad.net/fuel/+question/297853 (pre-existing question: fuel 8->9 upgrade)

| Channels | #fuel index | Today | | Search | Google Search | Plain-Text | summary