Perl 6 - the future is here, just unevenly distributed

IRC log for #gluster-dev, 2014-02-04

| Channels | #gluster-dev index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:04 overclk joined #gluster-dev
00:27 lluis joined #gluster-dev
00:28 lluis Hello, Can someone briefly describe me the difference between "struct iovec" and "struct iobref" in the writev arguments?
00:43 nixpanic joined #gluster-dev
00:43 nixpanic joined #gluster-dev
01:04 ira joined #gluster-dev
03:07 bharata-rao joined #gluster-dev
03:23 shubhendu joined #gluster-dev
04:05 kanagaraj joined #gluster-dev
04:06 itisravi joined #gluster-dev
04:18 ndarshan joined #gluster-dev
04:19 kdhananjay joined #gluster-dev
04:58 bala joined #gluster-dev
05:12 spandit joined #gluster-dev
05:19 hagarth joined #gluster-dev
05:29 mohankumar joined #gluster-dev
05:36 lalatenduM joined #gluster-dev
05:43 ppai joined #gluster-dev
05:47 raghu joined #gluster-dev
05:52 mohankumar joined #gluster-dev
06:23 aravindavk joined #gluster-dev
06:30 mohankumar joined #gluster-dev
06:34 purpleid1a joined #gluster-dev
06:37 sac`away` joined #gluster-dev
06:46 ndarshan joined #gluster-dev
06:51 aravindavk joined #gluster-dev
07:02 bharata-rao joined #gluster-dev
07:27 mohankumar joined #gluster-dev
07:39 mohankumar joined #gluster-dev
07:46 mohankumar joined #gluster-dev
07:53 pk1 joined #gluster-dev
07:57 aravindavk joined #gluster-dev
08:20 pk1 joined #gluster-dev
08:21 badone_ joined #gluster-dev
08:43 pk1 joined #gluster-dev
09:10 pk1 joined #gluster-dev
09:39 bala joined #gluster-dev
09:43 surabhi joined #gluster-dev
09:49 badone joined #gluster-dev
10:05 pk1 left #gluster-dev
10:49 ira joined #gluster-dev
11:09 spandit joined #gluster-dev
11:31 pk1 joined #gluster-dev
11:40 bala joined #gluster-dev
11:48 shubhendu joined #gluster-dev
11:53 ndarshan joined #gluster-dev
11:56 spandit joined #gluster-dev
11:57 kkeithley1 joined #gluster-dev
12:24 itisravi joined #gluster-dev
12:26 pk1 left #gluster-dev
12:50 hagarth joined #gluster-dev
12:52 surabhi joined #gluster-dev
13:00 bala1 joined #gluster-dev
13:19 shubhendu joined #gluster-dev
13:22 mohankumar joined #gluster-dev
13:42 purpleidea joined #gluster-dev
14:12 itisravi joined #gluster-dev
14:31 bala joined #gluster-dev
15:06 jobewan joined #gluster-dev
15:21 lalatenduM joined #gluster-dev
15:24 wushudoin joined #gluster-dev
15:27 jobewan joined #gluster-dev
15:35 ndevos hmm, mount-options.t still fails on occasion?
15:41 kkeithley_ indeed
15:49 hagarth ndevos: yes, I have managed to reproduce the problem on a separate 6.5 instance.
15:50 hagarth trying to understand the failure better in mount.nfs
15:50 ndevos hagarth: can you mount with -v and capture a tcpdump with the error?
15:52 ndevos something like: tcpdump -i any -s 0 -w /tmp/it-broke.pcap udp or tcp & TPID=$! ; $run_tests ; kill $TPID ; gzip /tmp/it-broke.pcap
15:53 hagarth ndevos: I did capture a pcap earlier in the day but experienced nothing unusual
15:53 hagarth ndevos: let me try capturing again
15:55 hagarth ndevos: http://fpaste.org/74295/
15:57 ndevos hagarth: looks as if glusterfs/nfs is not registed at rpcbind yet
15:58 ndevos hagarth: when you hit that error, the output of 'rpcinfo' will likely not list any nfs services
15:59 hagarth ndevos: let me quickly check that.. we do a test for showmount -e to list the volume
16:00 hagarth before attempting mount.nfs
16:01 ndevos hagarth: 'showmount -e' does not use the nfs service, but teh mountd service, I do not think that is a valid check :)
16:02 hagarth ndevos: that is correct
16:02 ndevos oh, agreement \o/
16:04 hagarth dumping rpcinfo right after mount.t fails
16:05 ndevos rpcbind is not running?
16:05 hagarth ndevos: http://fpaste.org/74298/91529944/
16:06 ndevos okay, so that looks good
16:06 hagarth yeah
16:07 hagarth let me upload the pcap to the bug
16:11 ndevos what was the bug again?
16:11 * ndevos has it somewhere in an email, but well, things seem to get lost
16:11 hagarth ndevos: https://bugzilla.redhat.com/attachment.cgi?id=859227
16:14 ndevos hagarth: if you load that in wireshark, and use the filter 'portmap' you'll find the error in frame 8299
16:14 ndevos that is actually a call for nfs/udp
16:14 ndevos of course that is not available!
16:15 hagarth ndevos: right, it is for udp
16:15 hagarth and further a retry for tcp happens
16:15 matclayton joined #gluster-dev
16:16 ndevos actually, it is for mountd/udp
16:18 ndevos hagarth: are you mounting with 'mount -t nfs -o proto=tcp host:/vol /mnt'?
16:18 ndevos if so, you could try 'mount -t nfs -o proto=tcp,mountproto=tcp host:/vol /mnt'
16:19 hagarth ndevos: let me explicitly specify mountproto and try
16:19 ndevos hagarth: whats the version of nfs-utils that you have there?
16:21 hagarth ndevos: nfs-utils-1.2.3-39.el6.x86_64
16:21 hagarth nfs-utils-lib-1.1.5-6.el6.x86_64
16:24 hagarth same failure when both -o proto and mountproto are specified
16:24 ndevos hmm
16:30 ndevos hagarth: and when you use mountproto, does mount.nfs still try to use udp?
16:30 hagarth ndevos: I don't see the failure on the console, so I presume it is not using udp
16:31 hagarth trying with loglevel TRACE now
16:32 ndevos hagarth: and run 'rpcbind -d' too (it wont be a deamon then)
16:32 ndevos daemon even
16:32 hagarth ndevos: will do
16:36 bala joined #gluster-dev
16:40 mohankumar joined #gluster-dev
16:45 bala1 joined #gluster-dev
16:49 matclayton joined #gluster-dev
17:16 bala joined #gluster-dev
17:48 xavih joined #gluster-dev
19:19 lluis_ joined #gluster-dev
19:20 lluis_ I'm compiling gluster 3.4.2 with "configure --enable-debug=yes" and normal "make && make install", but when I load glusterfsd in gdb it still says "no debugging symbols found"
19:21 lluis_ how do I get to include the debug symbols in glusterfs?
19:35 lluis_ I think the problem is that "make install" strips the debugging symbols. Is there any official way to aviod that?
20:49 badone joined #gluster-dev
22:09 _Bryan_ joined #gluster-dev

| Channels | #gluster-dev index | Today | | Search | Google Search | Plain-Text | summary