Camelia, the Perl 6 bug

IRC log for #gluster, 2013-09-15

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:00 ProT-0-TypE joined #gluster
00:05 diegows_ joined #gluster
00:12 ctria joined #gluster
00:13 l4v joined #gluster
00:13 jporterfield joined #gluster
00:31 TDJACR joined #gluster
00:48 jporterfield joined #gluster
00:54 jporterfield joined #gluster
01:00 jporterfield joined #gluster
01:06 jporterfield joined #gluster
01:27 jporterfield joined #gluster
01:34 vpshastry joined #gluster
01:36 elyograg let's approach my question from a different angle.  What would I need to have in /etc/vfstab to get a gluster NFS mount on a Solaris machine? it must work on reboot without first making an NFS mount from a Linux machine, which is what we have to do now.
01:37 elyograg gluster gets accessed primarily via NFS.  We do have some testing underway with a fuse mount re-exported via samba.
01:37 elyograg aside from the machine running samba, there are no fuse clients at this point.
02:05 jporterfield joined #gluster
02:25 jporterfield joined #gluster
02:29 vpshastry joined #gluster
02:32 jporterfield joined #gluster
02:33 asias joined #gluster
02:34 sac`away joined #gluster
02:35 sac joined #gluster
02:35 hchiramm_ joined #gluster
02:40 asias joined #gluster
02:46 jporterfield joined #gluster
02:51 purpleidea joined #gluster
02:52 \_pol joined #gluster
02:56 hagarth joined #gluster
03:05 jporterfield joined #gluster
03:11 jporterfield joined #gluster
03:20 vpshastry joined #gluster
03:31 jporterfield joined #gluster
03:55 asias joined #gluster
03:56 \_pol joined #gluster
04:22 jporterfield joined #gluster
04:28 jporterfield joined #gluster
04:36 jporterfield joined #gluster
04:40 hagarth joined #gluster
04:53 jporterfield joined #gluster
04:59 jporterfield joined #gluster
05:05 jporterfield joined #gluster
05:10 glusterbot New news from resolvedglusterbugs: [Bug 764966] gerrit integration fixes <http://goo.gl/AZDsh>
05:23 edong23 joined #gluster
05:38 jporterfield joined #gluster
05:42 ProT-0-TypE joined #gluster
05:49 jporterfield joined #gluster
05:58 mohankumar joined #gluster
06:02 jporterfield joined #gluster
06:11 ProT-0-TypE joined #gluster
06:21 jporterfield joined #gluster
06:31 jporterfield joined #gluster
06:50 jporterfield joined #gluster
06:57 jporterfield joined #gluster
07:04 d-fence joined #gluster
07:41 Nemo_bis joined #gluster
07:54 haritsu joined #gluster
08:02 davinder joined #gluster
08:03 \_pol joined #gluster
08:04 Nemo_bis Hello. Ideas? https://bugzilla.wikimedia​.org/show_bug.cgi?id=54143
08:04 glusterbot <http://goo.gl/PX6AqB> (at bugzilla.wikimedia.org)
08:04 glusterbot Bug 54143: medium, medium, ---, laroche, CLOSED DUPLICATE, external TCP disbled by default in sendmail-8.11.6-1.6.x
08:06 * Nemo_bis eyerolls at glusterbot
08:09 bala joined #gluster
08:18 jporterfield joined #gluster
08:26 dkorzhevin joined #gluster
08:26 jporterfield joined #gluster
08:32 StarBeast joined #gluster
08:37 jporterfield joined #gluster
08:53 ProT-0-TypE joined #gluster
09:04 ProT-0-TypE joined #gluster
09:16 jporterfield joined #gluster
09:22 jporterfield joined #gluster
09:28 jporterfield joined #gluster
09:34 jporterfield joined #gluster
09:40 jporterfield joined #gluster
09:40 PaulC2 joined #gluster
09:48 ProT-0-TypE joined #gluster
09:48 PaulC2 joined #gluster
09:52 mooperd_ joined #gluster
09:55 mooperd_ left #gluster
10:02 jporterfield joined #gluster
10:08 jporterfield joined #gluster
10:16 jporterfield joined #gluster
10:17 stickyboy When I upgrade from 3.3.x to 3.4, will my brick ports enumerate from 49152 upon restarting?
10:17 stickyboy (ie, not sure if new port enumeration base is only for new installs)
10:38 jporterfield joined #gluster
10:45 jporterfield joined #gluster
10:51 jporterfield joined #gluster
10:53 davinder joined #gluster
11:04 jporterfield joined #gluster
11:05 mohankumar joined #gluster
11:18 sysconfig joined #gluster
11:24 jporterfield joined #gluster
11:39 jporterfield joined #gluster
11:45 jporterfield joined #gluster
11:51 jporterfield joined #gluster
11:57 jporterfield joined #gluster
12:10 stickyboy Yay, I just updated my cluster to 3.4.0 (from 3.3.1).
12:10 stickyboy Little bit of ansible to help stuff along.
12:11 stickyboy No hiccups, everything working 100%.
12:14 shubhendu joined #gluster
12:14 social there are several issues on 3.4.0 you might hit, checkout memory consumption and no. of open files to be sure youre not hitting any of them
12:16 stickyboy social: Aight, I'll keep an eye on them.
12:17 stickyboy I had a window of opportunity when my users weren't using the servers, so had to seize it. :P
12:36 jporterfield joined #gluster
13:01 jporterfield joined #gluster
13:12 jporterfield joined #gluster
13:19 hagarth social: what memory problems have you noticed? is it on the client or the server?
13:20 jporterfield joined #gluster
13:26 jporterfield joined #gluster
13:37 jporterfield joined #gluster
13:51 diegows_ joined #gluster
13:59 mohankumar joined #gluster
14:05 jporterfield joined #gluster
14:13 jporterfield joined #gluster
14:24 realdannys joined #gluster
14:25 realdannys Guys, I'm getting this error when I run yum update, could someone help
14:25 jporterfield joined #gluster
14:25 realdannys http://download.gluster.org/pub/glus​ter/glusterfs/repos/YUM/glusterfs-3.​3/epel-6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
14:25 glusterbot <http://goo.gl/SGQxRc> (at download.gluster.org)
14:35 realdannys anyone?
14:45 jporterfield joined #gluster
14:49 social hagarth: fuse client
14:51 jporterfield joined #gluster
15:00 hagarth joined #gluster
15:00 hagarth social: do you have more details or a reproducible test case for this leak?
15:01 hagarth realdannys: http://download.gluster.org/pub/gluster/g​lusterfs/repos/YUM/glusterfs-3.3/LATEST/C​entOS/epel-6/x86_64/repodata/repomd.xml
15:01 glusterbot <http://goo.gl/i7jlW1> (at download.gluster.org)
15:02 realdannys how do I update my yum repo with this URL?
15:09 jporterfield joined #gluster
15:19 jporterfield joined #gluster
15:22 \_pol joined #gluster
15:34 hflai joined #gluster
15:36 edward1 joined #gluster
15:54 jporterfield joined #gluster
16:23 jporterfield joined #gluster
16:31 B21956 joined #gluster
16:32 B21956 left #gluster
16:47 jporterfield joined #gluster
17:08 realdannys Hello??
17:08 glusterbot realdannys: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an answer.
17:09 realdannys Can anyone please tell me how to fix this...
17:09 realdannys Loading mirror speeds from cached hostfile
17:10 realdannys * base: mirrors.advancedhosters.com
17:10 realdannys * epel: mirror.cogentco.com
17:10 realdannys * extras: mirror.symnds.com
17:10 realdannys * rpmforge: mirror.us.leaseweb.net
17:10 realdannys * updates: mirrors.advancedhosters.com
17:10 realdannys * webtatic: us-east.repo.webtatic.com
17:10 realdannys http://download.gluster.org/pub/glus​ter/glusterfs/repos/YUM/glusterfs-3.​3/epel-6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
17:10 glusterbot <http://goo.gl/SGQxRc> (at download.gluster.org)
17:10 realdannys Trying other mirror.
17:10 realdannys http://download.gluster.org/pub/glus​ter/glusterfs/repos/YUM/glusterfs-3.​3/epel-6/noarch/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
17:10 glusterbot <http://goo.gl/tjqiwi> (at download.gluster.org)
17:10 realdannys Trying other mirror.
17:10 realdannys Setting up Update Process
17:10 realdannys No Packages marked for Update
17:12 XpineX realdannys: it seems your link to the repository is incorrect
17:12 realdannys Ok so I've deleted the rpm now via SFTP
17:12 realdannys what is the correct rpm for centos6 and how do I add it?
17:13 realdannys that link used to work as its what I installed with, you must have changed something
17:13 XpineX Good question, I'm looking through the site to find something (btw, I am just a user of gluster as your self)
17:15 XpineX Not sure where to get an RPM that will install the correct repo for you, but you could try creating the repo file manually
17:15 XpineX The path for the repo you are looking for is changed, now its: http://download.gluster.org/pub/glu​ster/glusterfs/repos/YUM/glusterfs-​3.3/LATEST/EPEL.repo/epel-6/noarch/
17:15 glusterbot <http://goo.gl/D97A9o> (at download.gluster.org)
17:15 XpineX I think
17:19 XpineX http://www.gluster.org/community/d​ocumentation/index.php/QuickStart
17:19 glusterbot <http://goo.gl/OEzZn> (at www.gluster.org)
17:19 XpineX Have a look at step 4, it might help you
17:21 XpineX I think you want - wget -P /etc/yum.repos.d http://download.gluster.org/pub/gluster/glust​erfs/3.3/LATEST/EPEL.repo/glusterfs-epel.repo
17:21 glusterbot <http://goo.gl/BZfLsL> (at download.gluster.org)
17:22 realdannys hmm, I think I need to install it though
17:23 XpineX install what ?
17:23 realdannys the repo
17:23 realdannys I dunno I've done that
17:23 realdannys but its not in my yumupdates list now
17:24 XpineX If you mean install the repo through an RPM, it's not necessary. The only thing it does is the same as the above wget line
17:24 realdannys hmm ok
17:24 realdannys not sure why its not checking it in my yum update list then
17:24 XpineX check the contents of /etc/yum.repos.d
17:25 XpineX you should have a file called glusterfs-epel.repo
17:26 realdannys yeah it is there, and actually it is in my repolist so all is good
17:26 realdannys thanks man :)
17:26 XpineX You are welcome :)
17:26 XpineX Any particular reason you are not using 3.4 ?
17:28 realdannys none, other than the upgrade process seems to be a bit of a ball ache and 3.3 does what we want perfectly
17:28 XpineX Oki, thanks
17:28 realdannys we're probably only using 1% of what gluster does in the most simple way ever
17:29 realdannys how weird
17:30 realdannys I just added that repo to my other server and it updated gluster to 3.3.2
17:30 realdannys but on my main server its not doing anything to a 3.3.1 install
17:30 XpineX weird
17:31 XpineX have a look at the file /etc/yum.repos.d/glusterfs-epel.repo to ensure that they are the same
17:32 realdannys yup, the same one on both
17:32 realdannys "Setting up Install Process
17:32 realdannys Package matching glusterfs-3.3.1-1.el6.x86_64 already installed. Checking for update.
17:32 realdannys Nothing to do"
17:33 realdannys where as on the other server (which is the actual server)
17:33 realdannys Setting up Install Process
17:33 realdannys Package glusterfs-3.3.2-2.el6.x86_64 already installed and latest version
17:33 realdannys Nothing to do
17:33 realdannys the one with 3.3.1 on is a client
17:34 XpineX maybe it will not upgrade from 3.3.1 to 3.3.2 ?
17:36 realdannys maybe not
17:36 realdannys I appear to have broken my gluster mount now too
17:36 realdannys sigh
17:36 realdannys should have just left the yum update errrors!
17:37 XpineX there might be an incompatibility between 3.3.1 and 3.3.2 and that is the reason both for not updating and for mount not working ?
17:39 realdannys maybe
17:40 realdannys can I go back to 3.3.1 on both then :p
17:40 realdannys to be fair I've had nothing but problems with Gluster, once its working I should never touch it, its a nightmare
17:41 XpineX without beeing sure, I believe that you can force and "upgrade" to 3.3.1 if you use rpm directly instead of yum
17:41 XpineX rpm -Uvh --force <packagefile>
17:44 XpineX I have just recently started using glusterfs, it's on Debian (Proxmox) and so far it works great except it uses a lot of CPU when a node(brick) goes down
17:44 realdannys yep its buggered up again
17:44 realdannys grrr
17:44 realdannys where do I get the rpm link from?
17:44 realdannys I'll try and force the server to go back
17:44 realdannys I don't know if thats whats broken things but it might have done
17:45 XpineX http://download.gluster.org/pub/gluster​/glusterfs/3.3/3.3.1/EPEL.repo/epel-6/
17:45 glusterbot <http://goo.gl/2rK7a> (at download.gluster.org)
17:47 realdannys cheers - worth a shot I guess
17:48 XpineX Best of luck
17:49 Remco Does the gluster nfs server support exclusive locking?
17:49 Remco I'm having the problem described at http://supercolony.gluster.org/piperma​il/gluster-users/2013-July/036626.html
17:49 glusterbot <http://goo.gl/Ixp9NM> (at supercolony.gluster.org)
17:52 realdannys hmmm
17:52 realdannys rpm: only installation, upgrading, rmsource and rmspec may be forced
17:52 XpineX try with rpm -ivh --force <packegefile>
17:54 XpineX Remco: does this answer your question? http://www.gluster.org/pipermail/g​luster-users/2012-July/033849.html
17:54 glusterbot <http://goo.gl/6DFYUX> (at www.gluster.org)
17:56 realdannys ok I managed to downgrade with yum
17:56 realdannys but its went to 3.2.7 lol
17:56 realdannys when I do yum upgrade it wants to go back to 3.3.2
17:56 realdannys anyway to force 3.3.1 with yum?
17:57 XpineX You need to change the repo file in /etc/yum.repos.d
17:57 realdannys i did just try to use this
17:57 realdannys http://download.gluster.org/pub/gluster/glust​erfs/3.3/3.3.1/EPEL.repo/glusterfs-epel.repo
17:57 glusterbot <http://goo.gl/RWX6S5> (at download.gluster.org)
17:57 Remco XpineX: Not really. It's about mounting an nfs share on a server that also has gluster running
17:57 XpineX realdannys: that should do, are you sure you don't have other repos for gluster installed ?
17:58 Remco XpineX: My gluster server doesn't do anything but run gluster, and another server mounts it over nfs since the glusterfs fuse thing is horribly slow
17:58 realdannys positive, no other repos installed, if I remove that, it doesn't find anything, if I had that repo back its trying to install 3.3.2!!
17:59 realdannys maybe its this?
17:59 realdannys Not using downloaded repomd.xml because it is older than what we have:
17:59 XpineX Remco: sorry, then I have nothing
17:59 Remco XpineX: Good try, thanks anyway :)
17:59 XpineX realdannys, very likely
17:59 realdannys not sure where that file is located to delete though
18:00 XpineX realdannys: try running - yum clean
18:01 realdannys boom
18:01 realdannys nice one
18:01 realdannys right - i'll try rebooting that server once 3.3.1 is installed and see what happens, fingers crossed :S
18:08 XpineX Remco: another try - http://www.gluster.org/wp-content/up​loads/2012/05/Gluster_File_System-3.​3.0-Administration_Guide-en-US.pdf - pt. 6.2 ?
18:08 glusterbot <http://goo.gl/bzF5B> (at www.gluster.org)
18:10 realdannys phew its fixed again
18:10 realdannys thanks XpineX you helped me get out of that pickle
18:10 realdannys I'll just reboot main server a few times to make sure, but should be fine
18:11 XpineX np :)
18:13 jporterfield joined #gluster
18:16 XpineX Remco: I think this migh answer your question: http://irclog.perlgeek.de/gluster/2012-12-06  - search for lock
18:16 glusterbot Title: IRC log for #gluster, 2012-12-06 (at irclog.perlgeek.de)
18:21 Remco XpineX: That says there is exclusive locking if you connect to the same NFS server, but no distrubuted locks
18:21 Nemo_bis left #gluster
18:21 Remco The link I gave says that doesn't work though
18:22 Remco (I'm also on 3.2.7, but seeing the same thing happen)
18:24 jporterfield joined #gluster
18:25 ricky-ticky joined #gluster
18:37 zapotah joined #gluster
18:38 jporterfield joined #gluster
18:45 jporterfield joined #gluster
18:50 zapotah joined #gluster
18:50 zapotah joined #gluster
19:09 jporterfield joined #gluster
19:23 jporterfield joined #gluster
19:38 jporterfield joined #gluster
19:46 RedShift joined #gluster
19:48 jporterfield joined #gluster
19:56 jporterfield joined #gluster
20:02 jporterfield joined #gluster
20:08 jporterfield joined #gluster
20:43 jporterfield joined #gluster
21:07 jporterfield joined #gluster
21:19 abelur joined #gluster
21:22 jporterfield joined #gluster
21:50 jporterfield joined #gluster
21:56 jporterfield joined #gluster
22:11 jporterfield joined #gluster
22:20 fidevo joined #gluster
22:25 jporterfield joined #gluster
22:33 jporterfield joined #gluster
22:45 jporterfield joined #gluster
22:53 jporterfield joined #gluster
23:02 jporterfield joined #gluster
23:05 edong23 joined #gluster
23:45 jporterfield joined #gluster

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary