Perl 6 - the future is here, just unevenly distributed

IRC log for #gluster, 2014-12-15

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:01 Pupeno joined #gluster
00:02 doubt joined #gluster
00:05 Pupeno joined #gluster
00:05 Pupeno joined #gluster
00:24 foster joined #gluster
00:27 bennyturns joined #gluster
00:31 fandi joined #gluster
00:40 M28 once I add more bricks to an already running glusterfs, do I have to do anything else?
00:45 gildub_ joined #gluster
00:47 M28 also, can I just use private ips instead of hostnames for the "gluster peer probe"?
00:50 calisto joined #gluster
01:01 theron joined #gluster
01:50 haomaiwa_ joined #gluster
01:53 T3 joined #gluster
01:57 rjoseph joined #gluster
02:02 theron joined #gluster
02:06 bala joined #gluster
02:20 prasanth_ joined #gluster
02:22 fandi joined #gluster
02:25 nishanth joined #gluster
03:04 sac_ joined #gluster
03:09 fleducquede joined #gluster
03:37 theron joined #gluster
03:39 soumya joined #gluster
03:39 RameshN joined #gluster
03:42 hagarth joined #gluster
03:43 kdhananjay joined #gluster
03:44 kshlm joined #gluster
03:52 kanagaraj joined #gluster
04:01 sachin joined #gluster
04:01 spandit joined #gluster
04:03 shylesh__ joined #gluster
04:05 RameshN joined #gluster
04:11 itisravi joined #gluster
04:12 shubhendu joined #gluster
04:13 T3 joined #gluster
04:15 Ramereth joined #gluster
04:35 Ramereth joined #gluster
04:35 an joined #gluster
04:35 Ramereth joined #gluster
04:36 Ramereth joined #gluster
04:37 hagarth joined #gluster
04:42 nishanth joined #gluster
05:00 systemonkey2 joined #gluster
05:02 bala joined #gluster
05:12 sahina joined #gluster
05:18 tessier_ joined #gluster
05:28 nbalacha joined #gluster
05:29 aravindavk joined #gluster
05:30 ndarshan joined #gluster
05:35 lalatenduM joined #gluster
05:37 deepakcs joined #gluster
05:38 saurabh joined #gluster
05:42 karnan joined #gluster
05:45 R0ok_ joined #gluster
05:47 ramteid joined #gluster
05:47 theron joined #gluster
05:48 soumya joined #gluster
05:50 sahina joined #gluster
05:50 shubhendu joined #gluster
05:52 ndarshan joined #gluster
05:57 glusterbot News from newglusterbugs: [Bug 1174087] logging improvements in marker translator <https://bugzilla.redhat.com/show_bug.cgi?id=1174087>
05:58 overclk joined #gluster
05:58 zerick joined #gluster
05:58 rjoseph joined #gluster
06:03 harish_ joined #gluster
06:07 R0ok_ joined #gluster
06:08 nshaikh joined #gluster
06:14 hchiramm joined #gluster
06:15 ricky-ti1 joined #gluster
06:18 SOLDIERz joined #gluster
06:26 M28_ joined #gluster
06:31 anil_ joined #gluster
06:45 aravindavk joined #gluster
06:48 Pupeno joined #gluster
06:48 theron joined #gluster
06:50 sahina joined #gluster
06:51 ndarshan joined #gluster
06:52 rafi joined #gluster
06:54 anil_ joined #gluster
07:07 shubhendu joined #gluster
07:13 ctria joined #gluster
07:24 rgustafs joined #gluster
07:26 TvL2386 joined #gluster
07:27 jtux joined #gluster
07:27 pcaruana joined #gluster
07:28 an joined #gluster
07:34 deepakcs joined #gluster
07:37 an joined #gluster
07:40 kdhananjay joined #gluster
07:41 an joined #gluster
07:45 an joined #gluster
07:48 [Enrico] joined #gluster
07:49 aravindavk joined #gluster
07:54 an_ joined #gluster
08:00 Philambdo joined #gluster
08:18 Humble joined #gluster
08:18 deniszh joined #gluster
08:20 SOLDIERz joined #gluster
08:23 maveric_amitc_ joined #gluster
08:23 bala joined #gluster
08:27 side_control joined #gluster
08:28 glusterbot News from resolvedglusterbugs: [Bug 1021998] nfs mount via symbolic link does not work <https://bugzilla.redhat.com/show_bug.cgi?id=1021998>
08:28 glusterbot News from resolvedglusterbugs: [Bug 1077406] Striped volume does not work with VMware esxi v4.1, 5.1 or 5.5 <https://bugzilla.redhat.com/show_bug.cgi?id=1077406>
08:33 doekia joined #gluster
08:37 theron joined #gluster
08:37 fsimonce joined #gluster
08:43 an joined #gluster
08:44 ghenry joined #gluster
08:45 ghenry joined #gluster
08:46 karnan joined #gluster
08:47 dusmant joined #gluster
08:48 hagarth joined #gluster
08:49 ricky-ticky1 joined #gluster
08:52 liquidat joined #gluster
08:59 rolfb joined #gluster
09:02 rolfb_ joined #gluster
09:03 marbu joined #gluster
09:04 marbu joined #gluster
09:06 spandit joined #gluster
09:08 an joined #gluster
09:09 gothos Morning, I'm still getting weird error messages in my brick logs (only got two bricks). Part of the logs: http://fpaste.org/159778/18634573/
09:10 gothos the log has around 56GB accumulated since friday
09:10 ricky-ticky joined #gluster
09:11 gothos I'm currently kinda afraid to restart the gluster processes, tho it appears that the bricks are still being synced
09:14 gothos I also get the following log entries in my glustershd.log, but I don't know if it's related
09:14 gothos probably not, since the frequency of the output is totally different
09:14 gothos http://fpaste.org/159779/86348461/
09:17 Dw_Sn joined #gluster
09:17 Pupeno joined #gluster
09:21 Slashman joined #gluster
09:23 6A4AARK85 joined #gluster
09:24 rgustafs joined #gluster
09:24 rolfb_ joined #gluster
09:25 lalatenduM_ joined #gluster
09:27 rolfb joined #gluster
09:28 glusterbot News from newglusterbugs: [Bug 1174144] Wrong RPM dependencies for older Fedoras for glusterfs-libs <https://bugzilla.redhat.com/show_bug.cgi?id=1174144>
09:29 harish joined #gluster
09:30 aravindavk joined #gluster
09:31 bjornar joined #gluster
09:33 harish joined #gluster
09:38 theron joined #gluster
09:39 ndevos gothos: do you have quota enabled? if so, you might be hitting bug 1118591
09:39 glusterbot Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1118591 urgent, urgent, ---, nsathyan, MODIFIED , core: all brick processes crash when quota is enabled
09:40 ndevos gothos: should have been fixed in 3.6.0 and 3.5.2... what version are you on?
09:40 shubhendu joined #gluster
09:40 gothos ndevos: we are running 3.6.1
09:41 gothos and yes, quota is enabled
09:41 ndevos okay, well, that should have the change, I think
09:42 ndevos bug 1145623 was for 3.6, and its closed :-/
09:42 glusterbot Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1145623 high, high, ---, bugs, CLOSED CURRENTRELEASE, core: all brick processes crash when quota is enabled
09:42 sahina joined #gluster
09:43 karnan joined #gluster
09:44 gothos ndevos: so if this is related to quota disabling that would stop the error messages?
09:44 gothos that might at least narrow it down
09:44 ndevos gothos: I think so
09:45 ndevos gothos: are you in a position to try out a quick patch?
09:46 gothos ndevos: maybe, I'll have to ask by boss when he's back :/
09:47 gothos I'll try to disable the quota for now and see what happens
09:47 ndarshan joined #gluster
09:47 johndescs_ joined #gluster
09:51 ndevos gothos: you should also file a bug for this
09:51 glusterbot https://bugzilla.redhat.com/enter_bug.cgi?product=GlusterFS
09:52 ndevos gothos: and, when you do, please download+attach this patch http://paste.fedoraproject.org/159788/37095141/raw/ to your bug
09:52 ndevos gothos: I think that should prevent the issue, but I am not very familiar with the marker xlator, so it may not be correct
09:54 gothos ndevos: disabling quota at least stopped the messages :)
09:54 ndevos gothos: ah, good, thats a start :)
09:55 ndevos I think the change for that bug introduced the new error message, possibly the error was there all the time, just nobody noticed it?
09:56 hagarth ndevos: looks like that
09:57 gothos I would hate to apply that to both my gluster server right?
09:57 gothos *have
09:59 ndevos yes, the marker xlatos is part of the xlator stack on the bricks
09:59 ndevos s/xlatos/xlator/
09:59 glusterbot What ndevos meant to say was: An error has occurred and has been logged. Please contact this bot's administrator for more information.
10:00 ndevos JoeJulian: why does glusterbot always do that to me when I use s/.../.../?
10:00 verdurin joined #gluster
10:00 verdurin joined #gluster
10:01 dusmant joined #gluster
10:03 gothos ndevos: okay, boss is not too happy but we'll see
10:04 gothos I tried to reenable quota to check reproducibility and I'm just getting a lot of other messages now
10:05 gothos well, the old ones are back as well it appears
10:05 gothos the new one is: E [marker.c:2542:marker_removexattr_cbk] 0-data-marker: No data available occurred while creating symlinks
10:07 ndevos gothos: well, the patch would prevent the logging, but it does not address the underlying cause, someone that understands the marker xlator should check that out
10:09 ndevos and I have no idea why you would get an error in marker_removexattr_cbk(), but well, see my previous message :)
10:10 gothos ndevos: okay, I'll finish the bug report in a bit and attach your patch with that comment
10:12 SOLDIERz_ joined #gluster
10:16 haomaiwa_ joined #gluster
10:19 gothos done, hope someone has an idea :) 1174170
10:21 ricky-ticky joined #gluster
10:28 glusterbot News from newglusterbugs: [Bug 1174170] Glusterfs outputs a lot of warnings and errors when quota is enabled <https://bugzilla.redhat.com/show_bug.cgi?id=1174170>
10:29 bala joined #gluster
10:33 ndevos gothos: I've added some more details, and put Raghavendra on CC - he's the maintainer of the marker xlator :)
10:34 gothos ndevos: okay, thank you
10:37 gothos ndevos++
10:37 glusterbot gothos: ndevos's karma is now 6
10:38 ndevos ah, yes, and gothos++ thanks for the bug :)
10:38 glusterbot ndevos: gothos's karma is now 1
10:43 hagarth @karma
10:43 glusterbot hagarth: Highest karma: "jjulian" (4000001), "semiosis" (2000006), and "kkeithley" (21).  Lowest karma: "-" (-341), "(" (-54), and "-rw-r--r" (-15).  You (hagarth) are ranked 9 out of 89.
10:44 hagarth hmm, looks like karma values have been reset
10:44 ndevos hagarth: not sure, but I think glusterbot tracks score per channel
10:46 hagarth ndevos: ah ok
10:46 ricky-ticky joined #gluster
10:52 DV joined #gluster
10:56 mator ndevos, do you possibly knows, is there a tool to check bricks (.glusterfs subdir) for consistency after fsck? I mean if fsck "fixed" some files on block device, could I just discard/remove ".glusterfs" subdir on brick and bring it back to volume ? thanks
11:01 ndevos mator: sorry, I do not know if such a tool exists... I think it would be nice to have a tool that checks .glusterfs/ for consistency though
11:01 * ndevos thinks there was an email about that, something like fsck for gluster
11:02 ndarshan joined #gluster
11:03 dusmant joined #gluster
11:03 karnan joined #gluster
11:03 deepakcs joined #gluster
11:04 ndevos mator: aha, http://www.gluster.org/community/documentation/index.php/Projects lists one, and xavih seems to be 'working on it'
11:04 ctria joined #gluster
11:06 shubhendu joined #gluster
11:13 kkeithley joined #gluster
11:13 sahina joined #gluster
11:17 Pupeno_ joined #gluster
11:24 Norky joined #gluster
11:26 elico joined #gluster
11:26 theron joined #gluster
11:32 lalatenduM joined #gluster
11:34 LebedevRI joined #gluster
11:53 T3 joined #gluster
11:55 calisto joined #gluster
11:59 glusterbot News from newglusterbugs: [Bug 1174205] use different names for getting volfiles <https://bugzilla.redhat.com/show_bug.cgi?id=1174205>
12:04 shubhendu joined #gluster
12:07 pdrakewe_ joined #gluster
12:07 diegows joined #gluster
12:08 T3 joined #gluster
12:10 mikedep333 joined #gluster
12:13 bala joined #gluster
12:21 saurabh joined #gluster
12:23 ramteid joined #gluster
12:25 pkoro joined #gluster
12:27 Dw_Sn joined #gluster
12:36 diegows joined #gluster
12:37 itisravi_ joined #gluster
12:37 mikedep333 joined #gluster
12:38 itisravi__ joined #gluster
12:39 ira joined #gluster
12:40 dusmant joined #gluster
12:42 bala joined #gluster
12:42 theron joined #gluster
12:48 harish_ joined #gluster
12:58 hagarth joined #gluster
12:59 B21956 joined #gluster
13:00 JustinClift joined #gluster
13:05 Slashman joined #gluster
13:09 jonny30 joined #gluster
13:09 jonny30 hello!
13:09 glusterbot jonny30: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an answer.
13:09 jonny30 i already have two servers with replicated bricks
13:10 jonny30 how can i add one more replicated using an AMI of one of them?
13:11 jonny30 the result should be 3 mirror content
13:12 jonny30 how could i begin?
13:13 lpabon joined #gluster
13:14 deepakcs joined #gluster
13:15 rjoseph joined #gluster
13:26 jonny30 some from support there?
13:26 T3 jonny30, what is AMI?
13:27 jonny30 Amazon machine image, a copy of a entire virtual machine
13:29 T3 I don't know how things would go if you go for it
13:29 harish_ joined #gluster
13:29 T3 but if you don't, you should just add more peers to the cluster
13:29 T3 let me find some doc..
13:29 jonny30 ok, thanks!!
13:30 T3 from one of your 2 working servers, do something like:
13:31 T3 # gluster peer probe newserver.mydomain.com
13:31 jonny30 i already have 2 servers with replicated volume working
13:31 T3 after you have set up glusterfs on newsserver.mydomain.com, of course
13:31 jonny30 i want add one more replicated
13:31 jonny30 will be third
13:32 T3 yes, I understand that
13:33 hagarth jonny30: for general glusterfs usage in AWS, this might be useful - http://www.gluster.org/community/documentation/index.php/Getting_started_setup_aws
13:33 jonny30 then in new third server i have to exec: gluster peer probe  thirdserver.mydomain.com
13:35 jonny30 ah ok, i have to execute command: gluster peer probe  thirdserver.mydomain.com in other servers, where gluster already is working
13:35 jonny30 thank you very much T3 and hagarth
13:37 mikedep333 joined #gluster
13:40 tvb joined #gluster
13:42 jonny30 i have to stop volume already created before to connect to third server replicated volume
13:42 jonny30 ?
13:42 edward1 joined #gluster
13:44 tvb guys can anyone assist me. I am having issues with 2 bricks which are out of sync
13:47 rjoseph joined #gluster
13:49 harish_ joined #gluster
13:49 mikedep333 joined #gluster
13:52 bennyturns joined #gluster
13:53 bene joined #gluster
13:55 shubhendu joined #gluster
13:58 rgustafs joined #gluster
13:59 dgandhi joined #gluster
13:59 glusterbot News from newglusterbugs: [Bug 1174247] Glusterfs outputs a lot of warnings and errors when quota is enabled <https://bugzilla.redhat.com/show_bug.cgi?id=1174247>
13:59 glusterbot News from newglusterbugs: [Bug 1174250] Glusterfs outputs a lot of warnings and errors when quota is enabled <https://bugzilla.redhat.com/show_bug.cgi?id=1174250>
13:59 dgandhi joined #gluster
14:01 dgandhi joined #gluster
14:02 dgandhi joined #gluster
14:03 dblack joined #gluster
14:03 dgandhi joined #gluster
14:04 dgandhi joined #gluster
14:05 dgandhi joined #gluster
14:05 dgandhi joined #gluster
14:06 dgandhi joined #gluster
14:07 dgandhi joined #gluster
14:07 edwardm61 joined #gluster
14:09 dgandhi joined #gluster
14:10 dgandhi joined #gluster
14:10 fandi joined #gluster
14:10 tvb /usr/sbin/glusterd: option requires an argument -- 'f' what am I missing here?
14:11 theron joined #gluster
14:12 dgandhi joined #gluster
14:13 dgandhi joined #gluster
14:14 dgandhi joined #gluster
14:15 kshlm joined #gluster
14:17 dgandhi joined #gluster
14:18 dgandhi joined #gluster
14:19 julim joined #gluster
14:19 dgandhi joined #gluster
14:20 dgandhi joined #gluster
14:21 squizzi joined #gluster
14:22 dgandhi joined #gluster
14:22 tvb hmm reboot restored that
14:22 tvb now what does this mean "[2014-12-15 15:22:28.330195] W [client3_1-fops.c:1059:client3_1_getxattr_cbk] 0-STATIC-DATA-client-1: remote operation failed: No such file or directory. Path: <gfid:c475b81f-1fc0-4cd7-a0c1-18cc59d95a9b> (00000000-0000-0000-0000-000000000000). Key: glusterfs.gfid2path"
14:22 wmp joined #gluster
14:24 tvb anyone?
14:24 dgandhi joined #gluster
14:24 wmp hello, i have problem with mount glusterfs, mount hangs on mount -t glusterfs gluster1:/datapoint /mnt/gluster/
14:25 virusuy joined #gluster
14:25 virusuy joined #gluster
14:25 dgandhi joined #gluster
14:26 dgandhi joined #gluster
14:28 dgandhi joined #gluster
14:28 dgandhi joined #gluster
14:29 dgandhi joined #gluster
14:29 dgandhi joined #gluster
14:30 JonathanD joined #gluster
14:30 dgandhi joined #gluster
14:32 dgandhi joined #gluster
14:34 dgandhi joined #gluster
14:35 dgandhi joined #gluster
14:37 dgandhi joined #gluster
14:39 dgandhi joined #gluster
14:39 dgandhi joined #gluster
14:41 dgandhi joined #gluster
14:42 ninkotech joined #gluster
14:42 ninkotech_ joined #gluster
14:43 dgandhi joined #gluster
14:43 coredump joined #gluster
14:44 dgandhi joined #gluster
14:45 dgandhi joined #gluster
14:47 dgandhi joined #gluster
14:48 dgandhi joined #gluster
14:49 mator wmp, what in logs ?
14:49 wmp mator: in which file?
14:50 dgandhi joined #gluster
14:50 harish_ joined #gluster
14:51 dgandhi joined #gluster
14:52 dgandhi joined #gluster
14:52 mator wmp, /var/log/glusterfs/*
14:53 wmp mator: http://wklej.org/id/1558786
14:53 dgandhi joined #gluster
14:54 harish joined #gluster
14:54 mator wmp, lets start with   etc-glusterfs-glusterd.vol.log
14:54 mator last 100 lines of it
14:54 dgandhi joined #gluster
14:55 wmp mator: i cant beocuse i trying to remove gluster and create new
14:55 wmp and now i have error: C [glusterfsd.c:1445:parse_cmdline] 0-glusterfs: ERROR: parsing the volfile failed (No such file or directory)
14:55 wmp i want remove all and try again
14:55 mator wmp, is there any vol files in /var/lib/glusterd/vols/ ?
14:55 wmp yes
14:56 dgandhi joined #gluster
14:56 mator if you're going to scratch start, stop gluster services/processes, remove /var/lib/glusterd and start again
14:56 mator (remove means, make backup and rename)
14:56 wmp i remove /var/lib/gluster but glusterd has this same error
14:57 dgandhi joined #gluster
14:57 zerick joined #gluster
14:58 owlbot` joined #gluster
14:58 tdasilva joined #gluster
14:58 mator wmp, increase log level of glusterd and fpaste a few dozens of lines from /var/log/glusterfs/etc-glusterfs-glusterd.vol.log
14:59 dgandhi joined #gluster
14:59 wmp mator: nothing new
14:59 dizquierdo joined #gluster
15:00 wmp mator: maybe packages have bugs? I have packages from ppa to ubuntu 14.04
15:00 mator wmp I have rpm packages from fedora 21, it doesn't tell what glusterfs version you are using =)
15:01 mator wmp, all software has bugs
15:01 dgandhi joined #gluster
15:01 wmp ok, after reinstall glusterd works
15:02 mator and if you're really interested in glusterfs bugs, open redhat bugzilla and check for "GlusterFS" product id
15:02 B21956 joined #gluster
15:03 dgandhi joined #gluster
15:04 dgandhi joined #gluster
15:04 maveric_amitc_ joined #gluster
15:05 dgandhi joined #gluster
15:07 dgandhi joined #gluster
15:07 wmp mator:
15:07 wmp mount -t glusterfs gluster1:/mnt/gluster /mnt/gluster/
15:07 wmp Mount failed. Please check the log file for more details.
15:07 wmp oops ;)
15:08 dgandhi joined #gluster
15:08 wmp mator: hmmm, now works...
15:08 kovshenin joined #gluster
15:09 dgandhi joined #gluster
15:10 dgandhi joined #gluster
15:11 dgandhi joined #gluster
15:12 dgandhi joined #gluster
15:13 dgandhi joined #gluster
15:16 dgandhi joined #gluster
15:18 dgandhi joined #gluster
15:18 dgandhi joined #gluster
15:19 dgandhi joined #gluster
15:19 kkeithley joined #gluster
15:20 dgandhi joined #gluster
15:22 dgandhi joined #gluster
15:23 dgandhi joined #gluster
15:24 dgandhi joined #gluster
15:26 dgandhi joined #gluster
15:28 dgandhi joined #gluster
15:28 bennyturns joined #gluster
15:29 dgandhi joined #gluster
15:31 dgandhi joined #gluster
15:32 dgandhi joined #gluster
15:33 dgandhi joined #gluster
15:34 dgandhi joined #gluster
15:34 dberry joined #gluster
15:35 dgandhi joined #gluster
15:36 dgandhi joined #gluster
15:37 dgandhi joined #gluster
15:37 squizzi joined #gluster
15:39 dgandhi joined #gluster
15:41 dgandhi joined #gluster
15:42 dgandhi joined #gluster
15:43 dgandhi joined #gluster
15:56 _Bryan_ joined #gluster
15:57 karnan joined #gluster
15:57 rafi joined #gluster
16:01 jbrooks joined #gluster
16:04 jonny30 joined #gluster
16:10 bennyturns joined #gluster
16:15 lmickh joined #gluster
16:23 wushudoin joined #gluster
16:25 squizzi joined #gluster
16:26 wushudoin joined #gluster
16:27 T3 joined #gluster
16:29 calisto joined #gluster
16:35 _pol joined #gluster
16:35 T3 /dev/vdb1                       ext4           1008G  319G  639G  34% /export/images2-1
16:35 T3 localhost:/site-images fuse.glusterfs 1008G  420G  537G  44% /var/www/site-images
16:35 T3 the last one is the gluster peer, so in the end, both are the same disk/partition
16:36 T3 I removed about 100G of data from /export/images2-1
16:36 T3 no
16:36 T3 actually, I removed from /var/www/site-images
16:36 T3 now I don't understand why both have different sizing
16:36 T3 anyone?
16:37 T3 the remote peer also show as 420G used disk space
16:40 T3 # gluster volume status and # gluster peer status looks fine
16:41 RameshN joined #gluster
16:45 DV joined #gluster
16:45 theron joined #gluster
16:46 T3 # gluster volume heal site-images info => shows 244 entries on the server I did the data removal
16:47 bennyturns joined #gluster
16:52 sac_ joined #gluster
16:52 vimal joined #gluster
16:54 ira joined #gluster
16:59 nishanth joined #gluster
17:01 jobewan joined #gluster
17:01 doekia joined #gluster
17:18 jobewan joined #gluster
17:18 coredump joined #gluster
17:23 jonny30 hello
17:23 glusterbot jonny30: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an answer.
17:25 marcoceppi joined #gluster
17:25 marcoceppi joined #gluster
17:28 jonny30 i have this error when I connected a third node (command: gluster peer probe puppet04.socialbro.me ) to replicatred gluster enviroment (2 nodes).
17:29 jonny30 W [socket.c:1494:__socket_proto_state_machine] 0-tcp.gluster_data-server: reading from socket failed. Error (Transport endpoint is not connected), peer (XX.XX.XX.XX:1023)
17:29 glusterbot jonny30: That's just a spurious message which can be safely ignored.
17:30 jonny30 some ideas?
17:30 jonny30 thanks
17:30 JoeJulian I saw you created that from an image of one of your other servers. Did you wipe /var/lib/glusterd before starting glusterd?
17:31 jonny30 yes
17:31 jonny30 well there was in /etc/glusterd/peers
17:31 jonny30 rm uuid
17:32 jonny30 and restart
17:32 jonny30 now appear in new file
17:33 jonny30 uuid=00000000-0000-0000-0000-000000000000
17:33 jonny30 state=9
17:33 jonny30 hostname1=XX.XX.XX.XX
17:33 jonny30 Where XX.XX.XX.XX is first node i setup
17:37 Humble joined #gluster
17:40 JoeJulian You would want to wipe the whole thing. The uuid for the new server have been copied from the source server.
17:40 JoeJulian And /etc/glusterd/peers shouldn't exist, unless you're running a really old version.
17:43 jonny30 how can i wipe it
17:44 jonny30 i exec a rm command so
17:44 jonny30 rm 8cbe5b73-ff5e-40e9-83b3-177c5d0c20ef
17:44 jonny30 and now this file is calling XX.XX.XX.XX (IP)
17:45 jonny30 something strange
17:45 jonny30 what could i do?
17:47 lalatenduM joined #gluster
17:52 JustinClift joined #gluster
17:55 zerick joined #gluster
18:02 jonny30 some support there?
18:02 jonny30 thankyou in advance
18:06 chirino joined #gluster
18:14 JoeJulian jonny30: rm -rf /var/lib/glusterd/*
18:25 jonny30 ok thankyou !!
18:43 calisto1 joined #gluster
18:45 TrDS joined #gluster
18:50 calisto joined #gluster
18:55 calisto joined #gluster
19:01 calisto1 joined #gluster
19:06 PeterA joined #gluster
19:08 rwheeler joined #gluster
19:09 daMaestro joined #gluster
19:10 rwheeler joined #gluster
19:11 jobewan joined #gluster
19:11 calisto joined #gluster
19:15 doekia joined #gluster
19:39 kmai007 joined #gluster
19:40 kmai007 can someone help me understand why my /var/log/glusterfs/nfs.log is now growing on 3.5.3 http://fpaste.org/159990/41867234/
19:40 kmai007 Since i've upgraded from glusterfs3.4.3 to 3.5.3 I have had alot more logging that I have to address
19:50 krullie joined #gluster
20:05 calisto joined #gluster
20:05 deniszh joined #gluster
20:13 ira joined #gluster
20:15 M28 joined #gluster
20:16 M28 joined #gluster
20:31 ron-slc joined #gluster
20:31 Rydekull joined #gluster
20:31 suliba joined #gluster
20:31 ccha2 joined #gluster
20:31 sman_ joined #gluster
20:31 guntha_ joined #gluster
20:31 juhaj joined #gluster
20:31 jiffe joined #gluster
20:31 neoice joined #gluster
20:31 tru_tru joined #gluster
20:31 tobias- joined #gluster
20:31 Champi joined #gluster
20:36 kkeithley joined #gluster
20:40 coredump|br joined #gluster
20:45 primusinterpares joined #gluster
20:46 side_control joined #gluster
20:53 m0ellemeister joined #gluster
20:55 badone joined #gluster
21:01 mator_ joined #gluster
21:01 Arminder- joined #gluster
21:03 fleducquede joined #gluster
21:03 kaii joined #gluster
21:05 coredump joined #gluster
21:06 Dw_Sn joined #gluster
21:08 eightyeight joined #gluster
21:11 cfeller joined #gluster
21:15 virusuy joined #gluster
21:15 virusuy joined #gluster
21:15 diegows joined #gluster
21:16 XpineX joined #gluster
21:18 jonny30 joined #gluster
21:31 glusterbot News from newglusterbugs: [Bug 1057292] option rpc-auth-allow-insecure should default to "on" <https://bugzilla.redhat.com/show_bug.cgi?id=1057292>
21:33 klaas joined #gluster
21:41 jonny30 hello!
21:41 glusterbot jonny30: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an answer.
21:48 jonybravo30 joined #gluster
21:48 jonybravo30 hello!
21:48 glusterbot jonybravo30: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an answer.
21:49 jonybravo30 someone could help me to debug a problem adding third node by #gluster peer probe host but not replicate files
21:50 semiosis jonybravo30: you probably need to add another replica to your volume.  ,,(rtfm)
21:50 glusterbot jonybravo30: Read the fairly-adequate manual at https://github.com/gluster/glusterfs/tree/master/doc/admin-guide/en-US/markdown
21:51 jonybravo30 semiosis can you explain?
21:51 dgagnon joined #gluster
21:51 T3 anyway to get rid of this?
21:52 T3 root@web3:~# gluster volume status
21:52 T3 Another transaction could be in progress. Please try again after sometime.
21:52 T3 like a cleanup or so?
21:52 semiosis T3: restart glusterd on your servers, maybe?
21:52 semiosis jonybravo30: see ,,(glossary)
21:52 glusterbot jonybravo30: A "server" hosts "bricks" (ie. server1:/foo) which belong to a "volume"  which is accessed from a "client"  . The "master" geosynchronizes a "volume" to a "slave" (ie. remote1:/data/foo).
21:53 T3 semiosis, you're the man. thanks!
21:53 semiosis if you added a new server, then it has no bricks.  you need to add a brick to the existing volume for the new server, and increase replication
21:53 semiosis T3: did that work?
21:53 T3 like a charm
21:53 semiosis great!
21:53 T3 :D
21:53 wmp left #gluster
21:53 jonybravo30 i already have 2 bricks
21:53 semiosis jonybravo30: obviously
21:54 jonybravo30 i see
21:54 jonybravo30 thanks let me try
21:56 semiosis jonybravo30: volume add-brick <volname> replica 3 <new.server:/brick/path>
21:56 semiosis or something like that
21:58 T3 # gluster volume status output shows: Self-heal Daemon on localhostN/AY1744
21:58 T3 does that mean self-heal daemon is not working?
21:59 T3 I also have this:
21:59 T3 root@web4:~# gluster volume heal site-images info
21:59 T3 Gathering Heal info on volume site-images has been unsuccessful
22:00 semiosis T3: 1744 is probably a pid.  N/A is probably a TCP port.  check ps, if glustershd is running, you're ok
22:00 jonybravo30 i executed to create replicated bricks
22:00 jonybravo30 gluster volume create gluster_data replica 2 transport tcp host01.dns.me:/data/glusterfs/ host02.dns.me:/data/glusterfs
22:01 jonybravo30 so i think
22:01 jonybravo30 in for third server addition
22:01 jonybravo30 will be
22:01 jonybravo30 volume add-brick gluster_data replica 3 transport tcp host03.dns.me:/data/glusterfs/ ?
22:01 semiosis sounds right.  try it
22:02 diegows joined #gluster
22:04 jonybravo30 wrong brick type: replica, use <HOSTNAME>:<export-dir-abs-path>Usage: volume add-brick <VOLNAME> <NEW-BRICK> ...
22:04 jonybravo30 some ideas?
22:06 B21956 left #gluster
22:07 T3 semiosis, right.. so gluster Self-heal Daemon doesn't require a port?
22:07 T3 interesting..
22:08 semiosis it probably makes connections to bricks, but i doubt it listens for incoming connections
22:08 T3 got it
22:13 T3 ok, hope you are ready for the tricky one, semiosis
22:14 T3 root@web4:~# df -Th
22:14 T3 /dev/vdb1                       ext4           1008G  322G  636G  34% /export/images2-1
22:14 T3 localhost:/site-images fuse.glusterfs 1008G  420G  538G  44% /var/www/site-images
22:14 T3 the "client" is on the "server"
22:14 T3 yesterday I removed 100G from /var/www/site-images/
22:15 firemanxbr joined #gluster
22:15 T3 if I ls /export/images2-1/brick/ I can see the content was removed
22:15 badone joined #gluster
22:15 ghenry joined #gluster
22:15 T3 also, it is not found on the other peers too
22:15 T3 but the disk space was not "released"
22:16 T3 that's why I've been investigating the self-heal daemon
22:16 T3 not sure were to go from here
22:16 T3 s/were/where/
22:16 glusterbot What T3 meant to say was: An error has occurred and has been logged. Please contact this bot's administrator for more information.
22:23 semiosis istr someone having this problem before
22:23 semiosis can you try stopping & starting the volume?  it will interrupt clients
22:23 semiosis what version of glusterfs?  what distro?
22:23 T3 yes, actually I did that several times
22:24 T3 glusterfs 3.4.2 built on Jan 14 2014 18:05:37
22:24 T3 ubuntu 14.04
22:24 T3 from the client point of view, everything looks fine
22:24 semiosis hmm, might want to upgrade to the latest ,,(ppa) version
22:24 glusterbot The official glusterfs packages for Ubuntu are available here: STABLE: 3.4: http://goo.gl/M9CXF8 3.5: http://goo.gl/6HBwKh -- QA: 3.4: http://goo.gl/B2x59y 3.5: http://goo.gl/RJgJvV 3.6: http://goo.gl/ncyln5 -- QEMU with GlusterFS support: http://goo.gl/e8IHnQ (3.4) & http://goo.gl/tIJziO (3.5)
22:25 semiosis ehh, well, there should be a 3.6 GA by now.  i am remiss
22:25 T3 the files I deleted is gone if I mount any peer
22:25 T3 right
22:26 T3 let me work out the upgrade
22:26 elico joined #gluster
22:36 dizquierdo joined #gluster
22:53 T3 semiosis, can't find 3.6 packages for ubuntu
22:53 T3 is it safe to use the 3.6qa repo?
22:54 T3 or better go with the 3.5 ga?
22:54 JoeJulian I believe that's what "i am remiss" inferred.
22:54 semiosis no, i need to republish the 3.6 packages
22:54 semiosis 3.6qa is outdated
22:54 semiosis idk what you should use
22:54 semiosis 3.4.6 would probably be the safest
22:55 semiosis and it's already available
22:55 T3 oh, you are the ubuntu responsible hah
22:55 semiosis upgrade servers first, then clients, or since your servers are also clients, stop the volume and upgrade everything
22:56 semiosis yes i'm the debian/ubuntu packager
22:56 semiosis used to be a paintainer, but now i'm more like a slackager
22:56 JoeJulian hehe
22:56 T3 I see
22:56 T3 heh
22:57 JoeJulian I was once going to help, but then the skies parted and blessings rained down upon me and I no longer had to use ubuntu.
22:57 semiosis hah
22:57 JoeJulian There was much rejoicing.
22:58 T3 deb http://ppa.launchpad.net/semiosis/ubuntu-glusterfs-3.5/ubuntu YOUR_UBUNTU_VERSION_HERE main
22:58 T3 deb-src http://ppa.launchpad.net/semiosis/ubuntu-glusterfs-3.5/ubuntu YOUR_UBUNTU_VERSION_HERE main
22:58 T3 so, this is what I should use? ^^
22:59 semiosis i use the add-apt-repository command
23:02 T3 semiosis, right, but would you confirm this is the correct repository?
23:02 semiosis oh, no
23:02 semiosis ,,(ppa)
23:03 semiosis https://launchpad.net/~gluster/+archive/ubuntu/glusterfs-3.5
23:04 T3 oh, ok
23:05 klaas joined #gluster
23:07 T3 great. double thanks!
23:07 semiosis yw yw
23:11 glusterbot joined #gluster
23:11 JoeJulian foo
23:11 JoeJulian s/foo/bar/
23:11 glusterbot What JoeJulian meant to say was: An error has occurred and has been logged. Please contact this bot's administrator for more information.
23:11 * JoeJulian grumbles.
23:20 vimal joined #gluster
23:20 JoeJulian s/foo/bar/
23:20 glusterbot What JoeJulian meant to say was: An error has occurred and has been logged. Check the logs for more informations.
23:25 T3 well, still have the diff between "client" and "server" mount points
23:26 calisto1 joined #gluster
23:26 T3 /dev/vdb1                       ext4           1008G  322G  636G  34% /export/images2-1
23:26 T3 images2.mhmfun.com:/site-images fuse.glusterfs 1008G  420G  538G  44% /var/www/site-images
23:26 T3 glusterfs 3.5.3 built on Nov 18 2014 03:53:25
23:27 Paul-C joined #gluster
23:27 theron joined #gluster
23:31 fandi joined #gluster
23:31 jaank joined #gluster
23:32 T3 glfsheal working
23:33 T3 interesting to see a rsync process
23:39 fubada joined #gluster
23:39 fubada hi purpleidea
23:40 fubada do you know why operating-version keeps getting removed from /var/lib/glusterd/glusterd.info every puppet run with puppet-gluster
23:40 fubada its causing the gluster service to restart every agent run
23:41 glusterbot News from newglusterbugs: [Bug 1174170] Glusterfs outputs a lot of warnings and errors when quota is enabled <https://bugzilla.redhat.com/show_bug.cgi?id=1174170>
23:41 glusterbot News from newglusterbugs: [Bug 1174247] Glusterfs outputs a lot of warnings and errors when quota is enabled <https://bugzilla.redhat.com/show_bug.cgi?id=1174247>
23:41 glusterbot News from newglusterbugs: [Bug 1174250] Glusterfs outputs a lot of warnings and errors when quota is enabled <https://bugzilla.redhat.com/show_bug.cgi?id=1174250>
23:41 glusterbot News from newglusterbugs: [Bug 847821] After disabling NFS the message "0-transport: disconnecting now" keeps appearing in the logs <https://bugzilla.redhat.com/show_bug.cgi?id=847821>
23:41 glusterbot News from newglusterbugs: [Bug 1174144] Wrong RPM dependencies for older Fedoras for glusterfs-libs <https://bugzilla.redhat.com/show_bug.cgi?id=1174144>
23:41 glusterbot News from resolvedglusterbugs: [Bug 1021998] nfs mount via symbolic link does not work <https://bugzilla.redhat.com/show_bug.cgi?id=1021998>
23:41 glusterbot News from resolvedglusterbugs: [Bug 1077406] Striped volume does not work with VMware esxi v4.1, 5.1 or 5.5 <https://bugzilla.redhat.com/show_bug.cgi?id=1077406>
23:48 CROS__ left #gluster
23:54 fubada purpleidea: like this: -operating-version=1
23:55 dizquierdo joined #gluster
23:56 jonybravo30 sorry i have problems adding third replica, some help?
23:58 jonybravo30 jonybravo30@host03# gluster volume add-brick gluster_data replica 3 transport tcp host03.dns.me:/data/glusterfs
23:58 jonybravo30 wrong brick type: replica, use <HOSTNAME>:<export-dir-abs-path>Usage: volume add-brick <VOLNAME> <NEW-BRICK> ...
23:58 jonybravo30 #gluster volume info
23:58 jonybravo30 Volume Name: gluster_data
23:58 jonybravo30 Type: Replicate
23:58 jonybravo30 Status: Started
23:58 jonybravo30 Number of Bricks: 2
23:58 jonybravo30 Transport-type: tcp

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary