Perl 6 - the future is here, just unevenly distributed

IRC log for #gluster, 2015-06-07

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:03 badone_ joined #gluster
00:11 Jandre joined #gluster
00:20 LebedevRI joined #gluster
00:40 DV joined #gluster
00:54 Jandre joined #gluster
00:58 DV__ joined #gluster
01:27 PaulCuzner joined #gluster
01:27 nangthang joined #gluster
01:47 ilbot3 joined #gluster
01:47 Topic for #gluster is now Gluster Community - http://gluster.org | Patches - http://review.gluster.org/ | Developers go to #gluster-dev | Channel Logs - https://botbot.me/freenode/gluster/ & http://irclog.perlgeek.de/gluster/
03:08 TheSeven joined #gluster
03:21 PaulCuzner joined #gluster
03:34 haomaiwa_ joined #gluster
03:35 badone_ joined #gluster
04:19 nbalacha joined #gluster
04:25 haomaiwa_ joined #gluster
04:39 hagarth joined #gluster
05:10 gem joined #gluster
05:23 Jandre joined #gluster
05:56 smohan joined #gluster
06:25 badone_ joined #gluster
06:29 PaulCuzner joined #gluster
06:29 Folken joined #gluster
06:30 Folken hello gluster people, I note that the new gluster 3.7 has been released, the docs say to use the ubuntu PPA to install it but the files are not in the official PPA?
06:32 rotbeard joined #gluster
07:40 karnan joined #gluster
07:42 PaulCuzner joined #gluster
07:48 Jandre joined #gluster
07:58 WildyLion joined #gluster
08:49 karnan joined #gluster
09:45 nangthang joined #gluster
09:49 glusterbot News from newglusterbugs: [Bug 1228981] glusterfind throws syntax error while getting packaged on EL5 <https://bugzilla.redhat.com/show_bug.cgi?id=1228981>
09:54 al joined #gluster
09:58 karnan joined #gluster
10:01 Trefex joined #gluster
10:11 tessier joined #gluster
10:19 glusterbot News from newglusterbugs: [Bug 1227204] glusterfsd: bricks crash while executing ls on nfs-ganesha vers=3 <https://bugzilla.redhat.com/show_bug.cgi?id=1227204>
10:41 bootc left #gluster
11:01 anrao joined #gluster
11:17 Trefex joined #gluster
11:18 karnan joined #gluster
11:50 stickyboy joined #gluster
11:59 karnan joined #gluster
12:43 Prilly joined #gluster
12:46 n-st joined #gluster
12:50 rotbeard joined #gluster
13:07 Twistedgrim joined #gluster
13:07 harish joined #gluster
13:08 stickyboy joined #gluster
13:09 Twistedgrim1 joined #gluster
13:39 wkf joined #gluster
13:53 RajeshReddy joined #gluster
14:13 sonicrose joined #gluster
14:15 sonicrose good morning.  so i tested everything as 'OK' with version 3.7.1 and have upgrade my production xenserver pool (using gluster for VHD storage via NFS)... things were great for about an hour then VMs have started hanging.  I tried to downgrade back to 3.5.2 but the volume wont start after... is it possible to roll-back?  really hoping someone is around this morning i'm way up shits creek
14:16 sonicrose or maybe some way to determine why the VMs are freezin up now... and new features i can try disabling?
14:22 soumya_ joined #gluster
14:23 aaronott joined #gluster
14:28 karnan joined #gluster
14:30 sonicrose heres how things configured http://pastebin.com/SFgYJxjV   it says "test" but this is a production system (which is down)
14:30 glusterbot Please use http://fpaste.org or http://paste.ubuntu.com/ . pb has too many ads. Say @paste in channel for info about paste utils.
14:31 sonicrose http://fpaste.org/229693/ :D
14:32 sonicrose symptoms are... volumes mount OK, VMs boot OK.  VM runs fine for a while.  if I then go copy a 3 GB file within the VM (writing to the VHDs on Gluster)... it will hang after about 1GB and never recovers.  I have to hard reset the xen host
14:34 sonicrose if i could just roll back to 3.5.2 somehow i'd be happy... but i dont know how to do this without building new servers on 3.5.2 and copying all the data over (many TB)
14:38 sonicrose this stilll applicable http://www.gluster.org/community/documentation/index.php/Gluster_3.2:_Swapping_between_Versions ?
14:46 Trefex joined #gluster
14:48 sonicrose update... i did volume reset on both and downgraded and then reset my options and the volume do start now
14:49 anrao joined #gluster
14:50 ghenry joined #gluster
15:09 haomaiwang joined #gluster
15:12 sonicrose update...  downgrading back to 3.5.2 was successful, all volumes started, and all VMs booted back up.  now just to make sure they run more than an hour without lockups...  i've had similar experiences with past versions of gluster for running VMs...  mounts and VM boots OK and works for a while, then under high IO load the VHDs become locked/inaccessible or gluster crashes.  got it working initially in 352 by disabling most perform
15:13 sonicrose i dont see any sign that gluster crashed, just that file access is 'frozen'
15:13 sonicrose "du" even hangs a bit
15:13 sonicrose a bit... well hangs completely.  can't even kill it with an S 9, shows the process is in uninterruptable sleep
15:14 sonicrose i mount NFS with hard mount so if file storage is unavailable the VMs should hang
15:14 rotbeard joined #gluster
15:17 sonicrose if anyone knows why 3.7.1 was hanging for me or if more info is needed, please email me russell.purinton@gmail.com  thx a ton!
15:33 sonicrose joined #gluster
15:36 karnan joined #gluster
15:54 anrao joined #gluster
16:08 karnan joined #gluster
16:11 Hamcube joined #gluster
16:12 Hamcube Has anyone here had success in getting Gluster to function on an environment where some nodes are CentOS 7 and others are Arch Linux?
16:12 nangthang joined #gluster
16:13 Hamcube I'm able to get all the CentOS 7 nodes to create/attach bricks and start volumes no problem, but as soon as I add Arch Linux to the mix - those won't even let me add a brick to the volume.
16:14 Hamcube iptables is off, selinux is disabled, on the same ip block, file attrs looks correct, running the same verson of glusterd on all machines
16:15 deniszh joined #gluster
16:35 Sjors Hi all!
16:35 Hamcube Hello!
16:35 glusterbot Hamcube: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an answer.
16:36 Sjors I have a directory with stuff that was previously available over NFS, now trying to make it accessible over Gluster on two replica nodes
16:36 Sjors I've created a volume with a single brick at the original location, that seems to be working well
16:37 Sjors I've mounted the disk with -t glusterfs on the clients and they seem to be able to access it
16:37 nangthang joined #gluster
16:37 Sjors but now I'd like to add another replica brick -- so I tried to do this (add-brick <volume> replica 2 otherserver:<location>)
16:38 Sjors but no automatic migration of data is started which is what I kind of expected
16:38 Sjors is there a way to have this data migrated automatically?
16:38 plarsen joined #gluster
16:40 Sjors otherwise, would rsyncing over all the brick contents manually, then adding it as a brick, work even if some changes occured in the meantime?
16:42 anrao joined #gluster
16:44 karnan joined #gluster
16:45 Hamcube Here are etc logs when I tried to add a brick (it didn't have any fattrs but still claimed to be part of a volume, so I nuked the directory and tried again, getting the error I'm trying to resolve where I can't add a brick to a volume that lives on archlinux) http://fpaste.org/229727/95433143/
16:47 David_H_Smith joined #gluster
16:52 Hamcube Here's the log for the brick itself: http://fpaste.org/229731/
16:53 TheCthulhu1 joined #gluster
16:54 Sjors Hamcube: are there any distro-specific patches between arch and centos?
16:54 Sjors Hamcube: otherwise it seems really weird to me that this would break between distro's
16:54 Sjors Hamcube: is the arch machine able to host a volume by itself?
16:54 Sjors i.e. not synchronized to any peers?
16:56 Hamcube Sjors: I'm not sure if there are any patches, the PKGFILE for Arch's package manager doesn't indicate that it's behaving much differently than the RPM verion
16:56 Sjors super-weird
16:56 Hamcube and I'll check to see if I can make a local volume, gimmie a second. I'm trying to remember if it worked or not...
17:00 Hamcube Sjors: http://fpaste.org/229732/
17:00 Hamcube No, I can't add bricks to a volume added only on Archlinux
17:00 Hamcube I'm thinking I may be missing a dependency or something - I'm really inclined to think that the archlinux package is busted.
17:05 Sjors ah
17:05 Sjors /usr/lib/glusterfs//xlator/features/changelog.so: undefined symbol: changelog_select_event
17:06 Sjors I'm not into the internals of Gluster
17:06 Sjors so I don't know what xlator is, but it seems that dynamic library is broken/missing a dependency
17:06 Hamcube Running gcc 5.1.0-4 on Arch, 4.4.7-11 on Centos
17:06 Hamcube That could be it?
17:06 Sjors I doubt it
17:06 Sjors do you know where /usr/lib/glusterfs/xlator/features/changelog.so comes from?
17:07 Sjors do you have that file on both Arch and Centos?
17:07 Hamcube Let's see...
17:08 Hamcube I do, but they're in different places. md5sums don't match.
17:09 Hamcube arch: /usr/lib/glusterfs/xlator/features/changelog.so centos: /usr/lib/glusterfs/3.7.1/xlator/feature/changelog.so
17:11 Hamcube would it care that one is 32-bit and the other is 64-bit os?
17:12 Hamcube Well, I doubt that would be the problem for why I can't even create a local volume
17:18 Sjors well
17:18 Sjors the files are allowed to diff
17:18 Sjors differ*
17:18 Sjors but it seems the arch one is broken, because it can't be linked in
17:19 Sjors the warning is in "xlator.c:192:xlator_dynload" as well
17:19 Sjors "dynload", so it's trying to dynamically load that file and missing a symbol called changelog_select_event
17:19 Sjors looks like that file is just broken, i.e. the arch package seems to be broken
17:19 Hamcube I'm going to try to build the git version and see if I have any luck with that
17:19 Sjors yeah, that sounds like a good idea to me
17:35 TheCthulhu2 joined #gluster
17:36 Hamcube arch's symlinks /usr/bin/python -> /usr/bin/python3 , wonder if that could have something to do with it
17:37 Hamcube Didn't fix the issue with building a volume with the arch package manager, so back to building from the git repo
17:40 Hamcube Nope, doesn't build from source.
17:43 TheCthulhu1 joined #gluster
18:08 Sjors Hamcube: probably that's the most important thing to fix
18:15 ndevos Hamcube: bug 1226853 is about "changelog.so: undefined symbol: changelog_select_event" - should be fixed in 3.7.1
18:15 glusterbot Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1226853 high, high, ---, bugs, CLOSED CURRENTRELEASE, Volume start fails when glusterfs is source compiled with GCC v5.1.1
18:35 RobertLaptop joined #gluster
18:41 RobertLaptop joined #gluster
19:05 Hamcube Ok! I updated the arch package to build 3.7.1 and that resolved my problems. I'm able to create a local volume, and add arch linux bricks to the centos ones as well.
19:05 Hamcube ndevos: Thanks for the pointer, that got me on track!
19:30 Sjors Hamcube: oh! looks like I took you to the wrong direction then, sorry
19:30 Sjors Hamcube: apparantly it /was/ gcc version related
20:10 DV joined #gluster
20:17 ndevos Hamcube: oh, good!
20:18 ndevos Sjors: you pointed out the missing symbol, otherwise I wouldnt have guessed it :)
20:35 aaronott joined #gluster
20:46 sonicrose joined #gluster
20:48 sonicrose is it possible that the upgrade from 3.5.2 to 3.7.1 would have changed the volume configuration file to be called sr0-tcp-fuse.vol instead of sr0-fuse.vol ?
20:49 sonicrose i think i may know why my upgrade this morning flopped... maybe after the upgrade and before starting the volume i should reset all the volume settings... it looks like it probably tried to start initially with a set of default settings
20:50 sonicrose alls i have left post downgrade is some rpmsave files to look at... it would seem that's the case
21:53 Guest19352 joined #gluster
21:56 aaronott joined #gluster
22:34 aaronott1 joined #gluster
22:59 raatti- joined #gluster
23:13 plarsen joined #gluster
23:14 sonicrose nevermind that least inquiry, it seems the volume config does update correctly after upgrade to 3.7.1, so i'm back to being at a loss for why the hangs
23:23 raatti joined #gluster
23:55 badone_ joined #gluster

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary