Perl 6 - the future is here, just unevenly distributed

IRC log for #gluster, 2015-08-24

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:01 haomaiwa_ joined #gluster
00:20 nangthang joined #gluster
00:40 julim joined #gluster
00:53 shiv joined #gluster
00:54 pdrakeweb joined #gluster
00:55 shiv If I have 2 server nodes and add additional 2 or more, do clients need any configuration updates?
01:02 haomaiwa_ joined #gluster
01:02 volga629 I am getting this error on SSL connection E [socket.c:2555:socket_poller] 0-tcp.datapoint02-server: error in polling loop
01:33 Lee1092 joined #gluster
01:34 dlambrig joined #gluster
01:54 haomaiwa_ joined #gluster
01:54 haomaiwa_ joined #gluster
02:01 shiv joined #gluster
02:02 haomaiwa_ joined #gluster
02:03 shiv left #gluster
02:13 PaulCuzner joined #gluster
02:20 DV joined #gluster
02:25 DV__ joined #gluster
02:26 vmallika joined #gluster
02:27 gem joined #gluster
02:36 dlambrig joined #gluster
02:37 plarsen joined #gluster
02:38 kaushal_ joined #gluster
02:39 gbox joined #gluster
03:02 haomaiwa_ joined #gluster
03:25 sakshi joined #gluster
03:30 TheSeven joined #gluster
03:33 vmallika joined #gluster
03:34 shubhendu joined #gluster
03:42 nbalacha joined #gluster
03:45 dlambrig joined #gluster
03:55 kanagaraj joined #gluster
04:02 haomaiwa_ joined #gluster
04:03 kkeithley1 joined #gluster
04:03 overclk joined #gluster
04:09 ppai joined #gluster
04:09 ramteid joined #gluster
04:17 RameshN joined #gluster
04:30 kotreshhr joined #gluster
04:34 itisravi joined #gluster
04:36 TheCthulhu1 joined #gluster
04:38 gem joined #gluster
04:41 anil joined #gluster
04:43 atinm joined #gluster
04:43 yazhini joined #gluster
04:50 rafi joined #gluster
04:54 vimal joined #gluster
04:57 ndarshan joined #gluster
04:58 itisravi joined #gluster
04:58 jiffin joined #gluster
05:02 haomaiwa_ joined #gluster
05:03 qubozik joined #gluster
05:07 kdhananjay joined #gluster
05:08 skoduri joined #gluster
05:09 arcolife joined #gluster
05:15 Manikandan joined #gluster
05:15 ashiq joined #gluster
05:21 sahina joined #gluster
05:22 R0ok_ joined #gluster
05:23 Bhaskarakiran joined #gluster
05:23 yazhini joined #gluster
05:24 spalai joined #gluster
05:24 aravindavk joined #gluster
05:25 deepakcs joined #gluster
05:29 jcastill1 joined #gluster
05:30 atalur joined #gluster
05:30 kshlm joined #gluster
05:30 atalur_ joined #gluster
05:31 kshlm joined #gluster
05:31 harish joined #gluster
05:34 jcastillo joined #gluster
05:34 meghanam joined #gluster
05:35 karnan joined #gluster
05:39 hagarth joined #gluster
05:43 itisravi joined #gluster
05:43 vmallika joined #gluster
05:44 itisravi joined #gluster
05:47 sjohnsen joined #gluster
05:49 autoditac_ joined #gluster
05:52 meghanam_ joined #gluster
05:53 hgowtham joined #gluster
05:56 poornimag joined #gluster
06:00 beeradb joined #gluster
06:02 haomaiwa_ joined #gluster
06:05 Saravana_ joined #gluster
06:08 skoduri joined #gluster
06:20 bharata joined #gluster
06:21 akasurde joined #gluster
06:25 dusmant joined #gluster
06:27 jtux joined #gluster
06:29 dlambrig joined #gluster
06:31 Philambdo joined #gluster
06:37 jwd joined #gluster
06:41 hchiramm joined #gluster
06:42 nangthang joined #gluster
06:43 skoduri joined #gluster
06:45 kkeithley1 joined #gluster
06:47 maveric_amitc_ joined #gluster
06:53 aravindavk joined #gluster
06:59 aravindavk joined #gluster
07:01 dusmant joined #gluster
07:02 7GHAA02CD joined #gluster
07:08 badone__ joined #gluster
07:11 aravindavk joined #gluster
07:19 arcolife joined #gluster
07:23 qubozik joined #gluster
07:23 TvL2386 joined #gluster
07:25 skoduri joined #gluster
07:25 kkeithley1 joined #gluster
07:26 drankis joined #gluster
07:29 ninkotech joined #gluster
07:29 ninkotech_ joined #gluster
07:29 deniszh joined #gluster
07:32 mjrosenb Is there a strategy for upgrading from gluster-3.3 to 3.7?
07:37 calavera joined #gluster
07:37 ramky joined #gluster
07:38 mjrosenb I killed the old server, started the new one, and it isn't seeing any volumes.
07:39 ashiq joined #gluster
07:41 Zhang joined #gluster
07:42 * mjrosenb is guessing this is due to me moving the gluste install to a new path
07:43 fsimonce joined #gluster
07:43 Alex31 joined #gluster
07:55 meghanam_ joined #gluster
08:02 haomaiwa_ joined #gluster
08:02 ctria joined #gluster
08:05 s19n joined #gluster
08:22 Trefex joined #gluster
08:42 ashiq joined #gluster
08:46 meghanam_ joined #gluster
08:49 Zhang joined #gluster
08:58 monotek1 joined #gluster
08:59 ashiq- joined #gluster
09:01 haomaiwa_ joined #gluster
09:11 kshlm joined #gluster
09:11 hchiramm joined #gluster
09:11 LebedevRI joined #gluster
09:15 kkeithley1 joined #gluster
09:15 Saravana_ joined #gluster
09:16 atinm joined #gluster
09:16 vimal joined #gluster
09:22 T1loc joined #gluster
09:24 T1loc Hello, I have a problem and I think it is a split brain
09:24 Alex31 joined #gluster
09:25 T1loc I have this message ls: impossible d'accéder à videos/1cc3b2_638b.mp4: Erreur d'entrée/sortie
09:25 T1loc (input/output error)
09:26 T1loc And I don't know how to solve it
09:28 Bhaskarakiran joined #gluster
09:34 PaulCuzner joined #gluster
09:37 shruti joined #gluster
09:37 dlambrig joined #gluster
09:42 xiu joined #gluster
09:42 xiu hi guys, what puppet module would you recommend to automatize gluster installation?
09:47 hagarth xiu: puppet-gluster is probably the best bet as of now. there are also ansible modules like gdeploy for automation of gluster installation.
09:50 xiu ok thanks, I'll give puppet-gluster a shot :)
09:51 atalur_ joined #gluster
09:51 elico joined #gluster
09:53 jcastill1 joined #gluster
09:56 Alex31 joined #gluster
09:58 mjrosenb RPC Program procedure not available for procedure 4 in GlusterD svc cli read-only for 127.0.0.1:1023
09:58 mjrosenb :-/
09:58 mjrosenb I cannot create a volume.
09:58 jcastillo joined #gluster
09:59 mjrosenb T1loc: you can try poking the bricks with gluster peer status.
10:00 gem joined #gluster
10:00 hagarth T1loc: this might help - http://glusterfs.readthedocs.org/​en/latest/debugging/split-brain/
10:00 glusterbot Title: Split brain - glusterfs (at glusterfs.readthedocs.org)
10:01 T1loc mjrosenb: done : http://susepaste.org/24450890
10:01 glusterbot Title: SUSE Paste (at susepaste.org)
10:01 T1loc hagarth: I'm reading this website :)
10:02 hagarth T1loc: ok :)
10:02 haomaiwa_ joined #gluster
10:02 T1loc but I don't know what it is the attribute-name attribute-value :/
10:02 T1loc ^^
10:03 hagarth T1loc: check the example, it has the attributes listed
10:03 T1loc yes
10:05 T1loc hagarth: ok i understood, I try :)
10:07 mjrosenb I'm kind of sad that glusterbot didn't have a link for my log snippet.
10:10 kotreshhr joined #gluster
10:16 harish joined #gluster
10:19 gletessier joined #gluster
10:20 anonymus gletessier:
10:22 mjrosenb perhaps the issue is the 'readonly' there
10:22 hagarth joined #gluster
10:23 hgowtham joined #gluster
10:23 hagarth mjrosenb: are you trying to create a volume through gluster --remote ?
10:24 ramky joined #gluster
10:24 mjrosenb no, I'm running it on the local machine, I just ran gluster, and it looks like it connected to the glusterd instance on the local machine.
10:24 atinm joined #gluster
10:24 ira joined #gluster
10:25 Manikandan joined #gluster
10:26 mjrosenb how does it attempt to determine if it is connecting remotely?
10:26 hagarth mjrosenb: only if --remote option is provided to gluster
10:26 shruti joined #gluster
10:27 anil joined #gluster
10:31 mjrosenb it looks like it also falls back to read-only if it can't enable ssl?
10:32 ashiq- joined #gluster
10:32 hchiramm joined #gluster
10:33 T1loc hagarth: do I need to reset the three argument-value ? http://susepaste.org/45896101 I've reset the gfid argument, It's works temporarily :-/
10:33 glusterbot Title: SUSE Paste (at susepaste.org)
10:33 gem joined #gluster
10:34 mjrosenb [2015-08-24 10:33:15.231071] D [socket.c:3968:socket_init] 0-socket.management: SSL support on the I/O path is NOT enabled
10:34 mjrosenb [2015-08-24 10:33:15.231079] D [socket.c:3971:socket_init] 0-socket.management: SSL support for glusterd is NOT enabled
10:34 mjrosenb that could do it.
10:35 mjrosenb even though it is on the local machine, and it if someone is snooping on that connection, it probably doesn't matter if it is encrypted or not.
10:37 shruti joined #gluster
10:38 hagarth T1loc: what is the value for the same attribute on the other copy?
10:39 shruti joined #gluster
10:39 hagarth mjrosenb: all local cli - glusterd communication should happen over an unix domain socket
10:39 kkeithley1 joined #gluster
10:39 hagarth mjrosenb: glusterd registers a read-only program on the network socket
10:46 kotreshhr joined #gluster
10:49 shruti joined #gluster
10:51 TheCthulhu2 joined #gluster
10:51 DV__ joined #gluster
10:53 Manikandan joined #gluster
10:54 overclk joined #gluster
10:54 Manikandan joined #gluster
10:55 glusterbot` joined #gluster
10:56 glusterbot joined #gluster
10:56 VeggieMeat_ joined #gluster
10:58 sakshi joined #gluster
10:59 ELCALOR joined #gluster
10:59 overclk joined #gluster
10:59 Pintomatic joined #gluster
10:59 NuxRo joined #gluster
10:59 twisted` joined #gluster
11:01 al joined #gluster
11:02 haomaiwa_ joined #gluster
11:04 Bhaskarakiran joined #gluster
11:05 firemanxbr joined #gluster
11:05 hgowtham joined #gluster
11:05 anoopcs joined #gluster
11:06 jermudgeon joined #gluster
11:12 overclk joined #gluster
11:16 hchiramm ashiq++ thanks !
11:16 glusterbot hchiramm: ashiq's karma is now 3
11:21 jrm16020 joined #gluster
11:25 itisravi joined #gluster
11:31 ramky joined #gluster
11:31 itisravi joined #gluster
11:40 Bhaskarakiran joined #gluster
11:42 atalur joined #gluster
11:45 overclk joined #gluster
11:46 anil joined #gluster
11:51 kanagaraj joined #gluster
11:52 sakshi joined #gluster
11:53 hgowtham joined #gluster
12:00 muneerse2 joined #gluster
12:02 sahina joined #gluster
12:05 jcastill1 joined #gluster
12:07 mator left #gluster
12:09 hagarth joined #gluster
12:10 jtux joined #gluster
12:10 jcastillo joined #gluster
12:11 itisravi joined #gluster
12:12 kotreshhr joined #gluster
12:12 anil joined #gluster
12:12 rastar joined #gluster
12:12 rp_ joined #gluster
12:12 kanagaraj joined #gluster
12:12 atalur joined #gluster
12:12 ppai joined #gluster
12:12 sankarshan joined #gluster
12:12 sac joined #gluster
12:12 kkeithley1 joined #gluster
12:12 arcolife joined #gluster
12:12 maveric_amitc_ joined #gluster
12:12 Bhaskarakiran joined #gluster
12:12 Manikandan joined #gluster
12:12 ndarshan joined #gluster
12:13 poornimag joined #gluster
12:13 hchiramm joined #gluster
12:13 gem joined #gluster
12:13 deepakcs joined #gluster
12:13 shruti joined #gluster
12:13 ashiq- joined #gluster
12:14 lalatenduM joined #gluster
12:14 hgowtham joined #gluster
12:15 rafi joined #gluster
12:16 skoduri joined #gluster
12:17 kotreshhr left #gluster
12:17 overclk joined #gluster
12:18 sakshi joined #gluster
12:20 ashiq joined #gluster
12:20 diegows joined #gluster
12:21 jiffin joined #gluster
12:22 julim joined #gluster
12:26 itisravi joined #gluster
12:29 T1loc hagarth: http://susepaste.org/56522188 all the attribute seem différents
12:29 glusterbot Title: SUSE Paste (at susepaste.org)
12:29 T1loc my setfattr :  setfattr -n trusted.gfid -v 0xeb98e184261648a8a0284c673eef2884 /home/exports/1cca09_4ea7.mp4
12:30 T1loc I did the same with the trusted.afr attribute
12:32 neofob joined #gluster
12:35 kdhananjay joined #gluster
12:36 unclemarc joined #gluster
12:36 d-fence joined #gluster
12:41 Trefex hi all. is there anywere some doc that explains all the performance related parameters in gluster ?
12:41 maveric_amitc_ joined #gluster
12:41 skoduri joined #gluster
12:41 ashiq joined #gluster
12:41 anil joined #gluster
12:41 hchiramm joined #gluster
12:41 rp_ joined #gluster
12:41 sakshi joined #gluster
12:41 Manikandan joined #gluster
12:41 gem joined #gluster
12:41 poornimag joined #gluster
12:42 lalatenduM joined #gluster
12:42 shruti joined #gluster
12:42 kkeithley1 joined #gluster
12:43 sac joined #gluster
12:43 B21956 joined #gluster
12:44 rastar joined #gluster
12:45 rafi joined #gluster
12:47 Trefex joined #gluster
12:47 mjrosenb hagarth: ok, so it sounds like it fell back to a network socket?
12:48 mjrosenb I guess I'll runn it under truss.
12:48 jcastill1 joined #gluster
12:49 ashiq joined #gluster
12:50 overclk joined #gluster
12:50 sathees joined #gluster
12:52 kdhananjay joined #gluster
12:53 jcastillo joined #gluster
12:55 shaunm joined #gluster
12:55 Saravana_ joined #gluster
12:58 overclk_ joined #gluster
13:04 kkeithley1 joined #gluster
13:07 rwheeler joined #gluster
13:10 kdhananjay joined #gluster
13:10 mpietersen joined #gluster
13:14 sankarshan joined #gluster
13:15 jcastill1 joined #gluster
13:17 overclk joined #gluster
13:20 jcastillo joined #gluster
13:21 haomaiwang joined #gluster
13:25 kdhananjay joined #gluster
13:26 Manikandan joined #gluster
13:29 cabillman joined #gluster
13:32 al_ joined #gluster
13:33 plarsen joined #gluster
13:34 harold joined #gluster
13:34 shyam joined #gluster
13:35 plarsen joined #gluster
13:36 NuxRo /join #ceph
13:36 NuxRo lol, wrong window
13:38 anoopcs joined #gluster
13:46 kdhananjay joined #gluster
13:48 arcolife joined #gluster
13:50 mazl joined #gluster
13:56 dgandhi joined #gluster
14:02 haomaiwa_ joined #gluster
14:05 Peppard joined #gluster
14:05 Alex31 joined #gluster
14:08 overclk joined #gluster
14:10 jiku joined #gluster
14:11 spcmastertim joined #gluster
14:17 MessedUpHare joined #gluster
14:21 prg3 joined #gluster
14:25 papamoose left #gluster
14:28 Alex31 joined #gluster
14:33 cyberswat joined #gluster
14:36 qubozik joined #gluster
14:39 muneerse joined #gluster
14:42 NuxRo joined #gluster
14:43 mckaymatt joined #gluster
14:57 Bonaparte joined #gluster
14:57 Bonaparte I have glusterfs-server 3.4.x installed on CentOS 7. systemctl start glusterfsd does not start glusterfs-server. How can I start it?
14:59 mckaymatt joined #gluster
15:00 mckaymatt joined #gluster
15:00 jbrooks joined #gluster
15:01 jmarley joined #gluster
15:02 haomaiwang joined #gluster
15:03 timotheus1 joined #gluster
15:06 wushudoin joined #gluster
15:15 shyam Bonaparte: Try "gluster volume start <volname> force" in case the volume is already started and just one brick process is not up (i.e glusterfsd)
15:15 shaunm joined #gluster
15:16 jrm16020 joined #gluster
15:16 Bonaparte shaunm, I get Connection failed. Please check if gluster daemon is operational.
15:17 muneerse2 joined #gluster
15:18 uebera|| joined #gluster
15:18 uebera|| joined #gluster
15:20 anonymus joined #gluster
15:20 anonymus gletessier:
15:21 tertiary joined #gluster
15:21 mckaymatt joined #gluster
15:21 rafi joined #gluster
15:22 shyam Bonaparte: I think glusterd is not running in that case, try systemctl status/start glusterd
15:22 Bonaparte shaunm, tried that
15:22 tertiary I rebuilt a volume and it it's working fine, but the old directories are still there and cannot be deleted, it says "Directory not empty". Thoughts? I just want to delete everything...
15:22 jrm16020 joined #gluster
15:23 Bonaparte shyam, http://paste2.org/NMvzwCC7
15:23 glusterbot Title: Paste2.org - Viewing Paste NMvzwCC7 (at paste2.org)
15:23 Bonaparte shyam, my problem is: I am unable to start glusterfs
15:24 Bonaparte shyam, http://paste2.org/bF4ktkgg - glusterd
15:24 glusterbot Title: Paste2.org - Viewing Paste bF4ktkgg (at paste2.org)
15:24 overclk joined #gluster
15:24 Bonaparte shyam, http://paste2.org/hE47OkEe - this is cleaner
15:24 glusterbot Title: Paste2.org - Viewing Paste hE47OkEe (at paste2.org)
15:26 Trefex1 joined #gluster
15:27 shyam Bonaparte: ok, so glusterd is not running and is failing to start as well, is what I think. It would be helpful to check the logs to see why that is the case (should be, /var/log/glusterfs/usr-local-e​tc-glusterfs-glusterd.vol.log)
15:27 cholcombe joined #gluster
15:27 shyam tertiary: Did you 'purge' (i.e remove everything on them) the bricks before adding them back to the new volume
15:28 Bonaparte shyam, no such file
15:28 Bonaparte yes
15:28 Bonaparte removed everything except .info file
15:29 shyam Bonaparte: tertiary: are you working on the same volume :)
15:29 Bonaparte shyam, no
15:30 shyam Bonaparte: ok sorry, your response sounded like a response to the question I posed tertiary
15:30 Bonaparte No problem
15:30 Bonaparte shyam, http://paste2.org/n8yCI4fK this might help
15:30 glusterbot Title: Paste2.org - Viewing Paste n8yCI4fK (at paste2.org)
15:30 Bonaparte But I don't know what it means
15:31 Bonaparte (-->/usr/sbin/glusterd(main+0x3df) [0x7f4a376448ef] (-->/usr/sbin/glusterd(glu​sterfs_volumes_init+0xd8) [0x7f4a37647748] (-->/usr/sbin/glusterd(glus​terfs_process_volfp+0x103) [0x7f4a37647633]))) 0-: received signum (0), shutting down
15:31 glusterbot Bonaparte: ('s karma is now -99
15:31 glusterbot Bonaparte: ('s karma is now -100
15:31 glusterbot Bonaparte: ('s karma is now -101
15:31 Bonaparte Ouch
15:31 shyam Bonaparte: Line 29 in the paste is where your problem is (you are on 3.4.x right?)
15:31 Bonaparte shyam, yes
15:31 shyam Bonaparte: i.e "0-management: wrong op-version (30703) retreived"
15:31 tertiary Bonaparte-yes I am...
15:32 Bonaparte shyam, how can I fix it?
15:32 shyam Bonaparte: did you up the volume version or something or installed 3.7.x RPMs etc.?
15:32 Bonaparte shyam, yes
15:32 Bonaparte shyam, had, 3.7 did not work. So installed 3.3 and now 3.4
15:33 Bonaparte what a mess! :)
15:33 bennyturns joined #gluster
15:34 shyam Bonaparte: Hmmm... ok I do not know the exact steps here, trying to find some older posts that talk about this...
15:34 Bonaparte shyam, if I can find a way to cleanup the mess, it would be all right, I guess
15:34 shyam Bonaparte: is it a single brick volume?
15:35 Bonaparte shyam, no, 6 bricks
15:35 tertiary I fixed it, nm :)
15:36 shyam Could you check if the op-version in the file /var/lib/glusterd/glusterd.info is the same (incorrect value as of now) on all the bricks (see "operating-version ..." in that file)
15:36 Bonaparte shyam, UUID=805b96df-9432-4ebb-b870-9f40980e4099
15:36 Bonaparte operating-version=30703
15:36 calavera joined #gluster
15:37 shyam Bonaparte: Also, if the volume was created with 3.7.x and now you downgrade the gluster RPMs to a lower version I am not sure if the volume can be brought up, as there could be translators in the vol file, that are not part of 3.4.x
15:38 Bonaparte shyam, as of now, I have gluster 3.x on other 3 machines
15:38 Bonaparte and now want to run gluster on CentOS 7
15:38 Bonaparte shyam, I  am fine with any version (3.3 or 3.4 or 3.7)
15:38 Bonaparte as long as I can run some replicas
15:39 shyam Bonaparte: Ummm... when was the volume created? I just do not want to suggest something and nuke your setup in case it has data.
15:39 Bonaparte shaunm, volume was setup with 3.3 couple years ago
15:39 Bonaparte shyam, too
15:40 Bonaparte shyam, I upgraded OS on this machine. And installed 3.7
15:40 Bonaparte then ran into problems
15:40 Bonaparte so removed 3.7 and installed 3.3 and then 3.4
15:40 Bonaparte this is how I ended up in this mess
15:41 Bonaparte I can't nuke the volume, it has lot of data and running in production
15:41 shyam Bonaparte: ok, better to let the glusterd folks respond here. What I would suggest is, check operating-version on all bricks, post the log file that showed glusterd logs, and mention the op-version error and ask for suggestions, that should be enough data to proceed I think.
15:41 shyam Bonaparte: Agreed
15:42 Bonaparte shyam, surprisingly 3.3 on other machines don't have a problem starting
15:43 ccha joined #gluster
15:43 ccha joined #gluster
15:44 k-ma joined #gluster
15:46 ramky joined #gluster
15:48 skoduri joined #gluster
15:49 Bonaparte shyam, I was able to start glusterd after removing the op-version line
15:49 jbrooks joined #gluster
15:50 elico joined #gluster
15:55 jrm16020_ joined #gluster
15:58 T1loc They are some best practice for a volume who contains a lot of file, with a lot of sub directories ?  ? (eg : 300 000 images)
15:59 ccha joined #gluster
15:59 ccha joined #gluster
16:00 nage joined #gluster
16:00 k-ma joined #gluster
16:04 cyberswat joined #gluster
16:07 anonymus joined #gluster
16:07 nbalacha joined #gluster
16:08 Norky joined #gluster
16:11 jdossey joined #gluster
16:16 calavera_ joined #gluster
16:19 RedW joined #gluster
16:26 Bhaskarakiran joined #gluster
16:26 overclk joined #gluster
16:28 jmarley joined #gluster
16:29 Rapture joined #gluster
16:31 jwd joined #gluster
16:41 DV__ joined #gluster
16:42 dlambrig joined #gluster
16:44 dlambrig_ joined #gluster
16:48 gem joined #gluster
16:57 shyam Bonaparte: Good to hear!
16:59 highbass joined #gluster
17:00 diegows joined #gluster
17:00 highbass hey guys i am a bit confused with a concept... if i have a replica set to 2 and i have 6 nodes with 10GB ... how much space becomes available to use and how much is used for replica data?
17:01 Philambdo1 joined #gluster
17:07 Bonaparte http://paste2.org/F8NBP1xB - I am unable to mount the volume. This is the log when trying to mount
17:07 glusterbot Title: Paste2.org - Viewing Paste F8NBP1xB (at paste2.org)
17:07 Bonaparte shyam, some more issues to fix before sleeping tonight! :)
17:20 techsenshi joined #gluster
17:28 pwnguin joined #gluster
17:30 pwnguin I'm having trouble mounting a gluster volume. The mount says "Mount failed. Please check the log file for more details."
17:30 pwnguin the relevent log file shows: https://pastebin.osuosl.org/31561/14404373/
17:30 glusterbot Title: #31561 OSL Pastebin (at pastebin.osuosl.org)
17:30 pwnguin thoughts?
17:31 RedW joined #gluster
17:31 shyam pwnguin: The problem seems to be here "0-web-drupal-quick-read: Cache size 4294967296 is greater than the max size of 1225142272"
17:32 shyam pwnguin: Suggest resetting the same and attempting the mount
17:35 pwnguin option cache-size 4GB <-- think it's that number?
17:35 glusterbot pwnguin: <'s karma is now -16
17:35 shyam Bonaparte: What is your mount command CLI? Maybe that has some clues...
17:35 pwnguin yep. 2^32
17:36 pwnguin shyam: oddly, other systems mount it fine
17:37 overclk joined #gluster
17:37 Bonaparte shyam, mount -t glusterfs s7local:/newp2s  to/some/path
17:40 shyam Bonaparte: check if glusterd on s7local is running, looks like the process is not able to fetch the vol file
17:40 Bonaparte shyam, it is runnign
17:40 Bonaparte running
17:41 shyam Bonaparte: ok, try mounting using the IP instead then
17:41 shyam pwnguin: Which version of gluster are you running
17:41 pwnguin shyam: its in the pastebin
17:42 pwnguin 3.4.0
17:42 Bonaparte shyam, same error
17:43 shyam pwnguin: Ummm... pastebin shows 3.3.0?
17:43 pwnguin where?
17:43 shyam pwnguin: first line "0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0"
17:43 pwnguin i dont even
17:44 pwnguin https://pastebin.osuosl.org/31561/14404373/
17:44 glusterbot Title: #31561 OSL Pastebin (at pastebin.osuosl.org)
17:44 pwnguin 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.4.0
17:44 shyam Ah! was staring at Bonaparte ('s) paste, apologies
17:45 pwnguin yea, i think we're going to bump the server up to 4gb of ram
17:45 pwnguin I think that's the main difference between this server and the others
17:46 shyam pwnguin: yes, code checks for avbl. mem against the configured max and is failing in that check
17:47 shyam pwnguin: so what you state is the reason, bumping that up should help, or resetting the cache-size to suit this machine should help.
17:47 pwnguin i mean, its a cache, so IMO that shoudl be a warning but i havent thought it through much
17:49 shyam pwnguin: FWIW, 3.7 code base has the same behavior, i.e error instead of a warning, you could file a bug against the same for consideration
17:49 glusterbot https://bugzilla.redhat.com/en​ter_bug.cgi?product=GlusterFS
17:53 shyam Bonaparte: could you try, "glusterfs --volfile-server=s7local --volfile-id=newp2s to/some/path"
17:54 pwnguin welp, that fixed it. now to explain to the user how ssh works
17:54 shyam Bonaparte: The message pasted, shows the volfile-id as key:/new2ps whereas I believe it should be new2ps only, hence the suggestion
17:57 Bonaparte shyam, received no message. But the vol is not mounted
17:58 Bonaparte there mounted dir is empty
17:58 Bonaparte I tried:
17:58 Bonaparte glusterfs --volfile-server=s7local --volfile-id=newp2s /mnt/test1/
17:58 Bonaparte ls /mnt/test1/
17:58 Bonaparte has nothing
17:58 shyam Bonaparte: log file for the mount has anything in it?
17:59 shyam Bonaparte: is the process running?
17:59 shyam " ... still running ..." ^^^
18:00 Bonaparte shyam, yes still running
18:01 Bonaparte shyam, http://paste2.org/af8IBedI - log file for mount
18:01 glusterbot Title: Paste2.org - Viewing Paste af8IBedI (at paste2.org)
18:02 shyam Bonaparte: Sorry maybe I should be more specific, the "glusterfs --volfile-server..." process is still running (i.e the mount process), from the paste it looks like it shutdown.
18:02 pwnguin left #gluster
18:02 shyam Bonaparte: From the paste it also looks like it failed in a similar manner as before :(
18:02 Bonaparte shyam, no. it exited
18:02 shyam Bonaparte: which means I am out of ideas
18:03 shyam Bonaparte: One last thing before posting a bug or to the lists, are all RPMs back at the older 3.3 version?
18:04 Bonaparte shyam, on this server, s7local yes, 3.3
18:04 Bonaparte shyam, on one server it has 3.4
18:04 Bonaparte rest 8 have 3.3
18:05 Bonaparte shyam, I noticed some other problems. Creating new volumes are also failing
18:05 shyam Bonaparte: just check if the glusterd log file has anything interesting in terms of messages, that may point to why the vol file fetching is failing.
18:05 Bonaparte shyam, for testing purpose, I created a volume with 2 replica and started the volume
18:05 Bonaparte shyam, the volume does not show up in volume info
18:06 shyam Bonaparte: ok, something is wrong with glusterd and the management plane in general, the glusterd logs seem the best bet to possibly narrow this down further
18:06 shyam Bonaparte: that would be my best guess at this point.
18:06 Bonaparte shyam, what file would that be?
18:06 Bonaparte etc-glusterfs-glusterd.vol.log?
18:06 shyam yup
18:07 Bonaparte shyam, there are entries like: [2015-08-24 13:06:55.097894] E [rpcsvc.c:491:rpcsvc_handle_rpc_call] 0-glusterd: Request received from non-privileged port. Failing request
18:07 Bonaparte heaps of them
18:07 shyam Bonaparte: Did you restart glusterd post downgrading the RPMs? (I think earlier messages indicated that you did)
18:07 Bonaparte shyam, yes
18:08 shyam Bonaparte: Also, this (the privileged port issue) looks like a recent problem that was causing some trouble upstream (let me find the thread)
18:11 Bonaparte shyam, found this. https://bugzilla.redhat.co​m/show_bug.cgi?id=1128429
18:11 glusterbot Bug 1128429: medium, unspecified, ---, rhs-bugs, NEW , gluster commands frequently failing with "another transaction in progress" error even though no transaction is in progress
18:11 Bonaparte shyam, "
18:11 Bonaparte Description Rachana Patel 2014-08-10 08:09:55 EDT
18:11 Bonaparte Description of problem:
18:11 Bonaparte =======================
18:11 Bonaparte gluster commands frequently failing with "another transaction in progress" error even though no transaction is in progress
18:11 Bonaparte Version-Release number of selected component (if applicable):
18:11 Bonaparte ===============================​==============================
18:11 Bonaparte 3.4.0.59rhs-1.2.toyota.hotfix.el6rhs.x86_64
18:11 Bonaparte How reproducible:
18:11 Bonaparte =================
18:11 Bonaparte intermittent
18:11 Bonaparte Steps to Reproduce:
18:11 Bonaparte ===================
18:12 Bonaparte [root@rhs-client9 ~]# gluster volume stop toyota
18:12 Bonaparte Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
18:12 Bonaparte volume stop: toyota: failed: Another transaction could be in progress. Please try again after sometime.
18:12 Bonaparte [root@rhs-client9 ~]# gluster volume stop toyota
18:12 Bonaparte Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
18:12 Bonaparte volume stop: toyota: failed: Another transaction could be in progress. Please try again after sometime.
18:12 Bonaparte log snippet:-
18:12 Bonaparte [2014-08-09 06:02:46.342864] E [glusterd-syncop.c:103:gd_collate_errors] 0-: Locking failed on 2a9bd2e0-fd60-463e-b57a-dfee733ca7f4. P
18:12 Bonaparte lease check log file for details.
18:12 Bonaparte [2014-08-09 06:02:46.343096] E [glusterd-syncop.c:855:gd_lock_op_phase] 0-management: Failed to acquire lock
18:12 Bonaparte [2014-08-09 06:02:46.344431] E [glusterd-syncop.c:103:gd_collate_errors] 0-: Unlocking failed on 2a9bd2e0-fd60-463e-b57a-dfee733ca7f4.
18:12 Bonaparte Please check log file for details.
18:12 Bonaparte [2014-08-09 06:02:46.344536] E [glusterd-syncop.c:1088:gd_unlock_op_phase] 0-management: Failed to unlock on some peer(s)
18:12 Bonaparte [2014-08-09 06:02:49.647883] E [rpcsvc.c:566:rpcsvc_handle_rpc_call] 0-glusterd: Request received from non-privileged port. Failing re
18:12 Bonaparte quest
18:12 Bonaparte [2014-08-09 06:02:49.654647] E [rpcsvc.c:566:rpcsvc_handle_rpc_call] 0-glusterd: Request received from non-privileged port. Failing re
18:12 Bonaparte quest
18:12 Bonaparte [2014-08-09 06:02:49.661319] E [rpcsvc.c:566:rpcsvc_handle_rpc_call] 0-glusterd: Request received from non-privileged port. Failing re
18:12 Bonaparte quest
18:12 Bonaparte [2014-08-09 06:02:49.668261] E [rpcsvc.c:566:rpcsvc_handle_rpc_call] 0-glus"
18:12 Bonaparte oops
18:12 Bonaparte sorry
18:12 Bonaparte wrong paste
18:12 Bonaparte "From the log snippets provided, we can be pretty sure the failures are being caused because of exhaustion of privileged ports. This is a known issue, and the only way to avoid failures caused by this, is to run glusterd with 'rpc-auth-allow-insecure on' to allow requests from unprivileged ports."
18:12 hagarth Bonaparte: this is an unrelated issue. Please stop yank/pasting here. Use fpaste for posting non-trivial pastes.
18:13 Bonaparte hagarth, sorry. It was an accident
18:13 ipmango joined #gluster
18:16 hagarth Bonaparte: setting that config should help requests to be processed from unprivileged ports.
18:16 shyam Bonaparte: It could be related or just that privileged ports are exhausted, could you check that? Or as hagarth states use the rpc-auth-allow-insecure on' to overcome the problem.
18:18 Bonaparte shyam, I get this error:
18:18 Bonaparte option : rpc-auth-allow-insecure does not exist
18:18 Bonaparte Did you mean allow-insecure or rpc-auth-allow?
18:18 Bonaparte Set volume unsuccessful
18:18 Bonaparte when I run:
18:18 Bonaparte luster volume set newp2s rpc-auth-allow-insecure on
18:19 Bonaparte gluster*
18:21 hagarth Bonaparte: you need to add that option in /etc/glusterfs/glusterd.vol
18:21 hagarth and re-start glusterd
18:22 Bonaparte hagarth, in the 'volume management' section?
18:23 Bonaparte hagarth, I just saw that you could set it from CLI according to http://www.gluster.org/community/documentation​/index.php/Gluster_3.2:_Setting_Volume_Options
18:23 Bonaparte rpc-auth-allow-insecure is the listed there
18:34 RedW joined #gluster
18:40 Bonaparte joined #gluster
18:49 Bonaparte got disconnected
18:55 Bonaparte now, I can't even start glusterd on one of the servers. I have this in log: http://paste2.org/Pd6DLMhj
18:55 glusterbot Title: Paste2.org - Viewing Paste Pd6DLMhj (at paste2.org)
18:55 Bonaparte Like the logs says, the info file is missing
18:58 Bonaparte Is there a way to restore the info file? Perhaps from other servers?
19:17 Dasiel joined #gluster
19:17 Dasiel Hello mates
19:17 ctria joined #gluster
19:17 Dasiel I think I've broken my gluster
19:17 Dasiel How can I debug it properly mates?
19:18 Dasiel I had a stripped volume with 1 x 3 bricks, I've added fourth
19:18 Dasiel and it broke
19:18 Dasiel Volume is online, I can see the 4th brick in the list
19:19 Dasiel but the mountpoint is empty
19:20 Dasiel Is this the correct channel to ask these type of questions?
19:20 mpietersen Dasiel: response times are hit and/or miss
19:20 mpietersen mostly miss
19:20 Dasiel also one thing isn't clear to me from the doc
19:21 Dasiel If I have stripped volume
19:21 Dasiel do I need to rebalance it
19:21 Dasiel after I add a new brick?
19:21 mpietersen not sure, i've only done mirrored bricks before
19:22 Dasiel because when I try to rebalance the volume it says it's not distributed or it contains only one brick
19:22 Dasiel but it has 4 bricks, but it's stripped not distributed
19:23 jalljo joined #gluster
19:23 Xtreme i have a weird bug with gluster
19:24 Xtreme everytime my server restarts, my storage-pool is empty
19:24 Xtreme i have to restart gluster and force mount volume
19:24 Xtreme any idea why?
19:47 dastar joined #gluster
19:49 sacrelege joined #gluster
20:21 spcmastertim joined #gluster
20:24 Dasiel oh well I fixed my problem somehow
20:26 jrm16020 joined #gluster
20:28 DV joined #gluster
20:37 mpietersen thats usually how it works
20:43 coredump joined #gluster
20:51 badone__ joined #gluster
20:51 bennyturns joined #gluster
21:03 muneerse joined #gluster
21:12 elico joined #gluster
21:13 muneerse2 joined #gluster
21:14 jrm16020 joined #gluster
21:17 muneerse joined #gluster
21:19 RedW joined #gluster
21:28 RedW joined #gluster
21:33 shaunm joined #gluster
21:33 diegows joined #gluster
21:53 techsenshi on gluster 3.5.x do I have to run volume rebalance and then volume rebalance fix-layout
21:53 techsenshi running fix-layout as a second step?
21:54 techsenshi in my current rebalance log I'm seeing references for fix-layout which makes me unclear
21:54 cliluw joined #gluster
22:03 Philambdo joined #gluster
22:07 plarsen joined #gluster
22:23 hagarth joined #gluster
22:46 woakes070048 joined #gluster
22:51 dijuremo2 joined #gluster
22:51 neofob joined #gluster
22:53 dijuremo2 Quick question folks... If I am running ctdb to manage IP and I quickly stop and start a gluster volume, will ctdb go crazy?
22:54 dijuremo2 The ctdb config files are stored in the gluster volume
22:55 dijuremo2 I am trying to upgrade 3.6.x to 3.7.3 without downtime, but apparently the allow.insecure settings require a restart of the volume and glusterd service
22:57 mckaymatt joined #gluster
22:57 dijuremo2 Also information on the page: http://blog.gluster.org/category/gluster/ says to use option rpc-auth-allow-insecure on
22:57 dijuremo2 however, the actual option that gluster will take is simply rpc-auth-allow (without -insecure). Can anybody clarify this?
23:03 shyam joined #gluster
23:03 mjrosenb ok, so can anyone hazard a guess about why when I run /full/path/to/gluster on freebsd, it connects to glusterd in readonly mode?
23:09 dijuremo2 @mjrosenb are you running quorum issues?
23:09 dijuremo2 running into quorum issues?
23:09 volga629 Hello Everyone,     which package contain /3.7.3/xlator/configuration.so: cannot open shared object file: No such file or directory
23:10 volga629 can't find it ?
23:11 mjrosenb I don't think so?
23:11 mjrosenb I'm not sure what a quorum issue is.
23:12 dlambrig_ joined #gluster
23:13 volga629 also with libvirt when trying create volume getting this message 0-datapoint02-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
23:13 dijuremo2 Is your gluster volume a replica?
23:13 mjrosenb I don't have a volume
23:13 mjrosenb I cannot create one
23:14 mjrosenb because the control client only connects in readonly mode
23:15 jrm16020 joined #gluster
23:18 dijuremo2 @mjrosenb sry out of ideas...
23:20 mjrosenb JoeJulian: you have any ideas?
23:21 mjrosenb dijuremo2: fwiw, the standard protocol on IRC is to not use '@' symbols; that doesn't highlight me.
23:29 dijuremo2 neither does ":" so meh....
23:30 dlambrig joined #gluster
23:34 dlambrig_ joined #gluster
23:35 ccha2 joined #gluster
23:36 elitecoder joined #gluster
23:36 ws2k3_ joined #gluster
23:37 elitecoder JoeJulian: Any thoughts on this? http://pastebin.com/Z435s9Uk
23:37 glusterbot Please use http://fpaste.org or http://paste.ubuntu.com/ . pb has too many ads. Say @paste in channel for info about paste utils.
23:38 ELCALOR joined #gluster
23:44 ws2k3_ joined #gluster

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary