Perl 6 - the future is here, just unevenly distributed

IRC log for #gluster, 2017-02-22

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:06 pjrebollo joined #gluster
00:55 shutupsquare joined #gluster
01:09 shdeng joined #gluster
01:22 gyadav joined #gluster
01:22 gyadav_ joined #gluster
01:29 plarsen joined #gluster
02:03 cholcombe joined #gluster
02:13 daMaestro joined #gluster
03:00 derjohn_mob joined #gluster
03:38 atinm joined #gluster
03:41 magrawal joined #gluster
03:53 ahino joined #gluster
03:54 nbalacha joined #gluster
03:55 gyadav joined #gluster
03:55 gyadav_ joined #gluster
04:05 vbellur joined #gluster
04:09 buvanesh_kumar joined #gluster
04:10 sanoj|afk joined #gluster
04:20 mb_ joined #gluster
04:21 RameshN joined #gluster
04:22 Shu6h3ndu joined #gluster
04:23 vbellur1 joined #gluster
04:33 nbalacha joined #gluster
04:33 jiffin joined #gluster
04:41 jiffin joined #gluster
04:41 msvbhat joined #gluster
04:48 susant joined #gluster
04:50 apandey joined #gluster
04:51 rafi joined #gluster
04:51 ankitr joined #gluster
04:52 karthik_us joined #gluster
04:54 skumar joined #gluster
04:54 k4n0 joined #gluster
04:59 rafi1 joined #gluster
05:03 Saravanakmr joined #gluster
05:03 ppai joined #gluster
05:06 sanoj joined #gluster
05:06 susant joined #gluster
05:12 aravindavk joined #gluster
05:16 ndarshan joined #gluster
05:20 rafi joined #gluster
05:23 skoduri joined #gluster
05:24 k4n0 joined #gluster
05:37 prasanth joined #gluster
05:43 riyas joined #gluster
05:44 kotreshhr joined #gluster
05:56 sona joined #gluster
05:58 rjoseph joined #gluster
06:12 ankitr joined #gluster
06:20 Karan joined #gluster
06:24 aravindavk joined #gluster
06:28 mhulsman joined #gluster
06:32 ashiq joined #gluster
06:35 kdhananjay joined #gluster
06:37 aravindavk joined #gluster
06:38 jordie joined #gluster
06:43 ankitr joined #gluster
06:44 kramdoss_ joined #gluster
06:49 hgowtham joined #gluster
06:53 ndarshan joined #gluster
06:58 jkroon joined #gluster
07:01 Shu6h3ndu joined #gluster
07:02 DV__ joined #gluster
07:08 itisravi joined #gluster
07:13 hgowtham joined #gluster
07:17 unlaudable joined #gluster
07:29 jtux joined #gluster
07:30 saintpablos joined #gluster
07:37 jtux joined #gluster
07:40 Humble joined #gluster
07:47 apandey joined #gluster
07:53 humblec joined #gluster
07:59 moneylotion joined #gluster
08:02 ndarshan joined #gluster
08:04 Shu6h3ndu joined #gluster
08:08 arpu joined #gluster
08:11 shutupsquare joined #gluster
08:24 shutupsquare joined #gluster
08:28 saintpabloss joined #gluster
08:31 shutupsquare joined #gluster
08:32 rafi1 joined #gluster
08:39 armyriad joined #gluster
08:46 mbukatov joined #gluster
08:57 fsimonce joined #gluster
09:00 msvbhat joined #gluster
09:01 [diablo] joined #gluster
09:10 Humble joined #gluster
09:24 shutupsquare joined #gluster
09:26 skoduri joined #gluster
09:31 ShwethaHP joined #gluster
09:34 apandey joined #gluster
09:35 mhulsman joined #gluster
09:35 jkroon joined #gluster
09:47 saintpablo joined #gluster
09:48 rastar joined #gluster
09:49 aravindavk joined #gluster
09:50 skumar joined #gluster
09:54 skumar_ joined #gluster
09:55 glustercat joined #gluster
09:55 glustercat Hi
09:55 glusterbot glustercat: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually off
09:57 glustercat I have a problem with my 3 Replica. When one Node goes down and comes online again the staging Fails on that that Node and i have to resetup everything
09:57 mindgaze joined #gluster
09:58 skumar joined #gluster
09:59 mindgaze hi anyone willing to help in a performance problem ? (fuse native, gluster 3.9, smallfiles)
10:01 shutupsquare joined #gluster
10:01 p7mo joined #gluster
10:01 RameshN joined #gluster
10:09 poornima_ joined #gluster
10:14 mhulsman joined #gluster
10:16 anoopcs mindgaze, https://github.com/gluster/glusterfs/blob/releas​e-3.9/doc/release-notes/3.9.0.md#small-file-impr​ovements-in-gluster-with-md-cache-experimental
10:16 glusterbot Title: glusterfs/3.9.0.md at release-3.9 · gluster/glusterfs · GitHub (at github.com)
10:16 anoopcs Please note that it is experimental...
10:17 mindgaze yeah we tried that but that doesn't really help
10:17 mindgaze #smallfile --file-size 2 --files 500 --response-times Y on a volume still takes 20 sec
10:18 mindgaze via nfs 0.6 sec
10:25 shutupsq_ joined #gluster
10:36 mhulsman1 joined #gluster
10:42 panina joined #gluster
10:43 panina joined #gluster
10:44 karthik_us joined #gluster
10:49 mhulsman joined #gluster
10:52 sona joined #gluster
10:52 rafi1 joined #gluster
10:54 Akram joined #gluster
10:54 Akram hi all, HELP
10:55 Akram Is there any way to specify user UID for gluster mounted  volumes? in my case they appear to be mounted as root:root everytime, this causes issues
11:00 flying joined #gluster
11:03 BatS9 gluster volume set <glustervolume> storage.owner-uid <id>
11:05 john51 joined #gluster
11:06 apandey joined #gluster
11:06 mhulsman1 joined #gluster
11:19 mhulsman joined #gluster
11:19 atinm joined #gluster
11:24 rjoseph joined #gluster
11:26 Akram BatS9: I will try, thanks
11:26 hgowtham joined #gluster
11:29 Seth_Karlo joined #gluster
11:33 derjohn_mob joined #gluster
11:34 msvbhat joined #gluster
11:35 kdhananjay left #gluster
11:36 kotreshhr joined #gluster
11:40 Wizek__ joined #gluster
11:42 kdhananjay joined #gluster
11:46 atinm joined #gluster
11:47 jkroon joined #gluster
11:52 saintpablos joined #gluster
11:56 aravindavk joined #gluster
12:07 nbalacha joined #gluster
12:08 ivan_rossi left #gluster
12:08 mhulsman joined #gluster
12:13 atinm joined #gluster
12:23 kotreshhr joined #gluster
12:25 skoduri joined #gluster
12:34 siel joined #gluster
12:38 pcdummy joined #gluster
12:38 pcdummy joined #gluster
12:39 tdasilva joined #gluster
12:39 mindgaze joined #gluster
12:40 AppStore joined #gluster
12:40 kdhananjay joined #gluster
12:41 abyss^ joined #gluster
12:42 cloph_away joined #gluster
12:42 hybrid512 joined #gluster
12:43 jkroon joined #gluster
12:43 d0nn1e joined #gluster
12:46 siel joined #gluster
12:49 buvanesh_kumar joined #gluster
13:03 Wizek__ joined #gluster
13:05 Chinorro_ joined #gluster
13:05 Utking joined #gluster
13:05 Utking Hey guys!
13:05 Utking I'm having some problems with my glusterfs, the NFS part to be exact :p
13:05 Utking anyone care to help a poor guy? ^^
13:07 Utking My problem is that i'm not able to mount it as NFS from another client, i have been strugglign with this for two days now :/
13:08 Utking From the client:  mount -t nfs -o vers=3 192.168.1.109:/distributed /mnt/distributed
13:08 cloph first thing to check I guess is your firewall setup. and you should state whether you're using ganesha or not...
13:09 Utking my cat/etc/exports: /distributed *(rw,no_root_squash,fsid=11))
13:09 Utking Oh, im not using ganesha :)
13:09 Utking and this is my error: mount.nfs: access denied by server while mounting 192.168.1.109:/distributed
13:09 skoduri joined #gluster
13:10 skarlso joined #gluster
13:12 cloph stating the obvious: You did do "exportfs -a" after creating /etc/exports ?
13:15 _KaszpiR_ joined #gluster
13:17 Utking i only get a command not found when doing exportfs -a :S
13:18 ppai joined #gluster
13:25 jbrooks joined #gluster
13:29 Karan joined #gluster
13:30 mpingu_ Hello
13:30 glusterbot mpingu_: Despite the fact that friendly greetings are nice, please ask your question. Carefully identify your problem in such a way that when a volunteer has a few minutes, they can offer you a potential solution. These are volunteers, so be patient. Answers may come in a few minutes, or may take hours. If you're still in the channel, someone will eventually offer an
13:34 john51_ joined #gluster
13:35 martinetd joined #gluster
13:35 k4n0 joined #gluster
13:35 unclemarc joined #gluster
13:38 baber joined #gluster
13:38 mhulsman1 joined #gluster
13:44 atinm joined #gluster
13:51 mhulsman joined #gluster
13:53 jiffin joined #gluster
13:53 kramdoss_ joined #gluster
13:58 Karan joined #gluster
14:01 cholcombe joined #gluster
14:02 shyam joined #gluster
14:04 squizzi joined #gluster
14:06 Saravanakmr joined #gluster
14:11 pjrebollo joined #gluster
14:14 pjreboll_ joined #gluster
14:16 pjrebollo joined #gluster
14:17 ira joined #gluster
14:18 pjrebollo joined #gluster
14:18 aravindavk joined #gluster
14:22 Seth_Karlo joined #gluster
14:23 ankitr joined #gluster
14:24 rwheeler joined #gluster
14:26 nbalacha joined #gluster
14:37 mindgaze hi I tuned according to http://blog.gluster.org/2016/10/gluste​r-tiering-and-small-file-performance/ but still have very poor performance on the smallfile test
14:37 glusterbot Title: Gluster tiering and small file performance | Gluster Community Website (at blog.gluster.org)
14:38 mindgaze a very conservative test ./smallfile_cli.py --file-size 2 --files 500 --response-times Y --top /tmp/centos  still taks 6 secs
14:39 mindgaze somehow the hitratio of the cache is really bad
14:39 mindgaze #  find /var/run/gluster -name \*dump\* -exec grep -E 'stat_miss|stat_hit' {} \;
14:39 mindgaze stat_hit_count=152
14:39 mindgaze stat_miss_count=103160
14:40 mindgaze anyone have an inkling why I have such a bad cache hit ratio
14:40 skylar joined #gluster
14:40 mhulsman joined #gluster
14:45 shaunm joined #gluster
15:01 kotreshhr left #gluster
15:02 susant left #gluster
15:05 plarsen joined #gluster
15:05 Paeir joined #gluster
15:06 Paeir Hi, i have a problem. My cli log spams me with socket_event_handler messages and says 0-transport: disconnecting now. My Gluster also doesn't seem to work after a node restarts at all
15:09 mhulsman1 joined #gluster
15:14 shyam joined #gluster
15:15 kkeithley joined #gluster
15:15 kpease joined #gluster
15:16 kpease_ joined #gluster
15:20 buvanesh_kumar_ joined #gluster
15:20 kpease joined #gluster
15:21 kpease_ joined #gluster
15:22 mhulsman joined #gluster
15:29 cholcombe joined #gluster
15:34 Somedream joined #gluster
15:44 riyas joined #gluster
15:45 farhorizon joined #gluster
15:49 rastar joined #gluster
15:54 shyam joined #gluster
15:54 Wizek joined #gluster
16:00 wushudoin joined #gluster
16:02 msvbhat joined #gluster
16:13 ankitr_ joined #gluster
16:17 oajs joined #gluster
16:21 sona joined #gluster
16:23 Utking Does anyone else have any idea what could be wrong with my NFS setup?
16:24 Utking this is my error: mount.nfs: access denied by server while mounting 192.168.1.109:/distributed
16:24 Utking when trying to mount from a network client
16:24 Utking my cat/etc/exports: /distributed *(rw,no_root_squash,fsid=11)
16:25 Utking this is the mount command: mount -t nfs -o vers=3 192.168.1.109:/distributed /mnt/distributed
16:25 Utking and im not using ganesha
16:27 Gambit15 joined #gluster
16:47 jdossey joined #gluster
16:48 Shu6h3ndu joined #gluster
16:49 xumpi joined #gluster
16:51 superbofh joined #gluster
16:51 f0rpaxe joined #gluster
16:52 Shu6h3ndu joined #gluster
17:03 jiffin joined #gluster
17:07 farhorizon joined #gluster
17:11 farhorizon joined #gluster
17:14 ankitr_ joined #gluster
17:18 gyadav joined #gluster
17:19 skoduri joined #gluster
17:29 pjrebollo joined #gluster
17:31 Karan joined #gluster
17:33 jkroon joined #gluster
17:35 rastar joined #gluster
17:36 jiffin Utking: are u using kernel nfs?
17:38 ankitr_ joined #gluster
17:42 Humble joined #gluster
17:43 cholcombe joined #gluster
17:52 mhulsman joined #gluster
17:53 mhulsman joined #gluster
17:56 shutupsquare joined #gluster
17:57 shutupsq_ joined #gluster
17:59 ij left #gluster
18:00 shutups__ joined #gluster
18:00 ashiq joined #gluster
18:32 Utking i'm using the NFS server in glusterfs, the one that has been deprecated :p
18:36 bhakti joined #gluster
18:42 cholcombe joined #gluster
18:49 Utking the thing is i can connect with NFS locally on the same proxmox server via the gui, but not from another client
18:54 pjrebollo joined #gluster
19:04 buvanesh_kumar joined #gluster
19:05 shutupsquare joined #gluster
19:08 pjrebollo joined #gluster
19:16 sre joined #gluster
19:16 pjrebollo joined #gluster
19:16 sre hi all....anyone got openshift to use gluster as a volume following the instructions here: https://docs.openshift.org/latest/install_c​onfig/storage_examples/gluster_example.html
19:18 pjreboll_ joined #gluster
19:19 mhulsman joined #gluster
19:31 pjrebollo joined #gluster
19:35 baber joined #gluster
19:37 farhorizon joined #gluster
19:39 jwd joined #gluster
19:45 farhorizon joined #gluster
19:45 pjrebollo joined #gluster
19:47 Seth_Kar_ joined #gluster
19:48 moneylotion joined #gluster
19:48 derjohn_mob joined #gluster
19:56 jockek joined #gluster
19:56 cliluw joined #gluster
19:59 fubada joined #gluster
20:04 Seth_Karlo joined #gluster
20:07 moneylotion joined #gluster
20:08 mhulsman joined #gluster
20:10 ttkg joined #gluster
20:16 pjrebollo joined #gluster
20:19 baber joined #gluster
20:28 moneylotion joined #gluster
20:31 fubada Hi, Im seeing a ton of client side errors http://pastebin.ca/3770902 but nothing server side..no files in splitbrain reported server side on any volumes
20:31 glusterbot Title: pastebin - Someone - post number 3770902 (at pastebin.ca)
20:31 fubada can someon ehelp me troubleshoot this one
20:31 fubada also, client side CPU usage and machine load very high. Server cpu is basically idle
20:36 sre @fubada what type of client are you using?
20:36 fubada fuse
20:36 fubada glusterfs-3.7.11-1.el7.x86_64
20:37 JoeJulian "dht_migration_complete_check_task" seems like this has to do with an active rebalance?
20:37 farhorizon joined #gluster
20:38 fubada Number of Bricks: 1 x (2 + 1) = 3 is what I have
20:38 fubada 2 replicas and an arbiter
20:38 JoeJulian huh
20:38 mlg9000 joined #gluster
20:41 fubada according to volume heal info and status all is fine: http://pastebin.ca/3770917
20:41 glusterbot Title: pastebin - Anonymous - post number 3770917 (at pastebin.ca)
20:42 fubada but the client side logs are full of split-brain errors, i cant figure out whats actually going on
20:42 fubada but client side CPU utilization by the glusterfs process is through the roof
20:43 mlg9000 Hi All, I'm looking at using glusterfs with oVirt for my VM's.  I think I need 10GbE to each server (replica 3, 3 racks/ fiber extenders) but not sure if 10GbE is fine to the core too... anyone with real world experience?
20:43 rwheeler joined #gluster
20:48 jbrooks joined #gluster
20:53 JoeJulian fubada: I'm still looking at the source trying to figure out how you could hit that bit of code.
20:53 fubada thank you JoeJulian
20:54 fubada nothing in server side logs indicating any issues
20:54 fubada Im using the latest Gluster container from Dockerhub for the 3 node cluster
20:54 fubada glusterfs-3.8.5-1.el7.x86_64
20:55 fubada (server side)...3.7.11 client side
20:57 nirokato joined #gluster
21:01 JoeJulian meh, meeting. bbl.
21:01 farhorizon joined #gluster
21:05 saybeano joined #gluster
21:08 vbellur joined #gluster
21:12 pjrebollo joined #gluster
21:17 jdossey joined #gluster
21:18 shyam joined #gluster
21:21 buvanesh_kumar joined #gluster
21:48 Vapez_ joined #gluster
21:50 utking joined #gluster
21:51 utking Hi guys! Im trying again^^
21:51 utking Is there anyone who can help me with my NFS problem with gluster? i've been stuck with this for two days now, and i think i've read all there is on google!
21:51 utking Not running NFS ganesha
21:52 utking my error from client
21:52 utking mount.nfs: access denied by server while mounting 192.168.1.109:/distributed
21:52 utking NFS server is running when i check with gluster status
21:52 utking and i can mount it locally in proxmox
22:00 utking ok, is there any way to restart just the NFS part of gluster?
22:19 ndevos utking: make sure you do not have any non-gluster services running related to NFS
22:19 ira joined #gluster
22:19 ndevos utking: if there is a service like nfs-lock, nfs-server, nfs-client or such, those need to be disabled on the storage servers
22:20 ndevos utking: only rpcbind should be there, and when gluster/nfs is not running, it should only have a portmapper service listed in 'rpcinfo'
22:20 shyam joined #gluster
22:20 ndevos utking: once gluster/nfs starts, it will register the mountd, nlockmgr and a few other services in rpcbind
22:21 ndevos utking: the error you get, is most likely because there is a rpc.mountd process running (and registered at rpcbind)
22:23 fubada JoeJulian: I think I figured it out. My issue was with a single file constntly getting created/removed
22:23 fubada and it caused client side gluster errors
22:53 jdossey joined #gluster
23:03 jdossey joined #gluster
23:04 moneylotion joined #gluster
23:05 baber joined #gluster
23:10 jdossey_ joined #gluster
23:25 moneylotion joined #gluster
23:44 cyberbootje1 anyone got glusterfs working on freebsd? and if so, is it stable?
23:45 daMaestro joined #gluster
23:48 vbellur cyberbootje1: I know a few users using it. We have not done any intensive testing and hence not sure about the stability of the port.
23:49 cyberbootje1 hmm ok

| Channels | #gluster index | Today | | Search | Google Search | Plain-Text | summary