Perl 6 - the future is here, just unevenly distributed

IRC log for #metacpan, 2014-04-04

| Channels | #metacpan index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:40 t0m left #metacpan
01:38 klapperl joined #metacpan
01:51 oiami joined #metacpan
03:01 Christofosho joined #metacpan
04:21 Christofosho joined #metacpan
05:06 ether_ joined #metacpan
05:28 omega more than 999 results (0.744 seconds)
05:29 omega what is that time? is it time from ES search, or from start to end of request?
05:29 omega it sounds high (in reference to loading speed)
06:18 dolmen joined #metacpan
07:30 neilb joined #metacpan
07:52 * ranguard thinks it's ES time
07:56 omega doesn't that sound like a lot for a search for "catalyst"?
08:11 neilb joined #metacpan
08:26 neilb joined #metacpan
08:39 Seveas joined #metacpan
09:09 neilb_ joined #metacpan
10:30 oiami hi ! on https://github.com/CPAN-API/metacpan-web/pull/1143
10:30 dipsy [ Store user sorting type in cookie and set as default by oiami · Pull Request #1143 · CPAN-API/metacpan-web · GitHub ]
10:30 oiami I see Error — The Travis CI build could not complete due to an error
10:30 oiami what does it mean ? test fail ?
10:31 oiami I ran $prove -vlr t but all tests pass on my machine
10:51 alnewkirk joined #metacpan
11:00 ranguard oiami: looks like a glitch in Travis - https://travis-ci.org/CPAN-API/metacpan-web/builds/22256585 - you can see if passed on all perls except 5.18
11:00 dipsy [ Travis CI - Free Hosted Continuous Integration Platform for the Open Source Community ]
11:01 ranguard https://travis-ci.org/CPAN-API/metacpan-web/jobs/22256586 then shows that is was a problem installing Starman: Installing the dependencies failed: Installed version (0.034) of Module::Build::Tiny is not in range '0.035'
11:01 dipsy [ Travis CI - Free Hosted Continuous Integration Platform for the Open Source Community ]
11:01 ranguard Bailing out the installation for Starman-0.4009.
11:01 oiami ranguard:  can I do anything with that ?
11:02 ranguard I think just add a commit and update the pull request so that it tries again
11:03 ranguard if that doesn't work we'll need to add a specific requirement of 0.035 for Module::Build::Tiny in the carton file - OH! - starman just released a new version
11:03 oiami ranguard:  which perl version that Travis is using ?
11:04 ranguard 5.18 is the one that failed, 5.10 -> 5.16 all passed
11:04 oiami ohh, many versions there hehe :D
14:42 Christofosho joined #metacpan
17:10 kentnl joined #metacpan
17:10 neilb joined #metacpan
18:01 kentnl joined #metacpan
19:25 punter joined #metacpan
20:48 rashi joined #metacpan

| Channels | #metacpan index | Today | | Search | Google Search | Plain-Text | summary