Perl 6 - the future is here, just unevenly distributed

IRC log for #metacpan, 2016-10-19

| Channels | #metacpan index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
06:25 Khisanth joined #metacpan
06:31 oiami joined #metacpan
08:15 osfabibisi joined #metacpan
08:21 neilb joined #metacpan
13:05 kentnl joined #metacpan
13:13 mst joined #metacpan
14:00 oiami joined #metacpan
14:00 BinGOs joined #metacpan
16:51 ether joined #metacpan
20:36 metacpan joined #metacpan
20:36 metacpan [metacpan-client] mickeyn pushed 3 new commits to master: https://git.io/vP9xt
20:36 metacpan metacpan-client/master 529d2de Mickey Nasriachi: take prereqs from cpanfile
20:36 metacpan metacpan-client/master 9fc6888 Mickey Nasriachi: limit Search::Elasticsearch version
20:36 metacpan metacpan-client/master 68a5aaf Mickey Nasriachi: release 1.026000
20:36 metacpan left #metacpan
20:49 [Tux] WTF: https://gist.github.com/Tux/a49b65865192568a37ae7484baf6f537
20:50 [Tux] ExtUtils::MakeMaker
20:50 [Tux] /pro/lib/perl5/site_perl/5.22.0/ExtUtils/MakeMaker.pm: 7.24
20:53 oalders no idea what that's about
20:54 mst it's saying you need to *specify* a new enough makemaker
20:55 mst so that the generated makefile.PL deps on a version that has the feature
20:55 mst I think
20:55 mst eumm_version sounds like a config option to the dzil plugin
20:55 haarg yes
20:56 mst [Tux]: basically it doesn't care that your version is new enough, it cares that you configure it to make sure users' versions are new enough
21:19 ether I added that warning; I can explain further if it's still unclear
21:20 ether EUMM earlier than 7.1101 turns version ranges into '0', which is pretty darned useless and probably not what the author wants
21:20 ether instead of Dist::Zilla automatically injecting a configure_requires for EUMM 7.1101, we decided it would be better to warn about it
21:22 ether MetaCPAN-Client is using old APIs in Search::Elasticsearch which have since been removed or changed
21:22 ether so until that's fixed (which is probably not a quick job, or it would have already happened), there's a <= prereq specified.
21:29 mickey ether: will a fixed version instead of the range make it happy? (I just need to avoid the latest Search::Elasticsearch release)
21:32 haarg no
21:32 haarg old EUMM only understands plain version numbers (equivalent to >=)
21:35 ether right, saying "3.0" means "3.0 or greater"
21:35 ether so the latest version would satisfy that, and then kaboom.
21:36 mickey that's why i added the <= :)
21:36 mickey which is not really good cause now older versions are also satisfied... i'll have to change that regardless
21:37 neilb joined #metacpan
21:40 ether so you might need ">= 1.0, <= 3.0"
21:41 ether (I'm making up the numbers since I can't remember what they are)
21:42 mickey yeah, exactly what i'm currently doing :) thanks
21:42 metacpan joined #metacpan
21:42 metacpan [metacpan-client] mickeyn pushed 1 new commit to master: https://git.io/vPHk8
21:42 metacpan metacpan-client/master 0a136ae Mickey Nasriachi: fix version range for Search::Elasticsearch (restore limit on older than 2.02)
21:42 metacpan left #metacpan
21:44 TBSliver joined #metacpan
21:45 metacpan joined #metacpan
21:45 metacpan [metacpan-client] mickeyn pushed 1 new commit to master: https://git.io/vPHkH
21:45 metacpan metacpan-client/master 104a0bd Mickey Nasriachi: release 1.026001
21:45 metacpan left #metacpan
23:41 mickey joined #metacpan
23:47 mickey joined #metacpan

| Channels | #metacpan index | Today | | Search | Google Search | Plain-Text | summary