Camelia, the Perl 6 bug

IRC log for #mojo, 2011-10-01

| Channels | #mojo index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
01:21 chorny joined #mojo
02:46 zenbitz joined #mojo
02:52 alnewkirk joined #mojo
03:47 * crabthewhite throws sri off a mountain with a balrog
03:47 crabthewhite gotta get rid of you so i can come back and take over
03:48 zenbitz joined #mojo
04:45 * tempirethefuschia modernizes the story
05:48 kaare joined #mojo
05:56 MojoGuest330 joined #mojo
06:24 perlrocks Twitter: "Testing with Mojo is great fun. The Mojolicious framework provides an easy way to test your web applications wit... http://t.co/YNSKetFk" --Mariellabugii http://twitter.com/Mariellabu​gii/status/120021214675742720
07:02 Vandal joined #mojo
07:07 MojoGuest90 joined #mojo
07:08 MojoGuest90 ;)
07:11 perlite_ joined #mojo
07:20 anaio joined #mojo
07:25 MojoGuest898 joined #mojo
07:31 Eugene joined #mojo
07:59 noganex_ joined #mojo
08:33 MojoGuest347 joined #mojo
08:44 Eugene joined #mojo
08:51 Eugene joined #mojo
09:11 srithewhite crabthewhite: i'm back!
09:47 GitHub146 joined #mojo
09:47 GitHub146 [mojo] kraih pushed 1 new commit to master: http://git.io/FKZdGQ
09:47 GitHub146 [mojo/master] disable some more tests on Windows with older Perl versions - Sebastian Riedel
09:47 GitHub146 left #mojo
09:48 crabthewhite dammit, that's not how it was supposed to go
09:48 crabthewhite i'm going to sulk and turn over to the dark side
09:50 srithewhite Oo
10:48 * sri wonders if it's time again for the 5.8 discussion again
11:23 alnewkirk joined #mojo
11:41 andrefs joined #mojo
12:18 shonorio joined #mojo
12:28 crabofthenine step 1. remove mentions of 5.8 support
12:28 crabofthenine step 2. make incompatible changes
12:28 crabofthenine who needs discussions?
12:37 andrefs joined #mojo
12:41 sri if only it was that simple
12:42 mspo I demand your software works with perl from 2002
12:42 sri we recently had a bug though that prevented installation on perl 5.8 for weeks before someone reported it
13:02 crab sri: yes, that's what i was remembering :)
13:03 sri i'm going to start the discussion by proposing to skip 5.10 in favor of 5.12 :)
13:06 stephanj joined #mojo
13:08 preflex_ joined #mojo
13:20 perlrocks Twitter: "Removal of #perl 5.8 support from #mojolicious is up for discussion again, speak up now or forever hold your peace. :) http://t.co/13MkepNB" --kraih http://twitter.com/kraih/status/120125945293189120
13:24 stephan48 sri: dont do it! i still have 5.8 on some systems i need mojo on and cant upgrade...
13:25 sri stephan48: make a case on the list
13:25 sri you'll need good arguments though
13:25 mohan joined #mojo
13:25 stephan48 sure i would need arguments...
13:25 stephan48 and this might not been a good argument
13:26 stephan48 even a sucking mundane default argument but i think its still valid
13:27 sri what argument?
13:27 purl This is abuse.
13:28 sri if you're using outdated distributions, why would you expect to be able to use the latest mojolicious?
13:30 sri and if supporting outdated distributions is so important for you would you be willing to pay for the support costs?
13:32 alnewkirk joined #mojo
13:44 sri anyway, this discussion happens on the list, not here
13:45 f00li5h joined #mojo
14:03 crab sri: btw, someone suggested httponly by default for the session cookie. i think that's a fine idea.
14:04 crab do you want a patch? or will you do it?
14:04 crab (since you seemed to agree too)
14:05 stephan48 wont that break ajax stuff?
14:05 crab why should it?
14:06 stephan48 when they depend on the session cookie?
14:06 stephan48 f.e. they access content which is access regulated by session...
14:08 crab does ajax stuff need to read the session cookie? i've never had to do so in my code.
14:09 crab doesn't the browser just send it with the xmlhttprequest?
14:10 stephan48 ye
14:11 stephan48 but that was my question :)
14:11 stephan48 or rather i meant it like: wont it need to be non httponly for xmlhttprequest to be read?
14:11 stephan48 but idk :)
14:12 crab i don't think it matters
14:12 stephan48 then its ok
14:13 crab http://stackoverflow.com/questions/27972/how​-do-httponly-cookies-work-with-ajax-requests
14:14 stephan48 good :)
14:21 sri crab: i was expecting a patch
14:27 crab sri: should be sufficient to call ->httponly(1) at the end of Mojolicious::Sessions::store, right?
14:28 sri crab: dunno
14:29 perlrocks Twitter: "When you write something and has stuck Mojolicious:: Amon2 by Lite:: DBI or by using" (ja) --memememomo http://twitter.com/memememom​o/status/120143234298163200
14:50 sri wonder what we would do if perl 5.16 added new cool syntax features
14:52 sri bit jealous of ruby, nobody cares that the next rails won't support ruby 1.8
15:13 zenbitz joined #mojo
15:47 crab sri: i'm ok with moving away from 5.8 because it's got serious security/other problems
15:47 crab but dropping support for older versions because of "new cool" syntax features seems much less justified
16:16 grim_fandango joined #mojo
16:16 sri crab: you don't know what 5.16 might bring
16:16 sri what if it was a game changer?
16:16 marty moin
16:17 sri like say signatures and pretty class syntax
16:17 sri class Mojolicious extends Mojo { method handler ($tx) {…} }
16:18 * sri waves
16:19 marty Would new syntax like that require a lot of refactoring for Mojo?
16:19 sri nope
16:19 sri but it would require 5.16
16:20 sri the big question really is how cool would a perl release have to be to make it disruptive enough to break with all legacy :)
16:20 marty My first reaction is "pretty damn cool"   :)
16:21 sri for me i think signatures would hit that spot
16:21 marty I'm not familiar enough with signatures to make an informed opinion.  But I get a feeling you are.  :)
16:22 sri http://search.cpan.org/~rhesa/Method-Signature​s-Simple-1.02/lib/Method/Signatures/Simple.pm
16:22 sri that's the most popular implementation atm
16:23 sri at the moment it requires some very harsh xs magic and a compiler to install
16:23 sri but what if that was a core feature?
16:23 marty ohh ya.  That's pretty niffty.  Opens up lots of possibilities.
16:25 marty I just responded on the list about the 5.8 discussion.  My question is... Doesn't perlbrew make perl versions a non issue?
16:26 marty So if 5.16 is needed, just install it via perlbrew (when it is available) and Viola!  Yer dunz
16:27 marty Make perlbrew a prerequisite for Mojolicious.  :)
16:27 sri for me it already is :)
16:28 sri but we also have to think of the beginners that just want their shit to work
16:28 sri not to mention enterprise folks...
16:28 sri they are actually the real problem
16:29 crab public static Mojolicious extends Mojo { public void handler (tx) {...} }!
16:29 marty They always are.  :)
16:31 sri less java more scala please ;p
16:33 crab scalalicious: less mojo, more scales
16:34 sri :D
16:35 marty Heck, just the ability to change the invocant name is enough to convince me to move to 5.16 if they offer signatures. :)
16:36 marty s/they/it/
16:36 marty afk
16:38 trone_ joined #mojo
16:47 gbacon joined #mojo
17:18 noganex joined #mojo
17:23 MojoGuest629 joined #mojo
17:23 MojoGuest629 From: http://blog.kraih.com/?page=3 (1 hits)
17:23 MojoGuest629 Hi! It`s really works?
17:25 MojoGuest629 /help
17:26 MojoGuest629 Yes. It`s works! :)
17:34 MojoGuest137 joined #mojo
17:34 MojoGuest137 From: http://www.google.com.hk/search?source=ig&hl=z​h-TW&rlz=&q=websocket+demo&oq=websoc&a​mp;aq=1&aqi=g10&aql=&gs_sm=e&gs_up​l=1031l3084l0l5131l6l6l0l0l0l0l210l617l3.2.1l6l0 (1 hits)
17:35 MojoGuest137 hello
18:31 robinsmidsrod joined #mojo
18:49 Kulag joined #mojo
18:53 Kulag joined #mojo
19:23 GitHub71 joined #mojo
19:23 GitHub71 [mojo] kraih pushed 1 new commit to master: http://git.io/zdrsIg
19:23 GitHub71 [mojo/master] increased Perl version requirement to 5.10.1 - Sebastian Riedel
19:23 GitHub71 left #mojo
19:26 sri 70 lines of code removed, mostly by using the // operator :)
19:28 sri lib is now exactly at 12000 lines
19:29 sri t is 3661 lines ahead now :o
19:49 tempire I'd be ok with Mojolicious requiring 516 because of cool new syntax features, as long as a MOP/Declare module was provided for people on older versions.
19:49 tempire "get the same features with a few more dependencies"
19:50 sri that would be a nice solution
19:56 abra joined #mojo
20:01 perlrocks Twitter: "[Mojolicious] [apache] mod_proxy + Mojolicious (:: Lite) http://t.co/iumkZpLT If deployed" (ja) --memememomo http://twitter.com/memememom​o/status/120226748204974080
20:12 mattastrophe joined #mojo
20:44 Akron joined #mojo
22:06 grim_fandango joined #mojo
22:10 macroz joined #mojo
22:31 macroz joined #mojo
22:39 andrefs joined #mojo
22:41 MojoGuest874 joined #mojo
22:41 MojoGuest874 From: http://www.google.com/search?gcx=c&sou​rceid=chrome&ie=UTF-8&q=irc+html5 (1 hits)
22:57 macroz joined #mojo
23:11 Akron joined #mojo
23:19 GitHub178 joined #mojo
23:19 GitHub178 [mojo] kraih pushed 1 new commit to master: http://git.io/d_eYrA
23:19 GitHub178 [mojo/master] use more Perl 5.10 features - Sebastian Riedel
23:19 GitHub178 left #mojo
23:40 preflex_ joined #mojo

| Channels | #mojo index | Today | | Search | Google Search | Plain-Text | summary