The web in a box - a next generation web framework for the Perl programming language

IRC log for #mojo, 2017-07-23

| Channels | #mojo index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:18 itaipu joined #mojo
00:45 mr_wibble joined #mojo
01:10 itaipu joined #mojo
01:51 ilbot2 joined #mojo
01:51 Topic for #mojo is now � nom nom | http://mojolicious.org | http://irclog.mojolicious.org | http://code-of-conduct.mojolicious.org
02:05 noganex joined #mojo
03:20 Phil21 joined #mojo
05:39 bianca joined #mojo
06:02 petru_ joined #mojo
06:50 Vandal joined #mojo
06:54 flamey joined #mojo
08:08 dod joined #mojo
08:13 dod joined #mojo
08:33 bianca joined #mojo
09:12 bianca joined #mojo
10:05 brunoramos joined #mojo
10:25 bianca joined #mojo
10:55 itaipu joined #mojo
11:34 kes joined #mojo
12:06 zach anyone ever done JWT in mojo before?
12:07 zach I feel like I have to be doing the verify_iss thing wrong because I'm trying to get it to show an error and it's not
13:29 pink_mist pretty sure there are modules for it
13:35 jabberwok i have successfully sent and used jwt tokens based on this:  http://perltricks.com/article/193/2015/9/18/How-to-send-verification-emails-using-Mojolicious/
13:50 flamey joined #mojo
14:07 flamey hey guys. I need some help figuring out base url in my small app running on shared hosting/apache. the issue comes up in routes that are not at root (not /link, but /link1/link2).
14:07 flamey I was aking about it yesterday, sri mentiend I could have incorrect setup. but I followed the Apache setup article in mojo wiki, and pretty sure I have it set up as described there.
14:07 flamey I described my setup and the issue in some details here: https://stackoverflow.com/questions/45263380/mojolicious-base-url-when-running-mojolicious-lite-app-on-apache-under-subdirect
14:07 flamey and would greatly appreciane any tips to try
14:09 sri flamey: the wiki is not a guide
14:09 sri everybody can edit it, we don't know if it works
14:09 bianca joined #mojo
14:11 sri everything in the wiki is uncurated
14:12 sri (and don't look at me for answers, i don't remember anything about Apache rewriting... not done it in many years)
14:15 pink_mist flamey: I think someone recently had success by setting the SCRIPT_NAME env var to ... an empty string?
14:17 petru_ joined #mojo
14:20 flamey sri, I understand, I wasn't pointing fingers : )) I just thought maybe someone will see the issue and know exactly what it is, just feels like I'm missing a little piece...
14:20 flamey i know it's not common, though, to run it in this setup, so I guess not
14:20 flamey I'll google about the SCRIPT_NAME
14:20 flamey will report back if it works
14:23 flamey I'm not a sw dev, btw. sorry if my rumbling is not very clear. just love Perl do get some things done, been doing in for years as needed... and thanks, for creating Mojolicious and maintaining, btw. love it
14:38 bianca joined #mojo
14:41 Skylos_ joined #mojo
15:19 jabberwok flamey: why are you calling url_for with no argument?  What happens if you do <%= url_for('/') %> ...?  or perhaps pass the actual desired path:  <%= url_for('/css/styles.css') %> ...?
15:20 sri btw. the perltidy-more extension for vscode now works with the mojo extension
15:20 sri so, that's the one to use, not perltidy
15:31 PryMar56 joined #mojo
15:59 flamey jabberwok: <%= url_for('/') %> just gives me "/" , let me try url for css
16:00 flamey $ENV{SCRIPT_NAME} = '' didn't do anything
16:11 petru_ joined #mojo
16:12 flamey wow, this is it!! thank you!
16:12 flamey <%= url_for('/css/styles.css') %> gave the complete correct path.
17:01 sh14 joined #mojo
17:06 jabberwok cheers
17:16 dod joined #mojo
17:40 itaipu joined #mojo
18:19 zerah joined #mojo
18:32 gordonfish joined #mojo
18:38 bianca joined #mojo
18:44 abra joined #mojo
18:47 zerah joined #mojo
18:53 Lee_ joined #mojo
18:58 petru_ joined #mojo
19:27 zivester joined #mojo
20:16 purl joined #mojo
20:45 itaipu joined #mojo
20:48 petru_ joined #mojo
22:03 itaipu joined #mojo
22:21 Ptolemarch joined #mojo
23:10 zach what's wrong with this line?
23:10 zach $r->get('/password/reset/:token')->to('user#reset_token')->name('token');
23:11 zach I'm getting empty responses and the reset_token sub is never getting executed
23:27 schelcj joined #mojo
23:58 Grinnz zach: check that Your::Namespace::User is a Mojolicious::Controller subclass
23:58 zach Grinnz: ugh, there was nothing wrong with it
23:59 zach Grinnz: so I made an email body to send a JWT as the end of a route to get pulled in and in the email body I forgot to put the s for https and so it tried http and it failed, I added the s and it magically worked
23:59 zach Grinnz: two hours wasted
23:59 Grinnz heh

| Channels | #mojo index | Today | | Search | Google Search | Plain-Text | summary