Camelia, the Perl 6 bug

IRC log for #motoactv, 2013-01-16

| Channels | #motoactv index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:00 dproldan rotation doesn't work,  (but it worked this morning in one of my tests)
00:01 dproldan the most important thing at the moment
00:01 dproldan is
00:01 dproldan finding a way to do the busybox thing
00:01 dproldan at the moment, when I flash teh system.img
00:02 dproldan I boot into recovery,  and issue a "busybox --install -s ."
00:02 dproldan that makes all the links for me
00:02 Atarii copy all those from the device
00:02 Atarii and the add them into the system.img
00:02 Atarii when you do the mount thing to convert to ext3
00:03 dproldan when I pull them with adb,  they lose the "link" quality,  they appear as full binaries,  837 KB each
00:03 Atarii that's because they are following the likn
00:03 Atarii hmm
00:04 dproldan I tried making a tar
00:04 dproldan from inside the MotoACTV
00:04 dproldan I got the links in my desktop,  but the owner for each file is me,  not root or system
00:05 dproldan maybe that's fixed in init?
00:05 Atarii couldn't you chown them because adding them in?
00:05 Atarii before*
00:06 dproldan sorry,  don't get what you mean
00:06 Atarii chown root /xbin/*
00:06 Atarii like that
00:07 Atarii then add them to the system.img (via mounting it)
00:07 dproldan let me try
00:08 Atarii i've g2g
00:08 Atarii haven't done much tonight :(
00:08 Atarii kids are hard work lol
00:08 dproldan yeah,  me too
00:08 dproldan enough for today
00:08 Atarii anyways good job on the boot :)
00:08 dproldan btw
00:09 dproldan chown: cannot dereference `wc': No such file or directory
00:09 dproldan :-)
00:09 dproldan thanks
00:09 dproldan see ya
00:09 Atarii heh cya :)
08:01 Atarii joined #motoactv
08:01 Atarii joined #motoactv
08:13 dproldan joined #motoactv
11:29 dproldan Atarii: it's a bit dangerous,  because the battery doesn't charge,  but,  if you want to try:
11:29 dproldan https://docs.google.com/file/d/0​BxTLcy78OveNcVZxVW4yWjRJQkU/edit
16:28 dproldan joined #motoactv
16:35 zobi8225 hi
16:35 dproldan hello
18:07 Atarii hey dproldan
18:07 dproldan hey
18:07 Atarii my computer has been logged in all day whilst i was at work!
18:08 dproldan heh
18:08 Atarii just going to have tea then i'll be back on to try that image
18:08 Atarii cya in a bit
18:09 dproldan wait a bit,  adb doesn't work with a standard cable
18:09 dproldan i'm trying to fix it
18:09 dproldan I have fixed the issues with /data and /cache when wiped
19:24 Atarii hey back now
19:25 Atarii i'll try and get my factory cable working
19:32 Atarii dproldan did you say you have ubuntu 11.10
19:33 dproldan yep
19:37 Atarii so what are you working on now?
19:38 dproldan getting audio working
19:38 Atarii you copied over the libs from the stock ROM?
19:39 dproldan yes,  some of them
19:39 dproldan when the system complains,  I copy it  :-)
19:39 Atarii heh :)
19:40 dproldan have a problem with the display not turning off
19:40 dproldan it goes black when I push the power button,  but the backlight stays on
19:42 dproldan also,  why does adb only work with the factory cable?
19:42 Atarii hmm
19:43 Atarii ah
19:43 Atarii that's build.prop i think
19:43 Atarii persist.service.adb.enable=1
19:46 Atarii did you use the build.prop from the stock ROM?
19:46 dproldan sorry, back
19:47 dproldan I have the default.prop like this:
19:47 dproldan persist.factory.allow_adb=1
19:47 dproldan persist.service.adb.enable=1
19:47 dproldan just as a rooted rom
19:47 Atarii ah ok
19:47 Atarii which kernel did you use? the stock one?
19:47 dproldan yep
19:47 dproldan no changes to boot.img so far
19:52 Atarii back in a second
19:53 Atarii|afk joined #motoactv
19:54 Atarii joined #motoactv
19:54 Atarii joined #motoactv
19:59 dproldan I get this with a standard usb cable:
19:59 dproldan 01-02 00:13:13.913  1063  1098 W Vold    : Ignoring unknown switch 'usb_connected'
19:59 dproldan 01-02 00:13:13.921  1073  1073 I BATTD   : Battd USB INSERT = Success
19:59 dproldan 01-02 00:13:13.921  1073  1073 I BATTD   : Requested charge current 0mA; setting to 0mA (entry 0)
19:59 dproldan 01-02 00:13:13.921  1069  1069 I usbd    : process_usb_uevent_message(): cable type: usb
19:59 dproldan 01-02 00:13:13.921  1069  1069 I usbd    : process_usb_uevent_message(): USB online
19:59 dproldan 01-02 00:13:13.921  1069  1069 I usbd    : main(): Cable Status Changed, need to notify Cable Status to App
19:59 dproldan 01-02 00:13:13.960  1073  1073 I BATTD   : set_charge_voltage=4200
19:59 dproldan 01-02 00:13:13.960  1073  1073 I BATTD   : Requested charge current 0mA; setting to 0mA (entry 0)
19:59 dproldan 01-02 00:13:13.991  1073  1073 I BATTD   : Requested charge current 45mA; setting to 45mA (entry 4)
19:59 dproldan 01-02 00:13:13.991  1073  1073 I BATTD   : set_charge_current=45
20:01 dproldan this with a factory cable:
20:01 dproldan
20:01 dproldan
20:01 dproldan 01-02 00:13:25.788  1063  1098 W Vold    : Ignoring unknown switch 'usb_connected'
20:01 dproldan 01-02 00:13:25.804  1073  1073 I BATTD   : Battd Factory USB INSERT = Success
20:01 dproldan 01-02 00:13:25.804  1069  1069 I usbd    : process_usb_uevent_message(): cable type: factory
20:01 dproldan 01-02 00:13:25.804  1069  1069 I usbd    : process_usb_uevent_message(): USB online
20:01 dproldan 01-02 00:13:25.812  1069  1069 I usbd    : usbd_set_usb_mode(): new_mode: eth_adb
20:01 Atarii isn't that voltage high?
20:01 Atarii oh no
20:01 Atarii ignre me
20:01 dproldan no,  that's ok  :-)
20:01 Atarii I was thinking of current lol
20:01 Atarii current looks a bit low
20:02 dproldan yeah,  another thing to look at
20:02 Atarii have you got wireless adb on?
20:03 dproldan nah,  haven't tried to set up wifi yet
20:03 Atarii oh yea, forgot wifi drivers arn't in yet
20:03 dproldan maybe this is in some config file:   usbd_set_usb_mode(): new_mode: eth_adb
20:04 Atarii oh
20:04 Atarii that's the usb networking
20:04 Atarii you can connect to
20:04 dproldan but it says that when I connect te factory cable
20:05 dproldan with a normal cable, it says this:  usbd    : main(): Cable Status Changed, need to notify Cable Status to App
20:05 Atarii 192.168.16.2 is the address to connect to for that
20:05 dproldan there was a usbmanager apk in the stock rom IIRC
20:05 Atarii guess that would relate to "need to notify Cable Status to App"
20:06 Atarii maybe that needs to change the mode
20:06 dproldan trying to install it
20:06 dproldan usb.apk
20:07 Atarii yea found the source for that
20:07 Atarii looks promising
20:08 Atarii "Factory cable is handled directly in process_usb_uevent_message"
20:08 Atarii that's why that works
20:08 dproldan ok
20:09 dproldan naturally,  sub.apk is going to depend on more motorola libraries,  etc… :-)
20:09 dproldan :-(
20:10 Atarii well i think we can get the source
20:10 Atarii so can integrate it directly
20:10 Atarii this is the milestone one: https://github.com/a853/a853_usbd
20:11 dproldan dalvikvm: Could not find method android.os.MotoEnvironment.ge​tExternalAltStorageDirectory, referenced from method com.motorola.usb.UsbService.isSDCardPath
20:12 dproldan looking for how this is handled by vanilla android
20:15 Atarii yea this is a common motorola api
20:15 Atarii can't yet see which framework file it's in, in the stock ROM
20:16 Atarii this is the jar with the class in: http://www.java2s.com/Code/Jar/a/Downl​oadandroidmotorolastorageapi10jar.htm
20:17 Atarii it's in: com.motorola.android.frameworks.jar
20:17 Atarii in the stock ROM
20:17 Atarii com.motorola.android.frameworks.jar\com\mot​orola\android\storage\MotoEnvironment.smali
20:18 dproldan yeah,  ok
20:18 dproldan I wanted to keep this free of moto stuff
20:18 dproldan :-(
20:18 Atarii hmm
20:18 dproldan not possible,  I guess
20:19 Atarii not sure why motorola would implement all this
20:19 Atarii surely there is stock equivilant
20:19 dproldan dunno,  couldn't find usbd in the sources
20:20 Atarii there's hardly anything in that file, it's only like 38 lines of java
20:20 Atarii gets this system property: ro.mot.internalsdcard
20:22 dproldan I knew this would happen,  now it wants java.lang.NoClassDefFoundError: com.motorola.android.provider.MotorolaSettings
20:22 Atarii lol :(
20:25 dproldan of course:     PackageManager: Package com.motorola.android.providers.settings has no signatures that match those in shared user android.uid.system; ignoring!
20:26 Atarii hmm this sucks
20:30 dproldan bbl,  dinner
20:35 Atarii ok:)
20:35 Atarii me too
20:41 CEnnis91 dproldan: great! i saw you have an aosp booting
20:45 dproldan yeah!  some work still to do,  but it's a promising start
20:46 dproldan mostly hardware related,  everything works in soft
20:47 dproldan search,  web browser,  widgets,  wallpapers,,  etc
20:57 dproldan CEnnis91: you still have the MA?
20:57 CEnnis91 yes
21:01 Atarii hey CEnnis91
21:05 dproldan CEnnis91: wasn't there a trick to write eth_adb to the usb_mode?
21:06 Atarii write /dev/usb_device_mode msc_adb
21:06 Atarii write /tmp/usbd_current_state usb_mode_charge_adb
21:06 Atarii chmod 0666 /tmp/usbd_current_state
21:06 Atarii start adbd
21:06 Atarii somethign like that
21:07 dproldan k,  I'll try that later
21:08 Atarii that was in the ramdisk
21:09 Atarii for sholes
21:09 CEnnis91 yea idk about that trick
21:12 dproldan I'm uploading another preview,  only works with the factory cable though
21:12 Atarii ok cool :)
21:23 dproldan https://www.dropbox.com/s/7dz2​qvmadq9i2o8/reACTVpreview2.zip
21:23 dproldan it has misc.img, recovery.img and system.img
21:23 Atarii cool thanks
21:23 Atarii is it still uploading?
21:23 dproldan boot.img should be the DPRom9 or stock
21:24 dproldan no, it finished already
21:24 Atarii a lot smaller than the first
21:24 Atarii 107 to 47
21:24 dproldan yeah ,  teh first one had the userdata too
21:24 Atarii ah ok
21:24 dproldan and acache
21:25 dproldan because it wouldn't boot if you wiped them
21:25 dproldan misc and recovery can be flashed to get adb with a standard cable
21:26 Atarii you and your __MACOSX folders ;p
21:26 dproldan oops
21:26 dproldan http://imgur.com/wtbVc
21:26 Atarii oh nice, you fixed the icons :D
21:27 Atarii funny colours lol
21:27 dproldan http://imgur.com/lnzjL
21:27 Atarii is that how the colours look?
21:27 Atarii or is that the screenshot app?
21:27 Atarii binary*
21:28 dproldan I need to put a property in the build env
21:28 dproldan let me see
21:28 dproldan I think it's this :   BOARD_USE_YUV422I_DEFAULT_COLORFORMAT := true
21:29 dproldan trying now
21:29 Atarii ah ok
21:35 Atarii got 11.10 installed dproldan so i can try the build again
21:35 Atarii are all your latest changes in?
21:36 dproldan no,  one sec
21:36 Atarii ok thanks
21:38 dproldan now it is
21:40 dproldan btw,  I had to revert to the vanilla webkit sources,  the motorola webkit wouldn't work once flashed
21:41 Atarii right ok
21:41 Atarii oh yea i think i remember you mentioning that last night
21:41 dproldan do yo have to sync the android repos again?  :-)
21:44 Atarii yes
21:44 Atarii everything loll
21:49 Atarii btw dproldan does this build not charge with standard usb?
21:50 dproldan the charging light doesn't turn on,  but logcat says it gets 45 mA for charging
21:50 dproldan don't know if it charges or not
21:50 Atarii that could be less than it uses though I guess
21:51 dproldan yeah,  probably
21:51 dproldan I guess it's also related to the moto usb modifications
21:59 Atarii btw do you remember if you ran this:
21:59 Atarii sudo apt-get install libx11-dev:i386
21:59 Atarii from here: http://source.android.com/source/initializing.html
22:00 dproldan I guess,  tried ot follow that to the letter
22:01 Atarii because it says when i run that:
22:01 Atarii WARNING: The following essential packages will be removed.
22:01 Atarii This should NOT be done unless you know exactly what you are doing!
22:01 Atarii You are about to do something potentially harmful
22:01 Atarii To continue type in the phrase ‘Yes, do as I say!’
22:01 dproldan lol
22:02 dproldan dunno, sorry  :-)
22:02 dproldan be brave
22:02 dproldan let me check
22:02 dproldan one sec
22:04 dproldan don't know if I can list packages installed by apt-get
22:07 dproldan yes
22:07 dproldan libx11-dev seems to be installed
22:07 dproldan 1.4.4-2ubuntu1
22:09 Atarii ok :) thanks
22:58 Atarii repo sync is fun...
22:58 dproldan lol
23:03 Atarii think i'm going to head off, can't get much done with this lol
23:04 Atarii cya later :)
23:04 dproldan yep
23:04 dproldan bye

| Channels | #motoactv index | Today | | Search | Google Search | Plain-Text | summary