Camelia, the Perl 6 bug

IRC log for #motoactv, 2013-01-19

| Channels | #motoactv index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
09:51 dproldan joined #motoactv
11:53 dproldan anybody can get me the output of amixer?
11:55 dproldan which you can get from here:   http://forum.xda-developers.com/showp​ost.php?p=28718716&postcount=2515
15:50 Atarii joined #motoactv
15:50 Atarii joined #motoactv
16:04 Atarii hey
16:04 dproldan hi
16:04 Atarii how's it going?
16:05 dproldan so so
16:05 dproldan can't get audio working
16:06 dproldan not even with alsa_aplay
16:06 Atarii ah, you copying source from other motorola phones or just using the precompiled ones from the ROM?
16:06 dproldan source + stock,  mostly
16:07 Atarii I reset my VM with 10.04 btw
16:07 dproldan it's a PITA when I don't have another MA for checking things
16:07 Atarii you mean one with stock ROM on?
16:07 dproldan did you flash preview7? did it work?
16:08 dproldan yes,  one with stock rom
16:08 Atarii that didn't boot either :(
16:08 dproldan wow
16:10 dproldan are you back to dprom9?
16:10 dproldan maybe you can get me the output of "amixer"
16:10 dproldan which you can download from here:  http://forum.xda-developers.com/showp​ost.php?p=28718716&postcount=2515
16:11 Atarii i'm not at my pc atm
16:11 Atarii i can do it in a bit though
16:11 dproldan ok
16:11 dproldan let me check why preview7 doesn't boot
16:12 Atarii i got 2.3.4 source compiled successfully on 10.04
16:12 dproldan oh!  great
16:12 Atarii but after copying in the motorola sources, it fails (with the same error as before)
16:12 Atarii so atleast im a bit closer lol
16:13 dproldan remember,  I removed the folders from AOSP  before extracting the moto sources
16:13 Atarii ohh!
16:13 dproldan don't merge
16:13 Atarii which folders?
16:13 Atarii damn i bet thats it lol!
16:14 dproldan one sec,  i'll give an example
16:14 Atarii awesome, thanks dproldan
16:16 dproldan moto sources  : external-bluetooth-bluez.tgz     have to replace     YOURROOT2.3.4AOSPFOLDER/external/bluetooth/bluez
16:16 dproldan so,  you go into external,  bluetooth,  and delete the bluez folder  (actually save it somewhere else for comparing later)
16:17 Atarii right!
16:17 Atarii ok ill try that thanks :)
16:17 dproldan then  extract external-bluetooth-bluez.tgz  into external/bluetooth/
16:18 dproldan be sure to name the extracted folder as bluez
16:20 dproldan actually,  extract external-bluetooth-bluez.tgz  to    YOURROOT2.3.4AOSPFOLDER/
16:20 dproldan the folder estructure has been saved in the tgz files
16:21 Atarii right ok :)
16:24 dproldan are you trying to use CCACHE?
16:24 dproldan i've read that it can give errors, I'm not using it
16:24 Atarii im using it currently
16:25 Atarii ill try disabling that if this next oine doesnt work
16:25 dproldan ok
16:26 dproldan also,  if I do "make -j4"  sometimes it fails,  but if I do "make -j3" it works
16:27 Atarii ah ok, thanks for that too
16:27 Atarii i was doing 4 so ill reduce that
16:27 dproldan btw,  CCACHE in a VM seems a bit too much?
16:27 dproldan it says it needs 50 GB
16:28 Atarii yea i reduced it to 20GB
16:30 dproldan I see
16:30 dproldan you didn't follow the instructions to the letter :-P
16:30 Atarii heh no
16:31 Atarii hence why its not working probably :p
16:35 dproldan wtf,  extracted system.img,  wiped,  flashed it back,  and it doesn't boot
16:37 Atarii damn now there's no working booted one
16:40 Atarii you have the compiled one in your VM though right?
16:40 Atarii did you change it after flashing?
16:40 dproldan yeah,  a couple of binaries,  inserted
16:41 dproldan I'm seeing ext3fs errors when I mount system in recovery
16:41 Atarii ah
16:41 Atarii wrong fs type issues again?
16:42 Atarii how did you get into recovery btw?
16:42 Atarii using the misc.img?
16:42 dproldan yep
16:42 dproldan using mbm's recovery that has adb enabled
16:42 Atarii yea cool
16:43 Atarii compiling a newer CWM is on the todo list too
16:46 Atarii touch recovery would be cool
16:49 dproldan ok,  the compiled img works fine,  the errors seem to have ocurred during extraction
16:51 Atarii dammit same error
16:52 dproldan take that CCACHE thing out,  if you can...
16:52 Atarii ok
17:14 Atarii damn
17:14 Atarii system/core/libnetutils/ifc_utils.c:33:30: error: linux/ipv6_route.h: No such file or directory
17:15 dproldan https://www.dropbox.com/s/v7ay​nwjrj3yk18k/ReACTVpreview8.zip
17:16 Atarii nice you fixe it?
17:16 dproldan well this one booted on mine,  after wiping,  no extraction involved,  direct from the build
17:17 Atarii ok cool
17:17 dproldan can you build generic-userdebug still?
17:18 Atarii ill try
17:19 Atarii ill kick that off and be back later, dinner time :)
20:36 Atarii back
20:43 Atarii you around dproldan?
21:08 dproldan hi
21:08 dproldan yes
21:08 dproldan sup
21:11 Atarii hey :)
21:11 Atarii ive flashed dprom9 ready for any commands
21:11 Atarii also
21:11 Atarii can you do this other command for me please?
21:11 Atarii find . > files.txt
21:11 Atarii then i can check i have all the same files as you, in your motoactv_development folder
21:12 dproldan ok
21:14 dproldan that's a 20 MB file
21:14 dproldan uploading...
21:15 Atarii wow that was bigger than expected lol
21:15 Atarii oh did you have a build folder i guess
21:25 dproldan yeah
21:25 dproldan i'll erase that
21:28 Atarii oh damn
21:28 Atarii i think i may have realised
21:30 Atarii oh f~@:@"£$("£^$(*£"$!!!!
21:30 Atarii haahah
21:30 dproldan :-)
21:30 Atarii i missed bionic.tgz from the sourceforge download site!
21:30 dproldan no way
21:30 Atarii what a fucking waste of time
21:30 Atarii lol
21:32 Atarii trying a build with that
21:37 dproldan does this work?
21:37 dproldan https://www.dropbox.com/s/​3jey9x0oswrp817/files.txt
21:38 Atarii yes, but it's cut off
21:38 Atarii at: /dalvik/tests/004-annotations/​src/android/test/anno/AnnoArra
21:38 Atarii i may not need that now, if this build works
21:44 dproldan be sure to sync the git repos
21:46 Atarii have you added your latest stuff?
21:46 dproldan yes
21:47 Atarii ok thanks :)
21:59 dproldan building still?
22:01 Atarii yes lol :(
22:01 Atarii nee to get ubuntu on my other machine
22:01 Atarii so i don't have to use VM
22:04 dproldan do you know in what package is the screen lock system?
22:04 dproldan launcher? systemUI?
22:05 Atarii systemUI i think
22:06 Atarii you mean the lockscreen right?
22:06 Atarii with the sliders?
22:06 dproldan yep
22:06 dproldan I want to put them aside
22:06 Atarii there's a few cool mods on xda for lockscreens
22:07 Atarii you may need to mod android.policy.jar too
22:08 Atarii that has the lockscreen smali code
22:09 dproldan they're in framework-res
22:10 dproldan keyguard_screen_....
22:13 Atarii ah ok :)
22:13 Atarii you may need to change the smali to change the orientation though
22:14 dproldan nah,  it's ok
22:14 dproldan there's one for landscape
22:14 Atarii ah ok :)
22:24 Atarii damn, build failed, different error though
22:24 Atarii external/bluetooth/hcidump/src/hcidump.c:54: error: redefinition of 'ntoh64'
22:24 Atarii ah found a fix
22:24 dproldan yeah,  you showed me that fix
22:25 Atarii haha oh
22:25 Atarii round and round in circles
22:25 dproldan :-)
22:53 dproldan und?
22:53 Atarii still going lol
22:53 Atarii how's the lockscreen going?
22:53 dproldan wow
22:54 dproldan how much memry you gave the VM?
22:54 dproldan lockscren looks much better now
22:54 dproldan let me screenshot it
22:54 Atarii only 1.5GB
22:56 Atarii did you want me to run amixer for you btw?
23:01 dproldan http://imgur.com/QBOPBPb
23:01 dproldan oh, yes please
23:02 Atarii aah nice
23:02 dproldan it's so fast to modify things now
23:02 dproldan :-)
23:03 Atarii what do you mean?
23:03 dproldan just modify the xml,  then mm nameofpackage,  and it's done
23:04 Atarii oh heh :D
23:05 dproldan i don't know what's wrong with the battery icon in the status bar
23:05 Atarii do you want the whole amixer output?
23:06 dproldan yes, please
23:06 dproldan MA has a really good audio chip
23:06 dproldan lots of options
23:07 Atarii http://pastie.org/5730703
23:11 dproldan looks like I have a couple of volumes at 0
23:12 dproldan I hope that's the issue
23:13 Atarii ok hope so
23:14 Atarii i did a compare btw
23:14 Atarii and /etc/asound.conf is different
23:14 Atarii between reACTV and DPROMb9
23:15 Atarii could be realted
23:15 dproldan yeah,  I already changed that
23:15 Atarii ah ok
23:28 dproldan no luck
23:29 Atarii :(
23:38 dproldan ok let's go step by step
23:39 dproldan nah,  I have no clue
23:40 dproldan there are several errors,  mediaserver is segfaulting, etc
23:40 dproldan but sound should work with aplay as far as I know
23:40 dproldan can you test it?
23:42 dproldan here:  https://www.dropbox.com/s/​6kawt9xrfrakwf8/alsa_aplay
23:44 dproldan try:  alsa_aplay -l
23:44 Atarii ok
23:45 dproldan and alsa_aplay -v /preinstall/svox/resources/TTS/Data​/en-US_female/waves/en_US_during_ex​ercise_try_to_replace_at_l__1.wav
23:47 Atarii http://pastie.org/5730866
23:48 dproldan k,  that's the same
23:48 Atarii http://pastie.org/5730868
23:49 dproldan good,  did it  make any noise?
23:49 dproldan try with a headset
23:51 Atarii hmm nothing
23:51 dproldan crap
23:51 dproldan I had no idea how much they fucked this up
23:52 dproldan I hope they're not using pvplayer or something like that

| Channels | #motoactv index | Today | | Search | Google Search | Plain-Text | summary