Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2013-11-26

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:38 MegaMatt joined #openam
03:33 MegaMatt joined #openam
03:34 MegaMatt joined #openam
07:50 ludovicp joined #openam
08:10 bthalmayr joined #openam
08:13 hos001 joined #openam
09:01 hos001 joined #openam
09:03 kim__ any idea?
12:13 MegaMatt joined #openam
12:35 ibenox joined #openam
14:28 Zendron joined #openam
14:33 Zendron Hello! I'm having trouble when I set the agent property filter to ALL, I receive an 403 page after login on OpenAM. If I set to SSO_ONLY all works well but I need to work with JAAS. Does someone knows some tutorial or documentation covering this issue?
14:39 balo Zendron: set it to J2EE_POLICY or leave it to ALL and set the notenforced uri or add policies.
14:40 balo In your  agent debug log you can see that you get 403 because the agent can't decide what to do with that uri resource
14:41 balo so if you need openam policies use ALL else you can go with J2EE_POLICY
14:54 Zendron joined #openam
16:28 Zendron joined #openam
16:37 pdurbin joined #openam
16:41 Zendron Balo: Thanks, I will try it now, just a moment!
16:49 Zendron One of the error on Agent's log: Failed to obtain auth service url from server: null://null:null
16:49 Zendron And above: AmFilter: Error while delegating to inbound handler: J2EE Local Auth Task Handler, access will be denied
16:49 Zendron I left J2EE_POLICY as a filter
16:50 balo yeah, the null:null message is not used to be an issue.
16:50 balo the other is interesting. did you restart your container?
16:51 Zendron Yes, I'm using InteliJ with JBoss AS7! I change the properties from my agent and I restart the Jboss
16:51 Zendron I think I'm doing something wrong in my application!
16:53 balo which openam/agent version are your working with?
16:54 balo I'm using 11.0 / 3.3 with jboss as7 and J2EE_POLICY and it works.
17:26 Zendron joined #openam
18:29 Zendron Do you use the LoginModule from OpenAM or you implement the JAAS Login module for yourself? Do you did some special configuration in web.xml?
18:29 Zendron I use the same version as you!
18:31 Zendron Do I need set the security-constraint on web.xml?
19:16 asyd depend how web.xml looks like :)
19:44 balo Zendron: yeah, I remember it now, I needed to add a dummy security constraint to my web.xml too: https://github.com/kir-dev/korok/blob/master/sch-pek-web/src/main/webapp/WEB-INF/web.xml
19:56 Zendron Balo: Great!!! kkkk, I will try it now!! Lets see...
19:58 Zendron Balo: It works!!!!!!!!!! Great!!!! You save my life kkkkkkkk!! Negative points to Jboss!!
19:59 balo i like it :b
20:04 Zendron I will follow you on github Balaz, if you some help just contact me!
20:17 ludovicp joined #openam
22:36 ludovicp joined #openam
22:37 ludovicp joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary