Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2014-04-08

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
06:34 pfreixes joined #openam
06:45 SteveFerris joined #openam
07:59 fatbloke joined #openam
09:48 ilbot3 joined #openam
09:48 Topic for #openam is now Chat about the OpenAM project - http://download.forgerock.com - OpenAM 11.0.0 is out!!! - OpenAM 10.0.2 is out!!! Channel logs at: http://irclog.perlgeek.de/openam/today
09:50 tsmalmbe joined #openam
09:51 asyd joined #openam
09:54 GLHMarmot joined #openam
09:54 jjpp joined #openam
10:14 aldaris joined #openam
10:23 hos001 joined #openam
10:27 asyd aldaris: very nice blog posts!
10:28 aldaris ouch :)
10:30 aldaris yeah, I'm getting busier than usual nowadays, asyd
10:32 sayakb joined #openam
10:39 fatbloke joined #openam
10:39 jjpp joined #openam
10:40 Hunger- joined #openam
10:41 balo joined #openam
10:58 MegaMatt joined #openam
11:52 kala aldaris: hello. About doing upgrades. Do you already have a way to do zero-downtime upgrades on the cluster? With JRebel perhaps or some other trcikery?
11:53 aldaris that is a quite advanced subject
11:54 aldaris I would say there is a way to possibly do it, but it is rather tricky
11:54 kala I have an idea. about adding third ldap server to the cluster and then syncing sessions to that server and then running the service from that server. While the original OpenAM servers are upgrading. And after this is finished, then sync the sessions branch back
11:54 aldaris the main problem is https://bugster.forgerock.org/jira/browse/OPENAM-3192
11:55 kala hmm
11:55 aldaris the way to work around this is to disable replication between the configuration stores
11:55 kala ah ... now, this is about upgrading from 10.0 -> 11.0 ?
11:56 aldaris and upgrade one node at a time, then reenable replication between them and reinitialize
11:56 kala yes, disabling replication and enabling replication must be in the picture. Somewhere ...
11:56 kala . o O ( wonders, if the client would finance this kind of hacking :))
11:56 aldaris what do you want to upgrade from?
11:56 kala 11.0->11.0 ... or perhaps 11.0.1 or something like that
11:57 aldaris did you mean 10.1->11.0?
11:57 kala no
11:58 kala well. if we are doing a change in the production servers. HTML, strings, code, something else. This is a tomcat openam.war replacement, right? And after that we need to run the OpenAM upgrade wizard as well?
11:58 aldaris well you should only need the upgrade wizard if you modify the service schema
11:58 kala ok
11:58 kala we seem to have missed that part
11:59 aldaris though that means that your com.iplanet.am.version will remain the old version
12:20 MegaMatt joined #openam
12:24 ibenox joined #openam
13:10 pfreixes joined #openam
14:05 aldaris joined #openam
14:43 roysjosh joined #openam
17:35 MegaMatt_ joined #openam
17:43 aldaris joined #openam
21:10 MegaMatt joined #openam
21:20 m0sf3t joined #openam
21:54 MegaMatt joined #openam
22:18 aldaris joined #openam
22:27 MegaMatt joined #openam
22:50 tsmalmbe joined #openam
22:54 MegaMatt joined #openam
23:34 auke- joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary