Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2014-05-07

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:53 zendron joined #openam
01:47 ilbot3 joined #openam
01:47 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 11.0.1 is out!!! - OpenAM 10.0.2 is out!!! Channel logs at: http://irclog.perlgeek.de/openam/today
03:03 zendron joined #openam
04:32 tsmalmbe1 joined #openam
04:49 tsmalmbe joined #openam
06:07 pfreixes joined #openam
06:33 rghose joined #openam
06:58 aldaris joined #openam
07:11 SteveFerris joined #openam
07:40 SteveFerris joined #openam
07:59 kim___ joined #openam
08:00 kim___ What could cause OpenAM to return 200 with empty response durring login?
08:11 SteveFerris joined #openam
08:31 aldaris joined #openam
08:38 aldaris kim___ under what auth scenario?
08:46 kim___ Never mind, found the issue. Jmeter has some issues reading users from file, so username was empty
10:02 SteveFerris joined #openam
10:22 aldaris joined #openam
11:12 MegaMatt joined #openam
11:53 SteveFerris joined #openam
12:22 pfreixes joined #openam
12:33 SteveFerris joined #openam
13:35 zendron joined #openam
14:21 rghose1 joined #openam
14:22 rghose1 problem when installing. SEVERE: Caught exception: Error Configuring Directory Server. Any help?
14:22 MegaMatt What’s the rest of the message?
14:24 rghose1 Error Configuring Directory Server. at org.opends.quicksetup.installer.Installer$2.run(Installer.java:1071)
14:24 rghose1 this was the previous line: org.opends.quicksetup.installer.offline.OfflineInstaller run
14:26 MegaMatt Using the gui or config.jar ? some wacky char in there somewhere or something?
14:26 rghose1 gui from tomcat running in ssl mode
14:27 rghose1 SEVERE: Error installing. Error Configuring Directory Server. SEVERE: Caught exception: Error Configuring Directory Server.
14:27 MegaMatt 11.0 ?
14:27 rghose1 ya
14:28 MegaMatt What are your jvm settings? how much xmx?
14:28 aldaris can you see something in install.log?
14:29 rghose1 -Xms384M -Xmx1024M -XX:MaxPermSize=256m -Djava.awt.headless=true -Djava.net.preferIPv4Stack=true
14:30 rghose1 install.log: AMSetupServlet.processRequest: errorcom.sun.identity.setup.ConfiguratorException: configurator.embsetupopendsfailed
14:31 rghose1 at com.sun.identity.setup.EmbeddedOpenDS.setupOpenDS(EmbeddedOpenDS.java:371)
14:34 MegaMatt Are you running TC as root or something?
14:35 MegaMatt Not that it should matter
14:36 MegaMatt Just looking at other peoples resolutions, not sure why that one guy thought running as root was the root of the problem.. lol
14:36 rghose1 nope as user opensso
14:36 aldaris traitor :)
14:36 rghose1 I had 2 other instance of tomcat running openam on this box though. Which I had stopped prior to this
14:36 MegaMatt I’m pretty sure you get similar when java throws an OOM .. but I think those values should be sufficient
14:37 aldaris though I would certainly not set Xms to anything other than Xmx
14:38 MegaMatt yeah, but that’s minor
14:39 MegaMatt Just causes a full more GCs usually
14:39 MegaMatt *few more
14:40 MegaMatt you could try doubling the permsize and see if it works
14:40 MegaMatt heh
14:40 rghose1 hmm
14:40 MegaMatt double everything and see if it works ;)
14:40 MegaMatt I’d do that for giggles
14:40 rghose1 the more the merrier eh!
14:41 rghose1 well restarting tomcat and default configuration worked :P
14:41 MegaMatt Ah, maybe you didn’t really have those JVM options yet
14:41 rghose1 ah yeah probably
14:42 rghose1 god damn restarts
14:42 MegaMatt :D
14:42 rghose1 just when you think you are really stuck
14:42 rghose1 viola, a restart and it solves everything
14:43 rghose1 sick of this really
14:46 MegaMatt Should always shut it off and turn it on again first. ;) Troubleshooting 101 .. hehe
15:16 rghose1 well looks like openid connect breaks in ssl mode
15:18 aldaris oh, there is a bug for that
15:24 aldaris rghose1 google for the bug, I'm not gonna tell you which one it is ;)
15:25 failshell joined #openam
15:26 MegaMatt Does it have a 34 and a 33 in it?
15:26 rghose1 yeah found it :P
15:26 failshell MegaMatt: the other day, you had given me a link on how to setup opendj clustering. i forget to bookmark it. do you still have it handy?
15:27 MegaMatt You can probably look at the channel logs
15:27 aldaris I was thinking more about https://bugster.forgerock.org/jira/browse/OPENAM-3705
15:27 rghose1 actually, https://bugster.forgerock.org/jira/browse/OPENAM-3433
15:28 MegaMatt Was it http://ludopoitou.wordpress.com/2011/05/10/opendj-quick-replication-setup/ maybe?
15:28 MegaMatt They look like the same issue, imo
15:28 failshell yeah found it in the logs at the same time ;p
15:28 MegaMatt :D
15:33 failshell im prolly going to release my Chef cookbooks for opendj and openam once im done
15:35 MegaMatt Nice! In a blog post?
15:35 failshell most likely
15:35 failshell ive got the single node install/config done. missing the clustering.
15:35 failshell and then a LWRP to add configs like CoT, etc
15:36 rghose joined #openam
15:53 aldaris1 joined #openam
16:25 aldaris joined #openam
18:04 jfroot joined #openam
18:12 aldaris joined #openam
18:33 aldaris joined #openam
18:47 failshell so i did this, i wonder if it's ok or not. i installed 2 instances of openam having opendj local, then i linked both opendj instances using this: http://ludopoitou.wordpress.com/2011/05/10/opendj-quick-replication-setup/
18:47 failshell both openam have the same site configured
18:48 aldaris doesn't sound good
18:48 failshell please enligthen me
18:48 aldaris you should set up additional instances using the "Add to existing deployment" option on the configurator
18:48 failshell ah right
18:48 failshell i saw that
18:48 MegaMatt You’re replicating the onfiguration data?
18:49 failshell my goal is 2 openam/opendj instances in HA
18:49 failshell with session sharing etc
18:50 failshell BUT i have LB_SESSION_HA_SFO=true when i configured openam with the CLI configurator
19:02 pfreixes joined #openam
19:57 _br_ joined #openam
20:15 zendron joined #openam
21:41 aldaris joined #openam
22:06 jfroot_ joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary