Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2014-07-02

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:13 MegaMatt joined #openam
00:25 aldaris joined #openam
01:07 aldaris joined #openam
01:40 aldaris joined #openam
03:03 em-dash joined #openam
03:48 em-dash joined #openam
07:02 rghose1 joined #openam
08:02 aldaris joined #openam
08:36 fatbloke joined #openam
10:25 rghose1 joined #openam
10:57 em-dash joined #openam
11:29 ramteid joined #openam
11:31 MegaMatt joined #openam
11:42 aldaris joined #openam
11:53 rghose1 hey, in the HOTP module, by default e-mails are sent to  phone_number@txt.att.net. I need to change the @txt.att.net part and hence changed the "Mobile Carrier Attribute Name" but seems like this does not work ?
12:01 MegaMatt did you try restarting?
12:01 rghose1 restarting openam or the mail server ?
12:01 MegaMatt openam
12:01 rghose1 aah no. trying that
12:01 aldaris txt.att.net is actually the default mail suffix when you have SMS sending enabled!
12:02 MegaMatt It is? My attribute is blank in the console
12:02 rghose1 yeah it is hardcoded :P
12:02 aldaris and the mobile carrier attribute name is an LDAP attribute name. That attribute should contain the carrier
12:02 rghose1 aah alright
12:03 MegaMatt Should fix the info pane then ;)
12:03 MegaMatt “The code is different for each carrier. For example, if you will use Verizon as your carrier, you would enter @vtext.com or vtext.com in this field. Contact your carrier to find out the specific code should be used and find out whether they require country codes for the service.”
12:03 rghose1 yeah totally misleading :P
12:04 aldaris bugster.forgerock.org
12:04 MegaMatt But it makes more sense to have it an ldap attribute, so each user can have their own carrier ;)
12:04 rghose1 yes totally
12:04 rghose1 also it makes sense to have something as a fallback
12:04 MegaMatt At least the name of the field is “attribute name” rather than something suggesting it’s not an ldap attribute
12:04 rghose1 which can be configured
12:44 MegaMatt_ joined #openam
12:49 rghose1 I keep getting this: ERROR: ConsoleServletBase.onUncaughtException
12:49 rghose1 java.lang.NullPointerException
12:49 rghose1 sometimes
12:50 MegaMatt Check the email alias
12:51 rghose1 when I click on some tabs? It happens randomly! how does email alias come in to the picture :)
12:52 MegaMatt I think it was asked there? At least it comes up on a quick search
12:52 MegaMatt https://lists.forgerock.org/pipermail/openam/2013-June/012466.html
12:52 MegaMatt Which points to http://bugster.forgerock.org/jira/browse/OPENAM-2280
12:53 MegaMatt Which says Possible workaround when this happens on the console: try to change the browser locale to english.
12:53 rghose1 um, I never changed the locale in the first place ?
12:54 MegaMatt Go through the rest of the thread and bug then maybe?
12:56 rghose1 ok, so how do I change the locale? any ideas?
12:56 MegaMatt which browser?
12:56 rghose1 chrome
12:56 rghose1 chromium*
12:57 rghose1 btw, this war was built from source
12:57 rghose1 and I did change some locale files
12:57 rghose1 for the default locale
12:58 MegaMatt So does the bug description kinda match what you did?
12:58 MegaMatt PropertyXMLBuilderBase::getDefaultEncoding() sets the default XML encoding to UTF-8 whereas old XML content relies on platform specific encodings. As a result, uncaught exceptions may be thrown in the console if there are special characters in the localization.
12:58 rghose1 yeah I think so
12:59 rghose1 even the openam platform local is en_US
12:59 MegaMatt You built OpenAM 11 though, right?
12:59 rghose1 yeah
12:59 MegaMatt Should be fixed there
13:00 rghose1 get the same issue with firefox as well
13:00 rghose1 and it randomly works
13:00 rghose1 and randomly does not
13:32 em-dash joined #openam
14:09 MegaMatt joined #openam
14:15 em-dash joined #openam
14:42 mkulke joined #openam
14:43 mkulke hello, is there a way to access the svn repo anonymously?
14:45 MegaMatt Yes, what version of SVN are you using?
14:45 MegaMatt The older SVN can connect anon
14:48 mkulke uhm clientwise?
14:48 MegaMatt yep
14:49 mkulke 1.8.9
14:49 MegaMatt yep, too new
14:50 mkulke ah thx, intellij has 1.7 packaged
14:50 mkulke this works
14:50 MegaMatt I think we suggest 1.6 actually
14:50 MegaMatt iirc
14:51 MegaMatt Or else it will have some weird plugin error when you try to build
14:51 MegaMatt See: https://wikis.forgerock.org/confluence/display/openam/Build+OpenAM+from+Source
14:51 mkulke ahh
14:52 dmain joined #openam
15:13 fatbloke joined #openam
15:20 ramteid joined #openam
15:26 fatbloke joined #openam
15:34 aldaris joined #openam
16:10 aldaris joined #openam
16:28 em-dash joined #openam
16:54 em-dash joined #openam
17:01 aldaris joined #openam
17:40 cocotton joined #openam
17:41 cocotton Hey all. I'm looking to create a user with RO rights (which will be used to test if the login is working) but I'm not too sure how to do that. From what I understand, I'll need to create a realm, and then add a user in it. Is this the correct way to start?
17:46 aldaris joined #openam
18:00 aldaris1 joined #openam
18:01 cocotton Hmmm it seems that no matter what the realm the which I create a user, its has admin rights :/
18:05 aldaris joined #openam
18:27 em-dash joined #openam
18:52 aldaris joined #openam
19:06 fatbloke joined #openam
19:28 aldaris joined #openam
19:52 em-dash joined #openam
20:29 MegaMatt joined #openam
20:58 aldaris joined #openam
22:23 em-dash joined #openam
23:44 em-dash joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary