Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2014-08-14

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:10 aldaris joined #openam
00:30 aldaris joined #openam
00:41 MegaMatt joined #openam
01:06 MegaMatt joined #openam
03:52 GLHMarmo1 joined #openam
03:52 asyd_ joined #openam
03:53 metadaddy|vacati joined #openam
03:53 ibenox joined #openam
03:56 ilbot3 joined #openam
03:56 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 11.0.1 is out!!! - OpenAM 10.0.2 is out!!! Channel logs at: http://irclog.perlgeek.de/openam/today
04:11 ilbot3 joined #openam
04:11 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 11.0.1 is out!!! - OpenAM 10.0.2 is out!!! Channel logs at: http://irclog.perlgeek.de/openam/today
05:22 ramteid joined #openam
06:22 rghose joined #openam
07:23 asyd morning folks
07:24 fatbloke joined #openam
07:41 hos001 joined #openam
08:05 aldaris joined #openam
08:51 aldaris joined #openam
09:31 aldaris joined #openam
09:43 KermitTheFragger joined #openam
10:15 aldaris joined #openam
10:46 khushildep joined #openam
10:46 khushildep Hi All
10:47 khushildep I’m reading http://openam.forgerock.org/openam-documentation/openam-doc-source/doc/webhelp/dev-guide/rest-api-authz-policies.html#rest-api-authz-policies-update and trying to use the example to update a policy but I keep getting a 500 Internal Server error but nothing in anyof the logs in debug. Anyone come across this before?
10:47 aldaris what is your exact request?
10:56 khushildep curl  --request PUT --header "iPlanetDirectoryPro: AQIC5wM2LY4….*” --header "Content-Type: application/json" --data '{"name":"test-policy", "subject": { "type": "User", "subjectName": "marksyzm" }}' http://serverurl:8080/openam/json/policies/test-policy
10:56 aldaris are you testing this on a nightly build?
10:56 khushildep OpenAM 12.0.0-SNAPSHOT Build 10110 (2014-August-14 02:40)
10:56 aldaris well I guess that's recent enough then
10:56 aldaris do you see anything in the container logs?
10:57 khushildep which ones in particular
10:59 aldaris depends on your container
10:59 rghose1 joined #openam
11:00 khushildep tomcat
11:00 aldaris then catalina.out
11:00 khushildep Nothing of note at all in there...
11:01 aldaris alright
11:01 aldaris so let's look at OpenAM debug logs then
11:01 khushildep which file should I look at CoreSystem?
11:02 aldaris honestly I don't know :/
11:02 aldaris I would assume Policy though
11:06 khushildep Hmm. I see:
11:06 khushildep amPolicy:08/14/2014 11:04:10:297 AM UTC: Thread[http-bio-8080-exec-16,5,main]
11:06 khushildep returning named policy: test-policy for organization: dc=openam,dc=forgerock,dc=org
11:06 khushildep but the curl gets back:
11:06 khushildep {"code":500,"reason":"Internal Server Error","message":"Unable to retrieve policy test-policy."}
11:08 aldaris does the session ID belong to amadmin?
11:10 khushildep Yep. Was extracted from the cookie when I loging to webui with amadmin account.
11:11 aldaris well unfortunately the debug logging around that code is, well, shite
11:11 khushildep The policy is in the top level realm so I’m assuming that http://serverurl:8080/openam/json/policies/test-policy is correct (no realm after json/)
11:11 aldaris edit the policyresource class and add some debugging there, or debug the PolicyResource#updateInstance method
11:14 MegaMatt joined #openam
11:17 khushildep hmm for some reason now when I got the ‘Policies’ section I get http://access.sphoniclabs.net:8080/openam/base/AMUncaughtException
11:18 aldaris well, sorry about that
11:18 aldaris if you can make this error reproducible please file a bug in JIRA
11:20 khushildep I’m getting this "2014-08-14 11:16:09"   OAuth2Provider.error    19a10e0e23f8b10201      "cn=dsameuser,ou=DSAME Users,dc=openam,dc=forgerock,dc=org"     "Not Available" INFO    dc=openam,dc=forgerock,dc=org   LOG-2   "cn=dsameuser,ou=DSAME Users,dc=openam,dc=forgerock,dc=org"     "Not Available" OAuth2Provider.error
11:21 aldaris the audit logs are rather useless when you want to debug issues
11:23 khushildep I seem to getting ERROR: LogMessageProviderBase.formatMessage: FAILED_AUTHENTICATE_CLIENT mismatch in number of elements in string array with that is defined in message ID XML file in CoreSystem debug now...
11:26 aldaris that's usually a recoverable error
11:28 khushildep but this one may not be… http://pastebin.com/JK3QF3yU
11:28 khushildep After running those update curls I seem to have fubar’d the policies? *worries*
11:29 aldaris did you create a policy without any rules specified?
11:32 khushildep yes
11:32 khushildep shoudl I delete policies?
11:32 aldaris guess that killed it
11:38 khushildep How do I go about ‘resetting’ policiies. The ‘test-policy’ won’t even let me delete it..
11:41 aldaris manually deleting it from directory?
11:42 khushildep from backend datastore? OpenDDJ?
12:02 aldaris from the configuration store
12:17 MegaMatt (Which could be a opendj external)
13:54 fatbloke joined #openam
14:43 khushildep Hey all. When updaing a policy with the REST API, do I have to send all the policy details back in or just the bits I want updated?
14:50 aldaris I think you need to send in the whole thing
14:50 MegaMatt TIAS
15:21 khushildep Thanks chaps.
15:24 khushildep I’m trying to follow along at http://openam.forgerock.org/openam-documentation/openam-doc-source/doc/webhelp/dev-guide/rest-api-authz-policies.html#rest-api-authz-policies-create 6.1.2 but seem to be falling at the first hurdle( http://pastebin.com/39CBr3e8) it feels like I’m missing some piece of configuration perhaps.
15:30 aldaris well
15:30 aldaris json/example is not an endpoint
15:30 aldaris json/policies/example may be a bit better
15:34 khushildep ah of course - so now, http://pastebin.com/GCMLT2zn which is odd because that resource is used in a policy I created using the UI...
15:36 aldaris there was a commit like yesterday
15:36 aldaris I think the excluded JSON object is no longer necessary
15:36 aldaris the format changed a bit
15:39 aldaris see https://bugster.forgerock.org/jira/browse/OPENAM-4074
15:39 aldaris hmm, this isn't committed yet, my bad
15:53 khushildep so I tried POST and I get http://pastebin.com/W5kRV1Yx - aldaris: that’s not going to be the reason for my issues her right/
16:08 khushildep what should be in the ‘resources’ section of the input JSON - nothing I put in there seems to be ‘valid’ but putting the same thing in a GUI created policy seems to work…
16:10 aldaris try to GET an existing policy
16:10 aldaris that should show you
16:18 khushildep duoh!
16:18 khushildep yeah that makes sense :-P
16:27 KermitTheFragger joined #openam
16:28 khushildep should I be following this - http://openam.forgerock.org/openam-documentation/openam-doc-source/doc/webhelp/dev-guide/rest-api-policy-management-create.html
16:28 khushildep I wonder - the docs are a bit confusing tbh
16:33 khushildep even stranger when I curl for a policy I can see in the policy tab I get curl responded to with a ‘policy does not exist’ when it clearly does. we don’t use realms so everything is in top level
17:16 khushildep should resources be based off refereals? there doesn’t seem to be a good place for an understanding of how they relate.
18:06 khushildep I’m not possibly moments from going insane. I have a policy I created without error on the UI. A curl to list it shows me ( http://pastebin.com/PFzf5zZM ). I now ammed the JSON slightly and try to create a new policy thus ( http://pastebin.com/i7nazNeh ) and yet as you can see I have some strange ‘Invalid Resource’ messsage. Anyone know what might be going on here? The www.domain.com is set as an Alias for the Top
18:06 khushildep Level Realm which is the only realm I have.
18:29 aldaris joined #openam
18:30 MegaMatt joined #openam
19:23 aldaris joined #openam
19:37 MegaMatt joined #openam
19:48 khushildep Is there any reason why the button to create a refereal is greyed out?
20:06 aldaris joined #openam
20:07 balo joined #openam
20:07 balo re
20:09 balo so, a tricky question: can i configure the oauth2 auth module that it shows the login page instead of instant redirect? :)
20:10 balo i tried to add name and choice callbacks to the first callback in OAuth.xml but didn't work
20:11 aldaris1 joined #openam
20:17 aldaris joined #openam
20:27 khushildep hmm {"statusCode":303,"statusMessage":"Invalid Resource http://www.domain.com/widgets/line-charts/*"}
20:27 khushildep isn’t 303 a ‘See Other’ - why is it trying to redirect?
21:13 MegaMatt joined #openam
22:20 aldaris joined #openam
23:01 aldaris joined #openam
23:44 aldaris joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary