Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2014-10-21

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
02:56 MegaMatt joined #openam
04:55 ramteid joined #openam
06:39 aldaris joined #openam
06:51 TKA joined #openam
06:55 aldaris1 joined #openam
07:10 rghose joined #openam
07:48 aldaris joined #openam
08:12 kala hello
08:13 kala aldaris: do you think that https://bugster.forgerock.org/jira/browse/OPENDJ-660 might impact the OpenAM 11.0 as well?
08:14 aldaris no
08:14 aldaris I think 11.0.0 was shipped with at least 2.6.0-sdk
08:14 kala we are seeing some exceptions which point to that direction
08:14 kala yes. 2.6.4
08:14 aldaris 2.6.9 is better
08:15 kala howveer, the "affects version" and "fix versions" info is not very consistent on that issue
08:15 aldaris why?
08:15 kala affects 2.6.0 and fixed in 2.6.0?
08:16 kala they should be different, I think?
08:16 aldaris affects an unreleased version?
08:16 kala ah. ok
08:37 kala yes. this OPENDJ-660 is definitely included in the SDK 2.6.4. however, we see exceptions "An error occurred while trying to authenticate a user: org.forgerock.opendj.ldap.ErrorResultException: Operations Error: Bind or Start TLS operation in progress"
08:37 aldaris maybe different version of the sdk is on the classpath?
08:37 kala and also some errors about the heartbeat failures
08:37 kala hmm
08:38 kala thats a good question
09:20 KermitTheFragger joined #openam
09:24 eivind joined #openam
09:47 kala aldaris: well. I think the server is using the correct version of the SDK. At least the opendj-ldap-sdk-2.6.4.jar has 2.6.4 in it. And when I unpack every zip, war and jar in our release package, I only find the HeartBeatConnectionFactory.class from the SDK
09:47 kala however, the problem musteriously just went way ... the exception rate is down from about 60 per minut to 1 per hour :)
09:47 kala "went away"
09:49 aldaris still you should use 2.6.9..
09:49 kala you are probably right
09:51 kala is there a changelog for that?
09:51 aldaris see JIRA
10:10 kala btw, the opendj-ldap-sdk has different options for debug logging, right?
10:10 aldaris different compared to?
10:12 kala I see lines such as if (DEBUG_LOG.isLoggable(Level.FINE))
10:13 kala the level fine is something else from OpenAM regular debug levels
10:13 aldaris yes, the DJ SDK uses JUL
10:13 kala ah
10:13 kala I remember, I once turned that on
10:14 kala I wonder where I documented that  :-)
10:18 asyd morning
10:18 aldaris morning
10:52 casell joined #openam
10:53 casell morning
10:54 casell is this the right place for openam configuration questions?
10:55 MegaMatt joined #openam
10:55 aldaris yes
10:57 casell ok thx, so: I'm using openam with j2ee agent with filter mode = ALL
10:57 casell all is working fine except for "multiple logouts"
10:59 casell basically each war file has its own logout page, I set the logout URLs in the OpenAM configuration and a global logout entry URL
10:59 casell if I logout it promptly redirects me to the login page with 'goto' set to the entry url
11:01 casell but if I open multiple tabs, logout from one of them and then logout from another one, the first one gets handled correctly, while the 2nd one redirects me to the login page with GOTO set to the 'logout' page
11:02 casell if i then login it sends me to the logout which results in another redirect to the login page (this time with goto set correctly)
11:02 casell so how can I avoid this double login?
11:03 aldaris sounds like a bug
11:04 casell it seems the 'URI enforcement' comes in before the 'is this a logout URI'
11:04 aldaris if you can provide good reproduction steps, please file a bug in JIRA (bugster.forgerock.org)
11:06 casell ok I'll check if i'm able to produce a 'pet project' and try to post a JIRA
11:06 casell thanks aldaris
11:38 rghose joined #openam
11:45 MegaMatt joined #openam
12:37 MegaMatt joined #openam
12:43 fatbloke joined #openam
13:01 MegaMatt joined #openam
13:18 prasannaa joined #openam
13:22 MegaMatt joined #openam
13:28 prasannaa need some idea
13:29 prasannaa in a agent how am i to set the cookie prefix ... the default is HTTP_   ... i want this to be removed ....
13:29 prasannaa any ideas?
13:29 aldaris not sure
13:30 prasannaa hi peter
13:31 aldaris hi
13:32 prasannaa i saw we can se our own cookie value like ABCD ... but there is no way of setting or removing the HTTP_
13:35 aldaris com.sun.identity.agents.config.profile.attribute.cookie.prefix
13:35 prasannaa thats where i set the value
13:36 prasannaa i tried to set a space
13:36 prasannaa agent > Miscellaneous
13:37 prasannaa Cookie Processing > Profile Attributes Cookie Prefix:
13:37 prasannaa i tried all values like
13:37 prasannaa null
13:37 prasannaa NULL
13:37 prasannaa empty space
13:37 prasannaa ""
13:37 prasannaa all of these values are considered as a string by themself
13:38 prasannaa it seems like a bug of not able to remove the cookie prefix or set the cookie prefix to empty
13:41 prasannaa i dont know if such a bug exist or ... are there alternate ways of removing the HTTP_ that is being prefixed
13:42 aldaris I don't really know
13:42 aldaris sounds like a bug
13:42 aldaris have you tried to use some arbitrary other prefix instead?
13:42 prasannaa yeah
13:43 prasannaa allt he above values i had set
13:43 prasannaa null, NULL, "" were set as prefix
13:43 prasannaa like nullABCD , NULLABCD, """ABCD ... where ABCD was the cookie
13:43 prasannaa if i dint set any value
13:43 prasannaa it is like
13:44 prasannaa HTTP_ABCD
13:53 prasannaa is there a process i have to file a bug
13:53 prasannaa are there any guidelines
13:54 aldaris make it sensible, provide version information and debug log if you can. Also reproduction steps are appreciated
13:55 prasannaa is there a page or document explaining how to file a bug?
13:55 aldaris I'm not sure if there is one
13:55 aldaris bthalmayr?
13:56 bthalmayr I don't think so
13:56 bthalmayr but it's somewhat intuitive
13:57 prasannaa is there a process for me to get persmissions to file bugs?
13:57 prasannaa how does that go about
13:58 prasannaa am I to register for filing the bug
13:59 prasannaa maybe i will follow your comments and blog it so that it will help anyone in the future
14:00 aldaris yes, you need to register
14:00 prasannaa where about?
14:00 aldaris bugster.forgerock.org and sso.forgerock.org
14:00 prasannaa in both places?
14:00 aldaris bugster will lead you to sso
14:00 aldaris when you click login
14:00 aldaris it's a guess what - openam :)
14:01 prasannaa hahahahaah
14:02 prasannaa how about the mailing lis
14:02 prasannaa where do i register for the mailing list
14:02 aldaris https://lists.forgerock.org/mailman/listinfo/openam
14:02 aldaris http://openam.forgerock.org/faq.html
14:09 prasannaa thank you peter
14:31 prasannaa i am registered user ... once logged in forgerock (login screen) ... after i click on bugster.forgerock.org ... now it is not redirecting to sso.forgerock.org ....
14:31 prasannaa and it still states that i am not logged in
14:31 prasannaa seems wierd
14:38 bthalmayr joined #openam
14:39 MegaMatt joined #openam
14:46 aldaris yeah
14:46 aldaris we are bad at eating our own dogfood
14:47 aldaris JIRA synchronizes users every 2 hours or so
14:55 MegaMatt joined #openam
15:01 MegaMatt joined #openam
15:40 MegaMatt joined #openam
17:33 aldaris joined #openam
18:38 aldaris joined #openam
19:17 aldaris1 joined #openam
19:39 aldaris joined #openam
19:51 TKA joined #openam
20:37 MegaMatt joined #openam
20:45 aldaris joined #openam
21:23 aldaris1 joined #openam
22:15 aldaris joined #openam
22:22 aldaris joined #openam
22:47 aldaris joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary