Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2014-12-11

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
05:22 ramteid joined #openam
07:22 aldaris joined #openam
08:33 hos001 joined #openam
08:34 aldaris joined #openam
08:44 aldaris joined #openam
08:44 aldaris Good morning
08:45 jjpp good morning, indeed.
08:46 jjpp aldaris: you probably know if cts (in openam11) stumbles on OPENDJ-1123 ?
08:47 aldaris no, I don't really know :)
08:47 jjpp hm. okay.
08:48 jjpp basically -- it appears that some updates in slave replica get lost with error complaining that update tries to remove a value of attribute that was not present.
08:48 jjpp could be, that it is so because i enabled safe-read assured replication.
08:48 aldaris that's OPENAM-3447
08:48 aldaris you should improve your JIRA search skills :)
08:49 jjpp well, I came from "let's optimize opendj" direction. so, so far I haven't thought of it as openam problem :)
08:49 aldaris it's always OpenAM
08:50 aldaris and rarely DJ :)
08:50 jjpp for me it is opendj. because updates in master opendj succeed.
08:50 jjpp and the problem seems rather to be opendj slave that (for some reason) reorders some updates.
08:51 aldaris it's more about how you've set up CTS
08:51 aldaris and replication having a delay
08:51 aldaris most likely a single AM server can target more than one CTS nodes
08:51 aldaris i.e. you are using an LB
08:52 jjpp well, logs show that openam nodes talk exclusively to one opendj, so far.
08:52 jjpp at least the cts connections go against one opendj
08:52 aldaris there is still a chance for race condition within that one AM node
08:53 aldaris hence OPENAM-3447
08:53 aldaris which created a locking mechanism, so that it only performs one update at a time against a session
08:53 aldaris have a read of how updateOrCreate is implemented, and you'll see what's the problem
08:55 asyd morning folks
08:55 aldaris morning
08:58 jjpp i will. though I will still claim that what I was seeing was in opendj side (merely because the first opendj -- the one openams did talk to -- did everything successfully :)
10:49 asyd curious, ludovicmp doesn't blog anymore about opendj but openig
10:49 aldaris that's more shiny I suppose
10:50 aldaris he's PM for both products
10:50 asyd he still the opendj chief?
10:50 asyd ok!
11:47 shyvanna joined #openam
11:48 shyvanna hello everyone
11:49 shyvanna I've been trying to backup my openam configuration but when I try to install the tools zip I get a message saying versions doesn't match (tools is 11 and openAM is 12 despite UI shows 11 on versions button)
11:50 shyvanna digging here I've discovered in the configuration path (/root/openam) an upgrade folder with an upgrade report saying openam has been updated to 12
11:51 shyvanna it is possible to get tools working with this setup? should I "downgrade" despite I haven't upgrade it?
13:51 kala_ anyone knows what is this "Device Registration Cookie" mentioned in http://openam.forgerock.org/openam-document​ation/openam-doc-source/doc/webhelp/admin-g​uide/adaptive-auth-module-conf-hints.html ?
13:51 kala_ hashed device identifier value
13:53 kala_ ok, its basically hash(user-agent,accept,accept-language,a​ccept-encoding,accept-charset,username)
15:45 aldaris joined #openam
16:43 shyvanna joined #openam
18:05 aldaris joined #openam
18:11 aldaris joined #openam
18:37 aldaris joined #openam
18:45 aldaris joined #openam
19:36 aldaris joined #openam
20:09 aldaris joined #openam
20:13 sbrooks9 joined #openam
20:24 aldaris joined #openam
20:26 sbrooks9 For the web policy agent, how do you install gcc 4.4.7 so that the following commands work: strings libstdc++.so.6 | grep GLIBCXX_3 and strings libstdc++.so.6 | grep CXXAB_1? I have libstdc++6 installed and it's the newest version.
20:26 MegaMatt huh?
20:27 sbrooks9 haha, right? http://packages.ubuntu.com/l​ucid/libstdc%2B%2B6-4.3-dbg section 1.5.1 says that you need to be able to successfully run those commands to be able to set up the web policy agent correctly
20:28 sbrooks9 copied from inside a virtual box, wrong link
20:29 sbrooks9 docs.forgerock.org/en/openam-pa/3.3.​3/openam-3.3.3-web-release-notes.pdf
20:30 MegaMatt Yeah, it says you need to support the GLIBC_2.3 ABI
20:31 MegaMatt So you need  libc.so.6
20:32 MegaMatt http://rpmfind.net/linux/rpm2html/sear​ch.php?query=libc.so.6%28GLIBC_2.3%29
20:32 MegaMatt And also check that your libstdc++ has the right ABI
20:32 MegaMatt that’s all it’s saying
20:32 MegaMatt http://rpmfind.net/linux/rpm2html/search.ph​p?query=libstdc%2B%2B.so.6%28GLIBCXX_3.4%29
20:33 MegaMatt using strings to grep for them is just a lazy way of
20:33 MegaMatt .. I forget the command .. is it nm? or pvs .. on solaris … something like that
20:33 MegaMatt yeah it’s pvs
20:34 MegaMatt I don’t know if linux has a pvs command, which might be why they have you grep with strings
20:37 sbrooks9 Ah, okay, cool. :) The first link you provided doesn't have exactly libc.so.6, will any of them work? I searched it myself and arrived at the same page
20:37 MegaMatt … It should have libc.so.6 .. it’s part of glibc
20:38 MegaMatt You probably have it already though anyhow
20:38 MegaMatt if you are using a recent glibc
20:38 sbrooks9 when I grep, nothing is returned like it should be =\
20:38 MegaMatt you’re running it against your libc.so.6?
20:39 MegaMatt So what version of the glibc package do you have installed?
20:39 MegaMatt maybe you have an old one
20:41 sbrooks9 mm nothing in /lib has libc in it
20:42 MegaMatt what about if you list rpms and grep for glibc ?
20:42 MegaMatt pretty sure you have to have a libc.so.*
20:43 sbrooks9 I got nothing back
20:47 MegaMatt check in /lib64/
20:48 sbrooks9 also no libc.so.* in it
20:48 MegaMatt what does it say if you ldd your gcc binary then??
20:48 MegaMatt $ ldd /usr/bin/gcc
20:48 MegaMatt linux-vdso.so.1 =>  (0x00007fff1b9ff000)
20:48 MegaMatt libc.so.6 => /lib64/libc.so.6 (0x00000038b9000000)
20:50 sbrooks9 ldd /usr/bin/gcc
20:50 sbrooks9 linux-vdso.so.1 =>  (0x00007fff4fd3b000)
20:50 sbrooks9 libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f043fad3000)
20:50 sbrooks9 /lib64/ld-linux-x86-64.so.2 (0x00007f043feb1000)
20:51 MegaMatt so there it is
20:51 MegaMatt see? ;)
20:53 MegaMatt So you can strings that /lib/x86_64-linux-gnu/libc.so.6 and see if it’s got the right verssion
20:56 sbrooks9 right version of libc.so.6 but libstdc++.so.6 can't be found with ldd
20:57 MegaMatt well, gcc might not link in that library
20:57 MegaMatt but you might not have it installed
20:57 MegaMatt I just used ldd as an example because I know almost every binary links in libc
20:58 MegaMatt It’s possible that you need to install the package that contains libstdc++
21:03 aldaris joined #openam
21:03 sbrooks9 okay, thanks a lot :)
21:25 aldaris joined #openam
22:59 aldaris joined #openam
23:22 aldaris joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary