Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2015-07-29

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:20 MegaMatt joined #openam
01:48 ilbot3 joined #openam
01:48 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 12.0.0 is out! OpenAM 11.0.3 is out! Channel logs at: http://irclog.perlgeek.de/openam/today
04:47 ramteid joined #openam
06:12 aldaris joined #openam
06:28 aldaris joined #openam
07:56 KermitTheFragger joined #openam
08:29 ascarborough joined #openam
08:36 aldaris joined #openam
08:36 ascarborough joined #openam
08:56 ascarborough joined #openam
09:00 ascarborough joined #openam
09:13 ascarborough joined #openam
09:20 ascarborough joined #openam
09:34 ascarborough joined #openam
09:40 ascarborough joined #openam
10:24 ascarborough joined #openam
10:40 aldaris joined #openam
10:58 MegaMatt joined #openam
11:24 ascarborough joined #openam
11:32 ascarborough joined #openam
11:35 aldaris joined #openam
11:38 ascarborough joined #openam
11:59 aldaris joined #openam
12:05 mckeanbs joined #openam
12:08 aldaris joined #openam
12:12 ascarborough joined #openam
12:27 ascarborough joined #openam
12:52 aldaris joined #openam
12:58 aldaris joined #openam
14:28 aldaris joined #openam
14:47 aldaris joined #openam
15:44 ascarborough joined #openam
15:49 ascarborough joined #openam
16:02 Reepicheep joined #openam
16:15 metadaddy joined #openam
17:36 ascarborough joined #openam
17:41 ascarborough joined #openam
18:57 troy joined #openam
18:58 Guest12995 hi
18:58 Guest12995 i have openam behind a proxy which terminates SSL
18:58 Guest12995 openam is configured with a site that specifies the HTTPS proxy url
18:59 Guest12995 However, when I try to do IDPSSOINIT the Location header switchs the protocol from HTTPS to HTTP
18:59 Guest12995 I've set the auth URL for the IDP
19:00 Guest12995 as I was having issues before with Location Header setting port to 80
19:00 Guest12995 is there anything else I can set to prevent the protocol change?
19:09 aldaris joined #openam
19:12 Guest12995 i have openam behind a SSL proxy
19:12 Guest12995 openam is configured with a site that specifies the HTTPS proxy url
19:12 Guest12995 However, when I try to do IDPSSOINIT the Location header switchs the protocol from HTTPS to HTTP
19:12 Guest12995 I've set the auth URL for the IDP as I was having issues before with Location Header setting port to 80
19:13 Guest12995 is there anything else I can set to prevent the protocol change?
19:13 aldaris are you using tomcat?
19:13 Guest12995 yes
19:13 aldaris then look into proxyPort
19:13 Guest12995 ah, forgot that
19:20 Guest12995 scheme is still HTTP
19:20 aldaris then look into secure="true"?
19:29 Guest12995 didn't work
19:29 aldaris did you set it for the right connector?
19:30 Guest12995 i have a single http connector
19:32 Guest12995 ah, figured it out.
19:32 Guest12995 need trailing slash on Auth URL
19:34 Guest12995 thanks for the help
19:35 aldaris joined #openam
19:42 Guest12995 hmm.. "goto" param is still using HTTP
19:49 aldaris you can remove the auth url if you configured tomcat
19:49 aldaris that should resolve the goto problem imho
20:14 aldaris joined #openam
20:15 Guest12995 created new tomcat connector
20:15 Guest12995 needed to add scheme="https"
20:15 Guest12995 that appears to work
20:15 Guest12995 even w/o Auth URL
20:16 Guest12995 thanks for the ideas
20:24 aldaris joined #openam
21:12 Hunger- joined #openam
21:34 MegaMatt joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary