Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2015-08-21

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
01:30 MegaMatt joined #openam
06:43 fairuz joined #openam
06:50 KermitTheFragger joined #openam
07:14 fairuz1 joined #openam
07:17 fairuz1 left #openam
07:25 fairuz joined #openam
07:25 fairuz left #openam
09:07 adamsc joined #openam
09:28 takashi joined #openam
09:28 takashi Hello?
09:29 asyd hello
09:29 takashi I've got a problem with seting up OpenAM & OpenID
09:29 takashi Could somebody help me?
09:30 asyd i can help on openam, but not openid :)
09:30 takashi Thank you, but may be the problem is on openam:)
09:31 takashi I've set up as : https://backstage.forgerock.com/#!/docs/openig/3.1.0/gateway-guide#chap-password-capture-replay-tutorial
09:31 takashi But when I access http://www.example.com:8080/replay
09:32 takashi It return a login form (provided by openam)
09:32 asyd openig ?
09:32 asyd it's not openam
09:32 takashi I logged in with user name george
09:33 takashi And it return  Authorization Required
09:33 takashi So I have a question as: if I set up openam as: openam.example.com:8080
09:34 takashi But the agent is in example:8088
09:34 takashi Does I need to set up anything relate to CDSSO?
09:40 asyd example:8088 ? w/o domain?
09:40 asyd that can't work
09:42 takashi No, it mean that my agent url is http://www.example.com:8088/agentapp
09:42 takashi But OpenAm server URL is http://openam.example.com:8080/openam
09:49 asyd that should work
09:49 asyd look at your cookie it should set on .example.co
09:51 takashi But now I got 401 unauthorized from OpenAM to J2EE Agent
09:52 asyd check agent logs
09:53 takashi I've also set log level = message in Bootstrap file
09:53 takashi Could you give me some hint to check it?
09:55 asyd have you created your agent in the realm / ?
09:55 asyd are you  in SSO_ONLYE mode? if no, have you added some policies in OpenAM ?
09:59 takashi Yes, I've created agent in reaml "/"
09:59 takashi And SSO_ONLY mode also
10:01 asyd hmm ok
10:03 asyd well check logs in your policy installation directory
10:20 takashi This is what I got in tomcat log (OpenAM log)
10:20 takashi --- (request) exchange:829778165 --->  GET http://www.example.com:8081/replay HTTP/1.1 Cookie: amlbcookie=01; iPlanetDirectoryPro=AQIC5wM2LY4Sfcw53wL_-EDcIFttHYVET9Rg_jD-3OyLVHY.*AAJTSQACMDEAAlNLABQtNTQzMjQzMjg5NTAwMTgwMzExMQ..*; iPlanetDirectoryPro=AQIC5wM2LY4Sfcw53wL_-EDcIFttHYVET9Rg_jD-3OyLVHY.*AAJTSQACMDEAAlNLABQtNTQzMjQzMjg5NTAwMTgwMzExMQ..* Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 host: www.exam
10:20 takashi ahhh... it said WARNING: Authentication error: Unable to respond to any of these challenges: {}
10:20 takashi Is it normal?
10:21 takashi And in agent log (debug.out) I've got: ERROR: Failed to obtain auth service url from server: null://null:null
10:23 takashi It there any problem?
10:25 takashi Now I must to go out a little, so if you can help me any thing, could you send me an email to takashi.satoh1987@gmail.com ?
10:25 takashi i appreciate your help
10:25 takashi Thank you very much
10:38 adamsc joined #openam
10:41 adamsc joined #openam
11:15 MegaMatt joined #openam
11:59 adamsc joined #openam
12:08 mckeanbs joined #openam
13:33 adamsc joined #openam
14:46 adamsc joined #openam
15:47 adamsc joined #openam
17:25 adamsc joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary