Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2015-10-22

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:10 MegaMatt joined #openam
06:54 KermitTheFragger joined #openam
07:56 aldaris joined #openam
07:56 hos001 joined #openam
07:59 arm77 joined #openam
08:02 arm77 hey, trying to use openam 12.0.1 with liferay (java) portal, but cannot get it working. redirect loop. done it before with openam 10.
08:03 aldaris if you can run 12.0.1, then you should actually have a support contract? :)
08:03 arm77 tomcat 8, java 8, liferay 6.1.1 and tried with 6.2 ga4 also. same domain.
08:03 aldaris what OpenAM component are you using on the liferay side of things?
08:06 arm77 i guess it is 12.0.0 then :) just thougt i downloaded 12.0.1 source but you know better.
08:07 arm77 liferay has built in support for openam rest api
08:07 arm77 https://wikis.forgerock.org/confluence/dis​play/openam/integrate+OpenAM+with+Liferay
08:07 arm77 should be easy
08:08 arm77 oh and also we use wildcard certificate. it does not currently include dns name for the domain but could be included if that is a problem.
08:09 arm77 that confluence article is still quite old.
08:12 aldaris http://www.liferay.com/community/foru​ms/-/message_boards/message/12339463
08:12 aldaris this one suggests that liferay doesn't support cdsso
08:12 aldaris so probably that's your problem
08:12 aldaris using SAML as suggested could be a good workaround (as long as Liferay has SAML support)
08:14 arm77 yes, would love to do that, but liferay saml plugin is only for commercial EE version :(
08:14 arm77 argh
08:14 arm77 and one more thing - both openam and liferay are behind a frontend nginx "proxy" if that could be a problem
08:17 arm77 openam and liferay are on the same domain for that reason
08:20 aldaris if they are on the same domain, then you shouldn't get a redirect loop
08:20 aldaris you have misconfigured the cookie names maybe then?
08:29 arm77 that should not be the case, but will check once more...
08:33 arm77 assume that X-headers are not needed in this case but are they?
08:42 aldaris what X-headers?
08:48 arm77 X-Forwarded-For
08:49 arm77 that is not configured now because thought it is not needed
09:04 vmirzaian joined #openam
09:04 vmirzaian_ joined #openam
09:08 aldaris1 joined #openam
09:30 aldaris joined #openam
10:04 aldaris1 joined #openam
11:25 vmirzaian joined #openam
11:26 vmirzaian_ joined #openam
11:28 MegaMatt joined #openam
11:46 MegaMatt joined #openam
12:03 mckeanbs joined #openam
12:54 arm77 can someone please give correct syntax example for sso login url with XUI + realm / + goto address
13:52 aldaris joined #openam
14:09 aldaris arm77 what do you mean?
14:10 MegaMatt http://my.openam.com:8080/openam/XUI/#login/myRe​alm&module=MyModule&goto=http%3A%2F%2Fmy.example.com  maybe??
14:13 MegaMatt http://my.openam.com:8080/openam/XU​I/#login/&goto=http%3A%2F%2Fwww.example.com   if you wanted root realm … default
14:13 MegaMatt works fine for me
15:01 asyd_ joined #openam
15:01 balo_ joined #openam
15:11 Reepicheep joined #openam
15:29 vmirzaian__ joined #openam
15:33 vmirzaian joined #openam
17:34 us3r777 joined #openam
17:39 us3r777 joined #openam
18:13 us3r777_ joined #openam
18:56 aldaris joined #openam
21:48 vmirzaian_ joined #openam
21:48 vmirzaian joined #openam
23:15 MegaMatt joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary