Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2016-02-26

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:59 orriols joined #openam
01:05 MegaMatt joined #openam
02:47 ilbot3 joined #openam
02:47 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 13.0.0 is out! OpenAM 12.0.2 is out! Channel logs at: http://irclog.perlgeek.de/openam/today
02:57 aldaris1 joined #openam
03:24 aldaris joined #openam
03:38 aldaris joined #openam
04:52 ramteid joined #openam
06:23 daveloper joined #openam
07:06 auke- joined #openam
08:12 aldaris joined #openam
08:29 orriols joined #openam
09:00 aldaris joined #openam
09:06 HelgeO joined #openam
09:31 auke- joined #openam
09:45 aldaris joined #openam
09:51 daveloper joined #openam
10:28 daveloper joined #openam
10:36 aldaris1 joined #openam
10:46 aldaris joined #openam
11:00 aldaris joined #openam
11:24 aldaris joined #openam
11:45 aldaris joined #openam
11:52 MegaMatt joined #openam
12:44 aldaris1 joined #openam
12:44 daveloper joined #openam
12:49 aldaris joined #openam
15:07 mckeanbs joined #openam
15:08 aldaris joined #openam
15:55 mckeanbs joined #openam
16:41 aldaris joined #openam
17:06 aldaris1 joined #openam
17:29 ilbot3 joined #openam
17:29 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 13.0.0 is out! OpenAM 12.0.2 is out! Channel logs at: http://irclog.perlgeek.de/openam/today
17:30 mckeanbs joined #openam
17:50 aldaris1 joined #openam
18:09 aldaris joined #openam
18:37 aldaris joined #openam
19:00 techtenk I'm missing some concept here... I've got it configured so that my TAI redirects to the OpenAM page, I'm able to authenticate through that and it redirects me back to my web app but then the web app throws errors that the user is blank. The web app had been just using HTTP Basic authentication before but as soon as I disable that I lose my user
19:30 aldaris joined #openam
19:44 aldaris jee agents don't do anything with http basic auth
19:44 aldaris did you mean to use openig instead?
19:44 aldaris otherwise you should figure out what happens after the basic auth and try to mimic that with the agent
19:47 techtenk so that could be anything? writing a cookie or a session variable to store the username... just have to figure out what the web app is expecting and mimic that
19:53 techtenk and would I mimic that under the "Application" tab in the J2EE agent?
20:00 techtenk or maybe I am supposed to be using OpenIG... I have a client who's trying to integrate CA SSO (Siteminder) and so I'm just learning about all this SSO terminology. I just know they typically install a Siteminder agent on the web application server and do the integration with IBM HTTP Server, but in our case we are trying to integrate directly with WebSphere
20:00 aldaris Application tab it is, yes
20:01 techtenk my impression was that since they installed an agent on the application server that meant it would be the J2EE agent route... but I didn't read a lot on how reverse proxy auth works
20:01 aldaris but, yeah you would configure the agent so that it creates http headers/request attributes/ cookies/etc in a way that works nicely for your app
20:02 techtenk ok, I started going down that route but never saw the headers populate in my requests after the redirect so I got discouraged
20:04 daveloper joined #openam
20:09 daveloper joined #openam
20:22 mckeanbs joined #openam
20:22 daveloper joined #openam
20:26 MegaMatt joined #openam
20:30 daveloper joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary