Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2017-01-27

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
12:10 MegaMatt joined #openam
12:25 KermitTheFragger joined #openam
19:05 Jim___ joined #openam
19:19 Jim___ would someone here be able to do a quick sanity check on something before I file a bug?
19:20 Jim___ I am trying to use ssoadm to add an authentication module to a chain. I'm able to do it without any options, but with options the ssoadm client says the command is invalid.
19:21 Jim___ I would expect this to work, but it doesn't:
19:21 Jim___ ./ssoadm add-auth-cfg-entr \   --criteria SUFFICIENT \   --realm myrealm \   --name mychain \   --modulename mymodule \   --adminid amadmin \   --password-file /home/svc_idm/pwd.txt \   --options \     "iplanet-am-auth-shared-state-enabled=true" \     "iplanet-am-auth-shared-state-​behavior-pattern=useFirstPass"
19:24 MegaMatt https://bugster.forgerock.o​rg/jira/browse/OPENAM-8727 ?
19:24 MegaMatt sorry, I meant to paste: https://forgerock.org/topic/cant-set-m​odule-options-in-authentication-chain/
19:25 MegaMatt which links to that below, but don’t think that’s what it is
19:25 MegaMatt "workaround is to use ‘ssoadm update-auth-cfg-entr’ for chain options”
19:34 Jim___ I'll try the workaround, but still sounds like I should log it. Do you agree?
19:34 MegaMatt I think it is related to 8727
19:34 MegaMatt actually
19:34 Jim___ yup
19:35 MegaMatt Can you use 13.5?
19:35 Jim___ I am using 13.5.
19:35 Jim___ should I update 8727 then? I
19:35 MegaMatt I think it worked for me…
19:36 Jim___ I'm somewhat unfamiliar with bugster so I don't want to create a mess for the developers
19:36 MegaMatt I’d open a support ticket and make support open the JIRA then, give them all that you tried so they can search for duplicates and all that
19:36 Jim___ which worked, add-auth-cfg-entr or update ?
19:36 Jim___ ok, thanks Matt
19:37 MegaMatt ./ssoadm add-auth-cfg-entr -u amadmin -f /tmp/pwd.txt -e /myrealm -m ldapService -o MyAuthDataStore -c REQUISITE -p 3 -t "iplanet-am-auth-shared-state-enabled=true iplanet-am-auth-shared-state-b​ehavior-pattern=useFirstPass"
19:37 Jim___ oh.
19:40 MegaMatt Ah I wonder if you use | and all in one if it will work
19:40 MegaMatt like the comment in OPENAM-8579
19:40 MegaMatt openam/bin/ssoadm update-auth-cfg-entr -e / -m mychain -u amadmin -f .pass -a 'foobar|REQUIRED|iplanet-am-a​uth-shared-state-enabled=true iplanet-am-auth-store-shared-state-enabled=true' 'hello|SUFFICIENT|iplanet-am-a​uth-shared-state-enabled=true iplanet-am-auth-shared-state-b​ehavior-pattern=useFirstPass'
19:40 MegaMatt like all as one with | ’s
19:41 MegaMatt Support will confirm the right way .. hah.. I gotta step out
19:42 Jim___ thank you very much !!
22:31 MegaMatt joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary