Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2017-02-09

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:33 aldaris joined #openam
02:48 ilbot3 joined #openam
02:48 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 13.5.0 is out! OpenAM 12.0.3 is out! Channel logs at: http://irclog.perlgeek.de/openam/today
04:44 jelmd is there a JVM/catalina property to set the directory, which gets used by openAM to store its stuff instead of ~/ ?
07:57 KermitTheFragger joined #openam
08:04 aldaris joined #openam
08:05 asyd morning
08:06 asyd jelmd: you configure the openam data path at the initial setup. However you can change it by edit ~/.openamcfg/<file> iirc
09:05 aldaris joined #openam
12:09 aldaris joined #openam
13:30 aldaris joined #openam
14:34 Topic for #openam is now Chat about the OpenAM project - https://backstage.forgerock.com/#/downloads - OpenAM 13.5.0 is out! OpenAM 12.0.4 is out! Channel logs at: http://irclog.perlgeek.de/openam/today
14:34 aldaris Good afternoon everyone
15:45 aldaris joined #openam
18:34 aldaris joined #openam
19:07 aldaris joined #openam
19:46 aldaris joined #openam
21:21 jelmd asyd: thanx. But the problem is ~ . The user running the webservice alias tomcat (which is usually webservd) has no explicit home (for reason) and thus it results to /.  Anyway fixed it by adding ‘ -Duser.home=/data/oam/cfg-store’ to tomcats JAVA_OPTS. Now I need to find a way, that the embedded OpenDJ will work (config probably assumes, that it is allowed to use privileged ports, but webservd is an unprivileged user …)
21:26 jjpp jelmd: it does not assume that. at least it did not few versions back :)
21:26 jjpp iirc the embedded opendj will start on some random high port
21:27 jelmd OK - was just an assumption. Haven_t had the time to dig deeper yet.
21:28 jelmd probably need to find, what it tries to do via src ….
21:32 jelmd just shows ‘Please wait... configuration in progress…’ and nothing happens …
21:33 jjpp try to enable message-level debug logging and read logs
21:33 jjpp -Dcom.iplanet.services.debug.level=message
21:33 jjpp -Dcom.iplanet.services.debug.directory=$DEBUG_DIR -Dcom.sun.services.debug.mergeall=$DEBUG_MERGE
21:34 jjpp might also be useful
21:34 jjpp last can be "on" to get just one large debuglog
21:34 jelmd ok - thanx!
21:35 jjpp and it sounds familiar but i cannot remember what might have been the reason.. :)
21:37 jelmd ERROR: Caught exception: Error Configuring Directory Server.
21:37 jelmd but not something usable
21:39 jjpp hm. might be that there was some other directory-pointing system parameter.
21:43 jjpp we used to have startup script that could start standalone openam with datadirectories somewhere not-in-home-dir
21:46 jelmd ah - found openam-public/openam-core/src/main/java/c​om/sun/identity/setup/EmbeddedOpenDS.java - so dig target determined for after-launch (brb) ;-)
23:59 jelmd joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary