Perl 6 - the future is here, just unevenly distributed

IRC log for #openam, 2017-11-27

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
02:59 ilbot3 joined #openam
02:59 Topic for #openam is now Chat about the OpenAM project - https://forgerock.github.io - Channel logs at: http://irclog.perlgeek.de/openam/today
07:32 aldaris joined #openam
12:01 aldaris joined #openam
13:36 FireBurn|Work joined #openam
13:40 FireBurn|Work I think I've figured out why OpenAM won't work with IBMs JRE 8
13:40 FireBurn|Work I'm pretty sure OpenAM is using classes that have been depricated in Sun's Java 8 but have forbidden in IBM's
13:41 FireBurn|Work [ERROR] /apps/was/jenkins/workspace/Compile_OpenAM_CE/OpenAM/openam-shared/src/main/java/com/iplanet/security/x509/IssuingDistributionPointExtension.java:[574,24] avas() is not public in com.ibm.security.x509.RDN; cannot be accessed from outside package
13:41 FireBurn|Work [ERROR] /apps/was/jenkins/workspace/Compile_OpenAM_CE/OpenAM/openam-shared/src/main/java/com/iplanet/security/x509/IssuingDistributionPointExtension.java:[565,59] data has private access in com.ibm.security.util.DerValue
14:14 aldaris joined #openam
15:19 FireBurn|Work aldaris: I think I figured out the issue with IBM's JRE 8
15:24 FireBurn|Work And as a side note I've got OpenDJ & OpenAM compiling and running with Orcale JRE 8
15:24 FireBurn|Work *JDK
15:25 aldaris that could have been quite an effort
15:25 aldaris only 12 supported 8 as runtime iirc
15:32 FireBurn|Work 11 is been working fine here with 8 runtime, it was the compiling that was a pita
15:33 FireBurn|Work I think the ibm issue is classed which have been depricated on Oracle, are just forbidden for use on IBM's
15:33 FireBurn|Work I imagine you guys will be hitting that if you're getting OpenAM ready for Java 9 or 17.3
15:33 FireBurn|Work *18.3
15:41 FireBurn|Work You mentioned OPENAM-8080 the other day as a follow up, but I cna't find it in Jira or any references to it around the web
15:42 aldaris OPENAM-141 was about getting rid of the really old API calls
15:42 aldaris yeah, I'm not quite sure why that bug isn't really part of an advisory
15:43 aldaris ah
15:43 aldaris OPENAM-8080 was the backport of OPENAM-7583
15:43 aldaris we opened a separate bug for it
15:43 aldaris sorry about the confusion...
16:10 FireBurn|Work No worries
16:10 FireBurn|Work Thanks for reviewing those fixes
16:11 aldaris np
16:17 FireBurn|Work OPENAM-8575 does that belong in OpenAM 11, none of the files matched up
16:24 aldaris 8575 applies to 11.0.x, yes. The OAuth2 framework was rewritten for 12 and/or 13
16:27 FireBurn|Work :(
16:30 FireBurn|Work Any hints on how to solve OPENAM-7125
16:34 aldaris 7125 was #201601-06 as far as I can see
16:34 aldaris that's pretty much all I can tell
17:45 aldaris joined #openam
21:47 FireBurn joined #openam
21:47 FireBurn joined #openam

| Channels | #openam index | Today | | Search | Google Search | Plain-Text | summary