Camelia, the Perl 6 bug

IRC log for #openframeworks, 2013-09-13

| Channels | #openframeworks index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
02:20 workergnome joined #openframeworks
06:25 cla_ joined #openframeworks
07:13 denandreas joined #openframeworks
08:06 goodman joined #openframeworks
08:22 Hurtzy joined #openframeworks
08:32 denandreas joined #openframeworks
09:24 marcela joined #openframeworks
09:47 tgfrerer_ joined #openframeworks
10:33 denandreas joined #openframeworks
10:34 goodman joined #openframeworks
11:36 thefinal joined #openframeworks
12:06 denandre_ joined #openframeworks
12:20 denandreas joined #openframeworks
12:32 workergnome joined #openframeworks
12:36 tgfrerer joined #openframeworks
12:56 superFluid joined #openframeworks
12:59 workergnome joined #openframeworks
13:37 goodman joined #openframeworks
14:43 workergnome joined #openframeworks
16:14 denandreas joined #openframeworks
16:15 goodman joined #openframeworks
16:20 admsyn joined #openframeworks
16:56 Trenskow joined #openframeworks
16:59 pizthewiz joined #openframeworks
17:00 Trenskow Can someone explain to me, why this code does not draw a rectangle? https://gist.github.com/trenskow/6553271
17:09 oneironaut joined #openframeworks
17:10 admsyn Trenskow: hard to tell from a quick scan, but would you be better off with an ofFbo maybe?
17:10 admsyn also the ofEnableBlendMode(OF_BLENDMODE_ALPHA); and then ofEnableAlphaBlending(); is redundant, though that would be the problem
17:11 admsyn *wouldn't be
17:13 admsyn does the _internalImage.draw() draw anything at all?
17:24 adm joined #openframeworks
17:24 adm hey all
17:24 adm i'm trying to create an ofTexture with a floating point format and am struggling to fill it with anything
17:24 adm anyone have any experience with this?
17:24 Trenskow joined #openframeworks
17:25 Trenskow computer went to sleep...
17:27 admsyn Trenskow: hey, logs are here -> http://irclog.perlgeek.de/​openframeworks/2013-09-13
17:27 admsyn adm: what happens when you try to draw it? is it all graphics memory garbage?
17:28 adm pretty much
17:28 adm i tried to simplify the situation as much as possible
17:28 adm but first
17:29 adm based on stuff i was picking up from the forum, GL_RGBA32F seems well supported
17:29 adm even though i don't need 4 channels
17:29 admsyn adm: so it's probably an issue with binding then?
17:29 adm so i'd start with myTexture.allocate( 128, 128, GL_RGBA32F )
17:30 adm then i have an array of floats that i fill with random values for now
17:30 Trenskow @admsys thx
17:30 adm and then i call myTexture.loadData( pixels, 128, 128, GL_RGBA32F )
17:31 admsyn Trenskow: ofFbo is quite a bit easier, you basically just have to myFbo.begin(); draw your stuff, then myFbo.end();
17:31 admsyn adm: so if you just draw the "pixels" object everything's fine?
17:31 adm the pixels is just an array
17:31 adm i can't draw that
17:32 adm float * pixels = new[ 128 * 128 * 4 ]
17:34 admsyn ah thought it was an ofPixels
17:34 adm nah…
17:35 adm anyway i can't seem to find any examples
17:35 adm any idea where i could be going wrong
17:35 admsyn for loading raw floats into a texture?
17:35 adm yes
17:35 adm seems pretty straightforward
17:35 adm not sure where i could be going wrong. i was using GL_RG32F before, but it seems like that isn't as well supported at GL_RGBA32F so i switched to that
17:38 admsyn can you show some code on pastebin / etc?
17:38 adm yea one sec
17:42 admsyn and it'd be helpful if you can get it to a point where it's e.g. GL_RGBA and it works, then switching it to GL_RGBA32F breaks it
17:43 Trenskow phew. It's not just me... http://www.downforeveryoneor​justme.com/openframeworks.cc :)
17:43 admsyn huh I thought that was fixed :)
17:43 admsyn actually it works for me..
17:44 adm https://gist.github.com/Aaro​nMeyers/2befcd69bed00a489685
17:44 Trenskow now it's up
17:46 admsyn adm: yeah that looks like it should work :/
17:46 adm does it work for you?
17:47 admsyn no I haven't run it yet, just opening up an empty example :)
17:47 admsyn might be something to do with arb texture though?
17:47 admsyn open gl isn't really my strong point :/
17:53 jacres adm: are you on OS X by chance?
17:53 adm yes
17:54 jacres i have a few mins in a bit, but i'm curious to see if the contents of the texture are being set. Have you use XCode's OpenGL profiler?
17:55 jacres can previous the texture to see its pixels
17:55 jacres err preview
17:57 admsyn adm: yeah not sure what the deal is, but if I switch from a straight float * to an ofFloatPixels it works
17:57 adm oh?
17:57 adm i've never used ofFloatPixels
17:57 adm not sure how they work :P
17:57 adm can you post the gist?
17:57 admsyn it's pretty much a float * with meta deta
17:57 admsyn yepp
17:58 admsyn https://gist.github.com/ad​msyn/3d307ab75d37b289558a
17:58 admsyn just swapped out the tex.loadData() from the float * version to the ofFloatPixels version
18:02 jacres admsyn: ah interesting.. I think I had to that once as well come to think of it. Any idea why? Seems loading floats directly should work?
18:04 adm yeah that works for me too.
18:04 adm seems like a bug
18:05 adm but its workable for me to just use ofFloatPixels. what is the most performant way to do that?
18:05 adm i noticed there is a setFromPixels and a setFromExternalPixels method
18:07 admsyn setFromExternalPixels just stores the float * argument, setFromPixels copies them in
18:07 admsyn so it'll crash if the float * disappears for example
18:07 admsyn it's an "advanced" method :)
18:07 admsyn yeah that does seem like a bug though
18:10 tgfrerer_ joined #openframeworks
18:12 jacres be interesting to see if setFromExternalPixels works with a float array
18:12 jacres I guess that would be the most performant way, versus copying once on host and then once to device?
18:14 admsyn yeah or just working from the ofFloatPixels and not having a float * at all
18:15 admsyn e.g. getPixels() on an ofPixels will give you your float *
18:15 admsyn or you can use operator[] on it etc
18:16 jacres that's true
19:14 admsyn joined #openframeworks
19:31 admsyn left #openframeworks
19:31 admsyn joined #openframeworks
19:43 bbui joined #openframeworks
19:44 bbui Hello
19:46 dantheman joined #openframeworks
19:47 admsyn bbui: hi!
19:51 dantheman joined #openframeworks
19:55 bbui I'm having an issue with loadimage after moving a project from my 0.7.4 directory to my new of_0.8.0 directory.  is there something I need to do to move my projects around like this?  My application says it can't load the image and xml files, but loading a font file works okay
19:57 admsyn hm, there's been quite a few updates to XML between 0.7.4 and 0.8.0 so that's probably your xml issue
19:57 admsyn what's the issue though? crash? doesn't look right? doesn't compile?
20:00 bbui It compiles, it runs like normal, I just get an error saying that the image  could not be loaded from the files.  I'm assuming it doesn't see the files?  So moving my project from one folder structure to another might have broken this?
20:01 admsyn yeah that's pretty likely
20:01 admsyn did you just drag your app's folder from 0.7.4/apps/myApps/blah to 0.8.0/apps/myApps/blah ?
20:01 bbui Yea
20:02 bbui I made a copy
20:02 admsyn you might want to try building a new empty project, and just replacing the files in src/ and bin/
20:05 admsyn can I see the code you're using to load the image thogh?
20:08 admsyn it sounds like there's just an issue with file paths or something trivial like that
20:08 admsyn I don't think anything's changed RE: image loading between 0.7.4 and 0.8.0
20:12 peterZim joined #openframeworks
20:14 bbui It worked, I had to create a new blank project though.  I guess something was funky with the project I had originally started with
20:15 bbui I didn't think anythingchanged either, just wondering if there were some project file specific settings that I could have addressed w/o having to set it all up again.
20:15 bbui Thanks for the help!
20:23 peterZim hello everyone!
20:27 bbui Hi!
20:28 peterZim has anyone been able to get the ps3 eye camera running at 125fps in ubuntu using of?
20:38 peterZim_ joined #openframeworks
21:09 roxlu_ joined #openframeworks
21:27 robot joined #openframeworks
21:29 dantheman I haven't see it ever that high
21:29 dantheman I see it at 60 FPS on OSX
21:29 dantheman or 120
21:29 dantheman but ever 125
21:29 dantheman oh he ain't here
22:10 oneironaut joined #openframeworks
22:10 oneironaut <3!!!
22:13 dantheman less than 3
22:23 Dorald joined #openframeworks
22:41 jacres joined #openframeworks
23:32 goodman joined #openframeworks
23:34 admsyn joined #openframeworks
23:37 tmslnz joined #openframeworks
23:48 goodman joined #openframeworks

| Channels | #openframeworks index | Today | | Search | Google Search | Plain-Text | summary